Okno dialogowe "Wprowadzanie wartości parametru" wyświetlane po uruchomieniu zapytania, formularza lub raportu

Uwaga

Nazwa usługi Office 365 ProPlus została zmieniona na Aplikacje usługi Microsoft 365 dla przedsiębiorstw. Aby uzyskać więcej informacji na temat tej zmiany, przeczytaj ten wpis w blogu.

Umiarkowany. Wymaga podstawowych umiejętności makr, kodowania i współdziałania.

Ten artykuł dotyczy tylko bazy danych programu Microsoft Access (mdb).

Symptomy

Podczas próby uruchomienia zapytania, formularza lub raportu okno dialogowe Wprowadzanie wartości parametru może zostać nieoczekiwanie wyświetlone.

Przyczyna

To zachowanie występuje, gdy pole, kryteria, wyrażenie lub kontrolka w zapytaniu, formularzu lub raporcie odwołuje się do nazwy, która nie może zostać odnaleźć w programie Access. Na przykład nazwa może być błędnie napisany lub pole może być niedostępne w tym zakresie.

Rozwiązanie

Aby rozwiązać ten problem, zmień nazwę odwołania na prawidłową nazwę pola. Jeśli nie wiesz, gdzie znajduje się odwołanie, uruchom Dokumentator bazy danych dla obiektu wymienionego na liście w oknie dialogowym Wprowadzanie wartości parametru, a następnie wyeksymuj informacje do pliku tekstowego. Aby tak zrobić, wykonaj następujące kroki:

  • Jeśli korzystasz z programu Access 2002 i 2003, wykonaj następujące czynności:
    1. W menu Narzędzia wskaż polecenie Analiza, a następnie kliknij polecenie Dokumentator.

    2. Kliknij kartę odpowiadającą szukanemu typowi obiektu bazy danych, a następnie kliknij, aby zaznaczyć pole wyboru zapytania, formularza lub raportu, który próbowano uruchomić.

      Uwaga Jeśli obiekt jest formularzem lub raportem, do listy zaznaczeń uwzględnij wszystkie zapytania źródłowe, podformularze i podraporty.

    3. Kliknij pozycję Opcje, aby określić, która funkcja wybranego obiektu ma zostać wydrukowana, a następnie kliknij przycisk OK.

    4. Kliknij przycisk OK, aby zamknąć okno dialogowe Dokumentator.

    5. W menu Plik kliknij polecenie Eksportuj.

    6. Na liście Zapisz jako typ kliknij pozycję Pliki tekstowe, a następnie wypełnij resztę informacji zgodnie z potrzebami.

    7. Otwórz wyeksportowany plik w programie Microsoft Word, a następnie wyszukaj żądany parametr w oknie dialogowym Wprowadzanie wartości parametru.

  • Jeśli korzystasz z programu Access 2007 lub nowszego, wykonaj następujące czynności:
    1. Na karcie Narzędzia bazy danych kliknij pozycję Dokumentator bazy danych w grupie Analizowanie.

    2. Kliknij kartę odpowiadającą szukanemu typowi obiektu bazy danych, a następnie kliknij, aby zaznaczyć pole wyboru zapytania, formularza lub raportu, który próbowano uruchomić.

      Uwaga Jeśli obiekt jest formularzem lub raportem, do listy zaznaczeń uwzględnij wszystkie zapytania źródłowe, podformularze i podraporty.

    3. Kliknij pozycję Opcje, aby określić, która funkcja wybranego obiektu ma zostać wydrukowana, a następnie kliknij przycisk OK.

    4. Kliknij przycisk OK, aby zamknąć okno dialogowe Dokumentator.

    5. W grupie Dane kliknij pozycję Plik tekstowy, a następnie wypełnij pozostałą część informacji zgodnie z potrzebami.

    6. Otwórz wyeksportowany plik w programie Microsoft Word, a następnie wyszukaj żądany parametr w oknie dialogowym Wprowadzanie wartości parametru.

Jeśli nie można uruchomić Dokumentatora bazy danych, sprawdź, czy brakuje odwołania. Najczęstszym brakującym odwołaniem w tym przypadku jest plik Utility.mda. Aby sprawdzić to odwołanie, wykonaj następujące czynności:

  1. W oknie Baza danych kliknij pozycję Moduły w obszarze Obiekty.

    Uwaga Jeśli korzystasz z programu Access 2007 lub nowszego, na karcie Narzędzia bazy danych kliknij pozycję Visual Basic, a następnie przejdź do kroku 3.

  2. Wybierz dowolny istniejący moduł, a następnie kliknij pozycję Projektowanie lub wstaw nowy moduł. Spowoduje to uruchomienie Edytora Visual Basic.

  3. W menu Narzędzia kliknij polecenie Odwołania.

  4. Na liście Dostępne odwołania odszukaj wszelkie odwołanie, w przypadku których przed nazwą znajduje się nazwa "BRAK:". Kliknij, aby wyczyścić to pole wyboru.

    UWAGA Jeśli nie potrzebujesz odwoływać się do pliku Utility.mda, przejdź do kroku 8.

  5. Kliknij przycisk Przeglądaj.

  6. Na liście Pliki typu kliknij pozycję Dodatki (*.mda).

  7. Przejdź do folderu zawierającego plik Utility.mda, zaznacz go, a następnie kliknij przycisk Otwórz. Domyślnie ten plik znajduje się w folderze C:\Program Files\Microsoft Office\Office\1033.

  8. Kliknij przycisk OK.

  9. W menu Debugowanie kliknij polecenie Kompilowanie nazwy bazy danych.

  10. W menu Plik kliknij polecenie Zamknij i wróć do programu Microsoft Access.

Więcej informacji

Procedura odtworzenia tego zachowania w programie Access 2002 lub Access 2003

Przestroga

Jeśli wykonajesz czynności opisane w tym przykładzie, zmodyfikuj przykładową bazę danych Northwind.mdb. Możesz wykonać kopię zapasową pliku Northwind.mdb i wykonać te czynności na kopii bazy danych.

  1. Otwórz przykładową bazę danych Northwind.mdb.
  2. Otwórz zapytanie Suma częściowa zamówień w widoku projektu.
  3. Zmień nazwę pola OrderID na OrderIDNumber.
  4. Zamknij zapytanie, a następnie kliknij przycisk Tak, aby zapisać zmiany.
  5. Uruchom zapytanie Order Subtotals (Suma częściowa zamówień).

Zwróć uwagę, że zostanie wyświetlone okno dialogowe Wprowadzanie wartości parametru.