Opis ograniczeń dotyczących pracy z tablicami w programie Excel

Uwaga

Nazwa usługi Office 365 ProPlus została zmieniona na Aplikacje usługi Microsoft 365 dla przedsiębiorstw. Aby uzyskać więcej informacji na temat tej zmiany, przeczytaj ten wpis w blogu.

Podsumowanie

W wersjach programu Microsoft Excel wymienionych w sekcji "Dotyczy" temat Pomocy "Specyfikacje obliczeń" zawiera listę ograniczeń dotyczących pracy z tablicą. Ten artykuł zawiera opis ograniczeń tablic w programie Excel.

Więcej informacji

W programie Excel tablice w arkuszach są ograniczone przez dostępną pamięć losową, całkowitą liczbę formuł tablicowych i regułę "cała kolumna".

Dostępna pamięć

Wersje programu Excel wymienione w sekcji "Dotyczy" nie nakładają limitu rozmiaru tablic arkuszy. Zamiast tego ogranicza Cię tylko dostępna pamięć komputera. Dlatego można tworzyć bardzo duże tablice, które zawierają setki tysięcy komórek.

Reguła "cała kolumna"

W programie Excel można tworzyć bardzo duże tablice, ale nie można utworzyć tablicy, która używa całej kolumny lub wielu kolumn komórek. Ponowne obliczanie formuły tablicowej wykorzystującej całą kolumnę komórek jest czasochłonne, dlatego program Excel nie zezwala na tworzenie tego rodzaju tablicy w formule.

Uwaga

W kolumnie w programie Microsoft Office Excel 2003 i wcześniejszych wersjach programu Excel znajduje się 65 536 komórek. W kolumnie w programie Microsoft Office Excel 2007 znajduje się 1 048 576 komórek.

Maksymalna liczba formuł tablicowych

W programie Excel 2003 i we wcześniejszych wersjach programu Excel pojedynczy arkusz może zawierać maksymalnie 65 472 formuły tablicowe odwołujące się do innego arkusza. Jeśli chcesz użyć więcej formuł, podziel dane na wiele arkuszy, aby jeden arkusz zawierał mniej niż 65 472 odwołania.

Na przykład w arkuszu Arkusz1 skoroszytu można utworzyć następujące elementy:

  • 65 472 formuły tablicowe odwołujące się do Arkusza2
  • 65 472 formuły tablicowe odwołujące się do arkusza Arkusz3
  • 65 472 formuły tablicowe odwołujące się do Arkusza4

Jeśli spróbujesz utworzyć więcej niż 65 472 formuły tablicowe odwołujące się do określonego arkusza, formuły tablicowe wejdą po numerze formuły tablicowej 65 472 mogą zniknąć po ich wprowadzeniu.

Przykłady formuł tablicowych

Poniżej przedstawiono listę przykładów formuł tablicowych. Aby użyć tych przykładów, utwórz nowy skoroszyt, a następnie wprowadź każdą formułę jako formułę tablicową. W tym celu wpisz formułę na pasku formuły, a następnie naciśnij klawisze CTRL+SHIFT+ENTER, aby wprowadzić formułę.

Excel 2007

  • A1: =SUMA(JEŻELI(B1:B1048576=0;1;0))

    Formuła w komórce A1 zwraca wynik 1048576. Ten wynik jest poprawny.

  • A2: =SUMA(JEŻELI(B:B=0;1;0))

    Formuła w komórce A2 zwraca wynik 1048576. Ten wynik jest poprawny.

  • A3: =SUMA(JEŻELI(B1:J1048576=0;1;0))

    Formuła w komórce A3 zwraca wynik 9437184. Ten wynik jest poprawny.

    Uwaga

    Obliczanie wyniku przez formułę może zająć dużo czasu, ponieważ formuła sprawdza ponad milion komórek.

  • A4: =SUMA(JEŻELI(B:J=0;1;0))

    Formuła w komórce A4 zwraca wynik 9437184. Ten wynik jest poprawny.

    Uwaga

    Obliczanie wyniku przez formułę może zająć dużo czasu, ponieważ formuła sprawdza ponad milion komórek.

  • A5: =SUMA(JEŻELI(B1:DD1048576=0;1;0))

    Po wprowadzeniu tej formuły w komórce A5 może zostać wyświetlony jeden z następujących komunikatów o błędzie:

    W programie Excel zabrakło zasobów podczas próby obliczenia jednej lub większej liczby formuł. W wyniku tego nie można oszacować tych formuł.

    Aby określić unikatowy numer skojarzony z odbieraną wiadomością, naciśnij klawisze CTRL+SHIFT+I. W prawym dolnym rogu tej wiadomości jest wyświetlana następująca liczba:

    101758

    W tym przypadku rozmiar tablicy arkusza jest za duży dla dostępnej pamięci. W związku z tym nie można obliczyć formuły.

    Ponadto może się wydawać, że program Excel przestanie odpowiadać na kilka minut. Wynika to z tego, że wprowadzona formuła musi ponownie wykonać obliczanie wyników.

    Po zakończeniu ponownego obliczania wyników program Excel odpowiada zgodnie z oczekiwaniami. Formuła w komórce A5 zwraca wartość 0 (zero).

Excel 2003 i wcześniejsze wersje programu Excel

  • A1: =SUMA(JEŻELI(B1:B65535=0;1;0))

    Formuła w komórce A1 zwraca wynik 65 535. Ten wynik jest poprawny.

  • A2: =SUMA(JEŻELI(B:B=0;1;0))

    Formuła w komórce A2 zwraca #NUM! ponieważ formuła tablicowa odwołuje się do całej kolumny komórek.

  • A3: =SUMA(JEŻELI(B1:J65535=0;1;0))

    Formuła w komórce A3 zwraca wynik 589815. Ten wynik jest poprawny.

    Uwaga

    Obliczanie wyniku przez formułę może zająć dużo czasu, ponieważ formuła sprawdza prawie 600 000 komórek.

  • A4: =SUMA(JEŻELI(B:J=0;1;0))

    Podobnie jak formuła w komórce A2, formuła w komórce A4 zwraca #NUM! ponieważ formuła tablicowa odwołuje się do całej kolumny komórek.

  • A5: =SUMA(JEŻELI(B1:DD65535=0;1;0))

    Po wprowadzeniu formuły w komórce A5 może zostać wyświetlony jeden z następujących komunikatów o błędzie:

    Za mało pamięci. Kontynuować bez cofania?

    Za mało pamięci.

    W tym przypadku rozmiar tablicy arkusza jest za duży dla dostępnej pamięci. W związku z tym nie można obliczyć formuły.

    Ponadto może się wydawać, że program Excel przestanie odpowiadać na kilka minut. Wynika to z tego, że wprowadzona formuła musi ponownie wykonać obliczanie wyników.

    Po zakończeniu ponownego obliczania wyników program Excel odpowiada zgodnie z oczekiwaniami. Formuła w komórce A5 zwraca wartość 0 (zero).

Pamiętaj, że żadna z tych formuł nie działa we wcześniejszych wersjach programu Excel. Wynika to z tego, że liczba tablic arkuszy tworzona przez formuły jest większa niż maksymalna liczba limitów we wcześniejszych wersjach programu Excel. Poniżej przedstawiono listę niektórych funkcji w programie Excel, które korzystają z tablic:

  • LINEST()
  • MDETERM()
  • MIN.ODW()
  • MMULT()
  • SUMA(JEŻELI())
  • SUMPRODUCT()
  • TRANSPONUJ()
  • TREND()

Uwaga

Poniższe fakty dotyczące tych funkcji są pomocne do zapamiętania.

  • Jeśli którakolwiek komórka w tablicy jest pusta lub zawiera tekst, funkcja MACIERZ.ODW zwraca #VALUE! .
  • Funkcja ODWROTNA zwraca również #VALUE! jeśli tablica nie ma równej liczby wierszy i kolumn.
  • Funkcja ODWROTNY zwraca #VALUE! jeśli zwrócona tablica ma więcej niż 52 kolumny na 52 wiersze.
  • Funkcja MMULT zwraca #VALUE! jeśli wynik przekracza 5460 komórek.
  • Funkcja MDETERM zwraca #VALUE! jeśli zwrócona tablica jest większa niż 73 wiersze na 73 kolumny.