Opis podpisów cyfrowych i podpisywania kodu w skoroszytach w programie Excel

Uwaga

Nazwa usługi Office 365 ProPlus została zmieniona na Aplikacje usługi Microsoft 365 dla przedsiębiorstw. Aby uzyskać więcej informacji na temat tej zmiany, przeczytaj ten wpis w blogu.

Podsumowanie

W programie Microsoft Office Excel 2003 i nowszych wersjach programu Excel można cyfrowo podpisać skoroszyt lub kod projektu makra. Dzięki temu będziesz mieć pewność, że jesteś ostatnią osobą, która wprowadza zmiany w skoroszycie lub projekcie makra.

Więcej informacji

Co to jest certyfikat cyfrowy?

Certyfikaty i podpisy cyfrowe zapewniają, że plik, który będzie używać, pochodzi z wiarygodnego źródła. Zapewniają one, że plik nie został naruszony.

Certyfikat cyfrowy to identyfikator przechowyty razem z plikiem. Aby sprawdzić poprawność podpisu, urząd certyfikacji sprawdza poprawność informacji na temat twórcy pliku, a następnie wydaje certyfikat cyfrowy. Certyfikat cyfrowy zawiera informacje o osobie, której został wystawiony certyfikat, a także informacje o certyfikacie, który go wystawił. Gdy do podpisania pliku jest używany certyfikat cyfrowy, ten identyfikator jest przechowywany razem z plikiem w weryfikowalnym formularzu, dzięki czemu może być wyświetlany użytkownikowi.

Co to jest podpis cyfrowy?

Program Excel używa podpisów cyfrowych w zawartości skoroszytu, aby zapewnić, że skoroszyt nie został zmodyfikowany i zapisany od czasu jego podpisania. Podpisy cyfrowe ułatwiają również odróżnianie skoroszytów i makr utworzonych na podstawie wiarygodnego źródła od chłoniania i uszkodzenia skoroszytów lub kodu makr (wirusów).

Podpis cyfrowy to certyfikat publiczny oraz wartość podpisanych danych zaszyfrowanych za pomocą klucza prywatnego. Wartość jest liczbą wygenerowaną przez algorytm kryptograficzny dla wszystkich danych, które mają zostać podpisać. Ten algorytm prawie nie umożliwia zmiany danych bez zmiany wartości wynikowej. Zaszyfrowanie wartości zamiast danych ułatwia użytkownikowi sprawdzenie, czy dane nie zostały zmienione, podpis cyfrowy.

Co się dzieje, gdy używam podpisu cyfrowego?

Można wyświetlać i edytować podpisane skoroszyty programu Excel, ale nie można modyfikować ani zapisywać podpisanego skoroszytu bez unieważniania podpisu. Na przykład możesz podpisać plik, a inni użytkownicy będą go wyświetlać. O ile plik pozostanie podpisany, inne osoby będą wiedzieć, że pochodzi od Ciebie i nie zostały zmodyfikowane.

Podpisywanie cyfrowe skoroszytu różni się od podpisywania kodu projektu makra języka Visual Basic for Applications (VBA). Można cyfrowo podpisać skoroszyt dla zawartości, a także podpisać kod projektu makra VBA w tym samym skoroszycie.

Jakie pliki programu Excel można podpisywać cyfrowo?

Możesz podpisać cyfrowo dowolny skoroszyt programu Excel lub szablon programu Excel. Jednak wersje programu Excel starsze niż Microsoft Excel 2002 nie rozpoznają podpisu cyfrowego.

Jeśli podpiszesz skoroszyt udostępniony cyfrowo, program Excel nie zachowa podpisu cyfrowego, ponieważ więcej niż jedna osoba może wprowadzać zmiany w skoroszycie. Ponadto nie można podpisywać kodu projektu makra, ponieważ program Excel nie umożliwia tworzenia i zmieniania projektów makr w skoroszycie po skonfigurowaniu go jako skoroszytu udostępnionego.

Jak mogę uzyskać podpis cyfrowy?

Aby uzyskać podpis cyfrowy, musisz mieć certyfikat cyfrowy.

Certyfikat cyfrowy lub identyfikator podpisywania kodu można uzyskać od komercyjnego urzędu certyfikacji, administratora zabezpieczeń wewnętrznych lub specjalisty IT.

Urząd certyfikacji może wydaje Ci certyfikat cyfrowy lub identyfikator podpisywania kodu bezpłatnie. Urząd certyfikacji dogłębnie sprawdza identyfikację przed wydaje certyfikatem cyfrowym.

Aby uzyskać więcej informacji na temat uzyskiwania podpisu cyfrowego lub identyfikatora podpisywania kodu, odwiedź następującą witrynę internetową firmy Microsoft:

Członkowie programu Microsoft Root Certificate Program

Za pomocą narzędzia pakietu SelfCert.exe pakietu Microsoft Office możesz utworzyć własny certyfikat cyfrowy do użytku osobistego lub do celów testowych. Ten certyfikat nie jest jednak uwierzytelniany przez urząd certyfikacji.

Jak dodać podpis cyfrowy do skoroszytu?

Aby dodać podpis cyfrowy do skoroszytu, wykonaj poniższe czynności, odpowiednio do wersji programu Excel, która jest uruchomiona.

Program Microsoft Office Excel 2007

  1. Kliknij przycisk pakietu Microsoft Office, wskaż pozycję Przygotuj, a następnie kliknij pozycję Dodaj podpis cyfrowy.

  2. Kliknij przycisk OK.

    Jeśli skoroszyt uległ zmianie i nie został jeszcze zapisany lub nie został zapisany w formacie skoroszytu programu Excel 2007, zostanie wyświetlony następujący komunikat:

    Aby można było dodawać podpisy, należy zapisać skoroszyt w formacie, który obsługuje podpisy cyfrowe.

    Chcesz zapisać skoroszyt jako skoroszyt programu Microsoft Office Excel?

  3. Kliknij przycisk Tak, aby wyświetlić okno dialogowe Zapisywanie jako. Aby dodać podpis cyfrowy, należy zapisać plik w formacie skoroszytu programu Excel (*.xlsx).

  4. Po zapisaniu skoroszytu zostanie wyświetlone okno dialogowe Uzyskaj identyfikator cyfrowy. Wybierz typ identyfikatora cyfrowego, którego chcesz użyć, a następnie kliknij przycisk OK.

Po zakończeniu niezbędnych czynności dla wybranego typu identyfikatora cyfrowego skoroszyt programu Excel zostanie podpisany.

Uwaga

  • Jeśli zapiszemy skoroszyt po dodaniu identyfikatora cyfrowego, ten identyfikator cyfrowy zostanie usunięty. Na przykład po kliknięciu przycisku pakietu Microsoft Office, a następnie kliknięciu przycisku Zapisz jako po cyfrowym podpisie skoroszytu zostanie wyświetlony następujący komunikat:

    Zapisanie kopii tego skoroszytu unieważni wszystkie podpisy w kopii.

    Czy chcesz kontynuować? Jeśli klikniesz przycisk Tak, identyfikator cyfrowy zostanie usunięty z kopii skoroszytu.

  • Po zamknięciu i ponownym otwarciu podpisanego skoroszytu na pasku tytułu programu Excel po nazwie skoroszytu będą wyświetlane słowa [Tylko do odczytu] (w nawiasach). Ponadto na pasku stanu jest wyświetlana ikona identyfikatora cyfrowego, a wyświetlany okienko zadań podpisów wskazuje, że do skoroszytu został dodany podpis cyfrowy.

    Aby sprawdzić, czy w podpisanym skoroszycie nie wpisano zmian, sprawdź, czy podpis cyfrowy jest widoczny w podpisie okienko zadań.

Excel 2003

  1. W menu Narzędzia kliknij polecenie Opcje.

  2. Na karcie Zabezpieczenia kliknij pozycję Podpisy cyfrowe.

  3. Kliknij pozycję Dodaj.

    Jeśli skoroszyt uległ zmianie i nie został jeszcze zapisany lub nie został zapisany w formacie skoroszytu programu Excel 2003, zostanie wyświetlony następujący komunikat:

    Aby można było cyfrowo podpisać ten skoroszyt, należy go zapisać jako skoroszyt programu Microsoft Excel. Czy chcesz zapisać skoroszyt?

  4. Kliknij przycisk Tak, aby wyświetlić okno dialogowe Zapisywanie jako. Aby dodać podpis cyfrowy, należy zapisać plik w formacie Skoroszyt programu Microsoft Excel.

  5. Po zapisaniu skoroszytu zostanie wyświetlone okno dialogowe Wybieranie certyfikatu. Wybierz certyfikat, którego chcesz użyć, a następnie kliknij przycisk OK.

  6. Kliknij przycisk OK, aby zamknąć okno dialogowe Podpisy cyfrowe.

Skoroszyt programu Excel jest teraz podpisany.

Uwaga

  • Jeśli zapiszemy skoroszyt po dodaniu podpisu cyfrowego, podpis cyfrowy zostanie usunięty. Na przykład po kliknięciu przycisku Zapisz w menu Plik po cyfrowym podpisie skoroszytu zostanie wyświetlony następujący komunikat:

    Zapisanie spowoduje usunięcie wszystkich podpisów cyfrowych w skoroszycie.

    Czy chcesz kontynuować? Jeśli klikniesz przycisk Tak, podpisy cyfrowe zostaną usunięte ze skoroszytu.

  • Po zamknięciu i ponownym otwarciu podpisanego skoroszytu na pasku tytułu programu Excel po nazwie skoroszytu będą wyświetlane wyrazy [Podpisane, niezweryfikowane] (w nawiasach). Oznacza to, że do skoroszytu został dodany podpis cyfrowy.

Aby sprawdzić, czy w podpisanym skoroszycie nie wystąpiły zmiany, wykonaj następujące czynności:

  1. W menu Narzędzia kliknij polecenie Opcje.
  2. Na karcie Zabezpieczenia kliknij pozycję Podpisy cyfrowe.
  3. Na karcie Podpisy, jeśli podpis cyfrowy jest wymieniony na liście Poniżej podpisano cyfrowo tę listę dokumentów, możesz mieć pewność, że plik nie uległ zmianie od momentu dodania podpisu cyfrowego do pliku.

Jak podpisać kod projektu makra?

Aby podpisać kod projektu makra języka Visual Basic for Applications, wykonaj następujące czynności:

  1. Otwórz skoroszyt zawierający projekt makra, który chcesz podpisać.

  2. Naciśnij klawisze ALT+F11, aby otworzyć Edytor Visual Basic.

  3. W Eksploratorze projektów wybierz projekt, który chcesz podpisać.

  4. W menu Narzędzia kliknij polecenie Podpis cyfrowy.

  5. Wykonaj jeden z następujących kroków:

    • Jeśli certyfikat cyfrowy nie został wcześniej wybrany lub chcesz użyć innego certyfikatu, kliknij pozycję Wybierz , wybierz certyfikat, a następnie kliknij dwa razy przycisk OK.
    • Aby użyć bieżącego certyfikatu, kliknij przycisk OK.