Pakiet Microsoft Office przestaje odpowiadać przy próbie otwarcia lub zapisania pliku

Uwaga

Nazwa usługi Office 365 ProPlus została zmieniona na Aplikacje usługi Microsoft 365 dla przedsiębiorstw. Aby uzyskać więcej informacji na temat tej zmiany, przeczytaj ten wpis w blogu.

Symptomy

Jeśli wykonasz jedną z poniższych procedur w jednym z programów pakietu Microsoft Office wymienionych na końcu tego artykułu, program może przez dłuższy czas przestać odpowiadać (zawieszać się):

  • Kliknij listę Zapisz w w oknie dialogowym Zapisywanie jako.
  • Należy kliknąć listę Szukaj w w oknie dialogowym Otwieranie.

Jeśli klikniesz przycisk Anuluj lub spróbujesz zamknąć okno dialogowe, program nadal nie odpowiada.

Przyczyna

Ten problem może wystąpić, jeśli zostanie spełnione jeden z następujących warunków:

  • Gdy komputer jest połączony z co najmniej jednym zamapowanym udziałów sieciowym, które nie są dostępne lub są obecnie w trybie offline.
  • Gdy co najmniej jedna zamapowana dysk jest trwała, a dysk należy do domeny, która nie jest zaufana.
  • Gdy zamapowany dysk znajduje się na komputerze wolno lub niżej. Komputer z poziomem poniżej znajduje się w sytuacji, gdy system operacyjny komputera ma wcześniejszą wersję systemu Microsoft Windows niż ten, z którym korzystasz).
  • Gdy zamapowany dysk jest połączony przez sieć wide area network (WAN).
  • Jeśli dysk jest dyskem wymiennym, który nie jest dostępny.

Rozwiązanie

Aby rozwiązać ten problem, należy odłączyć wszystkie dyski sieciowe, które mają dowolny z warunków określonych w sekcji "Przyczyna". W tym celu wykonaj następujące czynności.

Uwaga Ponieważ istnieje kilka wersji systemu Microsoft Windows, poniższe czynności mogą się różnić na Twoim komputerze. Jeśli tak, zapoznaj się z dokumentacją produktu, aby wykonać te czynności.

  1. Kliknij prawym przyciskiem myszy pozycję Mój komputer, a następnie kliknij polecenie Odłącz dysk sieciowy.
  2. W oknie dialogowym Odłączanie dysku sieciowego kliknij literę dysku, który chcesz rozłączyć, a następnie kliknij przycisk OK.
  3. Powtarzaj kroki 1 i 2 do momentu rozłączenia wszystkich dysków sieciowych trybu offline. Jeśli nie masz pewności co do określonego dysku, wykonaj następujące czynności:
    1. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.

    2. W polu Otwórz wpisz następujące informacje, a następnie naciśnij klawisz ENTER \ nazwa komputera #A0 nazwa_udostępniania

      Jeśli nazwa komputera to nazwa serwera współużytkowego zasobu, a nazwa udziału to nazwa zasobu udostępnionego, którego chcesz użyć.

      Jeśli zasób jest niedostępny, jest wyświetlany komunikat o błędzie podobny do następującego:

      Nie można odnaleźć nazwy sieci.

Możesz również spróbować wyświetlić zawartość dysku w Eksploratorze Windows.

Obejście problemu

Aby omieć to zachowanie, użyj jednej z następujących metod.

Metoda 1. Nie używaj połączeń trwałych

Po połączeniu zamapego dysku kliknij, aby wyczyścić pole wyboru Połącz ponownie przy logniu. Wyczyszczenie tego pola wyboru spowoduje, że mapowany dysk nie zostanie podłączony po następnym zalogowaniu się do komputera. Zobacz sekcję "Więcej informacji", aby uzyskać więcej informacji na temat mapowania dysku sieciowego.

Metoda 2. Używanie skryptu logowania użytkownika

Jeśli możesz, użyj skryptu logowania, aby połączyć użytkownika z odpowiednimi serwerami za każdym razem, gdy użytkownik się zaloguje. Upewnij się, że skrypt mapuje dysk w stanie nietrwałych. Jeśli dysk nie jest dostępny, ponieważ zostanie uruchomiony skrypt logowania, dysk nie zostanie zamapowany. To zachowanie zapobiega problemowi.

Metoda 3. Używanie dublowania serwera

Jeśli połączenie jest za pośrednictwem sieci WAN(Wide Area Network), rozważ zaimplementowanie dublowania serwera. Serwer klonuje duplikaty serwera zdalnego lokalnie. Następnie zamapuj dysk na lokalny, zduplikowany serwer. W ten sposób możesz skrócić czas oczekiwania, łącząc się z serwerem lokalnym.

Metoda 4. Używanie skrótu do lokalizacji sieciowej

Aby połączyć się z lokalizacją sieciową, użyj skrótu na pulpicie systemu Microsoft Windows lub w witrynie Moje miejsca sieciowe.

Więcej informacji

Każda lokalizacja na liście jest sprawdzana w celu upewnienia się, że jest dostępna i że masz uprawnienia dostępu podczas wykonywania obu poniższych procedur w programach pakietu Microsoft Office:

  • Próbujesz otworzyć lub zapisać plik.
  • Uzyskujesz dostęp do listy Szukaj w lub Zapisz w.

Jeśli dowolny zamapowany dysk znajduje się w stanie udokumentowanym w sekcji "Przyczyna", wykrycie i rozwiązanie warunku przez program pakietu Office zajmuje trochę czasu. Aby uniknąć tego zachowania, należy odłączyć zamapowany dysk. Dostępność dysku możesz sprawdzić w dowolnym momencie w Eksploratorze Windows. Jeśli dysk jest dostępny, zamapuj ten dysk sieciowy ponownie później.

Aby zamapować dysk na zasób, który jest ponownie w trybie online, wykonaj następujące czynności:

  1. Kliknij prawym przyciskiem myszy pozycję Mój komputer, a następnie kliknij polecenie Mapuj dysk sieciowy.

  2. W polu Dysk kliknij literę dysku, którego chcesz użyć dla dysku sieciowego.

  3. W polu Folder wpisz następującą \ nazwę komputera\nazwa_udziału

    Jeśli nazwa komputera to nazwa serwera współużytkowego zasobu, a nazwa udziału to nazwa zasobu udostępnionego, którego chcesz użyć.

  4. Aby zamapowany dysk nie był trwały, kliknij pole wyboru Połącz ponownie przy logniu, aby usunąć trwałe połączenie.

  5. Kliknij przycisk Zakończ.

Jeśli próbujesz nawiązać połączenie z zasobami w innych sieciach, skontaktuj się z administratorem sieci. Dyski sieciowe, które już nie istnieją, nie są już udostępniane lub niedostępne na wymiennych dyskach wymiennych, należy rozłączyć trwale, aby uniknąć wpływania na wydajność produktów pakietu Office.