Jak eksportować slajdy o wysokiej rozdzielczości (high-dpi) z programu PowerPoint

Uwaga

Nazwa usługi Office 365 ProPlus została zmieniona na Aplikacje usługi Microsoft 365 dla przedsiębiorstw. Aby uzyskać więcej informacji na temat tej zmiany, przeczytaj ten wpis w blogu.

Rozdzielczość eksportu w programie Microsoft PowerPoint można zmienić, zapisując slajd w formacie obrazu. Istnieją dwa kroki tego procesu: za pomocą rejestru systemowego, aby zmienić domyślne ustawienie rozdzielczości dla eksportowanych slajdów, a następnie faktycznie zapisania slajdu jako obraz w nowej rozdzielczości.

Krok 1: Zmień ustawienia rozdzielczości eksportu

Ważne

Należy rozważnie wykonywać czynności podane w tej sekcji. Niepoprawne zmodyfikowanie rejestru może być przyczyną poważnych problemów. Przed zmodyfikowaniem rejestru należy utworzyć jego kopię zapasową, aby móc przywrócić rejestr na wypadek problemów.

Domyślnie rozdzielczość eksportu slajdu programu PowerPoint, który chcesz zapisać jako obraz, wynosi 96 punktów na cal (dpi). Aby zmienić rozdzielczość eksportu, wykonaj następujące czynności:

  1. Zakończ działanie wszystkich programów opartych na systemie Windows.

  2. Kliknij prawym przyciskiem myszy przycisk Start, a następnie kliknij polecenie Uruchom. (W systemie Windows 7 kliknij przycisk Start, a następnie kliknij polecenie Uruchom).

  3. W polu Otwórz wpisz polecenie regedit, a następnie kliknij przycisk OK.

  4. Zlokalizuj jeden z następujących podkluczy rejestru, w zależności od używanej wersji programu PowerPoint:

    PowerPoint 2016, 2019, PowerPoint dla Office 365

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\PowerPoint\Options

    PowerPoint 2013

    HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\PowerPoint\Options

    PowerPoint 2010

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\PowerPoint\Options

    PowerPoint 2007

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\PowerPoint\Options

    PowerPoint 2003

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\PowerPoint\Options

  5. Kliknij podklucz Opcje, wskaż polecenie Nowy w menu Edycja, a następnie kliknij polecenie Wartość DWORD (32-bit).

  6. Wpisz ciąg ExportBitmapResolution, a następnie naciśnij klawisz Enter.

  7. Upewnij się, że jest zaznaczona opcja ExportBitmapResolution, a następnie kliknij polecenie Modyfikuj w menu Edycja.

  8. W oknie dialogowym Edytowanie wartości DWORD wybierz opcję Dziesiętny.

  9. W polu Dane wartości określ rozdzielczość na 300. Lub użyj parametrów z poniższej tabeli.

    Wartość dziesiętna Piksele pełnoekranowe (poziome × pionowe) Piksele panoramiczne (poziome × pionowe) Kropki na cal (poziome i pionowe)
    50 500 × 375 667 × 375 50 dpi
    96 (domyślnie) 960 × 720 1280 × 720 96 dpi
    100 1000 × 750 1333 × 750 100 dpi
    150 1500 × 1125 2000 × 1125 150 dpi
    200 2000 × 1500 2667 × 1500 200 dpi
    250 2500 × 1875 3333 × 1875 250 dpi
    300 3000 × 2250 4000 × 2250 300 dpi

    Uwaga

    Więcej informacji odnośnie do ustawiania tej wartości można znaleźć w sekcji Ograniczenia.

  10. Wybierz przycisk OK.

  11. W menu Plik wybierz polecenie Zakończ, aby zamknąć Edytor rejestru.

Krok 2: Eksportowanie slajdu jako obrazu

  1. W programie PowerPoint otwórz prezentację slajdów, a następnie otwórz slajd, który chcesz wyeksportować.

  2. W menu Plik kliknij polecenie Zapisz jako.

  3. W polu Zapisz jako typ wybierz jeden z następujących formatów obrazów:

    • Format GIF Graphics Interchange (.gif)
    • Format JPEG File Interchange (*.jpg)
    • Format PNG Portable Network Graphics (*.png)
    • Format TIFF Tag Image File (*.tif)
    • Mapa bitowa niezależna od urządzenia (*.bmp)
    • Metaplik systemu Windows (*.wmf)
    • Ulepszony metaplik systemu Windows (*.emf)

    Uwaga

    Możesz zmienić lokalizację zapisu obrazu w polu Zapisz w. Możesz również zmienić nazwę obrazu w polu Nazwa pliku.

  4. Wybierz Zapisz. Zostanie wyświetlony monit z następującym oknem dialogowym:

    Wybierz tylko bieżący slajd.

    Wybierz Tylko bieżący slajd. Slajd zostanie zapisany w nowym formacie i rozdzielczości w lokalizacji określonej w polu Zapisz w.

  5. Aby sprawdzić, czy slajd jest zapisany w określonej rozdzielczości, kliknij prawym przyciskiem myszy obraz, a następnie wybierz polecenie Właściwości.

Ograniczenia

Podczas ustawiania wartości rejestru ExportBitmapResolution w programie PowerPoint należy wziąć pod uwagę ograniczenie maksymalnego DPI w niektórych wersjach programu PowerPoint.

Maksymalna wartość DPI zależy od rozmiaru slajdu. Wzór jest następujący: maxdpi = (sqrt(100 000 000 / (szerokość slajdu * wysokość slajdu))), gdzie szerokość slajdu / wysokość są podane w calach.

Na przykład dla standardowego slajdu 13,3" x 7,5" równanie to: sqrt(100 000 000 / (13 333 * 7,5) ) = 1000.

PowerPoint 2019, 2016, 2013 i 365

Nie ma ustalonego limitu DPI. Eksport slajdów jest ograniczony tylko przez wielkość wynikowej mapy bitowej. PowerPoint może obsługiwać tworzenie map bitowych o rozdzielczości do ~100 000 000 pikseli (szerokość x wysokość). Dla standardowych slajdów panoramicznych (13,3" x 7,5") oznacza to maksymalną DPI 1 000. Dla starszych slajdów (10" x 7,5") oznacza to maksymalną DPI 1 155.

PowerPoint 2010 i starsze

Maksymalna rozdzielczość eksportowana przez program PowerPoint wynosi 3 072 pikseli na podstawie najdłuższej krawędzi slajdu. Na przykład standardowy slajd 10" × 7,5" ma maksymalną efektywną wartość DPI 307. Wynik 3 070 pikseli (10 × 307 = 3 070) mieści się w limicie 3 072. Jednak każde ustawienie DPI, które jest większe niż 307 dla standardowego slajdu powraca do limitu 3 072.

Wartość dziesiętna Piksele (poziome × pionowe) Kropki na cal (poziome i pionowe)
307 3072 × 2304 307 dpi

Limit 3 072 pikseli dotyczy również programowania zapisywania slajdu.

Na przykład następujący kod programowo zapisuje obraz o wymiarach 3072 × 2304 pikseli:

ActiveWindow.Selection.SlideRange(1).export
"c:\<filename>.jpg","JPG",4000,3000

Więcej informacji

Aby uzyskać informacje dotyczące zmiany rozmiaru slajdów, zobacz artykuł Zmiana rozmiaru slajdów.