Program PowerPoint nie może załadować dodatku, gdy poziom zabezpieczeń makr jest niższy

Uwaga

Nazwa usługi Office 365 ProPlus została zmieniona na Aplikacje usługi Microsoft 365 dla przedsiębiorstw. Aby uzyskać więcej informacji na temat tej zmiany, przeczytaj ten wpis w blogu.

Symptomy

Jeśli obniżysz poziom zabezpieczeń makr w programie Microsoft PowerPoint, a następnie otworzysz plik dodatku programu PowerPoint (*.ppa), nowy poziom zabezpieczeń makr może nie zostać zastosowany i plik dodatku może nie działać zgodnie z oczekiwaniami. Dodatek jest wyświetlany jako dostępny dodatek w oknie dialogowym programu Add-Ins, ale to pole wyboru nie jest zaznaczone i podczas próby zaznaczania pola wyboru jest wyświetlany komunikat o błędzie podobny do następującego:

Program PowerPoint nie może załadować dodatku nazwa pliku.

Przyczyna

To zachowanie może wystąpić, jeśli spełnione są następujące warunki:

  1. Próba otwarcia pliku dodatku programu PowerPoint jest podejmowana przy użyciu polecenia Otwórz w menu Plik, gdy poziom bezpieczeństwa makr jest ustawiony na Wysoki.
  2. Obniżasz ustawienie poziomu zabezpieczeń makr.
  3. Ten sam plik dodatku programu PowerPoint można otworzyć przy użyciu polecenia Otwórz w menu Plik.

Podczas próby otwarcia pliku dodatku, gdy dodatek nie jest ładowany z powodu zabezpieczeń makr, program PowerPoint tymczasowo przechowuje (buforuje) informacje o błędach w celu załadowania tego dodatku. Program PowerPoint nie może załadować dodatku po obniżeniu poziomu zabezpieczeń makr, dopóki nie wyczyści informacji w pamięci podręcznej.

Obejście problemu

Aby go usunąć, wyczyść informacje przechowywane w pamięci podręcznej, a następnie załaduj dodatek, korzystając z jednej z poniższych metod po zmianie ustawienia na poziomie bezpieczeństwa makr.

Metoda 1. Zamykanie i ponowne uruchamianie programu PowerPoint

  1. Zamknij program PowerPoint.
  2. Uruchom ponownie program PowerPoint.
  3. Otwórz plik dodatku.
  4. Kliknij pozycję Zgadzam się, aby załadować dodatek.

Metoda 2. Usuwanie i dodawanie dodatku

Aby usunąć i dodać dodatek w programie PowerPoint 2002, wykonaj następujące czynności:

  1. W menu Narzędzia kliknij polecenie Dodatki.
  2. Na liście Add-Ins dodatku kliknij go, a następnie kliknij przycisk Usuń.
  3. Kliknij pozycję Dodaj nowy, wybierz dodatek, kliknij przycisk OK, kliknij pozycję "Zgadzam się", aby załadować dodatek, a następnie kliknij przycisk Zamknij.

Aby usunąć dodatek w programie PowerPoint 2007, wykonaj następujące czynności:

  1. Kliknij przycisk pakietu Microsoft Office, kliknij pozycję Opcje programu PowerPoint, a następnie kliknij pozycję Dodatki.
  2. Na liście Zarządzaj wybierz pozycję Dodatki programu PowerPoint, a następnie kliknij przycisk Przejdź.
  3. Na liście Dostępne dodatki zaznacz dodatek, który chcesz usunąć, kliknij pozycję Usuń , a następnie kliknij przycisk Zamknij.

Aby dodać dodatek w programie PowerPoint 2007, wykonaj następujące czynności:

  1. Kliknij przycisk pakietu Microsoft Office, kliknij pozycję Opcje programu PowerPoint, a następnie kliknij pozycję Dodatki.
  2. Na liście Zarządzaj kliknij pozycję Dodatki programu PowerPoint, a następnie kliknij przycisk Przejdź.
  3. W oknie dialogowym Dodatki kliknij pozycję Dodaj nowy.
  4. W oknie dialogowym Dodawanie nowego dodatku programu PowerPoint wyszukaj dodatek, który chcesz dodać, a następnie kliknij przycisk OK.
  5. Zostanie wyświetlone powiadomienie o zabezpieczeniach. Jeśli masz pewność, że dodatek pochodzi z zaufanego źródła, kliknij pozycję Włącz makra, a następnie kliknij przycisk Zamknij.

Stan

Firma Microsoft potwierdziła, że jest to problem w produktach firmy Microsoft wymienionych w sekcji "Dotyczy".

Procedura odtworzenia problemu

PowerPoint 2007

  1. Uruchom program PowerPoint 2007.

  2. Na karcie Deweloper kliknij pozycję Bezpieczeństwo makr w grupie Kod.

    Uwaga

    Domyślnie karta Deweloper może nie być wyświetlana. Aby wyświetlić kartę Deweloper, kliknij przycisk pakietu Microsoft Office, kliknij pozycję Opcje programu PowerPoint, wybierz pozycję Pokaż kartę Deweloper na Wstążce w obszarze Najważniejsze opcje pracy z programem PowerPoint, a następnie kliknij przycisk OK.

  3. Na stronie Centrum zaufania w obszarze Ustawienia makr wybierz pozycję Wyłącz wszystkie makra z powiadomieniem , a następnie kliknij przycisk OK.

  4. W menu Office kliknij polecenie Otwórz.

  5. W polu listy rozwijanej Pliki typu kliknij strzałkę, wybierz pozycję Dodatki programu PowerPoint(ppam;. ppa), wybierz dodatek, a następnie kliknij przycisk Otwórz.

    Uwaga

    Dodatek nie ładuje się zgodnie z oczekiwaniami.

  6. Na karcie Deweloper kliknij pozycję Bezpieczeństwo makr w grupie Kod.

  7. Na stronie Centrum zaufania wybierz pozycję Włącz wszystkie makra (zalecane; może zostać uruchomiony niebezpieczny kod) w obszarze Ustawienia makr , a następnie kliknij przycisk OK.

  8. W menu Office kliknij polecenie Otwórz.

  9. W polu listy rozwijanej Pliki typu kliknij strzałkę, wybierz pozycję Dodatki programu PowerPoint(ppam;. ppa), wybierz dodatek, a następnie kliknij przycisk Otwórz.

    Uwaga

    Nie zostanie wyświetlony monit o włączenie lub wyłączenie makra. Ponadto dodatek nadal nie ładuje się.

PowerPoint 2002

  1. Uruchom program PowerPoint.

  2. W menu Narzędzia wskaż polecenie Makro, a następnie kliknij polecenie Zabezpieczenia.

  3. Na karcie Poziom zabezpieczeń kliknij pozycję Wysoki.

  4. W menu Plik kliknij polecenie Otwórz.

  5. W polu Pliki typu kliknij strzałkę, wybierz pozycję Dodatki programu PowerPoint, wybierz dodatek, a następnie kliknij przycisk Otwórz.

    Uwaga

    Dodatek nie ładuje się zgodnie z oczekiwaniami.

  6. W menu Narzędzia wskaż polecenie Makro, a następnie kliknij polecenie Zabezpieczenia.

  7. Na karcie Poziom zabezpieczeń kliknij pozycję Średni.

  8. W menu Plik kliknij polecenie Otwórz.

  9. W polu Pliki typu kliknij strzałkę, wybierz pozycję Dodatki programu PowerPoint, wybierz dodatek, a następnie kliknij przycisk Otwórz.

    Uwaga

    Nie zostanie wyświetlony monit o włączenie lub wyłączenie makra, a dodatek nadal nie zostanie załadowany.