Sposób obliczania pracy i czasu trwania w przypadku zmian przydziału

Uwaga

Nazwa usługi Office 365 ProPlus została zmieniona na Aplikacje usługi Microsoft 365 dla przedsiębiorstw. Aby uzyskać więcej informacji na temat tej zmiany, przeczytaj ten wpis w blogu.

Podsumowanie

W tym artykule opisano sposób obliczania pracy i czasu trwania podczas zmieniania przydziałów zasobów.

Więcej informacji

W przypadku wielokrotnego zmieniania przydziałów zasobów w zadaniu o nakład pracy w tej samej sesji edycji program Microsoft Project oblicza pracę przy użyciu następującej formuły:

Praca = Praca całkowita * (Jednostki zasobów/Całkowita liczba jednostek zasobu)

Jeśli na przykład masz zadanie 2-dniowe (2d), w którym zasób (W1) jest przydzielony 200%, to zadanie 2D czasu trwania jest obliczane do 32 godzin (32 godz.) pracy. Jeśli dodasz do zadania nowy zasób (W2), program Microsoft Project obliczy dla każdego zasobu pracę i czas trwania w następujący sposób:

Praca zasobu R1:

21.33h = 32h Total Work * (200% R1 Units/300% Total Units)

Praca zasobu R2:

10.67 = 32h Total Work * (100% R2 Units/300% Total Units)

UWAGA: Całkowita liczba jednostek (300%) są obliczane przez dodanie jednostki zasobu R1 (200%) i jednostkę zasobu W2 (100%).

Obliczanie czasu trwania zadania T1:

2.67d = 21.33h (R1 Total Work)/100% (R1 Units based on 8 hour day)

1.33d = 10.67h (R2 Total Work)/100% (R2 Units based on 8 hour day)

Czas trwania zadania zmienia się z 2d na 2,67d ze względu na czas niezbędny do ukończenia przydzielonej pracy przez zasób jazdy. Zasób jazdy dla zadania jest określany jako najwyższy stosunek pracy/jednostek dla wszystkich przydziałów zasobów w zadaniu. W tym przykładzie R1 jest zasobem kierującym, ponieważ wartość 2,67d jest wyższa niż 1,33d. Na podstawie 8-godzinnego dnia ukończenie pracy zajmie 21,33 godz. R1 2,67d.

Procedura powtarzania w programie Project 2013

  1. Tworzenie nowego pustego projektu
  2. Ustaw nowe zadanie jako Planowane automatycznie. Wprowadź nowe zadanie o nazwie T1 z czasem trwania 2 dni.
  3. Na wstążce Widok w sekcji Widok dzielony wyczyść pole wyboru Oś czasu i zaznacz pole wyboru Szczegóły.
  4. Kliknij prawym przyciskiem myszy okienko Szczegóły i kliknij pozycję Harmonogram.
  5. Aby wykonać pozostałe kroki, użyj programu Project 2010 z kroku 6.

Procedura powtarzania w programie Project 2010

  1. Tworzenie nowego pustego projektu.

  2. Ustaw dla opcji Nowe zadania wartość Automatyczne zaplanowane. Wprowadź nowe zadanie (T1). Ustaw czas trwania na dwa dni.

  3. Na karcie Widok kliknij pole wyboru Widoku szczegółów, aby podzielić okno.

  4. Naciśnij klawisz F6. Dolne okienko staje się aktywnym okienkiem.

  5. Na karcie Formatowanie kliknij pozycję Harmonogram.

  6. Kliknij, aby zaznaczyć pole wyboru Nakład pracy, a następnie kliknij przycisk OK.

  7. Naciśnij klawisz F6. Górne okienko staje się aktywnym okienkiem.

  8. Wybierz zadanie T1.

  9. Na karcie Zasób kliknij pozycję Przydziel zasoby.

  10. W oknie dialogowym Przydzielanie zasobu wprowadź dwa zasoby: R1 i R2.

  11. Wybierz pozycję W1. W kolumnie Jednostki wpisz 200%, a następnie kliknij przycisk Przypisz.

    UWAGA Dolne okienko R1 jest przypisane w 200% dla 32 godzin pracy.

  12. Wybierz pozycję R2, a następnie kliknij przycisk Przypisz. Kliknij przycisk Zamknij.

    UWAGA Dolne okienko R1 jest przypisane w 100% dla 21,33 godz. pracy, podczas gdy R2 ma 100% dla 10,67 godz. pracy.

Procedura powtarzania w programie Project 2007 i wcześniejszych wersjach

  1. W menu Plik kliknij polecenie Nowy. Jeśli zostanie wyświetlone okno dialogowe Informacje podsumowujące, kliknij przycisk OK.

  2. Wprowadź nowe zadanie (T1). Ustaw czas trwania na dwa dni.

  3. W menu Okno kliknij polecenie Podziel.

  4. Naciśnij klawisz F6.

    Dolne okienko staje się aktywnym okienkiem.

  5. W menu Format wskaż polecenie Szczegóły, a następnie kliknij pozycję Harmonogram zasobów.

  6. Kliknij, aby zaznaczyć pole wyboru Nakład pracy, a następnie kliknij przycisk OK.

  7. Naciśnij klawisz F6.

    Górne okienko staje się aktywnym okienkiem.

  8. Wybierz zadanie T1.

  9. W menu Narzędzia wskaż polecenie Zasoby, a następnie kliknij polecenie Przydziel zasoby.

  10. W oknie dialogowym Przydzielanie zasobów wprowadź dwa zasoby: R1 i R2.

  11. Wybierz pozycję W1. W kolumnie Jednostki wpisz 200%, a następnie kliknij przycisk Przypisz.

    UWAGA Dolne okienko R1 jest przypisane w 200% dla 32 godzin pracy.

  12. Wybierz pozycję R2, a następnie kliknij przycisk Przypisz. Kliknij przycisk Zamknij.

    UWAGA Dolne okienko R1 jest przypisane w 100% dla 21,33 godz. pracy, podczas gdy R2 ma 100% dla 10,67 godz. pracy.