Automatyczne uruchamianie makra podczas uruchamiania programu Project

Oryginalny numer KB:   128622

Podsumowanie

Aby makro było uruchamiane automatycznie przy każdym uruchomieniu programu Microsoft Project za pomocą ikony programu Microsoft Project, należy zmodyfikować wiersz polecenia dla właściwości ikony tak, aby przy uruchamianiu był automatycznie otwierany projekt zawierający makro programu Auto_Open.

Więcej informacji

Wykonanie poniższych czynności spowoduje wykonanie makra programu Auto_Open po uruchomieniu programu Microsoft Project przez dwukrotne kliknięcie ikony skrótu programu Microsoft Project lub dwukrotne kliknięcie pliku programu Microsoft Project, który zawiera Auto_Open programu.

W programie Project 2013 i 2010 należy wykonać następujące czynności:

  1. Tworzenie nowego projektu.

    Uwaga

    W tym przykładzie projekt ma nazwę AUTOSTART. Format MPP, ale można użyć dowolnej prawidłowej nazwy pliku.

  2. Z menu Widok wybierz polecenie Makra, a następnie kliknij polecenie Wyświetl makra.

  3. Zacznij wpisywać nową nazwę makra o nazwie "Auto_Open" i kliknij przycisk Utwórz. Zostanie otwarte okno microsoft Visual Basic for Applications.

  4. W edytorze VBA wprowadź kod, który ma być uruchamiany przy każdym uruchomieniu programu Microsoft Project.

  5. Z menu Plik redaktora wybierz polecenie Zapisz URUCHAMIANIE. W programie MPP w menu Plik kliknij polecenie Zamknij i wróć do programu Microsoft Project.

  6. Zapisz plan i zamknij program Microsoft Project. Przy następnym otwarciu tego planu zostanie uruchomione makro Auto_Open zostanie uruchomione po odpowiedzi Tak w celu włączenia makr.

    Uwaga

    Makro Auto_Open może także uruchamiać inne makra. Jeśli na przykład w globalnej sieci istnieje tylko jedno makro. Plik MPT o nazwie "MyStartup" i jeśli nie przyjmuje żadnych argumentów, oznacza to Auto_Open uruchomić go przy użyciu makra "MyStartup".

  7. Utwórz skrót na pulpicie dla programu Microsoft Project. Plik wykonywalny nosi nazwę WINPROJ.EXE.

  8. Kliknij skrót prawym przyciskiem myszy i kliknij polecenie Właściwości. W programie Target dołącz ścieżkę do zapisanego uruchomienia planu. MPP. Na przykład: c:\winproj\winproj.exe c:\data\Startup.mpp, kliknij przycisk OK.

Uwaga

Makro Auto_Open może także uruchamiać inne makra. Jeśli na przykład w globalnej sieci istnieje tylko jedno makro. Plik MPT o nazwie "MyStartup" i jeśli nie przyjmuje żadnych argumentów, oznacza to Auto_Open uruchomić go przy użyciu makra "MyStartup".

Wykonaj poniższe czynności dla starszych wersji programu Microsoft Project:

  1. Tworzenie nowego projektu.

    Uwaga

    W tym przykładzie projekt ma nazwę AUTOSTART. Format MPP, ale można użyć dowolnej prawidłowej nazwy pliku.

  2. W menu Narzędzia wybierz pozycję Makra, a następnie wybierz przycisk Nowy. Wybierz pozycję Opcje, a następnie w obszarze Przechowaj makro w wybierz pozycję Bieżący plik projektu.

  3. W polu Nazwa makra wpisz tekst Auto_Open i wybierz przycisk OK.

  4. Wykonaj kroki od 4 do 8 powyżej.

Jeśli nie chcesz, aby makro Auto_Open uruchamianiu. Aby uruchomić program Microsoft Project, naciśnij i przytrzymaj klawisz SHIFT podczas uruchamiania programu Microsoft Project.

Program Microsoft Project nie tworzy automatycznie pustego programu Project1, gdy ikona jest tak ustawiona, aby automatycznie otwierała projekt. Aby utworzyć nowy projekt, możesz użyć metody FileNew w makrze Auto_Open uruchomieniu. MPP.

Jeśli chcesz zamknąć uruchamianie. Po uruchomieniu programu Microsoft Project w celu jego zamknięcia dodaj kod do Auto_Open MPP. Na przykład następujące wiersze aktywują AUTOSTART. W tym celu zamknij go bez zapisywania zmian:

Projects("Startup.mpp").Activate
FileClose save:=pjDoNotSave