Błąd podczas próby włączenia lub wyłączenia archiwaowej skrzynki pocztowej dla użytkownika usługi Exchange Online lub przeniesienia skrzynki pocztowej do środowiska lokalnego

Uwaga

Nazwa usługi Office 365 ProPlus została zmieniona na Aplikacje usługi Microsoft 365 dla przedsiębiorstw. Aby uzyskać więcej informacji na temat tej zmiany, przeczytaj ten wpis w blogu.

Oryginalny numer KB:   3050691

Problem

Gdy próbujesz włączyć lub wyłączyć archiwacyjną skrzynkę pocztową dla istniejącego użytkownika usługi Exchange Online lub podczas próby przeniesienia skrzynki pocztowej z usługi Exchange Online do środowiska lokalnego, jest wyświetlany komunikat o błędzie podobny do jednego z następujących:

Błąd: UserAlreadyBeingMigratedException: Użytkownik <User Email Address> ' ma już oczekujące żądanie. Usuń istniejące żądanie i wznów bieżącą partię lub uruchom nową partię dla tego użytkownika.

Z <User Display Name> skrzynką pocztową ' jest skojarzone ukończone żądanie przeniesienia. Przed utworzeniem nowego żądania przeniesienia dla skrzynki pocztowej uruchom polecenie cmdlet Remove-MoveRequest, aby wyczyścić ukończone żądanie przeniesienia.

Skrzynka <User Display Name> pocztowa ' ma stan przenoszenia <move status> . Podczas przenoszenia skrzynki pocztowej nie można włączyć ani wyłączyć archiwum.

Po uruchomieniu polecenia w celu sprawdzenia żądania przeniesienia należy sprawdzić, czy żądanie jest żądaniem przeniesienia do centrum danych usługi Get-MoveRequest | fl Office 365. Jest to wskazywane flagą IntraOrg.

Przyczyna

Ten problem występuje, ponieważ nieudane żądania przeniesienia nie są jeszcze usuwane z systemu.

Aby zachować kondycję usługi, usługa Exchange Online regularnie przenosi skrzynki pocztowe między różnymi serwerami. Ukończone żądania przeniesienia do centrum danych usługi Office 365 są szybko czyszczone. Nieudane żądania przeniesienia do centrum danych usługi Office 365 mogą pozostać nieco dłuższe, ale po pewnym czasie nadal są czyszczone. Żądania przeniesienia, których nie powiodło się, nie mają wpływu na użytkowników. Usługa ponowi próbę przeniesienia w przyszłości, jeśli będzie to wymagane.

Rozwiązanie

Ogólnie rzecz biorąc, jeśli przeniesienie wewnętrznego centrum danych nie wpływa na możliwość wykonywania zadań administracyjnych, możesz bezpiecznie zignorować komunikaty o błędach.

Jeśli żądania przeniesienia mają wpływ na zadania zarządzania, wykonaj następujące czynności:

  1. Połącz się z usługą Exchange Online przy użyciu zdalnego programu Windows PowerShell. Aby uzyskać więcej informacji, zobacz Nawiązywanie połączenia z usługą Exchange Online przy użyciu zdalnej pracy programu PowerShell.

  2. Sprawdź, czy skrzynka pocztowa jest przenoszony. Aby to zrobić, uruchom następujące polecenie:

    Get-MoveRequest | fl Status, Protect, "Display Name", Identity
    

    Jeśli symbol zastępczy "Nazwa wyświetlana" odpowiada skrzynce pocztowej, dla której chcesz włączyć lub wyłączyć archiwizację, przenoszenie skrzynki pocztowej jest w toku. Przeniesienie uniemożliwia zmianę.

  3. Sprawdź wyniki, a następnie wykonaj jedną z następujących czynności, odpowiednio do potrzeb:

    • Jeśli stan jest w kolejce lub inprogre, poczekaj na zakończenie przenoszenia. Powinno to wystąpić za jeden lub dwa dni. Jeśli nie możesz doczekać się tak długo, usuń żądanie przeniesienia, uruchamiając następujące polecenie:

      Remove-MoveRequest -Identity IdentityOfFailedRequest
      
    • Jeśli stan jest nieudany, usuń żądanie przeniesienia, uruchamiając następujące polecenie:

      Remove-MoveRequest -Identity IdentityOfFailedRequest
      

Ta operacja nie powinna mieć wpływu na dostęp użytkownika ani nie powodować żadnych problemów. Ponadto nie musisz powiadamiać firmy Microsoft ani właściciela skrzynki pocztowej o tej czynności.

Więcej informacji

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.