Błąd podczas próby włączenia lub wyłączenia archiwum skrzynki pocztowej dla użytkownika Exchange Online lub przeniesienia skrzynki pocztowej do środowiska lokalnego

Oryginalny numer KB: 3050691

Problem

Podczas próby włączenia lub wyłączenia archiwum skrzynki pocztowej dla istniejącego użytkownika Exchange Online lub podczas próby przeniesienia skrzynki pocztowej z Exchange Online do środowiska lokalnego zostanie wyświetlony komunikat o błędzie podobny do jednego z następujących:

Błąd: UserAlreadyBeingMigratedException: użytkownik "<User Email Address>" ma już oczekujące żądanie. Usuń istniejące żądanie i wznów bieżącą partię lub uruchom nową partię dla tego użytkownika.

Skrzynka pocztowa "<Nazwa> wyświetlana użytkownika" ma skojarzone ukończone żądanie przeniesienia. Przed utworzeniem nowego żądania przeniesienia dla skrzynki pocztowej uruchom polecenie cmdlet Remove-MoveRequest, aby wyczyścić ukończone żądanie przeniesienia.

Skrzynka pocztowa "<Nazwa> wyświetlana użytkownika" ma stan> przenoszenia stanu <przenoszenia. Nie można włączyć ani wyłączyć archiwum podczas przenoszenia skrzynki pocztowej.

Po uruchomieniu polecenia w Get-MoveRequest | fl celu zbadania żądania przeniesienia należy sprawdzić, czy żądanie jest żądaniem przeniesienia centrum danych platformy Microsoft 365. Wskazuje to flaga IntraOrg.

Przyczyna

Ten problem występuje, ponieważ żądania przeniesienia zakończone niepowodzeniem nie zostały jeszcze usunięte z systemu.

Aby zachować kondycję usługi, Exchange Online regularnie przenosi skrzynki pocztowe między różnymi serwerami. Ukończone żądania przeniesienia centrum danych platformy Microsoft 365 są bardzo szybko czyszczone. Nieudane żądania przeniesienia centrum danych platformy Microsoft 365 mogą pozostać nieco dłuższe, ale nadal są czyszczone po pewnym czasie. Te żądania przeniesienia zakończone niepowodzeniem nie mają wpływu na użytkowników. Jeśli jest to wymagane, usługa ponowi próbę przeniesienia w przyszłości.

Rozwiązanie

Ogólnie rzecz biorąc, jeśli przeniesienie wewnętrznego centrum danych nie ma wpływu na możliwość wykonywania zadań administracyjnych, można bezpiecznie zignorować komunikaty o błędach.

Jeśli żądania przeniesienia mają wpływ na zadania zarządzania, wykonaj następujące kroki:

  1. Nawiązywanie połączenia z Exchange Online przy użyciu Windows PowerShell zdalnego. Aby uzyskać więcej informacji, zobacz Nawiązywanie połączenia z Exchange Online przy użyciu zdalnego programu PowerShell.

  2. Sprawdź, czy skrzynka pocztowa jest przenoszona. Aby to zrobić, uruchom następujące polecenie:

    Get-MoveRequest | fl Status, Protect, "Display Name", Identity
    

    Jeśli symbol zastępczy "Nazwa wyświetlana" jest zgodny ze skrzynką pocztową, dla której chcesz włączyć lub wyłączyć archiwizowanie, przenoszenie skrzynki pocztowej jest w toku. Przeniesienie uniemożliwia dokonanie zmiany.

  3. Sprawdź dane wyjściowe, a następnie w razie potrzeby wykonaj jedną z następujących czynności:

    • Jeśli stan ma wartość Queued lub InProgre, poczekaj na zakończenie przenoszenia. Powinno to nastąpić w ciągu jednego lub dwóch dni. Jeśli nie możesz czekać tak długo, usuń żądanie przeniesienia, uruchamiając następujące polecenie:

      Remove-MoveRequest -Identity IdentityOfFailedRequest
      
    • Jeśli stan nie powiodł się, usuń żądanie przeniesienia, uruchamiając następujące polecenie:

      Remove-MoveRequest -Identity IdentityOfFailedRequest
      

Ta operacja nie powinna wpływać na dostęp użytkowników ani powodować żadnych problemów. Ponadto nie trzeba powiadamiać firmy Microsoft ani właściciela skrzynki pocztowej o podjęciu tej akcji.

Więcej informacji

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.