Foldery wyszukiwania programu Outlook nie są wypełnione w trybie online po migracji z programu Exchange 2013 do programu Exchange 2010

Oryginalny numer KB:   3056652

Symptomy

Załóżmy, że skrzynka pocztowa jest migrowana z programu Microsoft Exchange Server 2013 lub usługi Exchange Online do programu Exchange 2010, a Twoja skrzynka profil programu Outlook Microsoft jest skonfigurowana w trybie online. W takiej sytuacji może wystąpić co najmniej jeden z następujących symptomów:

  • Przypomnienia nie są dostarczane.
  • Oflagowane elementy nie są wyświetlane na liście zadań do wykonaj.
  • Elementy, które mają tag MRM, nie wygasają lub nie są usuwane po uruchomionym asystencie folderów zarządzanych.

Przyczyna

Ten problem występuje, gdy ukryta SEARCH_RUNNING jest ustawiona w niektórych folderach w skrzynce pocztowej.

Rozwiązanie

Aby rozwiązać ten problem, użyj narzędzia MFCMapi, aby ponownie uruchomić usługę wyszukiwania dla każdego folderu, którego dotyczy problem. Aby pobrać mfcmapi, przejdź do wersji z kwietnia 2017 r. MFCMAPI i MrMAPI.

Aby skonfigurować i użyć mfcmapi w celu ponownego uruchomienia usługi wyszukiwania, wykonaj następujące czynności:

  1. Rozpocznij mfcmapi.exe.

  2. W menu Narzędzia kliknij polecenie Opcje.

  3. Kliknij, aby włączyć opcję: Użyj flagi MDB_ONLINE podczas wywoływania openMsgStore.

  4. W menu Sesja kliknij polecenie Logowanie.

  5. Jeśli zostanie wyświetlony monit o profil, wybierz nazwę swojego profilu, a następnie kliknij przycisk OK.

  6. W górnym okienku znajdź wiersz odpowiadający Twojej skrzynce pocztowej, a następnie kliknij go dwukrotnie.

    Skrzynka pocztowa będzie zazwyczaj wyświetlana na liście według Twojego adresu e-mail, jak pokazano na poniższym zrzucie ekranu.

    Zrzut ekranu przedstawiający lokalizowanie adresu e-mail.

  7. W okienku nawigacji po lewej stronie rozwiń pozycję Kontener główny.

    • W przypadku problemu z przypomnieniami kliknij prawym przyciskiem myszy folder Przypomnienia, a następnie wybierz pozycję Edytuj kryteria wyszukiwania.

    • W przypadku To-Do problemu kliknij prawym przyciskiem myszy folder wyszukiwania to-do, a następnie wybierz pozycję Edytuj kryteria wyszukiwania.

    • W przypadku problemu z mrmem kliknij prawym przyciskiem myszy folder AllItems, a następnie wybierz pozycję Edytuj kryteria wyszukiwania.

      Na przykład poniższy zrzut ekranu przedstawia folder AllItems w obszarze Kontener główny.

      Zrzut ekranu przedstawiający folder AllItems w obszarze Kontener główny.

  8. W drugim polu Województwo wyszukiwania odszukaj SEARCH_RUNNING pola. Jeśli nie widzisz przycisku SEARCH_RUNNING, przejdź do następnego kroku.

    Zrzut ekranu przedstawiający pozycję Edytuj kryteria wyszukiwania.

  9. W pierwszym polu Flagi wyszukiwania zamień istniejący tekst na 0x2 tekst. Gdy skończysz wpisywać tekst 0x2, zostanie wyświetlone drugie pole Flagi wyszukiwania wypełnione "RESTART_SEARCH", jak pokazano na poniższym zrzucie ekranu. Kliknij przycisk OK w dolnej części okna. Powoduje to ponowne uruchomienie usługi wyszukiwania dla tego folderu.

    Zrzut ekranu przedstawiający pole Flagi wyszukiwania.

Więcej informacji

Jeśli po ukończeniu kroku 8 SEARCH_RUNNING w drugim polu Stan wyszukiwania, nie występuje problem opisany w sekcji "Objawy".