Wprowadzenie do programu Power BI DesktopGet started with Power BI Desktop

Witamy w przewodniku Wprowadzenie do programu Power BI Desktop.Welcome to the getting started guide for Power BI Desktop. W tym przewodniku pokazano, jak działa program Power BI Desktop, jakie są jego możliwości oraz jak tworzyć niezawodne modele danych i wspaniałe raporty wspierające analizę biznesową.This tour shows you how Power BI Desktop works, what it can do, and how to build robust data models and amazing reports to amplify your business intelligence.

Aby szybko poznać, jak działa program Power BI Desktop i jak z niego korzystać, możesz przejrzeć ekrany przedstawione w tym przewodniku w ciągu zaledwie kilku minut.For a quick overview of how Power BI Desktop works and how to use it, you can scan the screens in this guide in just a few minutes. Aby uzyskać bardziej szczegółowe informacje, możesz przeczytać poszczególne sekcje, wykonać opisane w nich czynności i utworzyć własny plik programu Power BI Desktop w celu opublikowania go w usłudze Power BI i udostępnienia innym osobom.For a more thorough understanding, you can read through each section, perform the steps, and create your own Power BI Desktop file to post on the Power BI service and share with others.

Zrzut ekranu programu Power BI Desktop przedstawiający przykładowy element pracy.

Możesz również obejrzeć wideo Wprowadzenie do programu Power BI Desktop i pobrać skoroszyt programu Excel zawierający przykład Financial Sample skorelowany z wideo.You can also watch the Getting Started with the Power BI Desktop video, and download the Financial Sample Excel workbook to follow along with the video.

Ważne

Aktualizacje programu Power BI Desktop są wydawane co miesiąc i uwzględniają opinie klientów oraz nowe funkcje.Power BI Desktop is updated and released on a monthly basis, incorporating customer feedback and new features. Obsługiwana jest tylko najnowsza wersja programu Power BI Desktop — klienci kontaktujący się z zespołem pomocy technicznej programu Power BI Desktop zostaną poproszeni o uaktualnienie go do najnowszej wersji.Only the most recent version of Power BI Desktop is supported; customers who contact support for Power BI Desktop will be asked to upgrade to the most recent version. Najnowszą wersję programu Power BI Desktop można uzyskać ze Sklepu Windows lub jako pojedynczy plik wykonywalny zawierający wszystkie obsługiwane języki do pobrania i zainstalowania na komputerze.You can get the most recent version of Power BI Desktop from the Windows Store, or as a single executable containing all supported languages that you download and install on your computer.

Jak działa program Power BI DesktopHow Power BI Desktop works

Program Power BI Desktop umożliwia:With Power BI Desktop, you can:

  1. Nawiązywanie połączenia z danymi, w tym z wieloma źródłami danych.Connect to data, including multiple data sources.
  2. Kształtowanie danych za pomocą zapytań umożliwiających tworzenie szczegółowych, atrakcyjnych modeli danych.Shape the data with queries that build insightful, compelling data models.
  3. Używanie modeli danych do tworzenia wizualizacji i raportów.Use the data models to create visualizations and reports.
  4. Udostępnianie plików raportów innym użytkownikom, którzy mogą z nich korzystać, bazować na nich i je udostępniać.Share your report files for others to leverage, build upon, and share. Pliki pbix programu Power BI Desktop można udostępniać tak samo jak inne pliki, ale najbardziej atrakcyjną metodą jest przekazanie ich do usługi Power BI.You can share Power BI Desktop .pbix files like any other files, but the most compelling method is to upload them to the Power BI service.

Program Power BI Desktop integruje sprawdzony aparat zapytań firmy Microsoft, modelowanie danych i technologie wizualizacji.Power BI Desktop integrates proven Microsoft query engine, data modeling, and visualization technologies. Analitycy danych i inni użytkownicy mogą tworzyć kolekcje zapytań, połączeń danych, modeli i raportów oraz łatwo udostępniać je innym osobom.Data analysts and others can create collections of queries, data connections, models, and reports, and easily share them with others. Dzięki połączeniu możliwości programu Power BI Desktop i usługi Power BI nowe szczegółowe informacje bazujące na danych są łatwiejsze do modelowania, tworzenia, udostępniania i rozszerzania.Through the combination of Power BI Desktop and the Power BI service, new insights from the world of data are easier to model, build, share, and extend.

Program Power BI Desktop centralizuje, upraszcza i ułatwia proces projektowania i tworzenia repozytoriów i raportów analizy biznesowej, który może być w innym przypadku odłączony, rozproszony i uciążliwy.Power BI Desktop centralizes, simplifies, and streamlines what can otherwise be a scattered, disconnected, and arduous process of designing and creating business intelligence repositories and reports. Chcesz spróbować?Ready to give it a try? Zacznijmy.Let's get started.

Uwaga

Istnieje osobna, wyspecjalizowana wersja usługi Power BI o nazwie Serwer raportów usługi Power BI przeznaczona dla danych i raportów, które muszą pozostać w środowisku lokalnym.For data and reporting that must remain on-premises, there's a separate and specialized version of Power BI called Power BI Report Server. Serwer raportów usługi Power BI korzysta z oddzielnej, wyspecjalizowanej wersji programu Power BI Desktop o nazwie Power BI Desktop dla serwera raportów usługi Power BI, która działa tylko w przypadku wersji serwera raportów dla usługi Power BI.Power BI Report Server uses a separate and specialized version of Power BI Desktop called Power BI Desktop for Power BI Report Server, which works only with the Report Server version of Power BI. W tym artykule opisano standardowy program Power BI Desktop.This article describes standard Power BI Desktop.

Instalowanie i uruchamianie programu Power BI DesktopInstall and run Power BI Desktop

Aby pobrać program Power BI Desktop, przejdź do strony pobierania programu Power BI Desktop i wybierz przycisk Pobierz bezpłatnie.To download Power BI Desktop, go to the Power BI Desktop download page and select Download Free. Aby sprawdzić opcje pobierania, wybierz pozycję Zobacz opcje pobierania lub języka.Or for download options, select See download or language options.

Program Power BI Desktop można również pobrać z poziomu usługi Power BI.You can also download Power BI Desktop from the Power BI service. W tym celu wybierz ikonę pobierania na górnym pasku menu, a następnie wybierz pozycję Power BI Desktop.Select the Download icon in the top menu bar, and then select Power BI Desktop.

Zrzut ekranu usługi Power BI z widoczną opcją pobierania programu Power BI Desktop.

Na stronie sklepu Microsoft Store wybierz pozycję Pobierz i postępuj zgodnie z monitami, aby zainstalować program Power BI Desktop na komputerze.On the Microsoft Store page, select Get, and follow the prompts to install Power BI Desktop on your computer. Uruchom program Power BI Desktop z poziomu menu Start systemu Windows lub za pomocą ikony na pasku zadań systemu Windows.Start Power BI Desktop from the Windows Start menu or from the icon in the Windows taskbar.

Podczas pierwszego uruchomienia programu Power BI Desktop jest wyświetlany ekran powitalny.The first time Power BI Desktop starts, it displays the Welcome screen.

Na ekranie powitalnym można pobrać dane, zobaczyć najnowsze źródła, otworzyć ostatnio używane raporty, otworzyć inne raporty lub wybrać inne linki.From the Welcome screen, you can Get data, see Recent sources, open recent reports, Open other reports, or select other links. Możesz również wybrać, czy ekran powitalny ma być zawsze wyświetlany podczas uruchamiania.You can also choose whether to always show the Welcome screen at startup. Wybierz ikonę zamknięcia, aby zamknąć ekran powitalny.Select the close icon to close the Welcome screen.

Zrzut ekranu programu Power BI Desktop przedstawiający ekran powitalny.

Wzdłuż lewej krawędzi programu Power BI Desktop znajdują się ikony reprezentujące trzy widoki programu Power BI Desktop: Raport, Dane i Relacje, od góry do dołu.Along the left side of Power BI Desktop are icons for the three Power BI Desktop views: Report, Data, and Relationships, from top to bottom. Bieżący widok jest wskazywany przez żółty pasek z lewej strony. Widoki można zmieniać, wybierając dowolną z tych ikon.The current view is indicated by the yellow bar along the left, and you can change views by selecting any of the icons.

Zrzut ekranu programu Power BI Desktop przedstawiający ikony Raport, Dane i Relacje.

Widok domyślny to widok Raport.Report view is the default view.

Zrzut ekranu programu Power BI Desktop przedstawiający widok domyślny.

Program Power BI Desktop zawiera również Edytor Power Query, który jest otwierany w osobnym oknie.Power BI Desktop also includes the Power Query Editor, which opens in a separate window. W Edytorze Power Query możesz tworzyć zapytania i przekształcać dane, a następnie załadować dostosowany model danych do programu Power BI Desktop w celu utworzenia raportów.In Power Query Editor, you can build queries and transform data, then load the refined data model into Power BI Desktop to create reports.

Łączenie z danymiConnect to data

Po zainstalowaniu programu Power BI Desktop możesz połączyć się z nieustannie rozszerzającym się światem danych.With Power BI Desktop installed, you're ready to connect to the ever-expanding world of data. Aby wyświetlić wiele dostępnych typów źródeł danych, wybierz pozycję Pobierz dane > Więcej na karcie Strona główna programu Power BI Desktop, a następnie w oknie Pobieranie danych przewiń listę wszystkich źródeł danych.To see the many types of data sources available, select Get Data > More in the Power BI Desktop Home tab, and in the Get Data window, scroll through the list of All data sources. W tym szybkim przewodniku nawiążesz połączenie z kilkoma różnymi internetowymi źródłami danych.In this quick tour, you connect to a couple of different Web data sources.

Zrzut ekranu programu Power BI Desktop przedstawiający narzędzie Pobierz dane.

Wyobraź sobie, że jesteś analitykiem danych pracującym dla detalicznego sprzedawcy okularów przeciwsłonecznych.Imagine you're a data analyst working for a sunglasses retailer. Chcesz pomóc swojemu klientowi nakierować sprzedaż na miejsca, w których słońce świeci najczęściej.You want to help your client target sunglasses sales where the sun shines most frequently. Na stronie z opisem najlepszych i najgorszych stanów do przejścia na emeryturę w serwisie Bankrate.com znajdują się interesujące dane dotyczące tego tematu.The Bankrate.com Best and worst states for retirement page has interesting data on this subject.

Na karcie Strona główna programu Power BI Desktop wybierz pozycję Pobierz dane > Internet, aby nawiązać połączenie z internetowym źródłem danych.On the Power BI Desktop Home tab, select Get Data > Web to connect to a web data source.

Zrzut ekranu programu Power BI Desktop przedstawiający opcję Internet narzędzia Pobierz dane.

W oknie dialogowym Z sieci Web wklej adres https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/ w polu Adres URL, a następnie wybierz przycisk OK.In the From Web dialog box, paste the address https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/ into the URL field, and select OK.

Zrzut ekranu programu Power BI Desktop przedstawiający okno dialogowe Z sieci Web.

Jeśli zostanie wyświetlony monit, na ekranie Dostęp do zawartości z Internetu wybierz pozycję Połącz, aby użyć dostępu anonimowego.If prompted, on the Access Web Content screen, select Connect to use anonymous access.

Funkcja zapytań programu Power BI Desktop nawiąże kontakt z zasobem internetowym.The query functionality of Power BI Desktop goes to work and contacts the web resource. W oknie Nawigator zwracane są informacje znalezione na stronie internetowej. W tym przypadku jest to tabela o nazwie Ranking of best and worst states for retirement (Klasyfikacja najlepszych i najgorszych stanów do przejścia na emeryturę) i dokument.The Navigator window returns what it found on the web page, in this case a table called Ranking of best and worst states for retirement, and a document. Interesuje Cię tabela, więc wybierz ją, aby wyświetlić jej podgląd.You're interested in the table, so select it to see a preview.

W tym momencie możesz wybrać opcję Załaduj, aby załadować tabelę, lub opcję Przekształć dane, aby wprowadzić zmiany w tabeli przed jej załadowaniem.At this point you can select Load to load the table, or Transform data to make changes in the table before you load it.

Zrzut ekranu programu Power BI Desktop przedstawiający wyświetloną tabelę zaimportowanych danych.

Po wybraniu opcji Przekształć dane jest uruchamiany Edytor Power Query z reprezentatywnym widokiem tabeli.When you select Transform data, Power Query Editor launches, with a representative view of the table. Po prawej stronie znajduje się okienko Ustawienia zapytania. Można je zawsze wyświetlić, wybierając pozycję Ustawienia zapytania na karcie Widok w Edytorze Power Query.The Query Settings pane is on the right, or you can always show it by selecting Query Settings on the View tab of Power Query Editor.

Zrzut ekranu programu Power BI Desktop przedstawiający Edytor Power Query z okienkiem Ustawienia zapytania.

Aby uzyskać więcej informacji o łączeniu się z danymi, zobacz Nawiązywanie połączenia z danymi w programie Power BI Desktop.For more information about connecting to data, see Connect to data in Power BI Desktop.

Kształtowanie danychShape data

Teraz po nawiązaniu połączenia ze źródłem danych możesz dostosować dane do swoich potrzeb.Now that you're connected to a data source, you can adjust the data to meet your needs. Aby ukształtować dane, należy w Edytorze Power Query wprowadzić instrukcje krok po kroku dotyczące dostosowywania danych podczas ładowania i prezentowania.To shape data, you provide Power Query Editor with step-by-step instructions for adjusting the data while loading and presenting it. Kształtowanie nie ma wpływu na oryginalne źródło danych, tylko na ten konkretny widok danych.Shaping doesn't affect the original data source, only this particular view of the data.

Uwaga

Dane tabeli używane w tym przewodniku mogą ulec zmianie z upływem czasu.The table data used in this guide might change over time. W związku z tym kroki, które należy wykonać, mogą różnić się, co będzie wymagało od Ciebie kreatywności w dopasowaniu kroków lub wyników, jednak dzięki temu proces nauki jest jeszcze bardziej ciekawy.As such, the steps you need to follow might vary, requiring you to be creative about how you adjust steps or outcomes, which is all part of the fun of learning.

Kształtowanie może oznaczać transformację danych, na przykład zmienianie nazw kolumn lub tabel, usuwanie wierszy lub kolumn bądź zmienianie typów danych.Shaping can mean transforming the data, such as renaming columns or tables, removing rows or columns, or changing data types. Edytor Power Query przechwytuje te kroki sekwencyjnie w obszarze Zastosowane kroki w okienku Ustawienia zapytania.Power Query Editor captures these steps sequentially under Applied Steps in the Query Settings pane. Te kroki są wykonywane przy każdym połączeniu zapytania ze źródłem danych. Dzięki temu dane są zawsze kształtowane zgodnie z Twoimi instrukcjami.Each time this query connects to the data source, those steps are carried out, so the data is always shaped the way you specify. Ten proces odbywa się za każdym, gdy użyjesz zapytania w programie Power BI Desktop lub gdy dowolny użytkownik użyje Twojego udostępnionego zapytania, na przykład w usłudze Power BI.This process occurs when you use the query in Power BI Desktop, or when anyone uses your shared query, such as in the Power BI service.

Zwróć uwagę, że w obszarze Zastosowane kroki w okienku Ustawienia zapytania znajduje się już kilka kroków.Notice that the Applied Steps in Query Settings already contain a few steps. Możesz wybrać poszczególne kroki, aby sprawdzić ich wpływ na działanie Edytora Power Query.You can select each step to see its effect in the Power Query Editor. Najpierw określono źródło internetowe, a następnie wyświetlono podgląd tabeli w oknie Nawigator.First, you specified a web source, and then you previewed the table in the Navigator window. W trzecim kroku Zmieniono typ. Usługa Power BI rozpoznała dane całkowitoliczbowe podczas importowania i automatycznie zmieniła oryginalny tekstowy typ danych znalezionych w Internecie na liczby całkowite.In the third step, Changed type, Power BI recognized whole number data when importing it, and automatically changed the original web Text data type to Whole numbers.

Zrzut ekranu programu Power BI Desktop przedstawiający Edytor Power Query z okienkiem Ustawienia zapytania z wyświetlonymi trzema zastosowanymi krokami.

Jeśli musisz zmienić typ danych, wybierz kolumnę lub kolumny, które mają zostać zmienione.If you need to change a data type, select the column or columns to change. Przytrzymaj wciśnięty klawisz Shift, aby zaznaczyć kilka sąsiadujących kolumn lub klawisz Ctrl, aby zaznaczyć kolumny niesąsiadujące.Hold down the Shift key to select several adjacent columns, or Ctrl to select non-adjacent columns. Kliknij prawym przyciskiem myszy nagłówek kolumny, wybierz pozycję Zmień typ i wybierz nowy typ danych z menu lub z listy rozwijanej obok pozycji Typ danych w grupie Przekształć na karcie Strona główna wybierz nowy typ danych.Either right-click a column header, select Change Type, and choose a new data type from the menu, or drop down the list next to Data Type in the Transform group of the Home tab, and select a new data type.

Zrzut ekranu programu Power BI Desktop przedstawiający opcję zmiany typu danych.

Uwaga

Dostępne zadania można wykonywać w Edytorze Power Query w programie Power BI Desktop za pomocą wstążki lub menu dostępnego po kliknięciu prawym przyciskiem myszy.The Power Query Editor in Power BI Desktop uses the ribbon or the right-click menus for available tasks. Większość zadań, które można wybrać na karcie Strona główna lub Przekształć na wstążce, jest również dostępna po kliknięciu prawym przyciskiem myszy elementu i wybraniu z wyświetlonego menu.Most of the tasks you can select on the Home or Transform tabs of the ribbon are also available by right-clicking an item and choosing from the menu that appears.

Teraz możesz zastosować własne zmiany oraz przekształcenia danych i zobaczyć je w obszarze Zastosowane kroki.You can now apply your own changes and transformations to the data and see them in Applied Steps.

Na przykład w przypadku sprzedaży okularów przeciwsłonecznych najbardziej interesująca jest pogoda, dlatego decydujesz się posortować tabelę według kolumny Weather (Pogoda) zamiast według kolumny Overall rank (Klasyfikacja ogólna).For example, for sunglasses sales you're most interested in the weather ranking, so you decide to sort the table by the Weather column instead of by Overall rank. Rozwiń strzałkę obok nagłówka Weather (Pogoda), a następnie wybierz pozycję Sortuj rosnąco.Drop down the arrow next to the Weather header, and select Sort ascending. Teraz dane będą posortowane według klasyfikacji pogody, a krok Posortowano wiersze pojawi się w obszarze Zastosowane kroki.The data now appears sorted by weather ranking, and the step Sorted Rows appears in Applied Steps.

Zrzut ekranu programu Power BI Desktop przedstawiający krok Posortowano wiersze wyświetlony w obszarze Zastosowane kroki.

Nie chcesz sprzedawać okularów przeciwsłonecznych w stanach, gdzie jest najgorsza pogoda, więc decydujesz o usunięciu ich z tabeli.You're not very interested in selling sunglasses to the worst weather states, so you decide to remove them from the table. Z grupy Zmniejsz wiersze na karcie Strona główna wybierz pozycję Usuń wiersze > Usuń końcowe wiersze.From the Reduce Rows group of the Home tab, select Remove Rows > Remove Bottom Rows. W oknie dialogowym Usuwanie końcowych wierszy wprowadź 10, a następnie wybierz przycisk OK.In the Remove Bottom Rows dialog box, enter 10, and then select OK.

Zrzut ekranu programu Power BI Desktop przedstawiający okno dialogowe Usuwanie końcowych wierszy.

Ostatnie 10 wierszy z najgorszą pogodą zostanie usuniętych z tabeli, a krok Usunięto końcowe wiersze pojawi się w obszarze Zastosowane kroki.The bottom 10 worst weather rows are removed from the table, and the step Removed Bottom Rows appears in Applied Steps.

Tabela zawiera zbyt dużo nieistotnych informacji, więc decydujesz się na usunięcie kolumn Affordability (Dostępność), Crime (Przestępczość), Culture (Kultura) i Wellness (Zdrowie).You decide the table has too much extra information for your needs, and to remove the Affordability, Crime, Culture, and Wellness columns. Wybierz nagłówek każdej kolumny, która ma zostać usunięta.Select the header of each column that you want to remove. Przytrzymaj wciśnięty klawisz Shift, aby zaznaczyć kilka sąsiadujących kolumn lub klawisz Ctrl, aby zaznaczyć kolumny niesąsiadujące.Hold down the Shift key to select several adjacent columns, or Ctrl to select non-adjacent columns.

Następnie w grupie Zarządzaj kolumnami na karcie Strona główna wybierz pozycję Usuń kolumny.Then, from the Manage Columns group of the Home tab, select Remove Columns. Możesz również kliknąć prawym przyciskiem myszy jeden z zaznaczonych nagłówków kolumn i z menu wybrać polecenie Usuń kolumny.You can also right-click one of the selected column headers and select Remove Columns from the menu. Wybrane kolumny zostaną usunięte, a krok Usunięto kolumny pojawi się w obszarze Zastosowane kroki.The selected columns are removed, and the step Removed Columns appears in Applied Steps.

Zrzut ekranu programu Power BI Desktop przedstawiający krok Usuń kolumny dodany do obszaru Zastosowane kroki.

Po zastanowieniu dochodzisz do wniosku, że jednak kolumna Affordability (Dostępność) może być istotna w przypadku sprzedaży okularów przeciwsłonecznych.On second thought, Affordability might be relevant to sunglasses sales after all. Chcesz odzyskać tę kolumnę.You'd like to get that column back. Z łatwością możesz cofnąć ostatni krok w okienku Zastosowane kroki, zaznaczając ikonę usuwania X obok tego kroku.You can easily undo the last step in the Applied Steps pane by selecting the X delete icon next to the step. Teraz wykonaj ponownie ten krok, zaznaczając tylko kolumny, które chcesz usunąć.Now redo the step, selecting only the columns you want to delete. Aby uzyskać większą elastyczność, możesz usunąć każdą kolumnę w osobnym kroku.For more flexibility, you could delete each column as a separate step.

Możesz kliknąć prawym przyciskiem myszy dowolny krok w okienku Zastosowane kroki, a następnie go usunąć, zmienić jego nazwę, przenieść go w górę lub w dół lub dodać bądź usunąć kroki następujące po nim.You can right-click any step in the Applied Steps pane and choose to delete it, rename it, move it up or down in the sequence, or add or delete steps after it. W przypadku kroków pośrednich w programie Power BI Desktop zostanie wyświetlone ostrzeżenie, jeśli zmiana może wpłynąć na późniejsze kroki i przerwać zapytanie.For intermediate steps, Power BI Desktop will warn you if the change could affect later steps and break your query.

Zrzut ekranu programu Power BI Desktop przedstawiający opcje modyfikacji obszaru Zastosowane kroki.

Przykładowo jeśli nie chcesz już sortować tabeli według kolumny Weather (Pogoda), możesz spróbować usunąć krok Posortowano wiersze.For example, if you no longer wanted to sort the table by Weather, you might try to delete the Sorted Rows step. W programie Power BI Desktop zostanie wyświetlone ostrzeżenie, że usunięcie tego kroku może spowodować przerwanie zapytania.Power BI Desktop warns you that deleting this step could cause your query to break. Po posortowaniu tabeli według pogody usunięto 10 ostatnich wierszy, więc jeśli usuniesz krok sortowania, różne wiersze zostaną usunięte.You removed the bottom 10 rows after you sorted by weather, so if you remove the sort, different rows will be removed. Ostrzeżenie zostanie również wyświetlone, jeśli zaznaczysz krok Posortowano wiersze i na tym etapie spróbujesz dodać nowy krok pośredni.You also get a warning if you select the Sorted Rows step and try to add a new intermediate step at that point.

Zrzut ekranu programu Power BI Desktop przedstawiający okno dialogowe Usuwanie kroku.

Na koniec zmieniasz tytuł tabeli tak, aby nawiązywał do sprzedaży okularów przeciwsłonecznych, a nie do przechodzenia na emeryturę.Finally, you change the table title to be about sunglass sales instead of retirement. W obszarze Właściwości w okienku Ustawienia zapytania zastąp stary tytuł wyrażeniem Best states for sunglass sales (Najlepsze stany do sprzedaży okularów przeciwsłonecznych).Under Properties in the Query Settings pane, replace the old title with Best states for sunglass sales.

Gotowe zapytanie dotyczące ukształtowanych danych wygląda następująco:The finished query for your shaped data looks like this:

Zrzut ekranu programu Power BI Desktop przedstawiający gotowe zapytanie dotyczące ukształtowanych danych.

Aby uzyskać więcej informacji na temat kształtowania danych, zobacz Kształtowanie i łączenie danych w programie Power BI Desktop.For more information about shaping data, see Shape and combine data in Power BI Desktop.

Łączenie danychCombine data

Dane dotyczące różnych stanów są interesujące i będą użyteczne podczas tworzenia dodatkowych zapytań i analizowania.The data about various states is interesting, and will be useful for building additional analysis efforts and queries. Jest jednak jeden problem: w większości istniejących danych używane są dwuliterowe skróty kodów stanów, a nie pełne ich nazwy.But there's one problem: most data out there uses two-letter abbreviations for state codes, not the full names of the states. Aby móc korzystać z tych danych, musisz znaleźć sposób na skojarzenie nazw stanów z ich skrótami.To use that data, you need some way to associate your state names with their abbreviations.

Masz szczęście.You're in luck. Zrobiono to w innym publicznym źródle danych, ale konieczne będzie odpowiednie ukształtowanie tych danych, zanim będzie można połączyć je z tabelą zawierającą dane o okularach przeciwsłonecznych.Another public data source does just that, but the data will need a fair amount of shaping before you can combine it with your sunglass table.

Aby zaimportować dane skrótów nazw stanów do Edytora Power Query, wybierz pozycję Nowe źródło > Internet z grupy Nowe zapytanie na karcie Strona główna na wstążce.To import the state abbreviations data into Power Query Editor, select New Source > Web from the New Query group on the Home tab of the ribbon.

Zrzut ekranu programu Power BI Desktop przedstawiający Edytor Power Query z wybraną opcją Internet z poziomu obszaru Nowe źródło.

W oknie dialogowym Z sieci Web wprowadź adres URL witryny zawierającej dane skrótów nazw stanów: https://en.wikipedia.org/wiki/List_of_U.S._state_abbreviations.In the From Web dialog box, enter the URL for the state abbreviations site: https://en.wikipedia.org/wiki/List_of_U.S._state_abbreviations.

W oknie Nawigator wybierz tabelę Codes and abbreviations for U.S. states, federal district, territories, and other regions (Kody i skróty nazw stanów USA, okręgów federalnych, terytoriów i innych regionów), a następnie wybierz przycisk OK.In the Navigator window, select the table Codes and abbreviations for U.S. states, federal district, territories, and other regions, and then select OK. Tabela zostanie otwarta w Edytorze Power Query.The table opens in Power Query Editor.

Usuń wszystkie kolumny z wyjątkiem kolumn Name and status of region (Nazwa i stan regionu), Name and status of region2 (Nazwa i stan regionu2) i ANSI.Remove all columns except for Name and status of region, Name and status of region2, and ANSI. Aby zachować tylko te kolumny, przytrzymaj wciśnięty klawisz Ctrl i wybierz kolumny.To keep only these columns, hold down Ctrl and select the columns. Następnie kliknij prawym przyciskiem myszy jeden z nagłówków kolumn i wybierz polecenie Usuń inne kolumny lub w grupie Zarządzaj kolumnami na karcie Strona główna wybierz pozycję Usuń inne kolumny.Then, either right-click one of the column headers and select Remove Other Columns, or, from the Manage Columns group of the Home tab, select Remove Other Columns.

Rozwiń strzałkę obok nagłówka kolumny Name and status of region2 i wybierz pozycję Filtry > Równa się.Drop down the arrow next to the Name and status of region2 column header, and select Filters > Equals. W oknie dialogowym Filtrowanie wierszy rozwiń pole Wprowadź lub wybierz wartość obok pola równa się i wybierz pozycję State.In the Filter Rows dialog box, drop down the Enter or select a value field next to equals and select State.

Zaznacz pole wyboru Lub i obok drugiego pola równa się wybierz pozycję State ("Commonwealth") .Select Or, and next to the second equals field, select State ("Commonwealth"). Wybierz przycisk OK.Select OK.

Zrzut ekranu programu Power BI Desktop przedstawiający pole zapytania Filtrowanie wierszy w Edytorze Power Query.

Po usunięciu dodatkowych wartości dotyczących na przykład okręgów federalnych i wysp masz teraz listę 50 stanów z oficjalnymi dwuliterowymi skrótami ich nazw.With extra values like Federal district and island removed, you now have a list of the 50 states and their official two-letter abbreviations. Jeśli chcesz, możesz zmienić nazwy kolumn, aby wskazywały one na ich zawartość, na przykład State name (Nazwa stanu), Status (Stan) i Abbreviation (Skrót). W tym celu wystarczy kliknąć nagłówki kolumn prawym przyciskiem myszy i wybrać polecenie Zmień nazwę.You can rename the columns to make more sense, for example State name, Status, and Abbreviation, by right-clicking the column headers and selecting Rename.

Zwróć uwagę, że wszystkie wykonywane kroki są rejestrowane w obszarze Zastosowane kroki w okienku Ustawienia zapytania.Note that all of these steps are recorded under Applied Steps in the Query Settings pane.

Przekształcona tabela wygląda teraz następująco:Your shaped table now looks like this:

Zrzut ekranu programu Power BI Desktop przedstawiający Edytor Power Query z obszarem Zastosowane kroki w okienku Ustawienia zapytania.

Zmień tytuł tabeli na State codes (Kody stanów) w polu Właściwości w okienku Ustawienia zapytania.Retitle the table to State codes in the Properties field of Query Settings.

Po ukształtowaniu tabeli State codes można połączyć te dwie tabele w jedną.With the State codes table shaped, you can combine these two tables into one. Ponieważ tabele, którymi teraz dysponujesz, są wynikiem zastosowanych zapytań do danych, są one również nazywane zapytaniami.Since the tables you now have are a result of queries you applied to the data, they're also called queries. Istnieją dwa podstawowe sposoby łączenia zapytań: scalanie i dołączanie.There are two primary ways of combining queries: merge and append.

Jeśli masz co najmniej jedną kolumnę, którą chcesz dodać do innego zapytania, scalasz zapytania.When you have one or more columns you'd like to add to another query, you merge the queries. Jeśli masz dodatkowe wiersze danych, które chcesz dodać do istniejącego zapytania, wówczas dołączasz zapytanie.When you have additional rows of data you'd like to add to an existing query, you append the query.

W tym przypadku scalisz zapytanie State codes z zapytaniem Best states for sunglasses.In this case, you want to merge the State codes query into the Best states for sunglasses query. Aby scalić zapytania, przełącz się do zapytania Best states for sunglasses, wybierając je w okienku Zapytania po lewej stronie Edytora Power Query.To merge the queries, switch to the Best states for sunglasses query by selecting it from the Queries pane on the left side of Power Query Editor. Następnie wybierz pozycję Scal zapytania z grupy Połącz na karcie Strona główna na wstążce.Then select Merge Queries from the Combine group in the Home tab of the ribbon.

W oknie Scalanie rozwiń pole, aby wybrać pozycję State codes z innych dostępnych zapytań.In the Merge window, drop down the field to select State codes from the other queries available. Wybierz kolumny, które mają być dopasowane z każdej tabeli. W tym przypadku jest to kolumna State z zapytania Best states for sunglasses i kolumna State name z zapytania State codes.Select the column to match from each table, in this case State from the Best states for sunglasses query and State name from the State codes query.

Jeśli zostanie wyświetlone okno dialogowe Poziomy prywatności, zaznacz pole wyboru Ignoruj kontrole poziomów prywatności dla tego pliku, a następnie wybierz przycisk Zapisz.If you get a Privacy levels dialog, select Ignore privacy levels checks for this file and then select Save. Wybierz przycisk OK.Select OK.

Zrzut ekranu programu Power BI Desktop przedstawiający okno Scal zapytania.

Po prawej stronie tabeli Best states for sunglass sales pojawi się nowa kolumna o nazwie State codes.A new column called State codes appears on the right of the Best states for sunglass sales table. Zawiera ona zapytanie z kodami stanów, które zostało scalone z zapytaniem dotyczącym najlepszych stanów do sprzedaży okularów przeciwsłonecznych.It contains the state code query that you merged with the best states for sunglass sales query. Wszystkie kolumny ze scalonej tabeli zostały zagęszczone w kolumnie State codes.All the columns from the merged table are condensed into the State codes column. Możesz rozszerzyć tę scaloną tabelę i uwzględnić tylko istotne kolumny.You can expand the merged table and include only the columns you want.

Zrzut ekranu programu Power BI Desktop przedstawiający kolumnę State codes.

Aby rozwinąć scaloną tabelę i wybrać kolumny do dołączenia, wybierz ikonę Rozwiń w nagłówku kolumny.To expand the merged table and select which columns to include, select the Expand icon in the column header. W oknie dialogowym Rozwiń zaznacz tylko kolumnę Abbreviation.In the Expand dialog box, select only the Abbreviation column. Usuń zaznaczenie pola wyboru Użyj oryginalnej nazwy kolumny jako prefiksu, a następnie wybierz przycisk OK.Deselect Use original column name as prefix, and then select OK.

Zrzut ekranu programu Power BI Desktop przedstawiający kolumnę Abbreviation tabeli State codes.

Uwaga

Jeśli chcesz, możesz spróbować poeksperymentować z tabelą State codes.You can play around with how to bring in the State codes table. Jeśli nie spodobają Ci się wyniki, po prostu usuń ten krok z listy Zastosowane kroki w okienku Ustawienia zapytania.Experiment a bit, and if you don't like the results, just delete that step from the Applied Steps list in the Query Settings pane. Możesz powtarzać te czynności dowolną liczbę razy, aż dostosujesz proces rozwijania do swoich potrzeb.It's a free do-over, which you can do as many times as you like until the expand process looks the way you want it.

Aby uzyskać bardziej szczegółowy opis kroków kształtowania i łączenia danych, zobacz Kształtowanie i łączenie danych w programie Power BI Desktop.For a more complete description of the shape and combine data steps, see Shape and combine data in Power BI Desktop.

Teraz masz pojedynczą tabelę zapytań, która łączy w sobie dwa źródła danych, a każde z nich zostało ukształtowane zgodnie z Twoimi potrzebami.You now have a single query table that combines two data sources, each of which has been shaped to meet your needs. To zapytanie może służyć jako podstawa dla wielu dodatkowych, interesujących połączeń danych, takich jak dane demograficzne, poziom zamożności lub możliwości spędzania wolnego czasu w wybranych stanach.This query can serve as a basis for lots of additional, interesting data connections, such as demographics, wealth levels, or recreational opportunities in the states.

Zrzut ekranu programu Power BI Desktop przedstawiający Edytor Power Query z ukształtowanymi i połączonymi zapytaniami.

Na razie masz dość danych, aby utworzyć interesujący raport w programie Power BI Desktop.For now, you have enough data to create an interesting report in Power BI Desktop. Ponieważ jest to punkt kontrolny, zastosuj zmiany w Edytorze Power Query i załaduj je do programu Power BI Desktop, wybierając pozycję Zamknij i zastosuj z karty Strona główna na wstążce.Since this is a milestone, apply the changes in Power Query Editor and load them into Power BI Desktop by selecting Close & Apply from the Home tab of the ribbon. Możesz również wybrać tylko opcję Zastosuj, aby podczas pracy w programie Power BI Desktop zapytanie było nadal otwarte w Edytorze Power Query.You can also select just Apply to keep the query open in Power Query Editor while you work in Power BI Desktop.

Zrzut ekranu programu Power BI Desktop przedstawiający opcję zmian Zamknij i zastosuj.

Po załadowaniu tabeli do programu Power BI Desktop możesz wprowadzić więcej zmian i ponownie załadować model, aby zmiany zostały zastosowane.You can make more changes to a table after it is loaded into Power BI Desktop, and reload the model to apply any changes you make. Aby ponownie otworzyć Edytor Power Query z poziomu programu Power BI Desktop, wybierz pozycję Edytuj zapytania na karcie Strona główna na wstążce programu Power BI Desktop.To reopen Power Query Editor from Power BI Desktop, select Edit Queries on the Home tab of the Power BI Desktop ribbon.

Tworzenie raportówBuild reports

W widoku Raport programu Power BI Desktop możesz tworzyć wizualizacje i raporty.In Power BI Desktop Report view, you can build visualizations and reports. Widok Raport ma sześć głównych obszarów:The Report view has six main areas:

Zrzut ekranu programu Power BI Desktop przedstawiający widok Raport.

  1. Wstążka w górnej części ekranu, na której wyświetlono typowe zadania związane z raportami i wizualizacjami.The ribbon at the top, which displays common tasks associated with reports and visualizations.
  2. Obszar kanwy w środkowej części ekranu, w którym tworzy się i rozmieszcza wizualizacje.The canvas area in the middle, where visualizations are created and arranged.
  3. Obszar karty stron u dołu, który umożliwia wybieranie lub dodawanie stron raportu.The pages tab area at the bottom, which lets you select or add report pages.
  4. Okienko Filtry, w którym można filtrować wizualizacje danych.The Filters pane, where you can filter data visualizations.
  5. Okienko Wizualizacje, w którym można dodawać, zmieniać lub dostosowywać wizualizacje oraz stosować przeglądanie szczegółowe.The Visualizations pane, where you can add, change, or customize visualizations, and apply drillthrough.
  6. Okienko Pola, w którym są wyświetlane dostępne pola w zapytaniach.The Fields pane, which shows the available fields in your queries. Te pola można przeciągać na kanwę, do okienka Filtry lub do okienka Wizualizacje, aby tworzyć lub modyfikować wizualizacje.You can drag these fields onto the canvas, the Filters pane, or the Visualizations pane to create or modify visualizations.

Okienka Filtry, Wizualizacje i Pola można rozwijać i zwijać za pomocą strzałek w górnej części okienek.You can expand and collapse the Filters, Visualizations, and Fields panes by selecting the arrows at the tops of the panes. Po zwinięciu okienek na kanwie pozostaje więcej miejsca na tworzenie wspaniałych wizualizacji.Collapsing the panes provides more space on the canvas to build cool visualizations.

Zrzut ekranu programu Power BI Desktop przedstawiający okienko Pola.

Aby utworzyć prostą wizualizację, wystarczy wybrać dowolne pole na liście pól lub przeciągnąć pole z listy Pola na kanwę.To create a simple visualization, just select any field in the fields list, or drag the field from the Fields list onto the canvas. Spróbuj na przykład przeciągnąć pole State z tabeli Best states for sunglass sales na kanwę i zobacz, co się stanie.For example, drag the State field from Best states for sunglass sales onto the canvas, and see what happens.

Zrzut ekranu programu Power BI Desktop przedstawiający przeciąganie pola State w celu utworzenia wizualizacji mapy.

Spójrz na to!Look at that! Program Power BI Desktop rozpoznał, że pole State (Stan) zawiera dane geolokalizacji i automatycznie utworzył wizualizację opartą na mapie.Power BI Desktop recognized that the State field contained geolocation data and automatically created a map-based visualization. Wizualizacja przedstawia punkty danych dla 40 stanów z modelu danych.The visualization shows data points for the 40 states from your data model.

Okienko Wizualizacje zawiera informacje o wizualizacji i umożliwia ich modyfikację.The Visualizations pane shows information about the visualization and lets you modify it.

Zrzut ekranu programu Power BI Desktop przedstawiający okienko Wizualizacje.

  1. Ikony pokazują typ utworzonej wizualizacji.The icons show the type of visualization created. Typ wybranej wizualizacji można zmienić, wybierając inną ikonę lub tworząc nową wizualizację przez wybranie ikony bez wybranej istniejącej wizualizacji.You can change the type of a selected visualization by selecting a different icon, or create a new visualization by selecting an icon with no existing visualization selected.
  2. Opcja Pola w okienku Wizualizacja umożliwia przeciąganie pól danych do Legendy i innych źródeł w okienku.The Fields option in the Visualization pane lets you drag data fields to Legend and other field wells in the pane.
  3. Opcja Format umożliwia zastosowanie formatowania i innych kontrolek do wizualizacji.The Format option lets you apply formatting and other controls to visualizations.

Opcje dostępne w obszarach Pola i Format zależą od typu wizualizacji i posiadanych danych.The options available in the Fields and Format areas depend on the type of visualization and data you have.

Chcesz, aby na Twojej wizualizacji mapy było wyświetlane tylko 10 stanów z najlepszymi warunkami pogodowymi.You want your map visualization to show only the top 10 weather states. Aby wyświetlić tylko 10 najważniejszych stanów, w okienku Filtry umieść wskaźnik myszy na elemencie State jest (wszystko) i rozwiń strzałkę, która zostanie wyświetlona.To show only the top 10 states, in the Filters pane, hover over State is (All) and expand the arrow that appears. W obszarze Typ filtru rozwiń listę rozwijaną i wybierz pozycję Pierwsze N. W obszarze Pokaż elementy wybierz pozycję Ostatnie, ponieważ chcesz pokazać elementy o najniższych rangach liczbowych, a w następnym polu wprowadź wartość 10.Under Filter type, drop down and select Top N. Under Show items, select Bottom, because you want to show the items with the lowest numerical ranks, and enter 10 in the next field.

Przeciągnij pole Weather (Pogoda) z okienka Pola do pola Według wartości, a następnie wybierz pozycję Zastosuj filtr.Drag the Weather field from the Fields pane into the By value field, and then select Apply filter.

Zrzut ekranu programu Power BI Desktop przedstawiający filtr Weather.

W wizualizacji mapy jest teraz widocznych tylko 10 stanów z najlepszymi warunkami pogodowymi.You now see only the top 10 weather states in the map visualization.

Zmień tytuł wizualizacji. W tym celu wybierz ikonę Format w okienku Wizualizacja, wybierz pozycję Tytuł i wpisz Top 10 weather states (10 stanów z najlepszymi warunkami pogodowymi) w obszarze Tekst tytułu.Retitle your visualization by selecting the Format icon in the Visualization pane, selecting Title, and typing Top 10 weather states under Title text.

Zrzut ekranu programu Power BI Desktop przedstawiający pole zmiany tytułu w okienku Wizualizacje.

Aby dodać wizualizację pokazującą nazwy 10 stanów z najlepszymi warunkami pogodowymi i ich rangi od 1 do 10, wybierz pusty obszar kanwy, a następnie wybierz ikonę Wykres kolumnowy z okienka Wizualizacja.To add a visualization that shows the names of the top 10 weather states and their ranks from 1 to 10, select a blank area of the canvas and then select the Column chart icon from the Visualization pane. W okienku Pola wybierz pozycje State (Stan) i Weather (Pogoda).In the Fields pane, select State and Weather. Na wykresie kolumnowym jest wyświetlanych 40 stanów z zapytania sklasyfikowanych według rangi liczbowej od najwyższej do najniższej, czyli od najgorszych warunków pogodowych do najlepszych.A column chart shows the 40 states in your query, ranked from highest to lowest numerical rank, or worst to best weather.

Zrzut ekranu programu Power BI Desktop przedstawiający wizualizację wykresu kolumnowego.

Aby zmienić kolejność rangi, tak aby numer 1 pojawił się jako pierwszy, wybierz wielokropek Więcej opcji w prawym górnym rogu wizualizacji, a następnie z menu wybierz pozycję Sortuj rosnąco.To switch the order of the ranking so that number 1 appears first, select the More options ellipsis at the upper right of the visualization, and select Sort ascending from the menu.

Zrzut ekranu programu Power BI Desktop przedstawiający opcję Sortuj rosnąco.

Aby ograniczyć tabelę do 10 najważniejszych stanów, zastosuj ten sam filtr 10 ostatnich elementów, który zastosowano do wizualizacji mapy.To limit the table to the top 10 states, apply the same bottom 10 filter as you did for the map visualization.

Zmień tytuł wizualizacji w taki sam sposób jak w przypadku wizualizacji mapy.Retitle the visualization the same way as for the map visualization. W sekcji Format w okienku Wizualizacja zmień Oś Y > Tytuł osi z Weather na Weather ranking (Ranking pogodowy), aby był on bardziej zrozumiały.Also in the Format section of the Visualization pane, change Y axis > Axis title from Weather to Weather ranking to make it more understandable. Następnie przełącz selektor Oś Y w pozycję Wyłączony, a selektor Etykiety danych w pozycję Włączony.Then, turn the Y axis selector to Off, and turn Data labels to On.

Teraz 10 stanów z najlepszymi warunkami pogodowymi jest wyświetlanych w kolejności rankingu wraz z wartościami liczbowymi rankingu.Now, the top 10 weather states appear in ranked order along with their numerical rankings.

Zrzut ekranu programu Power BI Desktop przedstawiający ukończony wykres kolumnowy.

Podobne lub inne wizualizacje można utworzyć dla pól Affordability (Dostępność) i Overall ranking (Klasyfikacja ogólna). Można też połączyć kilka pól w jedną wizualizację.You can make similar or other visualizations for the Affordability and Overall ranking fields, or combine several fields into one visualization. Istnieją różnego rodzaju interesujące raporty i wizualizacje, które możesz utworzyć.There are all sorts of interesting reports and visualizations you can create. Na poniższych wizualizacjach typu Tabela oraz Wykres liniowy i kolumnowy grupowany przedstawiono 10 stanów z najlepszymi warunkami pogodowymi wraz z ich dostępnością i ogólną klasyfikacją:These Table and Line and clustered column chart visualizations shows the top 10 weather states along with their affordability and overall rankings:

Zrzut ekranu programu Power BI Desktop przedstawiający wizualizacje Tabela oraz Wykres liniowy i kolumnowy grupowany.

Poszczególne wizualizacje można wyświetlać na różnych stronach raportu.You can show different visualizations on different report pages. Aby dodać nową stronę, wybierz symbol + obok istniejących stron na pasku stron lub wybierz kolejno pozycje Wstaw > Nowa strona na karcie Strona główna na wstążce.To add a new page, select the + symbol next to the existing pages on the pages bar, or select Insert > New Page in the Home tab of the ribbon. Aby zmienić nazwę strony, kliknij dwukrotnie nazwę strony na pasku stron lub kliknij ją prawym przyciskiem myszy, a następnie wybierz polecenie Zmień nazwę strony i wpisz nową nazwę.To rename a page, double-click the page name in the pages bar, or right-click it and select Rename Page, and then type the new name. Aby przejść do innej strony raportu, wybierz stronę na pasku stron.To go to a different page of the report, select the page from the pages bar.

Zrzut ekranu programu Power BI Desktop przedstawiający pasek stron.

Do stron raportu można dodawać pola tekstowe, obrazy i przyciski, korzystając z grupy Wstaw na karcie Strona główna. Aby ustawić opcje formatowania wizualizacji, wybierz wizualizację, a następnie wybierz ikonę Format w okienku Wizualizacje.You can add text boxes, images, and buttons to your report pages from the Insert group of the Home tab. To set formatting options for visualizations, select a visualization and then select the Format icon in the Visualizations pane. Aby skonfigurować rozmiar stron, tła i inne informacje o stronie, wybierz ikonę Format bez zaznaczania wizualizacji.To configure page sizes, backgrounds, and other page information, select the Format icon with no visualization selected.

Po zakończeniu tworzenia stron i wizualizacji wybierz pozycję Plik > Zapisz i zapisz swój raport.When you finish creating your pages and visualizations, select File > Save and save your report.

Zrzut ekranu programu Power BI Desktop przedstawiający stronę ukończonego raportu.

Aby uzyskać więcej informacji o raportach, zobacz Widok raportu w programie Power BI Desktop.For more information about reports, see Report View in Power BI Desktop.

Udostępnianie wyników pracyShare your work

Po utworzeniu raportu programu Power BI Desktop można udostępnić go innym osobom.Now that you have a Power BI Desktop report, you can share it with others. Istnieje kilka sposobów na udostępnienie wyników pracy.There are a few ways to share your work. Plik pbix raportu można dystrybuować podobnie jak każdy inny plik. Plik pbix można też przekazać do usługi Power BI lub opublikować w usłudze Power BI bezpośrednio z poziomu programu Power BI Desktop.You can distribute the report .pbix file like any other file, you can upload the .pbix file from the Power BI service, or you can publish directly from Power BI Desktop to the Power BI service. Aby móc publikować i przekazywać raporty do usługi Power BI, musisz mieć konto usługi Power BI.You must have a Power BI account to be able to publish or upload reports to Power BI service.

Aby opublikować raport w usłudze Power BI z poziomu programu Power BI Desktop, na karcie Strona główna wstążki wybierz pozycję Publikuj.To publish to the Power BI service from Power BI Desktop, from the Home tab of the ribbon, select Publish.

Zrzut ekranu programu Power BI Desktop przedstawiający opcję Publikuj.

Może zostać wyświetlony monit o zalogowanie się do usługi Power BI lub o wybranie lokalizacji docelowej.You may be prompted to sign in to Power BI, or to select a destination.

Po zakończeniu procesu publikowania zostanie wyświetlone następujące okno dialogowe:When the publish process is complete, you see the following dialog:

Zrzut ekranu programu Power BI Desktop przedstawiający komunikat o powodzeniu publikowania.

Jeśli wybierzesz link umożliwiający otwarcie raportu w usłudze Power BI, raport zostanie otwarty w witrynie Power BI w obszarze Mój obszar roboczy > Raporty.When you select the link to open the report in Power BI, your report opens in your Power BI site under My workspace > Reports.

Innym sposobem udostępnienia pracy jest załadowanie pliku z poziomu usług Power BI.Another way to share your work is to load it from within the Power BI service. Przejdź do witryny https://app.powerbi.com, aby otworzyć usługę Power BI w przeglądarce.Go to https://app.powerbi.com to open Power BI in a browser. Na Stronie głównej usługi Power BI wybierz pozycję Pobierz dane w lewym dolnym rogu, aby rozpocząć proces ładowania raportu programu Power BI Desktop.On your Power BI Home page, select Get data at lower left to start the process of loading your Power BI Desktop report.

Zrzut ekranu programu Power BI Desktop przedstawiający opcję Pobierz dane.

Na następnej stronie wybierz przycisk Pobierz w sekcji Pliki.On the next page, select Get from the Files section.

Zrzut ekranu programu Power BI Desktop przedstawiający ekran pobierania danych.

Na następnej stronie wybierz pozycję Plik lokalny.On the next page, select Local File. Przejdź do swojego pliku pbix programu Power BI Desktop i wybierz go, a następnie wybierz przycisk Otwórz.Browse to and select your Power BI Desktop .pbix file, and select Open.

Po zaimportowaniu pliku można go zobaczyć w obszarze Mój obszar roboczy > Raporty w lewym okienku usługi Power BI.After the file imports, you can see it listed under My workspace > Reports in the left pane of the Power BI service.

Zrzut ekranu programu Power BI Desktop przedstawiający plik zaimportowany do usługi Power BI.

Po wybraniu pliku zostanie wyświetlona pierwsza strona raportu.When you select the file, the first page of the report appears. Na kartach znajdujących się po lewej stronie raportu można wybrać inne strony.You can select different pages from the tabs at the left of the report.

W usłudze Power BI możesz wprowadzić zmiany w raporcie, wybierając opcję Więcej opcji > Edytuj w górnej części kanwy raportu.You can make changes to a report in the Power BI service by selecting More options > Edit from the top of the report canvas. Aby zapisać zmiany, wybierz pozycję Zapisz kopię.To save your changes, select Save a copy.

Zrzut ekranu programu Power BI Desktop przedstawiający opcje Edytuj i Zapisz.

Istnieją różnego rodzaju interesujące wizualizacje, które możesz utworzyć na podstawie raportu w usłudze Power BI, a następnie przypiąć je do pulpitu nawigacyjnego.There are all sorts of interesting visuals you can create from your report in the Power BI service, which you can pin to a dashboard. Aby dowiedzieć się więcej o pulpitach nawigacyjnych w usłudze Power BI, zobacz Porady dotyczące projektowania doskonałych pulpitów nawigacyjnych.To learn about dashboards in the Power BI service, see Tips for designing a great dashboard. Aby uzyskać więcej informacji o tworzeniu, udostępnianiu i modyfikowaniu pulpitów nawigacyjnych, zobacz Udostępnianie pulpitu nawigacyjnego.For more information about creating, sharing, and modifying dashboards, see Share a dashboard.

Aby udostępnić raport lub pulpit nawigacyjny, wybierz pozycję Udostępnij w górnej części otwartej strony raportu lub pulpitu nawigacyjny bądź wybierz ikonę Udostępnij obok nazwy raportu lub pulpitu nawigacyjnego na liście Mój obszar roboczy > Raporty bądź Mój obszar roboczy > Pulpity nawigacyjne.To share a report or dashboard, select Share at the top of the open report or dashboard page, or select the Share icon next to the report or dashboard name in the My workspace > Reports or My workspace > Dashboards lists.

Wypełnij pola na ekranie Udostępnij raport lub Udostępnij pulpit nawigacyjny, aby wysłać wiadomość e-mail bądź uzyskać link umożliwiający udostępnienie raportu lub pulpitu nawigacyjnego innym osobom.Complete the Share report or Share dashboard screen to send an email or get a link to share your report or dashboard with others.

Zrzut ekranu programu Power BI Desktop przedstawiający ekran Udostępnij raport.

Istnieją różne rodzaje interesujących kombinacji i wizualizacji związanych z danymi, które możesz wykonać przy użyciu programu Power BI Desktop i usługi Power BI.There are many compelling data-related mash-ups and visualizations you can do with Power BI Desktop and the Power BI service.

Następne krokiNext steps

Program Power BI Desktop obsługuje nawiązywanie połączenia z portem diagnostycznym.Power BI Desktop supports connecting to a diagnostics port. Port diagnostyczny umożliwia innym narzędziom nawiązywanie połączenia i przeprowadzanie śledzeń w celach diagnostycznych.The diagnostics port allows other tools to connect to and perform traces for diagnostic purposes. Podczas korzystania z portu diagnostycznego wprowadzanie jakichkolwiek zmian w modelu nie jest obsługiwane. Zmiany w modelu mogą prowadzić do uszkodzenia i utraty danych.When using the diagnostics port, making any changes to the model is not supported. Changes to the model may lead to corruption and data loss.

Aby uzyskać więcej informacji o wielu możliwościach programu Power BI Desktop, skorzystaj z następujących zasobów:For more information on the many capabilities of Power BI Desktop, check out the following resources: