Omówienie zapytań w programie Power BI Desktop

Program Power BI Desktop umożliwia łączenie się ze zbiorami danych, tworzenie atrakcyjnych i fundamentalnych raportów oraz udostępnianie wyników pracy innym osobom, które mogą je następnie rozbudowywać i rozwijać własne rozwiązania analizy biznesowej.

W programie Power BI Desktop dostępne są trzy widoki:

  • Widok Raport — umożliwia tworzenie za pomocą zapytań atrakcyjnych wizualizacji i rozmieszczanie ich w sposób, w jaki mają być wyświetlane. Widok zawiera wiele stron, które można udostępniać innym użytkownikom.
  • Widok Dane — umożliwia wyświetlanie danych w raporcie w formacie modelu danych, w którym można dodawać miary, tworzyć nowe kolumny i zarządzać relacjami.
  • Widok Relacje — zapewnia graficzną reprezentację relacji ustanowionych w modelu danych oraz zarządzanie nimi i modyfikowanie ich według potrzeb.

Dostęp do tych widoków można uzyskać, wybierając jedną z trzech ikon z lewej strony programu Power BI Desktop. Na poniższej ilustracji jest wybrany widok Raport, co jest wskazane żółtym paskiem obok ikony.

Screenshot of Power B I Desktop showing Report view selected.

W programie Power BI Desktop dostępny jest też Edytor Power Query. Edytor Power Query umożliwia połączenie się z jednym lub większą liczbą źródeł danych, ukształtowanie i przekształcenie danych zgodnie z potrzebami, a następnie załadowanie uzyskanego modelu do programu Power BI Desktop.

Ten dokument zawiera omówienie pracy z danymi w Edytorze Power Query, ale nie tylko. Na końcu tego dokumentu znajdziesz linki do szczegółowych wskazówek dotyczących obsługiwanych typów danych. Znajdziesz również wskazówki dotyczące łączenia się z danymi, kształtowania danych, tworzenia relacji i rozpoczynania pracy.

Jednak najpierw przyjrzyjmy się edytorowi Power Query.

Edytor Power Query

Aby przejść do Edytor Power Query, wybierz pozycję Przekształć dane na karcie Narzędzia główne Power BI Desktop.

Screenshot of Power BI Desktop showing Power Query Editor Home tab.

Gdy nie ma żadnych połączeń danych, Edytor Power Query ma postać pustego okienka gotowego na dane.

Screenshot of Power B I Desktop showing Power Query Editor with no data connections.

Po załadowaniu zapytania widok Edytora Power Query staje się bardziej interesujący. Jeśli połączymy się z następującym internetowym źródłem danych, w Edytorze Power Query zostaną załadowane informacje o danych, które można następnie zacząć kształtować:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Tak wygląda Edytor Power Query po nawiązaniu połączenia danych:

  1. Na wstążce wiele przycisków jest teraz aktywnych, umożliwiając interakcje z danymi w zapytaniu.

  2. Okienko po lewej stronie zawiera listę zapytań dostępnych do wyboru, wyświetlenia i kształtowania.

  3. Środkowe okienko zawiera dane z wybranego zapytania i umożliwia kształtowanie.

  4. Zostanie wyświetlone okienko Ustawienia zapytania zawierające listę właściwości zapytania i zastosowanych kroków.

    Screenshot of Power B I Desktop showing the Query Settings pane in Power Query Editor.

Przyjrzymy się każdemu z tych czterech obszarów: wstążce, okienku Zapytania, widokowi danych i okienku Ustawienia zapytania.

Wstążka zapytania

Wstążka w Edytor Power Query składa się z czterech kart: Narzędzia główne, Przekształć, Dodaj kolumnę, Widok, Narzędzia i Pomoc.

Na karcie Narzędzia główne znajdują się typowe zadania związane z zapytaniami.

Screenshot of Power B I Desktop showing the Power Query Editor query ribbon.

Aby połączyć się z danymi i rozpocząć proces tworzenia zapytania, wybierz pozycję Nowe źródło. Zostanie wyświetlone menu z najbardziej typowymi źródłami danych.

Screenshot of Power B I Desktop showing New Source button.

Aby uzyskać więcej informacji o dostępnych źródłach danych, zobacz Źródła danych. Aby uzyskać informacje o łączeniu się z danymi, w tym przykłady i procedury, zobacz Łączenie się z danymi.

Karta Przekształć zapewnia dostęp do typowych zadań transformacji danych, takich jak:

  • Dodawanie lub usuwanie kolumn
  • Zmienianie typów danych
  • Dzielenie kolumn
  • Inne zadania oparte na danych

Screenshot of Power B I Desktop showing Home tab.

Aby uzyskać więcej informacji na temat przekształcania danych, wraz z przykładami, zobacz Samouczek: Kształtowanie i łączenie danych w programie Power BI Desktop.

Karta Dodaj kolumnę zapewnia dostęp do dodatkowych zadań związanych z dodawaniem kolumny, formatowaniem danych kolumny i dodawaniem kolumn niestandardowych. Poniższa ilustracja przedstawia kartę Dodaj kolumnę.

Screenshot of Power B I Desktop showing Add Column tab.

Karta Widok na wstążce służy do wyświetlania i ukrywania określonych okienek i okien. Służy również do wyświetlania Edytora zaawansowanego. Poniższa ilustracja przedstawia kartę Widok.

Screenshot of Power B I Desktop showing View tab.

Warto wiedzieć, że wiele zadań dostępnych z poziomu wstążki jest również dostępnych po kliknięciu prawym przyciskiem myszy kolumny lub innych danych w środkowym okienku.

Okienko po lewej stronie (zapytań)

W okienku po lewej stronie (okienko zapytań) wyświetlana jest liczba aktywnych zapytań oraz nazwa zapytania. Po wybraniu zapytania z okienka po lewej stronie jego dane są wyświetlane w środkowym okienku, w którym można je kształtować i przekształcać zgodnie z potrzebami. Na poniższej ilustracji przedstawiono lewe okienko z zapytaniem.

Screenshot of Power B I Desktop showing Queries in left pane.

Środkowe okienko (danych)

Środkowe okienko (okienko danych) zawiera dane z wybranego zapytania. To w tym okienku realizowana jest znaczna część pracy w widoku zapytania.

Na poniższej ilustracji przedstawiono nawiązane wcześniej połączenie z danymi internetowymi. Wybrana jest kolumna Ogólny wynik , a jej nagłówek został kliknięty prawym przyciskiem myszy, aby wyświetlić dostępne elementy menu. Wiele z tych elementów menu dostępnych po kliknięciu prawym przyciskiem myszy jest identycznych z przyciskami na kartach wstążki.

Screenshot of Power B I Desktop showing Data in center pane.

Po wybraniu elementu menu dostępnego po kliknięciu prawym przyciskiem myszy (lub przycisku na wstążce) zapytanie spowoduje zastosowanie danego kroku do danych. Spowoduje także zapisanie go jako części samego zapytania. Kroki są rejestrowane w okienku Ustawienia zapytania w kolejności sekwencyjnej, tak jak to opisano w następnej sekcji.

Okienko po prawej stronie (ustawień zapytania)

W okienku po prawej stronie (okienko ustawień zapytania) wyświetlane są wszystkie kroki związane z zapytaniem. Na przykład na poniższej ilustracji sekcja Zastosowane kroki w okienku Ustawienia zapytania odzwierciedla fakt, że właśnie zmieniono typ kolumny Overall score.

Screenshot of Power B I Desktop showing Query Settings in right pane.

W miarę stosowania do zapytania dodatkowych kroków są one rejestrowane w sekcji Zastosowane kroki.

Należy mieć świadomość, że dane bazowe nie ulegają zmianie. Zamiast tego Edytor Power Query dostosowuje i kształtuje swój widok danych. Ponadto kształtuje i dostosowuje widok każdej interakcji z danymi bazowymi, która odbywa się w oparciu o ukształtowany i zmodyfikowany widok tych danych w edytorze Power Query.

W okienku Ustawienia zapytania można zmieniać nazwy kroków, usuwać kroki lub zmieniać ich kolejność według potrzeb. Aby to zrobić, kliknij prawym przyciskiem myszy krok w sekcji Zastosowane kroki, a następnie wybierz pozycję z wyświetlonego menu. Wszystkie kroki zapytania są wykonywane w kolejności przedstawionej w okienku Zastosowane kroki.

Screenshot of Power B I Desktop showing Query Settings Properties and Applied Steps filters.

Edytor zaawansowany

Edytor zaawansowany umożliwia wyświetlanie kodu tworzonego przez Edytor Power Query w każdym kroku. Pozwala również utworzyć własny kod kształtujący. Aby uruchomić Edytor zaawansowany, wybierz kartę Widok na wstążce, a następnie pozycję Edytor zaawansowany. Zostanie wyświetlone okno zawierające istniejący kod zapytania.
Screenshot of Power B I Desktop showing Advanced Editor dialog box.

W oknie Edytor zaawansowany ten kod można edytować bezpośrednio. Aby zamknąć okno, wybierz przycisk Gotowe lub Anuluj.

Zapisywanie pracy

Gdy zapytanie jest tam, gdzie chcesz, wybierz pozycję Zamknij & zastosuj z menu Plik Edytor Power Query. Ta akcja spowoduje zastosowanie zmian i zamknięcie edytora.
Screenshot of Power B I Desktop showing Close and Apply option under File tab.

W trakcie realizowania postępu w programie Power BI Desktop będzie udostępniane okno dialogowe z jego stanem.
Screenshot of Power B I Desktop showing Applied Query Changes confirmation dialog box.

Gdy wszystko jest gotowe, program Power BI Desktop może zapisać swoją pracę w postaci pliku pbix.

Aby zapisać swoją pracę, wybierz pozycję PlikZapisz>(lubPlikZapisz> jako), jak pokazano na poniższej ilustracji.
Screenshot of Power B I Desktop showing Power Query Editor File tab.

Następne kroki

Przy użyciu programu Power BI Desktop można wykonywać różnorodne zadania. Aby uzyskać więcej informacji na temat jego możliwości, skorzystaj z następujących zasobów: