Dodawanie ekranu z przewijaniem w usłudze PowerAppsAdd a scrolling screen in PowerApps

Utwórz ekran, który użytkownicy będą mogli przewijać w celu wyświetlenia innych elementów.Create a screen that users can scroll to show different items. Na przykład możesz utworzyć aplikację wyświetlającą dane na wykresie kolumnowym i wykresie liniowym.For example, you might want to create an app that displays data in a column chart and line chart. Tworząc ekran z przewijaniem, możesz dodać wiele kontrolek, które będą wyświetlane przez użytkowników podczas przewijania.By adding a scrolling screen, you can add multiple controls, which users can display if they scroll.

Gdy dodasz wiele kontrolek w sekcji, będą one zachowywały swoje położenie względne, niezależnie od tego, czy aplikacja jest przeznaczona na telefon, czy na tablet.When you add multiple controls in a section, the controls maintain their relative positions within that section, regardless if it's a phone app or a tablet app. Pamiętaj, że rozmiar i orientacja ekranu mogą określać sposób rozmieszczenia sekcji.Note that the screen size and orientation may determine how the sections are arranged.

 

Wymagania wstępnePrerequisites

Tworzenie ekranu z przewijaniemCreate a scrolling screen

  1. Na karcie Narzędzia główne kliknij lub naciśnij pozycję Nowy ekran:On the Home tab, click or tap New screen:

    Opcja dodawania ekranu do aplikacji

  2. Na karcie Narzędzia główne kliknij lub naciśnij pozycję Układy, a następnie kliknij lub naciśnij opcję dodania nieskończonej kanwy z przewijaniem:On the Home tab, click or tap Layouts, and then click or tap the option to add an infinite scrolling canvas:

    Opcja dodania nieskończonej kanwy z przewijaniem

    Zostanie dodana kanwa:The canvas is added:

    Ekran z domyślną nieskończoną kanwą z przewijaniem

Dodawanie elementówAdd elements

Teraz dodajmy kilka kontrolek do kanwy, aby zobaczyć, jak działa ekran z przewijaniem.Now, let's add some controls to the canvas to see how the scrolling screen works.

  1. Na dodanej kanwie kliknij lub naciśnij pozycję Dodaj element z karty Wstawianie.In the canvas you added, click or tap Add an item from the Insert tab.

  2. Na karcie Wstawianie kliknij lub naciśnij pozycję Wykresy, a następnie kliknij lub naciśnij pozycję Wykres kolumnowy.On the Insert tab, click or tap Charts, and then click or tap Column Chart.

    Opcja dodawania wykresu kolumnowego

    Na pierwszej karcie na ekranie zostanie wyświetlony wykres kolumnowy:A column chart appears in the first card on the screen:

    Domyślny wykres kolumnowy

  3. Na karcie Wstawianie kliknij lub naciśnij pozycję Tekst, a następnie kliknij lub naciśnij pozycję Wprowadzanie piórem:On the Insert tab, click or tap Text, and then click or tap Pen input:

    Opcja dodawania kontrolki pióra

  4. Przenieś kontrolkę pióra poniżej wykresu i zmień jej rozmiar tak, aby pokrywała ona dolną część karty:Move the pen control below the chart, and resize the pen control to cover the bottom of the card:

    Przenoszenie i zmienianie rozmiaru kontrolki pióra

Dodawanie sekcjiAdd a section

Teraz dodajmy kolejną kartę z inną kontrolką.Now, let's add another card with another control.

  1. W pobliżu dolnej części ekranu kliknij lub naciśnij pozycję Dodaj sekcję:Near the bottom of the screen, click or tap Add section:

    Opcja dodawania sekcji

    Na ekranie zostanie dodana nowa karta:A new card is added to the screen:

    Nowa karta poniżej domyślnej sekcji

  2. Gdy karta jest nadal zaznaczona, przejdź do karty Wstawianie, kliknij lub naciśnij pozycję Wykresy, a następnie kliknij lub naciśnij pozycję Wykres liniowy.With the card still selected, go to the Insert tab, click or tap Charts, and then click or tap Line chart.

    Nowy wykres jest zbyt duży, aby mieścił się na ekranie wraz z innymi kontrolkami:The new chart is too big to appear on the screen with the other controls:

    Wykres liniowy dodany w dolnej części nowej karty

  3. Otwórz tryb Podgląd, naciskając klawisz F5 (ewentualnie klikając lub naciskając ikonę odtwarzania w prawym górnym rogu).Open Preview mode by pressing F5 (or by clicking or tapping the play icon near the upper-right corner).

    Otwieranie trybu podglądu

  4. Przewiń w dół, aby wyświetlić nowy wykres liniowy.Scroll down to display the new line chart.

    Podgląd wykresu liniowego