Skrypty po stronie klienta nie działają już Microsoft Dynamics CRM Online po aktualizacji usługi z grudnia 2012 r.
Ten artykuł ułatwia naprawienie błędów skryptów po Microsoft Dynamics CRM Online aktualizacji usługi z grudnia 2012 r.
Dotyczy: Microsoft Dynamics CRM Online
Oryginalny numer KB: 2804561
Symptomy
Jeśli formularze używają interfejsu API klienta V4.0 (crmForm), po zaktualizowaniu organizacji programu Microsoft Dynamics CRM Online do aktualizacji usługi z grudnia 2012 r. mogą wystąpić błędy skryptów. Może zostać wyświetlone okno dialogowe z komunikatem "Nieokreślone" lub w lewym dolnym rogu formularza może zostać wyświetlony komunikat o błędzie "Błąd na stronie". Mogą być wyświetlane inne błędy skryptów.
Przyczyna
W aktualizacji usługi z grudnia 2012 r. dla systemu Microsoft Dynamics CRM wprowadzono nowe ustawienie systemowe, które kontroluje, czy składniki HTML (HTC) są zawarte w formularzach Microsoft Dynamics CRM formularzach. To ustawienie jest domyślnie wyłączone w programie Microsoft Dynamics CRM Online.
Następujące właściwości crmForm wymagają htc:
Właściwości programu CrmForm |
---|
. Save() |
. SaveAndClose( |
. FormType |
. ObjectTypeCode |
. ObjectId |
. ObjectTypeName |
. RequiredLevel |
. SetFocus( |
. FireOnChange |
. Minimum |
. Maksimum |
. DataValue |
isDirty |
. Wyłączone |
. SelectedOption |
. SelectedText |
. SortingEnum |
. Sortowanie |
. SelectedIndex |
. InnerText |
. OptionsXml |
. Dokładność |
. DataXml |
. Tekst |
. Wartość |
. DisplayValue |
. WillSubmit |
. DataChangeHandler |
. BypassValidation |
. AllowFormFocus |
._bSaving |
._htcInitCompleted |
. SubmitFormId |
.NO_DATA |
. RefreshOnSave |
. Widoczny |
. ForceSubmit |
. Formularz |
. TimeControl |
isInitialized |
allowblankdate |
. IsMoney |
. IsBaseCurrency |
. CurrencySymbol |
. Currency Amortyzowanie |
. IgnoreCurrencySymbol |
. IgnoreRange |
. PrecisionChangeHandler |
. TrimValue |
. MaxLength |
Wyliczenie |
Rozwiązanie
- Zaloguj się do aplikacji Microsoft Dynamics CRM sieci Web jako administrator systemu.
- Kliknij Ustawienia, kliknij pozycję Administracja, a następnie kliknij pozycję System Ustawienia.
- Kliknij kartę Dostosowywanie .
- Kliknij pole wyboru obok ustawienia oznaczonego etykietą Dołącz obsługę htc do Microsoft Dynamics CRM formularzach.
- Kliknij przycisk OK.
Więcej informacji
Interfejs API crmForm został wycofany w wersji Microsoft Dynamics CRM 2011. Aby uzyskać więcej informacji na ten temat i innych potencjalnych przyczyn błędów skryptów po aktualizacji usługi z grudnia 2012 r., zobacz następujące wpisy w blogu: