Zdalne debugowanie ASP.NET Core w usługach IIS na platformie Azure w programie Visual StudioRemote Debug ASP.NET Core on IIS in Azure in Visual Studio

W tym przewodniku wyjaśniono, jak skonfigurować i skonfigurować aplikację ASP.NET Core programu Visual Studio, wdrożyć ją w usługach IIS przy użyciu platformy Azure i dołączyć zdalny debuger z programu Visual Studio.This guide explains how to set up and configure a Visual Studio ASP.NET Core app, deploy it to IIS using Azure, and attach the remote debugger from Visual Studio.

Zalecany sposób zdalnego debugowania na platformie Azure zależy od Twojego scenariusza:The recommended way to remote debug on Azure depends on your scenario:

  • Aby debugować ASP.NET Core na Azure App Service, zobacz debugowanie aplikacji platformy Azure przy użyciu Snapshot Debugger.To debug ASP.NET Core on Azure App Service, see Debug Azure apps using the Snapshot Debugger. Jest to zalecana metoda.This is the recommended method.

  • Aby debugować ASP.NET Core na Azure App Service przy użyciu bardziej tradycyjnych funkcji debugowania, wykonaj kroki opisane w tym temacie (zobacz sekcję debugowanie zdalne na Azure App Service).To debug ASP.NET Core on Azure App Service using more traditional debugging features, follow steps in this topic (see the section Remote debug on Azure App Service).

    W tym scenariuszu należy wdrożyć aplikację z programu Visual Studio na platformie Azure, ale nie musisz ręcznie instalować ani konfigurować usług IIS ani zdalnego debugera (te składniki są reprezentowane przez linie kropkowane), jak pokazano na poniższej ilustracji.In this scenario, you must deploy your app from Visual Studio to Azure but you do not need to manually install or configure IIS or the remote debugger (these components are represented with dotted lines), as shown in the following illustration.

    Składniki debugera zdalnegoRemote debugger components

  • Aby debugować usługi IIS na maszynie wirtualnej platformy Azure, wykonaj kroki opisane w tym temacie (zobacz sekcję debugowanie zdalne na maszynie wirtualnej platformy Azure).To debug IIS on an Azure VM, follow steps in this topic (see the section Remote Debug on an Azure VM). Pozwala to na użycie niestandardowej konfiguracji usług IIS, ale kroki instalacji i wdrażania są bardziej skomplikowane.This allows you to use a customized configuration of IIS, but the setup and deployment steps are more complicated.

    W przypadku maszyny wirtualnej platformy Azure należy wdrożyć aplikację z programu Visual Studio na platformie Azure, a także ręcznie zainstalować rolę usług IIS i zdalny debuger, jak pokazano na poniższej ilustracji.For an Azure VM, you must deploy your app from Visual Studio to Azure and you also need to manually install the IIS role and the remote debugger, as shown in the following illustration.

    Składniki debugera zdalnegoRemote debugger components

  • Aby debugować ASP.NET Core na platformie Azure Service Fabric, zobacz debugowanie aplikacji zdalnej Service Fabric.To debug ASP.NET Core on Azure Service Fabric, see Debug a remote Service Fabric application.

Ostrzeżenie

Pamiętaj o usunięciu zasobów platformy Azure utworzonych po wykonaniu kroków opisanych w tym samouczku.Be sure to delete the Azure resources that you create when you have completed the steps in this tutorial. Dzięki temu można uniknąć niepotrzebnych opłat.That way you can avoid incurring unnecessary charges.

Wymagania wstępnePrerequisites

Aby wykonać kroki opisane w tym artykule, wymagany jest program Visual Studio 2019.Visual Studio 2019 is required to follow the steps shown in this article.

Aby wykonać kroki opisane w tym artykule, wymagany jest program Visual Studio 2017.Visual Studio 2017 is required to follow the steps shown in this article.

Wymagania dotyczące sieciNetwork requirements

Debugowanie między dwoma komputerami połączonymi za pomocą serwera proxy nie jest obsługiwane.Debugging between two computers connected through a proxy is not supported. Debugowanie w przypadku dużych opóźnień lub połączeń o niskiej przepustowości, takich jak Internet telefoniczny lub przez Internet w różnych krajach, nie jest zalecane i może się nie powieść.Debugging over a high latency or low bandwidth connection, such as dialup Internet, or over the Internet across countries is not recommended and may fail or be unacceptably slow. Aby uzyskać pełną listę wymagań, zobacz wymagania.For a complete list of requirements, see Requirements.

Tworzenie aplikacji ASP.NET Core na komputerze z Visual StudioCreate the ASP.NET Core application on the Visual Studio computer

  1. Utwórz nową aplikację ASP.NET Core.Create a new ASP.NET Core application.

    W programie Visual Studio 2019 naciśnij klawisze CTRL + Q , aby otworzyć pole wyszukiwania, wpisz ASP.NET, wybierz pozycję Szablony, a następnie wybierz pozycję Utwórz nową ASP.NET Core aplikacji sieci Web.In Visual Studio 2019, type Ctrl + Q to open the search box, type asp.net, choose Templates, then choose Create new ASP.NET Core Web Application. W wyświetlonym oknie dialogowym wpisz nazwę projektu MyASPApp, a następnie wybierz pozycję Utwórz.In the dialog box that appears, name the project MyASPApp, and then choose Create. Następnie wybierz pozycję aplikacja sieci Web (Model-View-Controller), a następnie wybierz pozycję Utwórz.Next, choose Web Application (Model-View-Controller), and then choose Create.

    W programie Visual Studio 2017 wybierz kolejno pozycje plik > nowy > projekt, a następnie wybierz pozycję Visual C# > Web > ASP.NET Core aplikacji sieci Web.In Visual Studio 2017, choose File > New > Project, then select Visual C# > Web > ASP.NET Core Web Application. W sekcji szablony ASP.NET Core wybierz pozycję aplikacja sieci Web (Model-View-Controller).In the ASP.NET Core templates section, select Web Application (Model-View-Controller). Upewnij się, że wybrano ASP.NET Core 2,1, że Obsługa platformy Docker nie jest zaznaczona i że uwierzytelnianie jest ustawione na wartość bez uwierzytelniania.Make sure that ASP.NET Core 2.1 is selected, that Enable Docker Support is not selected and that Authentication is set to No Authentication. Nazwij projekt MyASPApp.Name the project MyASPApp.

  2. Otwórz plik About.cshtml.cs i ustaw punkt przerwania w OnGet metodzie (w starszych szablonach otwórz HomeController.cs i ustaw punkt przerwania w About() metodzie).Open the About.cshtml.cs file and set a breakpoint in the OnGet method (in older templates, open HomeController.cs instead and set the breakpoint in the About() method).

ASP.NET Core debugowania zdalnego na Azure App ServiceRemote Debug ASP.NET Core on an Azure App Service

W programie Visual Studio można szybko publikować i debugować aplikację w w pełni zainicjowanym wystąpieniu usług IIS.From Visual Studio, you can quickly publish and debug your app to a fully provisioned instance of IIS. Jednak Konfiguracja usług IIS jest wstępnie ustawiona i nie można jej dostosować.However, the configuration of IIS is preset and you cannot customize it. Aby uzyskać bardziej szczegółowe instrukcje, zobacz wdrażanie aplikacji sieci web ASP.NET Core na platformie Azure przy użyciu programu Visual Studio.For more detailed instructions, see Deploy an ASP.NET Core web app to Azure using Visual Studio. (Jeśli potrzebujesz możliwości dostosowania usług IIS, wypróbuj debugowanie na maszynie wirtualnej platformy Azure).(If you need the ability to customize IIS, try debugging on an Azure VM.)

Aby wdrożyć aplikację i debugowanie zdalne za pomocą programu Cloud ExplorerTo deploy the app and remote debug using Cloud Explorer

  1. W programie Visual Studio kliknij prawym przyciskiem myszy węzeł projektu, a następnie wybierz polecenie Publikuj.In Visual Studio, right-click the project node and choose Publish.

    Jeśli wszystkie profile publikowania zostały wcześniej skonfigurowane, zostanie wyświetlone okienko Publikowanie .If you have previously configured any publishing profiles, the Publish pane appears. Kliknij pozycję Nowy profil.Click New profile.

  2. Wybierz Azure App Service z okna dialogowego Publikowanie , wybierz pozycję Utwórz nowyi postępuj zgodnie z monitami, aby utworzyć profil.Choose Azure App Service from the Publish dialog box, select Create New, and follow the prompts to create a profile.

    Aby uzyskać szczegółowe instrukcje, zobacz wdrażanie aplikacji sieci web ASP.NET Core na platformie Azure przy użyciu programu Visual Studio.For detailed instructions, see Deploy an ASP.NET Core web app to Azure using Visual Studio.

    Publikowanie w usłudze Azure App Service

  3. W oknie publikowanie wybierz polecenie Edytuj konfigurację i Przełącz się do konfiguracji debugowania, a następnie wybierz pozycję Publikuj.In the Publish window, choose Edit Configuration and switch to a Debug configuration, and then choose Publish.

    Do debugowania aplikacji wymagana jest Konfiguracja debugowania.A Debug configuration is required to debug the app.

  4. Otwórz program Cloud Explorer (Wyświetl > Eksplorator chmury), kliknij prawym przyciskiem myszy wystąpienie App Service i wybierz Dołącz debuger.Open Cloud Explorer (View > Cloud Explorer), right-click on the App Service instance and choose Attach Debugger.

    Jeśli program Cloud Explorer jest niedostępny, Otwórz Eksplorator serwera zamiast tego.If Cloud Explorer is not available, open Server Explorer instead. Następnie kliknij prawym przyciskiem myszy wystąpienie App Service w Eksplorator serwera i wybierz polecenie Dołącz debuger.Then, right-click on the App Service instance in Server Explorer and choose Attach Debugger.

  5. W uruchomionej aplikacji ASP.NET kliknij link do strony informacje .In the running ASP.NET application, click the link to the About page.

    Punkt przerwania powinien zostać trafiony w programie Visual Studio.The breakpoint should be hit in Visual Studio.

    Gotowe.That's it! Pozostałe kroki opisane w tym temacie mają zastosowanie do zdalnego debugowania na maszynie wirtualnej platformy Azure.The rest of the steps in this topic apply to remote debugging on an Azure VM.

ASP.NET Core debugowania zdalnego na maszynie wirtualnej platformy AzureRemote Debug ASP.NET Core on an Azure VM

Można utworzyć maszynę wirtualną platformy Azure dla systemu Windows Server, a następnie zainstalować i skonfigurować usługi IIS oraz inne wymagane składniki oprogramowania.You can create an Azure VM for Windows Server and then install and configure IIS and the other required software components. Zajmuje to więcej czasu niż wdrożenie do Azure App Service i wymaga wykonania pozostałych kroków opisanych w tym samouczku.This takes more time than deploying to an Azure App Service and requires that you follow the remaining steps in this tutorial.

Te procedury zostały przetestowane na tych konfiguracjach serwera:These procedures have been tested on these server configurations:

  • Windows Server 2012 R2 i IIS 8Windows Server 2012 R2 and IIS 8
  • Windows Server 2016 i IIS 10Windows Server 2016 and IIS 10
  • Windows Server 2019 i IIS 10Windows Server 2019 and IIS 10

Aplikacja jest już uruchomiona w usługach IIS na maszynie wirtualnej platformy Azure?App already running in IIS on the Azure VM?

Ten artykuł zawiera instrukcje dotyczące konfigurowania podstawowej konfiguracji usług IIS w systemie Windows Server i wdrażania aplikacji z programu Visual Studio.This article includes steps on setting up a basic configuration of IIS on Windows server and deploying the app from Visual Studio. Te kroki są dołączone do programu, aby upewnić się, że na serwerze są zainstalowane wymagane składniki, że aplikacja może działać poprawnie i że jest gotowy do zdalnego debugowania.These steps are included to make sure that the server has the required components installed, that the app can run correctly, and that you are ready to remote debug.

  • Jeśli aplikacja jest uruchomiona w usługach IIS i po prostu chcesz pobrać zdalny debuger i rozpocząć debugowanie, przejdź do pozycji Pobierz i zainstaluj narzędzia zdalne w systemie Windows Server.If your app is running in IIS and you just want to download the remote debugger and start debugging, go to Download and Install the remote tools on Windows Server.

  • Jeśli potrzebujesz pomocy, aby upewnić się, że aplikacja została prawidłowo skonfigurowana, wdrożona i uruchomiona w usługach IIS, aby umożliwić debugowanie, wykonaj wszystkie kroki opisane w tym temacie.If you want help to make sure that your app is set up, deployed, and running correctly in IIS so that you can debug, follow all the steps in this topic.

    • Przed rozpoczęciem wykonaj wszystkie kroki opisane w temacie Instalowanie i uruchamianie usług IIS.Before you begin, follow all the steps described in Install and run IIS.

    • Po otwarciu portu 80 w sieciowej grupie zabezpieczeń, należy również otworzyć właściwy port dla zdalnego debugera (4024 lub 4022).When you open port 80 in the Network security group, also open the correct port for the remote debugger (4024 or 4022). Dzięki temu nie będzie trzeba otwierać go później.That way, you won't have to open it later. Jeśli używasz Web Deploy, Otwórz również port 8172.If you're using Web Deploy, also open port 8172.

Aktualizowanie ustawień zabezpieczeń przeglądarki w systemie Windows ServerUpdate browser security settings on Windows Server

Jeśli konfiguracja zwiększonych zabezpieczeń jest włączona w programie Internet Explorer (jest włączona domyślnie), może być konieczne dodanie niektórych domen jako zaufanych lokacji, aby umożliwić pobranie niektórych składników serwera sieci Web.If Enhanced Security Configuration is enabled in Internet Explorer (it is enabled by default), then you may need to add some domains as trusted sites to enable you to download some of the web server components. Dodaj Zaufane witryny, wybierając Opcje internetowe > zabezpieczenia > zaufane lokacje > Lokacje.Add the trusted sites by going to Internet Options > Security > Trusted Sites > Sites. Dodaj następujące domeny.Add the following domains.

  • microsoft.commicrosoft.com
  • go.microsoft.comgo.microsoft.com
  • download.microsoft.comdownload.microsoft.com
  • iis.netiis.net

Podczas pobierania oprogramowania można uzyskać żądania udzielenia uprawnień do ładowania różnych skryptów i zasobów witryny sieci Web.When you download the software, you may get requests to grant permission to load various web site scripts and resources. Niektóre z tych zasobów nie są wymagane, ale aby uprościć proces, kliknij przycisk Dodaj po wyświetleniu monitu.Some of these resources are not required, but to simplify the process, click Add when prompted.

Zainstaluj ASP.NET Core w systemie Windows ServerInstall ASP.NET Core on Windows Server

  1. Zainstaluj pakiet hostingu platformy .NET Core w systemie hostingu.Install the .NET Core Hosting Bundle on the hosting system. Pakiet instaluje środowisko uruchomieniowe programu .NET Core, bibliotekę .NET Core i moduł ASP.NET Core.The bundle installs the .NET Core Runtime, .NET Core Library, and the ASP.NET Core Module. Aby uzyskać bardziej szczegółowe instrukcje, zobacz Publikowanie w usługach IIS.For more in-depth instructions, see Publishing to IIS.

    W przypadku platformy .NET Core 3 Zainstaluj pakiet hostingu platformy .NET Core.For .NET Core 3, install the .NET Core Hosting Bundle. W przypadku platformy .NET Core 2 Zainstaluj platformę .NET Core systemu Windows Server.For .NET Core 2, install the .NET Core Windows Server Hosting.

    Uwaga

    Jeśli system nie ma połączenia z Internetem, uzyskaj i zainstaluj pakiet redystrybucyjny Microsoft Visual C++ 2015 przed zainstalowaniem pakietu hostingu platformy .NET Core systemu Windows Server.If the system doesn't have an Internet connection, obtain and install the Microsoft Visual C++ 2015 Redistributable before installing the .NET Core Windows Server Hosting bundle.

  2. Uruchom ponownie system (lub wykonaj polecenie net stop was/y , a następnie net start W3SVC z wiersza polecenia, aby wybrać zmianę ścieżki systemowej).Restart the system (or execute net stop was /y followed by net start w3svc from a command prompt to pick up a change to the system PATH).

Wybierz opcję wdrożeniaChoose a deployment option

Jeśli potrzebujesz pomocy przy wdrażaniu aplikacji w usługach IIS, weź pod uwagę następujące opcje:If you need help to deploy the app to IIS, consider these options:

  • Wdróż aplikację, tworząc plik ustawień publikowania w usługach IIS i importując ustawienia w programie Visual Studio.Deploy by creating a publish settings file in IIS and importing the settings in Visual Studio. W niektórych scenariuszach jest to szybki sposób wdrożenia aplikacji.In some scenarios, this is a fast way to deploy your app. Podczas tworzenia pliku ustawień publikowania uprawnienia są konfigurowane automatycznie w usługach IIS.When you create the publish settings file, permissions are automatically set up in IIS.

  • Wdróż program przez opublikowanie w folderze lokalnym i skopiowanie danych wyjściowych za pomocą preferowanej metody do przygotowanego folderu aplikacji w programie IIS.Deploy by publishing to a local folder and copying the output by a preferred method to a prepared app folder on IIS.

Obowiązkowe Wdrażanie przy użyciu pliku ustawień publikowania(Optional) Deploy using a publish settings file

Tej opcji można użyć do utworzenia pliku ustawień publikowania i zaimportowania go do programu Visual Studio.You can use this option create a publish settings file and import it into Visual Studio.

Uwaga

Ta metoda wdrażania używa Web Deploy, która musi być zainstalowana na serwerze.This deployment method uses Web Deploy, which must be installed on the server. Jeśli chcesz skonfigurować Web Deploy ręcznie zamiast zaimportować ustawienia, możesz zainstalować Web Deploy 3,6 zamiast Web Deploy 3,6 dla serwerów hostingu.If you want to configure Web Deploy manually instead of importing the settings, you can install Web Deploy 3.6 instead of Web Deploy 3.6 for Hosting Servers. Jeśli jednak skonfigurujesz Web Deploy ręcznie, musisz upewnić się, że folder aplikacji na serwerze jest skonfigurowany z prawidłowymi wartościami i uprawnieniami (zobacz Konfigurowanie witryny sieci Web ASP.NET).However, if you configure Web Deploy manually, you will need to make sure that an app folder on the server is configured with the correct values and permissions (see Configure ASP.NET Web site).

Skonfiguruj witrynę sieci Web ASP.NET CoreConfigure the ASP.NET Core web site

  1. W Menedżerze usług IIS w lewym okienku w obszarze połączeniawybierz pozycję Pule aplikacji.In IIS Manager, in the left pane under Connections, select Application Pools. Otwórz przystawkę Domyślna i ustaw wersję środowiska .NET CLR na Brak kodu zarządzanego.Open DefaultAppPool and set the .NET CLR version to No Managed Code. Jest to wymagane w przypadku ASP.NET Core.This is required for ASP.NET Core. Domyślna witryna sieci Web używa tej domyślnej.The Default Web Site uses the DefaultAppPool.

  2. Zatrzymaj i uruchom ponownie tę samą wartość.Stop and restart the DefaultAppPool.

Instalowanie i Konfigurowanie Web Deploy serwerów hostingu w systemie Windows ServerInstall and configure Web Deploy for Hosting Servers on Windows Server

Web Deploy 3,6 dla serwerów hostingu oferuje dodatkowe funkcje konfiguracji, które umożliwiają tworzenie pliku ustawień publikowania w interfejsie użytkownika.Web Deploy 3.6 for Hosting Servers provides additional configuration features that enable the creation of the publish settings file from the UI.

  1. Jeśli Web Deploy już zainstalowane w systemie Windows Server, odinstaluj je za pomocą Control Panel > apletupanelu sterowania > Odinstaluj program.If you have Web Deploy already installed on Windows Server, uninstall it using Control Panel > Programs > Uninstall a Program.

  2. Następnie zainstaluj Web Deploy 3,6 dla serwerów hostingu w systemie Windows Server.Next, install Web Deploy 3.6 for Hosting Servers on Windows Server.

    Aby zainstalować Web Deploy dla serwerów hostingu, użyj Instalatora platformy sieci Web (Instalatora WebPI).To install Web Deploy for Hosting Servers, use the Web Platform Installer (WebPI). (Aby znaleźć łącze Instalatora platformy sieci Web z usług IIS, wybierz pozycję IIS w lewym okienku Menedżer serwera.(To find the Web Platform Installer link from IIS, select IIS in the left pane of Server Manager. W okienku serwera kliknij prawym przyciskiem myszy serwer, a następnie wybierz pozycję menedżer Internet Information Services (IIS).In the server pane, right-click the server and select Internet Information Services (IIS) Manager. Następnie użyj linku Pobierz nowe składniki platformy sieci Web w oknie Akcje .) Możesz również uzyskać dostęp do Instalatora platformy sieci Web (Instalatora WebPI) z plików do pobrania.Then use the Get New Web Platform Components link in the Actions window.) You can also obtain the Web Platform Installer (WebPI) from downloads.

    W Instalatorze platformy sieci Web Znajdź Web Deploy 3,6 dla serwerów hostingu na karcie aplikacje.In the Web Platform Installer, you find Web Deploy 3.6 for Hosting Servers in the Applications tab.

  3. Jeśli nie zostały jeszcze zainstalowane Narzędzia i skrypty zarządzania usługami IIS, zainstaluj je teraz.If you did not already install IIS Management Scripts and Tools, install it now.

    Wybierz kolejno pozycje serwer > serwer sieci Web > Narzędzia do zarządzaniaprogramu, a następnie wybierz rolę Narzędzia i skrypty zarządzania usługami IIS , kliknij przycisk dalej, a następnie Zainstaluj rolę.Go to Select server roles > Web Server (IIS) > Management Tools, and then select the IIS Management Scripts and Tools role, click Next, and then install the role.

    Zainstaluj narzędzia i skrypty zarządzania usługami IIS

    Do włączenia generowania pliku ustawień publikowania wymagane są skrypty i narzędzia.The scripts and tools are required to enable the generation of the publish settings file.

  4. Obowiązkowe Sprawdź, czy Web Deploy działa prawidłowo, otwierając Panel sterowania > system i zabezpieczenia > narzędzia administracyjne > usługi, a następnie upewnij się, że:(Optional) Verify that Web Deploy is running correctly by opening Control Panel > System and Security > Administrative Tools > Services, and then make sure that:

    • Usługa Deployment Agent sieci Web jest uruchomiona (nazwa usługi jest inna w starszych wersjach).Web Deployment Agent Service is running (the service name is different in older versions).

    • Usługa zarządzania siecią Web jest uruchomiona.Web Management Service is running.

    Jeśli jedna z usług agenta nie jest uruchomiona, uruchom ponownie usługę Deployment Agent sieci Web.If one of the agent services is not running, restart the Web Deployment Agent Service.

    Jeśli usługa Deployment Agent sieci Web nie istnieje, przejdź do pozycji Panel sterowania > programy > Odinstaluj program, Znajdź pozycję **Microsoft Web Deploy <version> **.If the Web Deployment Agent Service is not present at all, go to Control Panel > Programs > Uninstall a program, find Microsoft Web Deploy <version>. Wybierz opcję zmiany instalacji i upewnij się, że wybrana opcja zostanie zainstalowana na lokalnym dysku twardym dla składników Web Deploy.Choose to Change the installation and make sure that you choose Will be installed to the local hard drive for the Web Deploy components. Wykonaj kroki instalacji zmian.Complete the change installation steps.

Tworzenie pliku ustawień publikowania w usługach IIS w systemie Windows ServerCreate the publish settings file in IIS on Windows Server

  1. Zamknij i ponownie otwórz konsolę zarządzania usługami IIS, aby wyświetlić zaktualizowane opcje konfiguracji w interfejsie użytkownika.Close and reopen the IIS Management Console to show updated configuration options in the UI.

  2. W programie IIS kliknij prawym przyciskiem myszy domyślną witrynę sieci Web, wybierz polecenie Wdróż > Skonfiguruj Web Deploy publikowanie.In IIS, right-click the Default Web Site, choose Deploy > Configure Web Deploy Publishing.

    Konfigurowanie konfiguracji Web Deploy

    Jeśli nie widzisz menu Deploy , zapoznaj się z poprzednią sekcją, aby sprawdzić, czy Web Deploy jest uruchomiona.If you don't see the Deploy menu, see the preceding section to verify that Web Deploy is running.

  3. W oknie dialogowym Konfigurowanie publikowania Web Deploy przejrzyj ustawienia.In the Configure Web Deploy Publishing dialog box, examine the settings.

  4. Kliknij przycisk Setup (Konfiguracja).Click Setup.

    W panelu wyników dane wyjściowe pokazują, że prawa dostępu są udzielane określonemu użytkownikowi i że plik z rozszerzeniem . publishsettings został wygenerowany w lokalizacji pokazanej w oknie dialogowym.In the Results panel, the output shows that access rights are granted to the specified user, and that a file with a .publishsettings file extension has been generated in the location shown in the dialog box.

    <?xml version="1.0" encoding="utf-8"?>
    <publishData>
      <publishProfile
        publishUrl="https://myhostname:8172/msdeploy.axd"
        msdeploySite="Default Web Site"
        destinationAppUrl="http://myhostname:80/"
        mySQLDBConnectionString=""
        SQLServerDBConnectionString=""
        profileName="Default Settings"
        publishMethod="MSDeploy"
        userName="myhostname\myusername" />
    </publishData>
    

    W zależności od konfiguracji systemu Windows Server i usług IIS zobaczysz różne wartości w pliku XML.Depending on your Windows Server and IIS configuration, you see different values in the XML file. Poniżej przedstawiono kilka szczegółowych informacji o wartościach, które są widoczne:Here are a few details about the values that you see:

    • Plik MSDeploy. axd , do którego odwołuje się ten publishUrl atrybut jest dynamicznie generowanym plikiem programu obsługi HTTP dla Web Deploy.The msdeploy.axd file referenced in the publishUrl attribute is a dynamically generated HTTP handler file for Web Deploy. (Na potrzeby testowania http://myhostname:8172 zazwyczaj działa również).(For testing purposes, http://myhostname:8172 generally works as well.)

    • publishUrlPort jest ustawiony na port 8172, który jest wartością domyślną dla Web Deploy.The publishUrl port is set to port 8172, which is the default for Web Deploy.

    • destinationAppUrlPort jest ustawiony na port 80, który jest wartością domyślną dla usług IIS.The destinationAppUrl port is set to port 80, which is the default for IIS.

    • Jeśli nie można nawiązać połączenia z hostem zdalnym w programie Visual Studio przy użyciu nazwy hosta (w dalszych krokach), Przetestuj adres IP zamiast nazwy hosta.If you are unable to connect to the remote host in Visual Studio using the host name (in later steps), test the IP address in place of the host name.

      Uwaga

      W przypadku publikowania w usługach IIS działających na maszynie wirtualnej platformy Azure należy otworzyć Web Deploy i porty usług IIS w sieciowej grupie zabezpieczeń.If you are publishing to IIS running on an Azure VM, you must open the Web Deploy and IIS ports in the Network Security group. Aby uzyskać szczegółowe informacje, zobacz Instalowanie i uruchamianie usług IIS.For detailed information, see Install and run IIS.

  5. Skopiuj ten plik na komputer, na którym jest uruchomiony program Visual Studio.Copy this file to the computer where you are running Visual Studio.

Importowanie ustawień publikowania w programie Visual Studio i wdrażanieImport the publish settings in Visual Studio and deploy

  1. Na komputerze, na którym jest otwarty projekt ASP.NET w programie Visual Studio, kliknij prawym przyciskiem myszy projekt w Eksplorator rozwiązań i wybierz polecenie Publikuj.On the computer where you have the ASP.NET project open in Visual Studio, right-click the project in Solution Explorer, and choose Publish.

  2. Jeśli wszystkie profile publikowania zostały wcześniej skonfigurowane, zostanie wyświetlone okienko Publikowanie .If you have previously configured any publishing profiles, the Publish pane appears. Kliknij pozycję Utwórz nowy profil.Click Create new profile.

  3. W oknie dialogowym Wybierz cel publikacji kliknij przycisk Importuj profil.In the Pick a publish target dialog box, click Import Profile.

    Wybierz pozycję Publikuj

  4. Przejdź do lokalizacji pliku ustawień publikowania, który został utworzony w poprzedniej sekcji.Navigate to the location of the publish settings file that you created in the previous section.

  5. W oknie dialogowym Importowanie pliku ustawień publikowania przejdź do i wybierz profil, który został utworzony w poprzedniej sekcji, a następnie kliknij przycisk Otwórz.In the Import Publish Settings File dialog, navigate to and select the profile that you created in the previous section, and click Open.

    Program Visual Studio rozpocznie proces wdrażania, a okno dane wyjściowe pokazuje postęp i wyniki.Visual Studio begins the deployment process, and the Output window shows progress and results.

    Jeśli wystąpią jakieś błędy wdrażania, kliknij przycisk Ustawienia , aby edytować ustawienia.If you get an any deployment errors, click Settings to edit settings. Zmodyfikuj ustawienia i kliknij przycisk Weryfikuj , aby przetestować nowe ustawienia.Modify settings and click Validate to test new settings. Jeśli nazwa hosta nie zostanie znaleziona, spróbuj użyć adresu IP zamiast nazwy hosta w polach serwer i docelowy adres URL .If the host name is not found, try the IP address instead of the host name in the Server and Destination URL fields.

    Edytuj ustawienia w narzędziu do publikowania

Uwaga

Po ponownym uruchomieniu maszyny wirtualnej platformy Azure adres IP może się zmienić.If you restart an Azure VM, the IP address may change.

Po pomyślnym wdrożeniu aplikacji należy uruchomić ją automatycznie.After the app deploys successfully, it should start automatically. Jeśli aplikacja nie uruchamia się z programu Visual Studio, uruchom aplikację w usługach IIS, aby sprawdzić, czy działa poprawnie.If the app does not start from Visual Studio, start the app in IIS to verify that it runs correctly. W przypadku ASP.NET Core należy również upewnić się, że w polu Pula aplikacji dla tej opcji określono wartość Brak kodu zarządzanego.For ASP.NET Core, you also need to make sure that the Application pool field for the DefaultAppPool is set to No Managed Code.

  1. W oknie dialogowym Ustawienia Włącz debugowanie, klikając przycisk dalej, wybierz konfigurację debugowania , a następnie wybierz pozycję Usuń dodatkowe pliki w miejscu docelowym w obszarze Opcje publikowania plików .In the Settings dialog box, enable debugging by clicking Next, choose a Debug configuration, and then choose Remove additional files at destination under the File Publish options.

    Ważne

    W przypadku wybrania konfiguracji wydania można wyłączyć debugowanie w pliku web.config podczas publikowania.If you choose a Release configuration, you disable debugging in the web.config file when you publish.

  2. Kliknij przycisk Zapisz , a następnie ponownie Opublikuj aplikację.Click Save and then republish the app.

Obowiązkowe Wdróż przez opublikowanie w folderze lokalnym(Optional) Deploy by publishing to a local folder

Za pomocą tej opcji można wdrożyć aplikację, jeśli chcesz skopiować aplikację do usług IIS przy użyciu programu PowerShell, RoboCopy lub ręcznie skopiować pliki.You can use this option to deploy your app if you want to copy the app to IIS using PowerShell, RoboCopy, or you want to manually copy the files.

Konfigurowanie witryny sieci Web ASP.NET Core na komputerze z systemem Windows ServerConfigure the ASP.NET Core Web site on the Windows Server computer

W przypadku importowania ustawień publikowania można pominąć tę sekcję.If you are importing publish settings, you can skip this section.

  1. Otwórz menedżera Internet Information Services (IIS) i przejdź do witryny.Open the Internet Information Services (IIS) Manager and go to Sites.

  2. Kliknij prawym przyciskiem myszy domyślny węzeł witryny sieci Web i wybierz polecenie Dodaj aplikację.Right-click the Default Web Site node and select Add Application.

  3. W polu alias ustaw wartość MyASPApp , a pole Pula aplikacji nie ma kodu zarządzanego.Set the Alias field to MyASPApp and the Application pool field to No Managed Code. Ustaw ścieżkę fizyczną na C:\Publish (w którym później zostanie wdrożony projekt ASP.NET Core).Set the Physical path to C:\Publish (where you will later deploy the ASP.NET Core project).

  4. Po wybraniu lokacji w Menedżerze usług IIS wybierz pozycję Edytuj uprawnieniai upewnij się, że konto IUSR, IIS_IUSRS lub użytkownik skonfigurowany dla puli aplikacji jest autoryzowanym użytkownikiem z uprawnieniami do odczytu & wykonywania.With the site selected in the IIS Manager, choose Edit Permissions, and make sure that IUSR, IIS_IUSRS, or the user configured for the Application Pool is an authorized user with Read & Execute rights.

    Jeśli nie widzisz jednego z tych użytkowników z dostępem, wykonaj kroki, aby dodać IUSR jako użytkownik z uprawnieniami do odczytu & wykonywania.If you don't see one of these users with access, go through steps to add IUSR as a user with Read & Execute rights.

Obowiązkowe Publikowanie i wdrażanie aplikacji przez publikowanie do folderu lokalnego z programu Visual Studio(Optional) Publish and Deploy the app by publishing to a local folder from Visual Studio

Jeśli nie używasz Web Deploy, musisz opublikować i wdrożyć aplikację przy użyciu systemu plików lub innych narzędzi.If you're not using Web Deploy, you must publish and deploy the app using the file system or other tools. Możesz rozpocząć od utworzenia pakietu przy użyciu systemu plików, a następnie wdrożyć pakiet ręcznie lub użyć innych narzędzi, takich jak PowerShell, RoboCopy lub XCopy.You can start by creating a package using the file system, and then either deploy the package manually or use other tools like PowerShell, RoboCopy, or XCopy. W tej sekcji założono, że ręcznie skopiujesz pakiet, jeśli nie używasz Web Deploy.In this section, we assume you are manually copying the package if you are not using Web Deploy.

  1. W Eksplorator rozwiązańkliknij prawym przyciskiem myszy węzeł projektu i wybierz polecenie Publikuj (dla formularzy sieci Web, Opublikuj aplikację sieci Web).In the Solution Explorer, right-click the project node and select Publish (for Web Forms, Publish Web App).

    Jeśli wszystkie profile publikowania zostały wcześniej skonfigurowane, zostanie wyświetlone okienko Publikowanie .If you have previously configured any publishing profiles, the Publish pane appears. Kliknij pozycję Nowy profil.Click New profile.

  2. W oknie dialogowym Publikowanie wybierz pozycję folder, kliknij pozycję Przeglądaj, a następnie utwórz nowy folder C:\Publish.In the Publish dialog box, select Folder, click Browse, and create a new folder, C:\Publish.

    RemoteDBG_Publish_LocalRemoteDBG_Publish_Local

    W przypadku aplikacji formularzy sieci Web wybierz pozycję niestandardowe w oknie dialogowym Publikowanie, wprowadź nazwę profilu, a następnie wybierz przycisk OK.For a Web Forms app, choose Custom in the Publish dialog box, enter a profile name, and choose OK.

  3. Na liście rozwijanej kliknij pozycję Utwórz profil (wartość domyślna toOpublikuj ).Click Create profile in the drop-down list (Publish is the default value).

  4. W oknie dialogowym Publikowanie kliknij link Ustawienia , a następnie wybierz kartę Ustawienia .In the Publish dialog box, click the Settings link, and then select the Settings tab.

  5. Ustaw konfigurację na Debuguj, wybierz opcję Usuń wszystkie istniejące pliki przed opublikowaniem, a następnie kliknij przycisk Zapisz.Set the configuration to Debug, select Delete all existing files prior to publish, and then click Save.

    Uwaga

    Jeśli używasz kompilacji wydania, po opublikowaniu należy wyłączyć debugowanie w pliku web.config.If you use a Release build, you disable debugging in the web.config file when you publish.

  6. Kliknij przycisk Opublikuj.Click Publish.

    RemoteDBG_Publish_Debug_ConfigRemoteDBG_Publish_Debug_Config

    Aplikacja publikuje konfigurację debugowania projektu w folderze lokalnym.The application publishes a Debug configuration of the project to the local folder. Postęp jest wyświetlany w oknie danych wyjściowych.Progress shows in the Output window.

  7. Skopiuj katalog projektu ASP.NET z komputera programu Visual Studio do katalogu lokalnego skonfigurowanego dla aplikacji ASP.NET (w tym przykładzie C:\Publish) na komputerze z systemem Windows Server.Copy the ASP.NET project directory from the Visual Studio computer to the local directory configured for the ASP.NET app (in this example, C:\Publish) on the Windows Server computer. W tym samouczku przyjęto założenie, że kopiowanie odbywa się ręcznie, ale można użyć innych narzędzi, takich jak PowerShell, XCOPY lub Robocopy.In this tutorial, we assume you are copying manually, but you can use other tools like PowerShell, Xcopy, or Robocopy.

    Przestroga

    Jeśli trzeba wprowadzić zmiany w kodzie lub skompilować ponownie, należy ponownie opublikować i powtórzyć ten krok.If you need to make changes to the code or rebuild, you must republish and repeat this step. Plik wykonywalny skopiowany na komputer zdalny musi dokładnie pasować do lokalnego źródła i symboli.The executable you copied to the remote machine must exactly match your local source and symbols. Jeśli tego nie zrobisz, cannot find or open the PDB file w programie Visual Studio pojawi się ostrzeżenie podczas próby debugowania tego procesu.If you do not do this you will receive a cannot find or open the PDB file warning in Visual Studio when you attempt to debug the process.

  8. Na serwerze z systemem Windows sprawdź, czy można prawidłowo uruchomić aplikację, otwierając aplikację w przeglądarce.On the Windows Server, verify that you can run the app correctly by opening the app in your browser.

    Jeśli aplikacja nie działa prawidłowo, może wystąpić niezgodność między wersją programu ASP.NET zainstalowaną na serwerze a maszyną programu Visual Studio lub może wystąpić problem z konfiguracją usług IIS lub witryny sieci Web.If the app doesn't run correctly, there may be a mismatch between the version of ASP.NET installed on your server and your Visual Studio machine, or you may have an issue with your IIS or Web site configuration. Ponownie Sprawdź wcześniejsze kroki.Recheck earlier steps.

Pobieranie i Instalowanie narzędzi zdalnych w systemie Windows ServerDownload and Install the remote tools on Windows Server

Pobierz wersję narzędzi zdalnych, która pasuje do używanej wersji programu Visual Studio.Download the version of the remote tools that matches your version of Visual Studio.

Na urządzeniu zdalnym lub serwerze, który ma być debugowany, a nie z maszyną programu Visual Studio, Pobierz i zainstaluj poprawną wersję narzędzi zdalnych z linków w poniższej tabeli.On the remote device or server that you want to debug on, rather than the Visual Studio machine, download and install the correct version of the remote tools from the links in the following table.

  • Pobierz najnowsze narzędzia zdalne dla używanej wersji programu Visual Studio.Download the most recent remote tools for your version of Visual Studio. Najnowsza wersja narzędzi zdalnych jest zgodna ze starszymi wersjami programu Visual Studio, ale wcześniejsze wersje narzędzi zdalnych nie są zgodne z nowszymi wersjami programu Visual Studio.The latest remote tools version is compatible with earlier Visual Studio versions, but earlier remote tools versions aren't compatible with later Visual Studio versions. (Na przykład jeśli używasz programu Visual Studio 2017, Pobierz najnowszą aktualizację narzędzi Remote Tools for Visual Studio 2017.(For example, if you are using Visual Studio 2017, download the latest update of the remote tools for Visual Studio 2017. W tym scenariuszu nie należy pobierać narzędzi Remote Tools for Visual Studio 2019.In this scenario, do not download the remote tools for Visual Studio 2019.)
  • Pobierz narzędzia zdalne z tą samą architekturą, w której są instalowane maszyny.Download the remote tools with the same architecture as the machine you're installing them on. Na przykład jeśli chcesz debugować aplikację 32-bitową na komputerze zdalnym z systemem operacyjnym 64-bitowym, zainstaluj narzędzia zdalnego 64-bit.For example, if you want to debug a 32-bit app on a remote computer running a 64-bit operating system, install the 64-bit remote tools.
WersjaVersion LinkLink UwagiNotes
Visual Studio 2019Visual Studio 2019 Zdalne narzędziaRemote tools Zgodne ze wszystkimi wersjami programu Visual Studio 2019.Compatible with all Visual Studio 2019 versions. Pobierz wersję zgodną z systemem operacyjnym urządzenia (x86, x64 lub ARM64).Download the version matching your device operating system (x86, x64, or ARM64). W systemie Windows Server zapoznaj się z tematem Odblokuj pobieranie pliku , aby uzyskać pomoc dotyczącą pobierania narzędzi zdalnych.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2017Visual Studio 2017 Zdalne narzędziaRemote tools Zgodne ze wszystkimi wersjami programu Visual Studio 2017.Compatible with all Visual Studio 2017 versions. Pobierz wersję zgodną z systemem operacyjnym urządzenia (x86, x64 lub ARM64).Download the version matching your device operating system (x86, x64, or ARM64). W systemie Windows Server zapoznaj się z tematem Odblokuj pobieranie pliku , aby uzyskać pomoc dotyczącą pobierania narzędzi zdalnych.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2015Visual Studio 2015 Zdalne narzędziaRemote tools Narzędzia Remote Tools for Visual Studio 2015 są dostępne z My.VisualStudio.com.Remote tools for Visual Studio 2015 are available from My.VisualStudio.com. Jeśli zostanie wyświetlony monit, Dołącz do bezpłatnego programu Visual Studio Dev Essentials lub Zaloguj się przy użyciu identyfikatora subskrypcji programu Visual Studio.If prompted, join the free Visual Studio Dev Essentials program, or sign in with your Visual Studio subscription ID. W systemie Windows Server zapoznaj się z tematem Odblokuj pobieranie pliku , aby uzyskać pomoc dotyczącą pobierania narzędzi zdalnych.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2013Visual Studio 2013 Zdalne narzędziaRemote tools Strona pobierania w dokumentacji Visual Studio 2013Download page in Visual Studio 2013 documentation
Visual Studio 2012Visual Studio 2012 Zdalne narzędziaRemote tools Strona pobierania w dokumentacji programu Visual Studio 2012Download page in Visual Studio 2012 documentation
WersjaVersion LinkLink UwagiNotes
Visual Studio 2017Visual Studio 2017 Zdalne narzędziaRemote tools Zgodne ze wszystkimi wersjami programu Visual Studio 2017.Compatible with all Visual Studio 2017 versions. Pobierz wersję zgodną z systemem operacyjnym urządzenia (x86, x64 lub ARM64).Download the version matching your device operating system (x86, x64, or ARM64). W systemie Windows Server zapoznaj się z tematem Odblokuj pobieranie pliku , aby uzyskać pomoc dotyczącą pobierania narzędzi zdalnych.On Windows Server, see Unblock the file download for help downloading the remote tools. Aby uzyskać najnowszą wersję narzędzi zdalnych, Otwórz dokument Visual Studio 2019.For the most recent version of the remote tools, open the Visual Studio 2019 doc.
Visual Studio 2015Visual Studio 2015 Zdalne narzędziaRemote tools Narzędzia Remote Tools for Visual Studio 2015 są dostępne z My.VisualStudio.com.Remote tools for Visual Studio 2015 are available from My.VisualStudio.com. Jeśli zostanie wyświetlony monit, Dołącz do bezpłatnego programu Visual Studio Dev Essentials lub Zaloguj się przy użyciu identyfikatora subskrypcji programu Visual Studio.If prompted, join the free Visual Studio Dev Essentials program, or sign in with your Visual Studio subscription ID. W systemie Windows Server zapoznaj się z tematem Odblokuj pobieranie pliku , aby uzyskać pomoc dotyczącą pobierania narzędzi zdalnych.On Windows Server, see Unblock the file download for help downloading the remote tools.
Visual Studio 2013Visual Studio 2013 Zdalne narzędziaRemote tools Strona pobierania w dokumentacji Visual Studio 2013Download page in Visual Studio 2013 documentation
Visual Studio 2012Visual Studio 2012 Zdalne narzędziaRemote tools Strona pobierania w dokumentacji programu Visual Studio 2012Download page in Visual Studio 2012 documentation

Zdalny debuger można uruchomić, kopiując msvsmon.exe na komputer zdalny, zamiast instalować narzędzia zdalne.You can run the remote debugger by copying msvsmon.exe to the remote computer, rather than installing the remote tools. Jednak Kreator konfiguracji debugera zdalnego (rdbgwiz.exe) jest dostępny tylko po zainstalowaniu narzędzi zdalnych.However, the Remote Debugger Configuration Wizard (rdbgwiz.exe) is available only when you install the remote tools. Może być konieczne użycie Kreatora konfiguracji, jeśli chcesz uruchomić zdalny debuger jako usługę.You may need to use the wizard for configuration if you want to run the remote debugger as a service. Aby uzyskać więcej informacji, zobacz (opcjonalnie). Skonfiguruj zdalny debuger jako usługę.For more information, see (Optional) Configure the remote debugger as a service.

Uwaga

  • Aby debugować aplikacje systemu Windows 10 na urządzeniach ARM, użyj ARM64, który jest dostępny w najnowszej wersji narzędzi zdalnych.To debug Windows 10 apps on ARM devices, use ARM64, which is available with the latest version of the remote tools.
  • Aby debugować aplikacje systemu Windows 10 na urządzeniach z systemem Windows RT, użyj ARM, który jest dostępny tylko w pobieraniu narzędzi zdalnych programu Visual Studio 2015.To debug Windows 10 apps on Windows RT devices, use ARM, which is available only in the Visual Studio 2015 remote tools download.

Konfigurowanie zdalnego debugera w systemie Windows ServerSet up the remote debugger on Windows Server

  1. Na komputerze zdalnym Znajdź i uruchom zdalny debuger z menu Start .On the remote computer, find and start the Remote Debugger from the Start menu.

    Jeśli nie masz uprawnień administracyjnych na komputerze zdalnym, kliknij prawym przyciskiem myszy aplikację Remote Debugger i wybierz polecenie Uruchom jako administrator.If you don't have administrative permissions on the remote computer, right-click the Remote Debugger app and select Run as administrator. W przeciwnym razie po prostu uruchom je normalnie.Otherwise, just start it normally.

    Jeśli planujesz dołączenie do procesu, który jest uruchomiony jako administrator lub działa na innym koncie użytkownika (na przykład IIS), kliknij prawym przyciskiem myszy aplikację Remote Debugger i wybierz polecenie Uruchom jako administrator.If you are planning to attach to a process which is running as an administrator, or is running under a different user account (such as IIS), right-click the Remote Debugger app and select Run as administrator. Aby uzyskać więcej informacji, zobacz Uruchamianie debugera zdalnego jako administrator.For more information, see Run the remote debugger as an administrator.

  2. Przy pierwszym uruchomieniu zdalnego debugera (lub przed jego skonfigurowaniem) zostanie wyświetlone okno dialogowe Konfiguracja zdalnego debugowania .The first time you start the remote debugger (or before you have configured it), the Remote Debugging Configuration dialog box appears.

    Konfiguracja zdalnego debugeraRemote Debugger configuration

  3. Jeśli nie zainstalowano interfejsu API usług sieci Web systemu Windows, który występuje tylko w systemie Windows Server 2008 R2, wybierz przycisk Instaluj .If the Windows Web Services API is not installed, which happens only on Windows Server 2008 R2, select the Install button.

  4. Wybierz co najmniej jeden typ sieci, na którym chcesz korzystać z narzędzi zdalnych.Select at least one network type you want to use the remote tools on. Jeśli komputery są połączone za pomocą domeny, należy wybrać pierwszy element.If the computers are connected through a domain, you must choose the first item. Jeśli komputery są połączone przez grupę roboczą lub grupę domową, wybierz drugi lub trzeci element stosownie do potrzeb.If the computers are connected through a workgroup or homegroup, choose the second or third item as appropriate.

  5. Wybierz pozycję Konfiguruj zdalne debugowanie , aby skonfigurować zaporę i uruchomić zdalny debuger.Select Configure remote debugging to configure the firewall and start the remote debugger.

  6. Po zakończeniu konfiguracji zostanie wyświetlone okno zdalny debuger .When configuration is complete, the Remote Debugger window appears.

    Okno debugera zdalnegoRemote Debugger window

    Zdalny debuger czeka teraz na połączenie.The remote debugger is now waiting for a connection. Użyj nazwy serwera i numeru portu podanego do ustawienia konfiguracji połączenia zdalnego w programie Visual Studio.Use the server name and port number shown to set the remote connection configuration in Visual Studio.

Aby zatrzymać zdalny debuger , wybierz pozycję > Zakończ.To stop the remote debugger, select File > Exit. Możesz uruchomić go ponownie z menu Start lub z wiersza polecenia:You can restart it from the Start menu, or from the command line:

<Remote debugger installation directory>\msvsmon.exe

Uwaga

Jeśli musisz dodać uprawnienia dla dodatkowych użytkowników, zmienić tryb uwierzytelniania lub numer portu dla zdalnego debugera, zobacz Konfigurowanie zdalnego debugera.If you need to add permissions for additional users, change the authentication mode, or port number for the remote debugger, see Configure the remote debugger.

Dołączanie do aplikacji ASP.NET z komputera z programu Visual StudioAttach to the ASP.NET application from the Visual Studio computer

  1. Na komputerze z Visual Studio Otwórz rozwiązanie, które próbujesz debugować (MyASPApp , jeśli wykonano kroki opisane w tym artykule).On the Visual Studio computer, open the solution that you are trying to debug (MyASPApp if you are following the steps in this article).

  2. W programie Visual Studio kliknij pozycję debuguj > Dołącz do procesu (Ctrl + Alt + P).In Visual Studio, click Debug > Attach to Process (Ctrl + Alt + P).

    Porada

    W programie Visual Studio 2017 i nowszych wersjach można ponownie dołączyć do tego samego procesu, który został wcześniej dołączony do programu przy użyciu debugowania > ponownie dołączyć do procesu... (Shift + Alt + P).In Visual Studio 2017 and later versions, you can re-attach to the same process you previously attached to by using Debug > Reattach to Process... (Shift+Alt+P).

  3. Ustaw pole kwalifikator na <remote computer name> i naciśnij klawisz Enter.Set the Qualifier field to <remote computer name> and press Enter.

    Sprawdź, czy program Visual Studio dodaje wymagany port do nazwy komputera, która jest wyświetlana w formacie: ** <remote computer name> :p** .Verify that Visual Studio adds the required port to the computer name, which appears in the format: <remote computer name>:port

    W programie Visual Studio 2019 powinna zostać wyświetlona ** <remote computer name> : 4024**On Visual Studio 2019, you should see <remote computer name>:4024

    W programie Visual Studio 2017 powinna zostać wyświetlona ** <remote computer name> : 4022**On Visual Studio 2017, you should see <remote computer name>:4022

    Port jest wymagany.The port is required. Jeśli nie widzisz numeru portu, Dodaj go ręcznie.If you don't see the port number, add it manually.

  4. Kliknij przycisk Odśwież.Click Refresh. Niektóre procesy powinny być widoczne w oknie dostępne procesy .You should see some processes appear in the Available Processes window.

    Jeśli nie widzisz żadnych procesów, spróbuj użyć adresu IP zamiast nazwy komputera zdalnego (port jest wymagany).If you don't see any processes, try using the IP address instead of the remote computer name (the port is required). Można użyć ipconfig w wierszu polecenia, aby uzyskać adres IPv4.You can use ipconfig in a command line to get the IPv4 address.

    Jeśli chcesz użyć przycisku Znajdź , może być konieczne otwarcie portu UDP 3702 na serwerze.If you want to use the Find button, you may need to open UDP port 3702 on the server.

  5. Zaznacz opcję Pokaż procesy wszystkich użytkowników.Check Show processes from all users.

  6. Wpisz pierwszą literę nazwy procesu, aby szybko znaleźć aplikację.Type the first letter of your process name to quickly find your app.

    • Jeśli używasz modelu hostingu w procesie na serwerze IIS, wybierz właściwy proces w3wp.exe .If you're using the in-process hosting model on IIS, select the correct w3wp.exe process. Począwszy od platformy .NET Core 3, jest to ustawienie domyślne.Starting in .NET Core 3, this is the default.

    • W przeciwnym razie wybierz proces dotnet.exe .Otherwise, select the dotnet.exe process. (Jest to model hostingu poza procesem).(This is the out-of-process hosting model.)

    Jeśli masz wiele procesów pokazujących w3wp.exe lub dotnet.exe, Sprawdź kolumnę Nazwa użytkownika .If you have multiple processes showing w3wp.exe or dotnet.exe, check the User Name column. W niektórych scenariuszach kolumna Nazwa użytkownika zawiera nazwę puli aplikacji, na przykład APPPOOL\DefaultAppPool IIS.In some scenarios, the User Name column shows your app pool name, such as IIS APPPOOL\DefaultAppPool. Jeśli zobaczysz pulę aplikacji, ale nie jest ona unikatowa, Utwórz nową nazwę puli aplikacji dla wystąpienia aplikacji, które chcesz debugować, a następnie możesz ją łatwo znaleźć w kolumnie Nazwa użytkownika .If you see the App Pool, but it's not unique, create a new named App Pool for the app instance you want to debug, and then you can find it easily in the User Name column.

    RemoteDBG_AttachToProcessRemoteDBG_AttachToProcess

    RemoteDBG_AttachToProcessRemoteDBG_AttachToProcess

  7. Kliknij przycisk Dołącz.Click Attach.

  8. Otwórz witrynę sieci Web komputera zdalnego.Open the remote computer's website. W przeglądarce przejdź do **http:// <remote computer name> **.In a browser, go to http://<remote computer name>.

    Powinna zostać wyświetlona strona sieci Web ASP.NET.You should see the ASP.NET web page.

  9. W uruchomionej aplikacji ASP.NET kliknij link do strony informacje .In the running ASP.NET application, click the link to the About page.

    Punkt przerwania powinien zostać trafiony w programie Visual Studio.The breakpoint should be hit in Visual Studio.

Rozwiązywanie problemów: otwieranie wymaganych portów w systemie Windows ServerTroubleshooting: Open required ports on Windows Server

W większości instalacji wymagane porty są otwierane przez instalację ASP.NET i zdalnego debugera.In most setups, required ports are opened by the installation of ASP.NET and the remote debugger. Jednak w przypadku rozwiązywania problemów z wdrażaniem, gdy aplikacja znajduje się za zaporą, może być konieczne zweryfikowanie, czy są otwarte odpowiednie porty.However, if you are troubleshooting deployment issues and the app is hosted behind a firewall, you may need to verify that the correct ports are open.

Na maszynie wirtualnej platformy Azure należy otworzyć porty za pomocą sieciowej grupy zabezpieczeń.On an Azure VM, you must open ports through the Network security group.

Wymagane porty:Required ports:

  • 80 — wymagane dla usług IIS80 - Required for IIS
  • UDP 3702 — (opcjonalnie) port odnajdywania umożliwia korzystanie z przycisku Znajdź podczas dołączania do zdalnego debugera w programie Visual Studio.UDP 3702 - (Optional) Discovery port enables you to the Find button when attaching to the remote debugger in Visual Studio.

Ponadto te porty powinny być już otwarte przez instalację ASP.NET:In addition, these ports should already be opened by the ASP.NET installation:

  • 8172 — (opcjonalnie) wymagane do Web Deploy wdrożenia aplikacji z programu Visual Studio8172 - (Optional) Required for Web Deploy to deploy the app from Visual Studio