Witamy w środowisku IDE programu Visual StudioWelcome to the Visual Studio IDE

Zintegrowane środowisko programistyczne programu Visual Studio to twórczy pad do uruchamiania, który umożliwia edytowanie, debugowanie i kompilowanie kodu, a następnie publikowanie aplikacji.The Visual Studio integrated development environment is a creative launching pad that you can use to edit, debug, and build code, and then publish an app. Zintegrowane środowisko programistyczne (IDE) to program bogaty w funkcje, który może być używany w wielu aspektach tworzenia oprogramowania.An integrated development environment (IDE) is a feature-rich program that can be used for many aspects of software development. W porównaniu z standardowym edytorem i debugerem, który środowisk IDE zapewnia, program Visual Studio obejmuje kompilatory, narzędzia do uzupełniania kodu, graficzne projektanci i wiele innych funkcji, które ułatwiają proces tworzenia oprogramowania.Over and above the standard editor and debugger that most IDEs provide, Visual Studio includes compilers, code completion tools, graphical designers, and many more features to ease the software development process.

Środowisko IDE programu Visual Studio 2017

The środowisko IDE programu Visual Studio 2019The Visual Studio 2019 IDE

Ten obraz przedstawia program Visual Studio z otwartym projektem i kilkoma oknami narzędzi kluczowych, których prawdopodobnie używasz:This image shows Visual Studio with an open project and several key tool windows you'll likely use:

  • Eksplorator rozwiązań (prawy górny) umożliwia wyświetlanie plików kodu i nawigowanie w nich oraz zarządzanie nimi.Solution Explorer (top right) lets you view, navigate, and manage your code files. Eksplorator rozwiązań może pomóc organizować kod przez zgrupowanie plików na rozwiązania i projekty.Solution Explorer can help organize your code by grouping the files into solutions and projects.

  • Okno edytora (środkowe), w którym najprawdopodobniej będzie można spędzać większość czasu, zostanie wyświetlona zawartość pliku.The editor window (center), where you'll likely spend a majority of your time, displays file contents. Jest to miejsce, w którym można edytować kod lub zaprojektować interfejs użytkownika, taki jak okno z przyciskami i polami tekstowymi.This is where you can edit code or design a user interface such as a window with buttons and text boxes.

  • W oknie danych wyjściowych (u dołu) jest miejsce, gdzie program Visual Studio wysyła powiadomienia, takie jak debugowanie i komunikaty o błędach, ostrzeżenia kompilatora, publikowanie komunikatów o stanie itd.The Output window (bottom center) is where Visual Studio sends notifications such as debugging and error messages, compiler warnings, publishing status messages, and more. Każde źródło wiadomości ma własną kartę.Each message source has its own tab.

WersjeEditions

Program Visual Studio jest dostępny dla systemów Windows i Mac.Visual Studio is available for Windows and Mac. Visual Studio dla komputerów Mac ma wiele takich samych funkcji, jak program Visual Studio 2017 i jest zoptymalizowany pod kątem opracowywania aplikacji mobilnych i międzyplatformowych.Visual Studio for Mac has many of the same features as Visual Studio 2017, and is optimized for developing cross-platform and mobile apps. Ten artykuł koncentruje się na wersji systemu Windows programu Visual Studio 2017.This article focuses on the Windows version of Visual Studio 2017.

Istnieją trzy wersje programu Visual Studio 2017: Community, Professional i Enterprise.There are three editions of Visual Studio 2017: Community, Professional, and Enterprise. Zobacz porównanie programu Visual Studio 2017 środowisk IDE , aby dowiedzieć się, jakie funkcje są obsługiwane w poszczególnych wersjach.See Compare Visual Studio 2017 IDEs to learn about which features are supported in each edition.

Program Visual Studio jest dostępny dla systemów Windows i Mac.Visual Studio is available for Windows and Mac. Visual Studio dla komputerów Mac ma wiele takich samych funkcji, jak program Visual Studio 2019 i jest zoptymalizowany pod kątem opracowywania aplikacji mobilnych i międzyplatformowych.Visual Studio for Mac has many of the same features as Visual Studio 2019, and is optimized for developing cross-platform and mobile apps. Ten artykuł koncentruje się na wersji systemu Windows programu Visual Studio 2019.This article focuses on the Windows version of Visual Studio 2019.

Istnieją trzy wersje programu Visual Studio 2019: Community, Professional i Enterprise.There are three editions of Visual Studio 2019: Community, Professional, and Enterprise. Zobacz porównanie programu Visual Studio środowisk IDE , aby dowiedzieć się, jakie funkcje są obsługiwane w poszczególnych wersjach.See Compare Visual Studio IDEs to learn about which features are supported in each edition.

Niektóre popularne funkcje programu Visual Studio, które ułatwiają wydajniejszą pracę podczas opracowywania oprogramowania, obejmują:Some of the popular features in Visual Studio that help you to be more productive as you develop software include:

  • Zygzaki i szybkie akcjeSquiggles and Quick Actions

    Zygzaki to faliste podkreślenia, które wysyłają alerty do błędów lub potencjalnych problemów w kodzie podczas wpisywania.Squiggles are wavy underlines that alert you to errors or potential problems in your code as you type. Te wizualne wskazówki umożliwiają natychmiastowe Rozwiązywanie problemów bez oczekiwania na odnalezienie błędu podczas kompilacji lub podczas uruchamiania programu.These visual clues enable you to fix problems immediately without waiting for the error to be discovered during build or when you run the program. Po umieszczeniu wskaźnika myszy na zygzaku pojawią się dodatkowe informacje o błędzie.If you hover over a squiggle, you see additional information about the error. Żarówka może również pojawić się na lewym marginesie z akcjami, znanymi jako szybkie akcje, aby naprawić błąd.A light bulb may also appear in the left margin with actions, known as Quick Actions, to fix the error.

    Zygzaky w programie Visual Studio

  • Czyszczenie koduCode Cleanup

    Po kliknięciu przycisku sformatuj kod i Zastosuj wszelkie poprawki kodu sugerowane przez Ustawienia stylu kodu, konwencje editorconfigi analizatory Roslyn.With the click of a button, format your code and apply any code fixes suggested by your code style settings, .editorconfig conventions, and Roslyn analyzers. Czyszczenie kodu ułatwia rozwiązywanie problemów w kodzie przed przekazaniem ich do przeglądu kodu.Code Cleanup helps you resolve issues in your code before it goes to code review. (Obecnie dostępne tylko C# dla kodu).(Currently available for C# code only.)

    Przycisk czyszczenia kodu w programie Visual Studio

  • RefaktoryzacjaRefactoring

    Refaktoryzacja obejmuje operacje, takie jak inteligentne Zmienianie nazw zmiennych, wyodrębnianie jednego lub większej liczby wierszy kodu do nowej metody, zmiana kolejności parametrów metody i nie tylko.Refactoring includes operations such as intelligent renaming of variables, extracting one or more lines of code into a new method, changing the order of method parameters, and more.

    Refaktoryzacja w programie Visual Studio

  • Funkcja IntelliSenseIntelliSense

    Technologia IntelliSense to termin dla zestawu funkcji, który wyświetla informacje o kodzie bezpośrednio w edytorze, a w niektórych przypadkach zapisuje małe bity kodu.IntelliSense is a term for a set of features that displays information about your code directly in the editor and, in some cases, write small bits of code for you. Jest tak jak w przypadku, gdy podstawowa dokumentacja jest wbudowana w edytorze, co umożliwia zaoszczędzenie informacji o typie w innym miejscu.It's like having basic documentation inline in the editor, which saves you from having to look up type information elsewhere. Funkcje IntelliSense różnią się w zależności od języka.IntelliSense features vary by language. Aby uzyskać więcej informacji, zobacz C# IntelliSense, C++ Visual IntelliSense, JavaScript IntelliSensei Visual Basic IntelliSense.For more information, see C# IntelliSense, Visual C++ IntelliSense, JavaScript IntelliSense, and Visual Basic IntelliSense. Na poniższej ilustracji przedstawiono, w jaki sposób technologia IntelliSense wyświetla listę elementów członkowskich typu:The following illustration shows how IntelliSense displays a member list for a type:

    Lista elementów członkowskich programu Visual Studio

  • Pole wyszukiwaniaSearch box

    Program Visual Studio może pozornie przeciążać, tak jak wiele menu, opcji i właściwości.Visual Studio can seem overwhelming at times with so many menus, options, and properties. Pole wyszukiwania to doskonały sposób na szybkie znajdowanie potrzebnych informacji w programie Visual Studio.The search box is a great way to rapidly find what you need in Visual Studio. Po rozpoczęciu wpisywania nazwy szukanego elementu program Visual Studio Wyświetla listę wyników, które dokładnie zapoznają się z tym, co należy zrobić.When you start typing the name of something you're looking for, Visual Studio lists results that take you exactly where you need to go. Aby dodać funkcję do programu Visual Studio, na przykład w celu dodania obsługi dodatkowego języka programowania, w polu wyszukiwania znajdują się wyniki otwierające Instalator programu Visual Studio w celu zainstalowania obciążenia lub pojedynczego składnika.If you need to add functionality to Visual Studio, for example to add support for an additional programming language, the search box provides results that open Visual Studio Installer to install a workload or individual component.

    Tip

    Naciśnij klawisz Ctrl +Q jako skrót do pola wyszukiwania.Press Ctrl+Q as a shortcut to the search box.

    Pole wyszukiwania szybkiego uruchamiania w programie Visual Studio 2017

    Aby uzyskać więcej informacji, zobacz Szybki Start.For more information, see Quick Launch.

    Pole wyszukiwania w programie Visual Studio 2019

  • Live ShareLive Share

    Współpracuj z innymi osobami w czasie rzeczywistym, niezależnie od typu aplikacji lub języka programowania.Collaboratively edit and debug with others in real time, regardless of what your app type or programming language. Możesz natychmiast i bezpiecznie udostępnić projekt oraz, w razie konieczności, debugowanie sesji, wystąpienia terminala, aplikacje sieci Web, połączenia głosowe i inne.You can instantly and securely share your project and, as needed, debugging sessions, terminal instances, localhost web apps, voice calls, and more.

  • Hierarchia wywołańCall Hierarchy

    W oknie Hierarchia wywołań są wyświetlane metody wywołujące wybraną metodę.The Call Hierarchy window shows the methods that call a selected method. Te informacje mogą być przydatne, gdy myślisz o zmianie lub usunięciu metody lub podczas próby śledzenia błędu.This can be useful information when you're thinking about changing or removing the method, or when you're trying to track down a bug.

    Okno hierarchii wywołań

  • CodeLensCodeLens

    CodeLens pomaga znaleźć odwołania do kodu, zmiany w kodzie, połączone błędy, elementy robocze, przeglądy kodu i testy jednostkowe, bez opuszczania edytora.CodeLens helps you find references to your code, changes to your code, linked bugs, work items, code reviews, and unit tests, all without leaving the editor.

    CodeLens

  • Przejdź do definicjiGo To Definition

    Funkcja przejdź do definicji przenosi bezpośrednio do lokalizacji, w której zdefiniowana jest funkcja lub typ.The Go To Definition feature takes you directly to the location where a function or type is defined.

    Przejdź do definicji

  • Definicja wgląduPeek Definition

    Okno Definicja wglądu pokazuje definicję metody lub typu bez faktycznego otwierania osobnego pliku.The Peek Definition window shows the definition of a method or type without actually opening a separate file.

    Wgląd do definicji

Instalowanie środowiska IDE programu Visual StudioInstall the Visual Studio IDE

W tej sekcji utworzysz prosty projekt, aby wypróbować niektóre elementy, które można wykonać za pomocą programu Visual Studio.In this section, you'll create a simple project to try out some of the things you can do with Visual Studio. Użyjesz funkcji IntelliSense jako pomocy dotyczącej kodowania, Debuguj aplikację, aby wyświetlić wartość zmiennej podczas wykonywania programu, i Zmień motyw kolorów.You'll use IntelliSense as a coding aid, debug an app to see the value of a variable during the program's execution, and change the color theme.

Aby rozpocząć, Pobierz program Visual Studio i zainstaluj go w systemie.To get started, download Visual Studio and install it on your system. Modułowy Instalator umożliwia wybieranie i instalowanie obciążeń, które są grupami funkcji wymaganych przez preferowany język programowania lub platformę.The modular installer enables you to choose and install workloads, which are groups of features needed for the programming language or platform you prefer. Aby postępować zgodnie z instrukcjami dotyczącymi tworzenia programu, należy wybrać środowisko programistyczne dla wielu platform .NET Core podczas instalacji.To follow the steps for creating a program, be sure to select the .NET Core cross-platform development workload during installation.

Aby rozpocząć, Pobierz program Visual Studio i zainstaluj go w systemie.To get started, download Visual Studio and install it on your system. Modułowy Instalator umożliwia wybieranie i instalowanie obciążeń, które są grupami funkcji wymaganych przez preferowany język programowania lub platformę.The modular installer enables you to choose and install workloads, which are groups of features needed for the programming language or platform you prefer. Aby postępować zgodnie z instrukcjami dotyczącymi tworzenia programu, należy wybrać środowisko programistyczne dla wielu platform .NET Core podczas instalacji.To follow the steps for creating a program, be sure to select the .NET Core cross-platform development workload during installation.

Obciążenie Międzyplatformowe dla platformy .NET Core w Instalator programu Visual Studio

Po otwarciu programu Visual Studio po raz pierwszy możesz zalogować się przy użyciu konto Microsoft lub konta służbowego.When you open Visual Studio for the first time, you can optionally sign in using your Microsoft account or your work or school account.

Tworzenie programuCreate a program

Szczegółowemy i utworzysz prosty program.Let's dive in and create a simple program.

  1. Otwórz program Visual Studio.Open Visual Studio.

  2. Na pasku menu wybierz kolejno pozycje plik > Nowy > projekt.On the menu bar, choose File > New > Project.

    Plik > Nowy projekt na pasku menu

    Okno dialogowe Nowy projekt zawiera kilka szablonówprojektów.The New Project dialog box shows several project templates. Szablon zawiera podstawowe pliki i ustawienia, które są zbędne dla danego typu projektu.A template contains the basic files and settings needed for a given project type.

  3. Wybierz kategorię szablon .NET Core w obszarze Wizualizacja C# , a następnie wybierz szablon Aplikacja konsolowa (.NET Core) .Choose the .NET Core template category under Visual C#, and then choose the Console App (.NET Core) template. W polu tekstowym Nazwa wpisz HelloWorld, a następnie wybierz przycisk OK .In the Name text box, type HelloWorld, and then select the OK button.

    Szablon aplikacji .NET Core

    Note

    Jeśli nie widzisz kategorii .NET Core , musisz zainstalować środowisko programistyczne dla wielu platform .NET Core .If you don't see the .NET Core category, you need to install the .NET Core cross-platform development workload. Aby to zrobić, wybierz link otwórz Instalator programu Visual Studio w lewym dolnym rogu okna dialogowego Nowy projekt .To do this, choose the Open Visual Studio Installer link on the bottom left of the New Project dialog. Po otwarciu Instalator programu Visual Studio przewiń w dół i wybierz pozycję .NET Core Międzyplatformowe obciążenie dla deweloperów, a następnie wybierz polecenie Modyfikuj.After Visual Studio Installer opens, scroll down and select the .NET Core cross-platform development workload, and then select Modify.

    Program Visual Studio tworzy projekt.Visual Studio creates the project. Jest to prosta aplikacja "Hello world", która wywołuje metodę Console.WriteLine() w celu wyświetlenia ciągu literału "Hello world!"It's a simple "Hello World" application that calls the Console.WriteLine() method to display the literal string "Hello World!" w oknie Konsola (dane wyjściowe programu).in the console (program output) window.

    Wkrótce powinna zostać wyświetlona następująca zawartość:Shortly, you should see something like the following:

    Visual Studio IDE

    Kod C# aplikacji jest wyświetlany w oknie edytora, który zajmuje najwięcej miejsca.The C# code for your application shows in the editor window, which takes up most of the space. Zauważ, że tekst jest automatycznie kolorowy, aby wskazać różne części kodu, takie jak słowa kluczowe i typy.Notice that the text is automatically colorized to indicate different parts of the code, such as keywords and types. Ponadto małe, pionowe linie kreskowane w kodzie wskazują, które nawiasy są zgodne ze sobą, a numery wierszy ułatwiają znalezienie kodu później.In addition, small, vertical dashed lines in the code indicate which braces match one another, and line numbers help you locate code later. Możesz wybrać małe, opakowane znaki minus, aby zwinąć lub rozwinąć bloki kodu.You can choose the small, boxed minus signs to collapse or expand blocks of code. Ta funkcja tworzenia konspektu kodu umożliwia ukrycie kodu, który nie jest potrzebny, pomagając na zminimalizowanie bałaganu na ekranie.This code outlining feature lets you hide code you don't need, helping to minimize onscreen clutter. Pliki projektu są wymienione po prawej stronie w oknie o nazwie Eksplorator rozwiązań.The project files are listed on the right side in a window called Solution Explorer.

    Środowisko IDE programu Visual Studio z czerwonymi polami

    Dostępne są inne menu i okna narzędzi, ale teraz przyjrzyjmy się.There are other menus and tool windows available, but let's move on for now.

  4. Teraz uruchom aplikację.Now, start the app. Można to zrobić, wybierając pozycję Uruchom bez debugowania z menu Debuguj na pasku menu.You can do this by choosing Start Without Debugging from the Debug menu on the menu bar. Możesz również nacisnąć klawisz Ctrl +F5.You can also press Ctrl+F5.

    Debuguj > Rozpocznij bez debugowania menu

    Program Visual Studio kompiluje aplikację i zostanie otwarte okno konsoli z komunikatem Hello World! .Visual Studio builds the app, and a console window opens with the message Hello World!. Masz teraz działającą aplikację.You now have a running app!

    Okno konsoli

  5. Aby zamknąć okno konsoli, naciśnij dowolny klawisz na klawiaturze.To close the console window, press any key on your keyboard.

  6. Dodajmy do aplikacji dodatkowy kod.Let's add some additional code to the app. Dodaj następujący C# kod przed wierszem, który brzmi Console.WriteLine("Hello World!");:Add the following C# code before the line that says Console.WriteLine("Hello World!");:

    Console.WriteLine("\nWhat is your name?");
    var name = Console.ReadLine();
    

    Ten kod wyświetla nazwę użytkownika w oknie konsoli, a następnie czeka, aż użytkownik wprowadzi jakiś tekst, a następnie klawisz Enter .This code displays What is your name? in the console window, and then waits until the user enters some text followed by the Enter key.

  7. Zmień wiersz, który brzmi Console.WriteLine("Hello World!");, do następującego kodu:Change the line that says Console.WriteLine("Hello World!"); to the following code:

    Console.WriteLine($"\nHello {name}!");
    
  8. Uruchom aplikację ponownie, wybierając pozycję debuguj > Rozpocznij bez debugowania lub naciskając klawisz Ctrl +F5.Run the app again by selecting Debug > Start Without Debugging or by pressing Ctrl+F5.

    Program Visual Studio ponownie kompiluje aplikację i zostanie otwarte okno konsoli z prośbą o wprowadzenie nazwy.Visual Studio rebuilds the app, and a console window opens and prompts you for your name.

  9. Wprowadź swoją nazwę w oknie konsoli i naciśnij klawisz Enter.Enter your name in the console window and press Enter.

    Dane wejściowe okna konsoli

  10. Naciśnij dowolny klawisz, aby zamknąć okno konsoli i zatrzymać uruchomiony program.Press any key to close the console window and stop the running program.

  1. Otwórz program Visual Studio.Open Visual Studio.

    Zostanie wyświetlone okno uruchamiania z różnymi opcjami klonowania repozytorium, otwarciem ostatniego projektu lub utworzeniem nowego projektu.The start window appears with various options for cloning a repo, opening a recent project, or creating a brand new project.

  2. Wybierz pozycję Utwórz nowy projekt.Choose Create a new project.

    Okno uruchamiania programu Visual Studio — Tworzenie nowego projektu

    Zostanie otwarte okno Utwórz nowy projekt zawierające kilka szablonówprojektów.The Create a new project window opens and shows several project templates. Szablon zawiera podstawowe pliki i ustawienia, które są zbędne dla danego typu projektu.A template contains the basic files and settings needed for a given project type.

  3. Aby znaleźć żądany szablon, wpisz lub wprowadź w polu wyszukiwania konsolę .NET Core .To find the template we want, type or enter .net core console in the search box. Lista dostępnych szablonów jest automatycznie filtrowana na podstawie wprowadzonych słów kluczowych.The list of available templates is automatically filtered based on the keywords you entered. Można bardziej filtrować wyniki szablonu, wybierając C# z listy rozwijanej Język .You can further filter the template results by choosing C# from the Language drop-down list. Wybierz szablon Aplikacja konsolowa (.NET Core) , a następnie wybierz przycisk dalej.Select the Console App (.NET Core) template, and then choose Next.

    Tworzenie nowego projektu w programie Visual Studio

  4. W oknie Konfigurowanie nowego projektu wprowadź HelloWorld w polu Nazwa projektu , opcjonalnie Zmień lokalizację katalogu dla plików projektu, a następnie wybierz pozycję Utwórz.In the Configure your new project window, enter HelloWorld in the Project name box, optionally change the directory location for your project files, and then choose Create.

    Konfigurowanie nowego projektu w programie Visual Studio

    Program Visual Studio tworzy projekt.Visual Studio creates the project. Jest to prosta aplikacja "Hello world", która wywołuje metodę Console.WriteLine() w celu wyświetlenia ciągu literału "Hello world!"It's a simple "Hello World" application that calls the Console.WriteLine() method to display the literal string "Hello World!" w oknie Konsola (dane wyjściowe programu).in the console (program output) window.

    Wkrótce powinna zostać wyświetlona następująca zawartość:Shortly, you should see something like the following:

    Visual Studio IDE

    Kod C# aplikacji jest wyświetlany w oknie edytora, który zajmuje najwięcej miejsca.The C# code for your application shows in the editor window, which takes up most of the space. Zauważ, że tekst jest automatycznie kolorowy, aby wskazać różne części kodu, takie jak słowa kluczowe i typy.Notice that the text is automatically colorized to indicate different parts of the code, such as keywords and types. Ponadto małe, pionowe linie kreskowane w kodzie wskazują, które nawiasy są zgodne ze sobą, a numery wierszy ułatwiają znalezienie kodu później.In addition, small, vertical dashed lines in the code indicate which braces match one another, and line numbers help you locate code later. Możesz wybrać małe, opakowane znaki minus, aby zwinąć lub rozwinąć bloki kodu.You can choose the small, boxed minus signs to collapse or expand blocks of code. Ta funkcja tworzenia konspektu kodu umożliwia ukrycie kodu, który nie jest potrzebny, pomagając na zminimalizowanie bałaganu na ekranie.This code outlining feature lets you hide code you don't need, helping to minimize onscreen clutter. Pliki projektu są wymienione po prawej stronie w oknie o nazwie Eksplorator rozwiązań.The project files are listed on the right side in a window called Solution Explorer.

    Środowisko IDE programu Visual Studio z czerwonymi polami

    Dostępne są inne menu i okna narzędzi, ale teraz przyjrzyjmy się.There are other menus and tool windows available, but let's move on for now.

  5. Teraz uruchom aplikację.Now, start the app. Można to zrobić, wybierając pozycję Uruchom bez debugowania z menu Debuguj na pasku menu.You can do this by choosing Start Without Debugging from the Debug menu on the menu bar. Możesz również nacisnąć klawisz Ctrl +F5.You can also press Ctrl+F5.

    Debuguj > Rozpocznij bez debugowania menu

    Program Visual Studio kompiluje aplikację i zostanie otwarte okno konsoli z komunikatem Hello World! .Visual Studio builds the app, and a console window opens with the message Hello World!. Masz teraz działającą aplikację.You now have a running app!

    Okno konsoli

  6. Aby zamknąć okno konsoli, naciśnij dowolny klawisz na klawiaturze.To close the console window, press any key on your keyboard.

  7. Dodajmy do aplikacji dodatkowy kod.Let's add some additional code to the app. Dodaj następujący C# kod przed wierszem, który brzmi Console.WriteLine("Hello World!");:Add the following C# code before the line that says Console.WriteLine("Hello World!");:

    Console.WriteLine("\nWhat is your name?");
    var name = Console.ReadLine();
    

    Ten kod wyświetla nazwę użytkownika w oknie konsoli, a następnie czeka, aż użytkownik wprowadzi jakiś tekst, a następnie klawisz Enter .This code displays What is your name? in the console window, and then waits until the user enters some text followed by the Enter key.

  8. Zmień wiersz, który brzmi Console.WriteLine("Hello World!");, do następującego kodu:Change the line that says Console.WriteLine("Hello World!"); to the following code:

    Console.WriteLine($"\nHello {name}!");
    
  9. Uruchom aplikację ponownie, wybierając pozycję debuguj > Rozpocznij bez debugowania lub naciskając klawisz Ctrl +F5.Run the app again by selecting Debug > Start Without Debugging or by pressing Ctrl+F5.

    Program Visual Studio ponownie kompiluje aplikację i zostanie otwarte okno konsoli z prośbą o wprowadzenie nazwy.Visual Studio rebuilds the app, and a console window opens and prompts you for your name.

  10. Wprowadź swoją nazwę w oknie konsoli i naciśnij klawisz Enter.Enter your name in the console window and press Enter.

    Okno konsoli

  11. Naciśnij dowolny klawisz, aby zamknąć okno konsoli i zatrzymać uruchomiony program.Press any key to close the console window and stop the running program.

Używanie refaktoryzacji i technologii IntelliSenseUse refactoring and IntelliSense

Przyjrzyjmy się kilku sposobom, które Refaktoryzacja i technologia IntelliSense mogą pomóc w bardziej wydajnym kodzie.Let's look at a couple of the ways that refactoring and IntelliSense can help you code more efficiently.

Najpierw Zmień nazwę zmiennej name:First, let's rename the name variable:

  1. Kliknij dwukrotnie zmienną name, aby ją zaznaczyć.Double-click the name variable to select it.

  2. Wpisz nową nazwę zmiennej, username.Type in the new name for the variable, username.

    Zauważ, że wokół zmiennej pojawia się szare pole, a żarówka pojawia się na marginesie.Notice that a gray box appears around the variable, and a light bulb appears in the margin.

  1. Wybierz ikonę żarówki, aby wyświetlić dostępne szybkie akcje.Select the light bulb icon to show the available Quick Actions. Wybierz pozycję Zmień nazwę na "username" .Select Rename 'name' to 'username'.

    Zmień nazwę akcji w programie Visual Studio

    Zmienna została zmieniona na projekt, który w naszym przypadku ma tylko dwa miejsca.The variable is renamed across the project, which in our case is only two places.

    Animowany plik GIF pokazujący refaktoryzację zmiany nazwy w programie Visual Studio

  1. Wybierz ikonę żarówki, aby wyświetlić dostępne szybkie akcje.Select the light bulb icon to show the available Quick Actions. Wybierz pozycję Zmień nazwę na "username" .Select Rename 'name' to 'username'.

    Zmień nazwę akcji w programie Visual Studio

    Zmienna została zmieniona na projekt, który w naszym przypadku ma tylko dwa miejsca.The variable is renamed across the project, which in our case is only two places.

  1. Teraz przyjrzyjmy się technologii IntelliSense.Now let's take a look at IntelliSense. Poniżej wiersza, który brzmi Console.WriteLine($"\nHello {username}!");, wpisz DateTime now = DateTime..Below the line that says Console.WriteLine($"\nHello {username}!");, type DateTime now = DateTime..

    W polu są wyświetlane elementy członkowskie klasy DateTime.A box displays the members of the DateTime class. Ponadto w osobnym polu jest wyświetlany opis aktualnie wybranego elementu członkowskiego.In addition, the description of the currently selected member displays in a separate box.

    Elementy członkowskie listy IntelliSense w programie Visual Studio

  2. Wybierz element członkowski o nazwie Now, który jest właściwością klasy, klikając ją dwukrotnie lub naciskając klawisz Tab. Wypełnij wiersz kodu, dodając średnik do końca.Select the member named Now, which is a property of the class, by double-clicking on it or pressing Tab. Complete the line of code by adding a semi-colon to the end.

  3. Poniżej wpisz lub Wklej następujące wiersze kodu:Below that, type in or paste the following lines of code:

    int dayOfYear = now.DayOfYear;
    
    Console.Write("Day of year: ");
    Console.WriteLine(dayOfYear);
    

    Tip

    Console.Write jest nieco inna dla Console.WriteLine, ponieważ nie dodaje terminatora wiersza po wydrukowaniu.Console.Write is a little different to Console.WriteLine in that it doesn't add a line terminator after it prints. Oznacza to, że Następny fragment tekstu, który jest wysyłany do danych wyjściowych, będzie drukowany w tym samym wierszu.That means that the next piece of text that's sent to the output will print on the same line. Możesz umieścić wskaźnik myszy nad każdą z tych metod w kodzie, aby zobaczyć ich opis.You can hover over each of these methods in your code to see their description.

  4. Następnie użyjemy ponownie refaktoryzacji, aby kod był nieco bardziej zwięzły.Next, we'll use refactoring again to make the code a little more concise. Kliknij zmienną now w wierszu DateTime now = DateTime.Now;.Click on the variable now in the line DateTime now = DateTime.Now;.

    Zauważ, że na marginesie w tym wierszu pojawia się ikona małego śrubokrętu.Notice that a little screwdriver icon appears in the margin on that line.

  5. Kliknij ikonę śrubokrętu, aby zobaczyć, jakie sugestie są dostępne dla programu Visual Studio.Click the screwdriver icon to see what suggestions Visual Studio has available. W tym przypadku jest wyświetlana wbudowana zmienna tymczasowa Refaktoryzacja w celu usunięcia wiersza kodu bez zmiany ogólnego zachowania kodu:In this case, it's showing the Inline temporary variable refactoring to remove a line of code without changing the overall behavior of the code:

    Refaktoryzacja wbudowanej zmiennej tymczasowej w programie Visual Studio

  6. Kliknij przycisk wbudowana zmienna tymczasowa , aby refaktoryzacji kodu.Click Inline temporary variable to refactor the code.

  1. Ponownie uruchom program, naciskając klawisz Ctrl +F5.Run the program again by pressing Ctrl+F5. Dane wyjściowe wyglądają następująco:The output looks something like this:

    Okno konsoli z danymi wyjściowymi programu

  1. Ponownie uruchom program, naciskając klawisz Ctrl +F5.Run the program again by pressing Ctrl+F5. Dane wyjściowe wyglądają następująco:The output looks something like this:

    Okno konsoli z danymi wyjściowymi programu

Debuguj kodDebug code

Podczas pisania kodu należy go uruchomić i przetestować pod kątem błędów.When you write code, you need to run it and test it for bugs. System debugowania programu Visual Studio umożliwia przechodzenie przez kod jednej instrukcji w czasie i sprawdzanie zmiennych w miarę rzeczywistym.Visual Studio's debugging system lets you step through code one statement at a time and inspect variables as you go. Można ustawić punkty przerwania , które zatrzymują wykonywanie kodu w konkretnym wierszu.You can set breakpoints that stop execution of the code at a particular line. Można obserwować, jak zmienia się wartość zmiennej w miarę uruchamiania kodu i nie tylko.You can observe how the value of a variable changes as the code runs, and more.

Ustawmy punkt przerwania, aby widział wartość zmiennej username, gdy program jest "w locie".Let's set a breakpoint to see the value of the username variable while the program is "in flight".

  1. Znajdź wiersz kodu, który mówi Console.WriteLine($"\nHello {username}!");.Find the line of code that says Console.WriteLine($"\nHello {username}!");. Aby ustawić punkt przerwania w tym wierszu kodu, czyli w celu wstrzymania wykonywania programu w tym wierszu, kliknij górny lewy margines edytora.To set a breakpoint on this line of code, that is, to make the program pause execution at this line, click in the far left margin of the editor. Możesz również kliknąć dowolne miejsce w wierszu kodu, a następnie nacisnąć klawisz F9.You can also click anywhere on the line of code and then press F9.

    Czerwony okrąg pojawia się na marginesie po lewej stronie, a kod zostanie wyróżniony kolorem czerwonym.A red circle appears in the far left margin, and the code is highlighted in red.

    Punkt przerwania w wierszu kodu w programie Visual Studio

  2. Rozpocznij debugowanie, wybierając pozycję debuguj > rozpocząć debugowanie lub naciskając klawisz F5.Start debugging by selecting Debug > Start Debugging or by pressing F5.

  3. Gdy zostanie wyświetlone okno konsoli i zostanie wyświetlony monit o podanie nazwy, wpisz ją w i naciśnij klawisz Enter.When the console window appears and asks for your name, type it in and press Enter.

    Fokus wraca do edytora kodu programu Visual Studio, a wiersz kodu z punktem przerwania zostanie wyróżniony kolorem żółtym.The focus returns to the Visual Studio code editor and the line of code with the breakpoint is highlighted in yellow. Oznacza to, że jest to kolejny wiersz kodu, który zostanie wykonany przez program.This signifies that it's the next line of code that the program will execute.

  4. Przesuń wskaźnik myszy nad zmienną username, aby zobaczyć jej wartość.Hover your mouse over the username variable to see its value. Alternatywnie możesz kliknąć prawym przyciskiem myszy username i wybrać polecenie Dodaj czujkę , aby dodać zmienną do okna czujki , gdzie można także zobaczyć jego wartość.Alternatively, you can right-click on username and select Add Watch to add the variable to the Watch window, where you can also see its value.

    Wartość zmiennej podczas debugowania w programie Visual Studio

  5. Aby pozwolić programowi na zakończenie pracy, naciśnij ponownie klawisz F5 .To let the program run to completion, press F5 again.

Aby uzyskać więcej informacji na temat debugowania w programie Visual Studio, zobacz Przewodnik po funkcjach debugera.To get more details about debugging in Visual Studio, see Debugger feature tour.

Dostosuj program Visual StudioCustomize Visual Studio

Możesz spersonalizować interfejs użytkownika programu Visual Studio, w tym zmiany domyślnego motywu kolorów.You can personalize the Visual Studio user interface, including change the default color theme. Aby przejść do ciemnego motywu:To change to the Dark theme:

  1. Na pasku menu wybierz polecenie narzędzia > Opcje , aby otworzyć okno dialogowe Opcje .On the menu bar, choose Tools > Options to open the Options dialog.
  1. Na stronie opcje środowiska > Ogólne Zmień wybór motywu koloru na ciemny, a następnie wybierz przycisk OK.On the Environment > General options page, change the Color theme selection to Dark, and then choose OK.

    Motyw kolorów dla całego środowiska IDE zmieni się na ciemny.The color theme for the entire IDE changes to Dark.

    Visual Studio w ciemnym motywie

  1. Na stronie opcje środowiska > Ogólne Zmień wybór motywu koloru na ciemny, a następnie wybierz przycisk OK.On the Environment > General options page, change the Color theme selection to Dark, and then choose OK.

    Motyw kolorów dla całego środowiska IDE zmieni się na ciemny.The color theme for the entire IDE changes to Dark.

    Visual Studio w ciemnym motywie

Aby dowiedzieć się więcej na temat innych sposobów personalizowania środowiska IDE, zobacz Personalizowanie programu Visual Studio.To learn about other ways you can personalize the IDE, see Personalize Visual Studio.

Następne krokiNext steps

Zapoznaj się dodatkowo program Visual Studio, wykonując wraz z jednym niniejsze artykuły wprowadzające zawierają:Explore Visual Studio further by following along with one of these introductory articles:

Jeśli chcesz zacząć korzystać do kodowania więcej jedną z następujących przewodników Szybki Start specyficzny dla języka jest dobre następnego kroku:If you're ready to dive into more coding, one of the following language-specific quickstarts is a good next step:

Zobacz takżeSee also