Funkcje edytora kodu

Edytor Visual Studio udostępnia wiele funkcji, które ułatwiają pisanie kodu i tekstu oraz zarządzanie nim. Za pomocą zwijania można rozwijać i zwijać różne bloki kodu. Aby dowiedzieć się więcej na temat kodu, możesz użyć funkcji IntelliSense, przeglądarki obiektów i hierarchii wywołań. Kod można znaleźć przy użyciu funkcji, takich jak Przejdź do, Przejdź do definicji i Znajdź wszystkie odwołania. Bloki kodu można wstawiać za pomocą fragmentów kodu, a kod można wygenerować przy użyciu funkcji, takich jak Generuj na podstawie użycia. Jeśli edytor kodu nie był Visual Studio nigdy wcześniej, zobacz Learn to use the code editor (Dowiedz się, jak używać edytora kodu).

Uwaga

Ten temat dotyczy Visual Studio na Windows. Aby uzyskać Visual Studio dla komputerów Mac, zobacz Edytor źródła (Visual Studio dla komputerów Mac).

Kod można wyświetlić na wiele różnych sposobów. Domyślnie kod Eksplorator rozwiązań uporządkowany według plików. Możesz kliknąć kartę Widok klasy u dołu okna, aby wyświetlić kod uporządkowany według klas.

Możesz wyszukiwać i zamieniać tekst w pojedynczych lub wielu plikach. Aby uzyskać więcej informacji, zobacz Znajdowanie i zastępowanie tekstu. Aby znaleźć i zamienić tekst, można użyć wyrażeń regularnych. Aby uzyskać więcej informacji, zobacz Używanie wyrażeń regularnych w programie Visual Studio.

Różne języki Visual Studio oferują różne zestawy funkcji, a w niektórych przypadkach funkcje zachowują się inaczej w różnych językach. Wiele z tych różnic jest określonych w opisach funkcji, ale aby uzyskać więcej informacji, zobacz sekcje dotyczące określonych Visual Studio językowych.

Funkcje edytora

Cecha Opis
Kolorowanie składni Niektóre elementy składni plików kodu i znaczników mają różne kolory, aby je odróżnić. Na przykład słowa kluczowe (takie jak w języku C# i Visual Basic) są jednym kolorem, ale typy (takie jak using i ) to inny Imports Console Uri kolor. Inne elementy składni są również pokolorowane, takie jak literały ciągu i komentarze. Język C++ używa koloru do odróżnienia typów, wyliczeń i makr, od innych tokenów.

Można zobaczyć domyślny kolor dla każdego typu i można zmienić kolor dla dowolnego elementu składni w czcionki i kolory, środowiska,opcje okno dialogowe, które można otworzyć z narzędzia menu.
Znaczniki błędów i ostrzeżeń Podczas dodawania kodu i kompilowania rozwiązania w kodzie mogą pojawić się (a) podkreślenia faliste o różnych kolorach (nazywane zygieł) lub (b) żarówki. Czerwone zygniaki oznaczają błędy składniowe, niebieski oznacza błędy kompilatora, zielony oznacza ostrzeżenia, a purpurowy oznacza inne typy błędów. Szybkie akcje sugerują poprawki problemów i ułatwiają zastosowanie poprawki.

Domyślny kolor dla każdego błędu i ostrzeżenia jest wyświetlany w oknie dialogowym Opcje narzędzi Czcionki > > > i kolory środowiska. Poszukaj błędów składni, błędów kompilatora, ostrzeżeń i innych błędów.
Dopasowywanie nawiasów klamrowych Gdy punkt wstawiania jest umieszczany w otwartym nawiasie klamrowym w pliku kodu, wyróżniony jest zarówno go, jak i zamykający nawias klamrowy. Ta funkcja zapewnia natychmiastową opinię na temat zgubionych lub brakujących nawiasów klamrowych. Dopasowywanie nawiasów klamrowych można włączyć lub wyłączyć za pomocą ustawienia wyróżniania ogranicznika automatycznego (Narzędzia > Opcje > Edytor tekstu). Kolor wyróżnienia można zmienić w ustawieniu Czcionki i kolory (Środowisko opcji > > narzędzi). Poszukaj pasującego nawiasu klamrowego (wyróżnienia) lub dopasowania nawiasów klamrowych (prostokąt).
Wizualizator struktury Linie kropkowane łączą pasujące nawiasy klamrowe w plikach kodu, co ułatwia wyświetlanie otwieranych i zamykających par nawiasów klamrowych. Może to pomóc w szybciej znaleźć kod w bazie kodu. Te wiersze można włączać i wyłączać za pomocą wytycznych dotyczących wyświetlania struktury w sekcji Wyświetlanie na stronie Narzędzia > Opcje > Edytor tekstu > Ogólne.
Numery wiersza Numery wiersza mogą być wyświetlane na lewym marginesie okna kodu. Nie są one wyświetlane domyślnie. Tę opcję można włączyć w ustawieniach Edytor tekstu Wszystkie języki (Narzędzia > Opcje > Edytor tekstu Wszystkie > języki). Numery wiersza dla poszczególnych języków programowania można wyświetlić, zmieniając ustawienia dla tych języków (Narzędzia > Opcje > Edytor > <language> tekstu). Aby wydrukować numery linii, należy wybrać pozycję Uwzględnij numery wiersza w oknie dialogowym Drukowanie.
Śledzenie zmian Kolor lewego marginesu umożliwia śledzenie zmian wprowadzonych w pliku. Zmiany wprowadzone od czasu otwarcia pliku, ale nie zostały zapisane, są oznaczane żółtym pasek na lewym marginesie (nazywanym marginesem zaznaczenia). Po zapisaniu zmian (ale przed zamknięciem pliku) pasek zmieni kolor na zielony. Jeśli cofniesz zmianę po zapisaniu pliku, pasek zmieni kolor na pomarańczowy. Aby wyłączyć i włączyć tę funkcję, zmień opcję Śledź zmiany w ustawieniach Edytora tekstów (Narzędzia > Opcje > Edytor tekstu).
Wybieranie kodu i tekstu Możesz zaznaczyć tekst w standardowym trybie ciągłego przesyłania strumieniowego lub w trybie skrzynki, w którym wybierasz prostokątną część tekstu zamiast zestawu wierszy. Aby dokonać wyboru w trybie pola, naciśnij klawisz Alt, przeciągając wskaźnik myszy nad zaznaczeniem (lub naciśnij klawisz Alt + Shift + <arrow key> ). Zaznaczenie obejmuje wszystkie znaki w prostokącie zdefiniowane przez pierwszy i ostatni znak w zaznaczeniu. Wszystkie elementy wpisane lub wklejone w wybranym obszarze są wstawiane w tym samym punkcie w każdym wierszu.
Zoom Możesz powiększać lub pomniejszać w dowolnym oknie kodu, naciskając i przytrzymując klawisz Ctrl, a następnie przesuwając kółka przewijania myszy (lub klawisz Ctrl + Shift + . w celu zwiększenia i Ctrl + Shift + , aby zmniejszyć). Możesz również użyć pola Powiększenie w lewym dolnym rogu okna kodu, aby ustawić określoną wartość procentową powiększenia. Funkcja powiększenia nie działa w oknach narzędzi.
Przestrzeń wirtualna Domyślnie wiersze w edytorach Visual Studio kończą się po ostatnim znaku, dzięki czemu klawisz Strzałka w prawo na końcu wiersza przenosi kursor na początek następnego wiersza. W niektórych innych edytorach wiersz nie kończy się po ostatnim znaku i możesz umieścić kursor w dowolnym miejscu wiersza. Możesz włączyć przestrzeń wirtualną w edytorze w ustawieniach Narzędzia > Opcje > Edytor tekstu > Wszystkie języki. Należy pamiętać, że możesz włączyć wirtualną przestrzeń lub zawijanie wyrazów, ale nie oba.
Drukowanie Opcji dostępnych w oknie dialogowym Drukowanie można użyć do dołączania numerów wiersza lub ukrywania zwiniętych regionów kodu podczas drukowania pliku. W oknie dialogowym Ustawienia strony możesz również wybrać opcję drukowania pełnej ścieżki i nazwy pliku, wybierając pozycję Nagłówek strony.

Opcje drukowania kolorów można ustawić w oknie dialogowym Opcje > narzędzi > > Czcionki i kolory środowiska. Wybierz pozycję Drukarka na liście Pokaż ustawienia, aby dostosować drukowanie kolorów. Można określić różne kolory drukowania pliku niż w przypadku edytowania pliku.
Globalne cofanie i ponowne cofanie Polecenia Cofnij ostatnią akcję globalną i Ponownie wywłaszj ostatnią akcję globalną w menu Edycja cofnij lub ponownie wytnij globalne akcje, które mają wpływ na wiele plików. Akcje globalne obejmują zmianę nazwy klasy lub przestrzeni nazw, wykonanie operacji find-and-replace w rozwiązaniu, refaktoryzowanie bazy danych lub dowolną inną akcję, która zmienia wiele plików. Globalne polecenia cofania i ponownego cofania można zastosować do akcji w bieżącej sesji Visual Studio, nawet po zamknięciu rozwiązania, w którym zastosowano akcję.

Zaawansowane funkcje edycji

Wiele zaawansowanych funkcji można znaleźć w menu Edytuj > zaawansowane na pasku narzędzi. Nie wszystkie te funkcje są dostępne dla wszystkich typów plików kodu.

Cecha Opis
Formatuj dokument Ustawia odpowiednie wcięcia wierszy kodu i przenosi nawiasy klamrowe do oddzielnych wierszy w dokumencie.
Formatowanie zaznaczenia Ustawia odpowiednie wcięcia wierszy kodu i przenosi nawiasy klamrowe w celu oddzielenia wierszy w zaznaczeniu.
Tabify Selected Lines Zmienia wiodące spacje na tabulatory tam, gdzie jest to konieczne.
Untabify Selected Lines Zmienia wiodące karty na spacje. Jeśli chcesz przekonwertować wszystkie spacje w pliku na karty (lub wszystkie karty na spacje), możesz użyć Edit.ConvertSpacesToTabs poleceń Edit.ConvertTabsToSpaces i . Te polecenia nie są wyświetlane Visual Studio menu, ale można je wywołać z okna Szybki dostęp lub okna poleceń.
Nadaj wielkie litery Zmienia wszystkie znaki w zaznaczeniu na wielkie litery lub jeśli nie ma zaznaczenia, zmienia znak w punkcie wstawiania na wielkie litery. Skrót: Ctrl + Shift + U.
Zamieć małe litery Zmienia wszystkie znaki w zaznaczeniu na małe litery lub, jeśli nie ma zaznaczenia, zmienia znak w punkcie wstawiania na małe litery. Skrót: Ctrl + U.
Przenieś wybrane wiersze w górę Przenosi wybrany wiersz w górę o jeden wiersz. Skrót: Alt + Strzałka w górę.
Przenieś wybrane linie w dół Przenosi zaznaczony wiersz w dół o jeden wiersz. Skrót: Alt + Strzałka w dół.
Usuwanie poziomego białego miejsca Usuwa karty lub spacje na końcu bieżącego wiersza. Skrót: Ctrl + K, Ctrl+\
Wyświetlanie białych spacji Wyświetla spacje jako podniesione kropki, a karty jako strzałki. Koniec pliku jest wyświetlany jako prostokątny glif. Jeśli opcja Narzędzia Edytor tekstu Wszystkie języki Zawijanie wyrazów Pokaż widoczne glify dla zawijania wyrazów > > > > > jest zaznaczona, ten glyph jest również wyświetlany.
Zawijanie wierszy Powoduje, że wszystkie wiersze w dokumencie są widoczne w oknie kodu. Zawijanie i włączanie zawijania wyrazów można włączyć i wyłączyć w ustawieniach Edytor tekstu Wszystkie języki (Opcje > narzędzi > Edytor tekstu Wszystkie > języki).
Wybór komentarza Dodaje znaki komentarza do zaznaczenia lub bieżącego wiersza. Skrót: Ctrl + K, Ctrl + C
Zaznaczenie z cokomentu Usuwa znaki komentarza z zaznaczenia lub bieżącego wiersza. Skrót: Ctrl + K, Ctrl + U
Zwiększanie wcięcia wiersza Dodaje kartę (lub równoważne spacje) do wybranych wierszy lub bieżącego wiersza.
Zmniejszanie wcięcia wiersza Usuwa kartę (lub równoważne spacje) z wybranych wierszy lub bieżącego wiersza.
Wybierz tag W dokumencie zawierającym tagi (na przykład XML lub HTML) wybiera tag.
Wybierz pozycję Taguj zawartość W dokumencie, który zawiera tagi (na przykład XML lub HTML), wybiera zawartość.

W edytorze kodu można poruszać się na kilka różnych sposobów, w tym przechodzić wstecz i do przodu do poprzednich punktów wstawiania, wyświetlać definicję typu lub członka i przechodzić do określonej metody przy użyciu paska nawigacyjnego. Aby uzyskać więcej informacji, zobacz Navigate code ( Nawiguj po kodzie).

Znajdowanie odwołań w bazie kodu

Aby znaleźć odwołania do konkretnych elementów kodu w bazie kodu, możesz użyć polecenia Znajdź wszystkie odwołania lub nacisnąć klawisz Shift + F12. Ponadto po kliknięciu typu lub elementu członkowskiego funkcja wyróżniania odwołań automatycznie wyróżnia wszystkie odwołania do tego typu lub elementu członkowskiego. Aby uzyskać więcej informacji, zobacz Znajdowanie odwołań w kodzie.

Dopasowywanie edytora

Ustawienia usługi Visual Studio można udostępnić inowi deweloperowi, ustawienia są zgodne ze standardem lub przywrócić domyślne ustawienia usługi Visual Studio za pomocą polecenia Importuj i eksportuj kreatora Ustawienia w menu Narzędzia. W Kreatorze importowania i eksportowania Ustawienia można zmienić wybrane ustawienia ogólne lub ustawienia języka i specyficzne dla projektu.

Aby zdefiniować nowe klawisze dostępu lub ponownie zdefiniować istniejące klawisze dostępu, przejdź do tematu Narzędzia > Opcje > Klawiatury środowiska > . Aby uzyskać więcej informacji na temat klawiszy dostępu, zobacz Domyślne skróty klawiaturowe.

Aby uzyskać informacje na temat opcji edytora specyficznych dla języka JavaScript, zobacz Opcje edytora języka JavaScript.

Zobacz też