Wprowadzenie do tworzenia gier za pomocą aparatu Unity w Visual Studio dla komputerów Mac

Unity to aparat gier, który umożliwia tworzenie gier w języku C#. W tym przewodniku pokazano, jak rozpocząć tworzenie i debugowanie gier Unity przy użyciu narzędzi Visual Studio dla komputerów Mac i rozszerzenia Visual Studio dla komputerów Mac Tools for Unity obok środowiska Unity.

Visual Studio dla komputerów Mac Tools for Unity to bezpłatne rozszerzenie instalowane z Visual Studio dla komputerów Mac. Umożliwia ona deweloperom aparatu Unity korzystanie z funkcji produktywności Visual Studio dla komputerów Mac, takich jak doskonała obsługa intelliSense, funkcje debugowania i inne.

Cele

  • Dowiedz się więcej o programie Unity przy użyciu Visual Studio dla komputerów Mac

Wymagania wstępne

Docelowi odbiorcy

To laboratorium jest przeznaczone dla deweloperów, którzy znają język C#, chociaż nie jest wymagane głębokie doświadczenie.

Zadanie 1. Tworzenie podstawowego projektu aparatu Unity

  1. Uruchom platformę Unity. Zaloguj się, jeśli jest to wymagane.

  2. Kliknij pozycję Nowy.

    Nowy przycisk w a aparatu Unity

  3. Ustaw nazwę Project na "UnityLab", a następnie wybierz pozycję 3D. Kliknij pozycję Create project (Utwórz projekt).

    Ekran tworzenia nowego projektu

  4. Teraz patrzysz na domyślny interfejs aparatu Unity. Po lewej stronie znajduje się hierarchia scen z obiektami gry, widok 3D pustej sceny wyświetlany w środku, okienko plików projektu u dołu oraz inspektor i usługi po prawej stronie. Oczywiście jest ich o wiele więcej, ale jest to kilka najważniejszych składników.

    pusty interfejs aparatu Unity

  5. Dla deweloperów, którzy nie mają jeszcze aparatu Unity, wszystko, co działa w aplikacji, będzie istnieć w kontekście sceny . Plik sceny to pojedynczy plik zawierający wszelkiego rodzaju metadane dotyczące zasobów używanych w projekcie dla bieżącej sceny i jej właściwości. Gdy spakujesz aplikację dla platformy, wynikowa aplikacja stanie się kolekcją co najmniej jednej sceny oraz dowolnego kodu zależnego od platformy, który dodasz. W projekcie możesz mieć tyle scen, ile potrzebujesz.

  6. Nowa scena ma tylko kamerę i kierunkowe światło. Scena wymaga kamery, aby wszystko było widoczne, i odbiornika audio, aby wszystko było słyszalne. Te składniki są dołączone do gameobject.

  7. Wybierz obiekt Main Camera (Kamera główna) w okienku Hierarchy (Hierarchia).

    obiekt aparatu głównego wyróżniony w okienku hierarchii

  8. Wybierz okienko Inspector (Inspektor) z prawej strony okna, aby przejrzeć jego właściwości. Właściwości aparatu obejmują informacje o transformacji, tło, typ projekcji, pole widoku i tak dalej. Domyślnie został również dodany składnik Odbiornik audio, który zasadniczo renderuje dźwięk sceny z wirtualnego mikrofonu dołączonego do aparatu.

    okienko inspektora

  9. Wybierz obiekt Directional Light (Kierunkowe światło). Zapewnia to światło dla sceny, dzięki czemu składniki, takie jak cieniowania, wiedzą, jak renderować obiekty.

    wyróżniony obiekt kierunkowy jasny

  10. Użyj inspektora, aby zobaczyć, że zawiera typowe właściwości oświetlenia, takie jak typ, kolor, natężenie, typ cienia i tak dalej.

    przyglądanie się właściwościom w okienku inspektora

  11. Należy pamiętać, że projekty w a unity są nieco inne niż ich Visual Studio dla komputerów Mac odpowiedniki. Na karcie Project u dołu kliknij prawym przyciskiem myszy folder Assets i wybierz polecenie Reveal in Finder (Ujawnij w programie Finder).

    ujawnianie w akcji kontekstowej wyszukiwania

  12. Projekty zawierają elementy zawartości, biblioteki, elementy ProjectSettings i foldery tymczasowe, jak widać. Jednak jedyną wartością, która pojawia się w interfejsie, jest folder Assets. Folder Biblioteka jest lokalną pamięcią podręczną importowanych zasobów. Przechowuje wszystkie metadane dla zasobów. Folder ProjectSettings przechowuje ustawienia, które można skonfigurować. Folder Temp jest używany dla plików tymczasowych z platform Mono i Unity podczas procesu kompilacji. Istnieje również plik rozwiązania, który można otworzyć w Visual Studio dla komputerów Mac (UnityLab.sln tutaj).

    zasoby w programie finder

  13. Zamknij okno programu Finder i wróć do aparatu Unity.

  14. Folder Assets zawiera wszystkie elementy assets-art, kod, dźwięk itp. Teraz jest ono puste, ale każdy pojedynczy plik, który można wprowadzić do projektu, jest tutaj dostępny. Jest to zawsze folder najwyższego poziomu w edytorze aparatu Unity. Zawsze jednak należy dodawać i usuwać pliki za pośrednictwem interfejsu aparatu Unity (lub Visual Studio dla komputerów Mac), a nigdy bezpośrednio za pośrednictwem systemu plików.

    folder assets w a aparatu Unity

  15. Projekt GameObject jest centralnym elementem rozwoju w a aparatu Unity, ponieważ niemal wszystko pochodzi od tego typu, w tym modeli, światła, układy cząstek itd. Dodaj nowy obiekt Cube do sceny za pośrednictwem menu > GameObject 3D Object > Cube.

    obiekt sześcianu w scenie

  16. Przyjrzyj się szybko właściwościom nowego obiektu GameObject i zobacz, że ma on nazwę, tag, warstwę i przekształcenie. Te właściwości są wspólne dla wszystkich obiektów GameObject. Ponadto do modułu dołączono kilka składników w celu zapewnienia potrzebnych funkcji, w tym filtru siatki, sortatora skrzynki i modułu renderowania.

    właściwości obiektu gry

  17. Zmień nazwę obiektu Cube (Sześcian), który domyślnie ma nazwę "Cube" (Sześcian) na "Wańcowy". Pamiętaj, aby nacisnąć klawisz Enter, aby zapisać zmianę. Będzie to sześcian w naszej prostej grze.

    właściwość zmiany nazwy obiektu modułu

  18. Dodaj kolejny obiekt Cube do sceny przy użyciu tego samego procesu co powyżej i nadaj temu obiektowi nazwę "Player".

    zmiana nazwy drugiego obiektu modułu

  19. Otaguj również obiekt odtwarzacza "Player" (zobacz kontrolkę listy rozwijanej Tag tuż pod polem nazwy). Użyjemy go w skrypcie skrypcie, aby ułatwić zlokalizowanie obiektu gry player.

    tagowanie obiektu odtwarzacza

  20. W widoku Scene (Scena) przenieś obiekt odtwarzacza z kierunku obiektu chrzętnego wzdłuż osi Z przy użyciu myszy. Możesz poruszać się wzdłuż osi Z, zaznaczając i przeciągając sześcian przy jego czerwonym panelu w kierunku niebieskiej linii. Ponieważ sześcian znajduje się w przestrzeni 3D, ale za każdym razem można go przeciągać tylko w 2D, oś, na której przeciągasz, jest szczególnie ważna.

    widok sceny przedstawiający sześcian

  21. Przenieś sześcian w dół i w prawo wzdłuż osi. To aktualizuje właściwość Transform.Position w inspektorze. Pamiętaj, aby przeciągnąć do lokalizacji podobnej do przedstawionej tutaj, aby ułatwić późniejsze kroki w laboratorium.

    przenoszenie jednego modułu wzdłuż osi

  22. Teraz możesz dodać kod, który będzie napędzał logikę logiki logiki, tak aby podążała za graczem. Kliknij prawym przyciskiem myszy folder Assets w oknie Project, a następnie wybierz > skrypt języka C#.

    Akcja kontekstowa skryptu języka C#

  23. Nadaj noweowi skryptowi w języku C# nazwę "NawiązanaAI".

    Skrypt języka C#

  24. Aby dołączyć skrypty do obiektów gry, przeciągnij nowo utworzony skrypt do obiektu Chyb w okienku Hierarchia. Teraz ten obiekt będzie używać zachowań z tego skryptu.

    wyróżnianie pokazujące dodawanie skryptu do obiektu game

  25. Wybierz pozycję > zapisz sceny, aby zapisać bieżącą scenę. Nadaj jej nazwę "MyScene".

Zadanie 2. Praca z narzędziami Visual Studio dla komputerów Mac Tools for Unity

  1. Najlepszym sposobem edytowania kodu w języku C# jest użycie Visual Studio dla komputerów Mac. Możesz skonfigurować unity do używania Visual Studio dla komputerów Mac jako domyślnego programu obsługi. Wybierz pozycję Preferencje > Unity.

  2. Wybierz kartę Narzędzia zewnętrzne. Z listy rozwijanej Zewnętrzny edytor skryptów wybierz pozycję Przeglądaj i wybierz pozycję Aplikacje/Visual Studio.app. Alternatywnie, jeśli istnieje już opcja Visual Studio, po prostu ją wybierz.

    karta narzędzi zewnętrznych w preferencjach

  3. Unity jest teraz skonfigurowana do używania Visual Studio dla komputerów Mac do edytowania skryptów. Zamknij okno dialogowe Preferencje aparatu Unity.

    Visual Studio wybrane w preferencjach

  4. Kliknij dwukrotnie pozycję AI.cs, aby otworzyć go w Visual Studio dla komputerów Mac.

    Zasób trwały wybrany w a unity

  5. Rozwiązanie Visual Studio jest proste. Zawiera on folder Assets (ten sam folder z programu Finder) i utworzony wcześniej skrypt WAI.cs. W bardziej zaawansowanych projektach hierarchia prawdopodobnie będzie wyglądać inaczej niż w a aparatu Unity.

    Okno rozwiązania w Visual Studio dla komputerów Mac

  6. W edytorze jest otwarty open AI.cs. Początkowy skrypt zawiera tylko wycinki dla metod Start i Update.

  7. Zastąp początkowy kod początkowy kodem poniżej.

    public class EnemyAI : MonoBehaviour
    {
        public float Speed = 50;
        private Transform _playerTransform;
        private Transform _myTransform;
    
        void Start()
        {
            var player = GameObject.FindGameObjectWithTag("Player");
            if (!player)
            {
                Debug.LogError(
                    "Could not find the main player. Ensure it has the player tag set.");
            }
            else
            {
                _playerTransform = player.transform;
            }
            _myTransform = this.transform;
        }
    
        void Update()
        {
            var moveAmount = Speed * Time.deltaTime;
            _myTransform.position = Vector3.MoveTowards(_myTransform.position,
                _playerTransform.position, moveAmount);
    
            if (_myTransform.position == _playerTransform.position)
            {
                _myTransform.position = Vector3.back * 10;
            }
        }
    }
    
  8. Przyjrzyj się prostego zachowania pogotowie, które jest tutaj zdefiniowane. W metodzie Start pobierzemy odwołanie do obiektu odtwarzacza (według jego tagu), a także do jego przekształcenia. W metodzie Update, która jest nazywana każdą ramką, chyli się w kierunku obiektu odtwarzacza. Słowa kluczowe i nazwy używają kodowania kolorami, aby ułatwić zrozumienie bazy kodu w Visual Studio dla komputerów Mac.

  9. Zapisz zmiany w skrypcie skrypcie w Visual Studio dla komputerów Mac.

Zadanie 3. Debugowanie projektu aparatu Unity

  1. Ustaw punkt przerwania w pierwszym wierszu kodu w metodzie Start. Możesz kliknąć na marginesie edytora w wierszu docelowym lub umieścić kursor w wierszu i nacisnąć klawisz F9.

    ustawianie punktu przerwania w Visual Studio dla komputerów Mac

  2. Kliknij przycisk Rozpocznij debugowanie lub naciśnij klawisz F5. Spowoduje to skompilowanie projektu i dołączenie go do aparatu Unity w celu debugowania.

    Przycisk start w Visual Studio dla komputerów Mac

  3. Wróć do aparatu Unity i kliknij przycisk Run (Uruchom), aby rozpocząć grę.

    przycisk uruchamiania w a aparatu Unity

  4. Punkt przerwania powinien zostać trafiony i można teraz używać Visual Studio dla komputerów Mac debugowania.

    punkt przerwania w Visual Studio dla komputerów Mac

  5. W oknie Locals (Lokalizacje lokalne) znajdź ten wskaźnik, który odwołuje się do obiektu WI. Rozwiń odwołanie i sprawdź, czy możesz przeglądać skojarzone elementy członkowskie, takie jak Speed.

    Okno Locals (Lokalne) w Visual Studio dla komputerów Mac

  6. Usuń punkt przerwania z metody Start w taki sam sposób, w jaki został dodany — kliknij go na marginesie lub wybierz wiersz i naciśnij klawisz F9.

    Usuwanie punktu przerwania w Visual Studio dla komputerów Mac przez kliknięcie go

  7. Naciśnij klawisz F10, aby zawęzić pierwszy wiersz kodu, który znajduje obiekt gry Player przy użyciu tagu jako parametru.

  8. Umieść kursor myszy na zmiennej player w oknie edytora kodu, aby wyświetlić skojarzone elementy członkowskie. Możesz nawet rozwinąć nakładkę, aby wyświetlić właściwości podrzędne.

    okno debugowania w Visual Studio dla komputerów Mac edytorze

  9. Naciśnij klawisz F5 lub naciśnij przycisk Uruchom, aby kontynuować wykonywanie. Wróć do aparatu Unity, aby zobaczyć, jak sześcian wielokrotnie podchodzi do sześcianu odtwarzacza. Jeśli aparat nie jest widoczny, może być konieczne dostosowanie go.

    odtwarzanie sceny w a unity

  10. Wróć do Visual Studio dla komputerów Mac i ustaw punkt przerwania w pierwszym wierszu metody Update. Powinien on zostać natychmiast trafiony.

    Usuwanie punktu przerwania w Visual Studio dla komputerów Mac

  11. Załóżmy, że szybkość jest zbyt szybka i chcemy przetestować wpływ zmiany bez ponownego uruchamiania aplikacji. Znajdź zmienną Speed w oknie Wartości automatyczne lub Zmienne lokalne, a następnie zmień ją na wartość "10" i naciśnij klawisz Enter .

    dostosowywanie zmiennych w oknie zmiennych lokalnych

  12. Usuń punkt przerwania i naciśnij klawisz F5, aby wznowić wykonywanie.

  13. Wróć do aparatu Unity, aby wyświetlić uruchamianą aplikację. Sześcian sześcianu porusza się teraz z piątą szybkością.

    Okno aparatu Unity z uruchamianą aplikacją

  14. Zatrzymaj aplikację aparatu Unity, ponownie klikając przycisk Odtąd.

    zatrzymywanie aplikacji aparatu Unity

  15. Wróć do Visual Studio dla komputerów Mac. Zatrzymaj sesję debugowania, klikając przycisk Zatrzymaj.

    Zatrzymywanie sesji debugowania w programie Visual Studio dla komputerów Mac

Zadanie 4. Eksplorowanie funkcji aparatu Unity w Visual Studio dla komputerów Mac

  1. Visual Studio dla komputerów Mac zapewnia szybki dostęp do dokumentacji aparatu Unity w edytorze kodu. Umieść kursor na symbolu Vector3 w metodzie Update i naciśnij klawisze ⌘ Command + '.

    wybieranie metody w edytorze programu Visual Studio dla komputerów Mac

  2. Zostanie otwarte nowe okno przeglądarki z dokumentacją dla wektora 3. Zamknij okno przeglądarki, gdy zostanie spełnione.

    Zostanie otwarte okno przeglądarki z dokumentacją

  3. Visual Studio dla komputerów Mac udostępnia również kilku pomocników, którzy mogą szybko tworzyć klasy zachowań aparatu Unity. W Eksplorator rozwiązań kliknij prawym przyciskiem myszy pozycję Assets (Zasoby) i wybierz > New MonoBehaviour (Dodaj > MonoBehaviour).

    nowa akcja kontekstu monobehaviour

  4. Nowo utworzona klasa udostępnia wycinki dla metod Start i Update. Po zamykającym nawiasie klamrowy metody Update rozpocznij wpisywanie "onmouseup". Zauważ, że podczas wpisywania funkcja IntelliSense Visual Studio szybko zeruje w metodzie, która ma być implementowana. Wybierz go z podanej listy autouzupełniania. Wypełni on wycinki metody, w tym wszelkie parametry.

    Funkcja IntelliSense w programie Visual Studio dla komputerów Mac

  5. W metodzie OnMouseUp wpisz "base". , aby wyświetlić wszystkie metody podstawowe dostępne do wywołania. Możesz również eksplorować różne przeciążenia poszczególnych funkcji przy użyciu opcji stronicowania w prawym górnym rogu okna wysuwanego funkcji IntelliSense.

    eksplorowanie przeciążeń w Visual Studio dla komputerów Mac

  6. Visual Studio dla komputerów Mac umożliwia również łatwe definiowanie nowych cieniowania. W Eksplorator rozwiązań kliknij prawym przyciskiem myszy pozycję Assets (Zasoby) i wybierz > New Shader (Dodaj > cieniowania).

    nowa akcja cieniowania w Visual Studio dla komputerów Mac

  7. Format pliku cieniowania jest w pełni kolorowy i zawiera czcionkę, co ułatwia ich odczytywanie i zrozumienie.

    wyróżnianie składni

  8. Wróć do aparatu Unity. Zobaczysz, że ponieważ Visual Studio dla komputerów Mac z tym samym systemem projektu, zmiany wprowadzone w każdym miejscu są automatycznie synchronizowane z drugim. Teraz zawsze można używać najlepszego narzędzia do wykonania zadania.

    panel zasobów aparatu Unity

Podsumowanie

W tym laboratorium nauczyliśmy się, jak rozpocząć tworzenie gry za pomocą aparatu Unity i środowiska Visual Studio dla komputerów Mac. Zobacz , https://unity3d.com/learn aby dowiedzieć się więcej na temat aparatu Unity.