Informacje o wersji 15.3 programu Visual Studio 2017 Visual Studio 2017 version 15.3 Release Notes

Społeczność deweloperów | Wymagania systemowe | Zgodność | Kod dystrybucyjny | Postanowienia licencyjne | Blogi | Znane problemyDeveloper Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Known Issues


Uwaga

To nie jest najnowsza wersja programu Visual Studio 2017.This is not the latest version of Visual Studio 2017. Aby wyświetlić informacje dotyczące najnowszej wersji programu Visual Studio 2017, odwiedź aktualną stronę Informacje o wersji.To see information on the latest version of Visual Studio 2017, please visit the current Release Notes page.

Porada

Język strony możesz przełączać u dołu tej strony.You can switch the page language at the bottom of this page. Kliknij ikonęClick the i wyszukaj swój język albo wybierz go z listy dostępnych języków. icon, search for your language, or select from the list of available languages.


Ten artykuł zawiera informacje o wydaniach programu Visual Studio 2017 w wersji 15.3.This article contains information about releases for Visual Studio 2017 version 15.3.

OpinieFeedback

Chcemy poznać Twoją opinię!We’d love to hear from you! Problem możesz zgłosić, korzystając z opcji Zgłoś problem w instalatorze lub bezpośrednio w środowisku IDE programu Visual Studio.You can report a problem from the Report a Problem option in either the installer or the Visual Studio IDE itself. ProgramThe Feedback Icon znajduje się w prawym górnym rogu.icon is located in the upper right hand corner. Swoje opinie możesz śledzić w portalu Społeczność deweloperów.You can track your feedback in the Developer Community portal. Jeśli masz sugestie, poinformuj nas o nich w witrynie UserVoice.For suggestions, let us know through the UserVoice site.

Historia wersjiRelease History

Porada

Więcej informacji o sposobie dostarczania wydań znajdziesz w dokumencie Rytm wydawania wersji programu Visual Studio 2017.You can learn more about how we ship our releases in the Visual Studio 2017 Release Rhythm document.

Pobieranie bieżącej wersji programu Visual Studio 2017Download the Current Release of Visual Studio 2017

Kliknij przycisk, aby pobrać najnowszą wersję programu Visual Studio 2017.Click the button to download the latest version of Visual Studio 2017. Aby uzyskać instrukcje, zobacz temat Instalowanie programu Visual Studio 2017.For instructions, see Install Visual Studio 2017.

Uwaga: rozmiar pakietu instalacyjnego zależy od bieżącej konfiguracji programu Visual Studio.Note: Installation package size will vary depending on your current Visual Studio configuration.


Data wydania: 19 września 2017 r. — Visual Studio 2017 w wersji 15.3.5Release Date: September 19, 2017 - Visual Studio 2017 version 15.3.5

Problemy rozwiązane w wydaniu z 19 września 2017 r.Issues Fixed in September 19, 2017 Release

Problemy zgłaszane przez klientów, które zostały rozwiązane w tej wersji:These are the customer-reported issues addressed in this version:

  • Wprowadzono obsługę programu Xcode 9 firmy Apple oraz systemów iOS 11, tvOS 11 i watchOS 4Introduced support for Apple's Xcode 9, iOS 11, tvOS 11 and watchOS 4

Data wydania: 12 września 2017 r. — Visual Studio 2017 w wersji 15.3.4Release Date: September 12, 2017 - Visual Studio 2017 version 15.3.4

Problemy rozwiązane w wydaniu z 12 września 2017 r.Issues Fixed in September 12, 2017 Release

Problemy zgłaszane przez klientów, które zostały rozwiązane w tej wersji:These are the customer-reported issues addressed in this version:


Data wydania: 29 sierpnia 2017 r. — Visual Studio 2017 w wersji 15.3.3Release Date: August 29, 2017 - Visual Studio 2017 version 15.3.3

Problemy rozwiązane w wersji z 29 sierpnia 2017 r.Issues Fixed in August 29, 2017 Release

Problemy zgłaszane przez klientów, które zostały rozwiązane w tej wersji:These are the customer-reported issues addressed in this version:


Data wydania: 22 sierpnia 2017 r. — Visual Studio 2017 w wersji 15.3.2Release Date: August 22, 2017 - Visual Studio 2017 version 15.3.2

Problemy rozwiązane w wersji z 22 sierpnia 2017 r.Issues Fixed in August 22, 2017 Release

Problemy zgłaszane przez klientów, które zostały rozwiązane w tej wersji:These are the customer-reported issues addressed in this version:

Dodatkowe poprawki zawarte w tym wydaniu:Additional fixes included in this release:

  • Aktualizacja narzędzi usługi Service Fabric.Service Fabric tooling update.
  • Niepowodzenie uaktualnienia programu Visual Studio z błędem AccessDenied podczas instalowania/odinstalowywania składnika VSIX.Visual Studio upgrade fails with AccessDenied failure during VSIX install / uninstall.
  • Problem dotyczący generowania projektu na platformie Unity w wersji co najwyżej 5.5.Project generation issue on Unity version <= 5.5.
  • Przechwytywanie zrzutów dla plików połączonych.Dump capture for linked files.
  • Ciche generowanie nieprawidłowego kodu z powodu optymalizacji pętli.Silent bad codegen due to loop optimization.

Data wydania: 18 sierpnia 2017 r. — Visual Studio 2017 w wersji 15.3.1Release Date: August 18, 2017 - Visual Studio 2017 version 15.3.1

Problemy rozwiązane w tej wersjiIssues Fixed in this Release

Problemy zgłaszane przez klientów, które zostały rozwiązane w tej wersji:These are the customer-reported issues addressed in this version:


Data wydania: 14 sierpnia 2017 r. — Visual Studio 2017 w wersji 15.3Release Date: August 14, 2017 - Visual Studio 2017 version 15.3

Podsumowanie: nowości w tej wersjiSummary: What's New in this Release

  • Ulepszenia ułatwień dostępu zapewniają jeszcze łatwiejszy dostęp do programu Visual Studio.Accessibility Improvements make Visual Studio more accessible than ever.
  • Narzędzia usługi Azure Functions są dołączone do obciążenia deweloperskiego platformy Azure.Azure Function Tools are included in the Azure development workload. Możesz tworzyć aplikacje usługi Azure Functions lokalnie i publikować je bezpośrednio na platformie Azure.You can develop Azure Function applications locally and publish directly to Azure.
  • Teraz w programie Visual Studio 2017 możesz tworzyć aplikacje, które będą działać w usłudze Azure Stack i chmurach instytucji rządowych, np. na platformie Azure w Chinach.You can now build applications in Visual Studio 2017 that run on Azure Stack and government clouds, like Azure in China.
  • Poprawiliśmy obsługę programowania na platformie .NET Core dla platformy .NET Core 2.0 i kontenerów systemu Windows Nano Server.We improved .NET Core development support for .NET Core 2.0, and Windows Nano Server containers.
  • W środowisku IDE programu Visual Studio poprawiliśmy obszary logowania i tożsamości, stronę startową, uproszczone ładowanie rozwiązań oraz interfejs wiersza polecenia konfiguracji.In Visual Studio IDE, we improved Sign In and Identity, the start page, Lightweight Solution Load, and setup CLI. Ponadto poprawiliśmy refaktoryzację, generowanie kodu i szybkie akcje.We also improved refactoring, code generation and Quick Actions.
  • Edytor programu Visual Studio zapewnia lepszą dostępność ze względu na nowy motyw — „Niebieski (dodatkowy kontrast)” — oraz ulepszoną obsługę czytników zawartości ekranu.The Visual Studio Editor has better accessibility due to the new ‘Blue (Extra Contrast)’ theme and improved screen reader support.
  • Poprawiliśmy środowisko użytkownika debugera i diagnostyki.We improved the Debugger and diagnostics experience. Obejmuje to wskazanie i kliknięcie w celu ustawienia następnej instrukcji.This includes Point and Click to Set Next Statement. Ponadto odświeżyliśmy wszystkie zagnieżdżone wartości w oknie zmiennych i wprowadziliśmy ulepszenia do debugowania funkcji Otwórz folder.We've also refreshed all nested values in variable window, and made Open Folder debugging improvements.
  • Środowisko Xamarin ma nowy samodzielny edytor do edytowania uprawnień aplikacji.Xamarin has a new standalone editor for editing app entitlements.
  • Zaktualizowano środowisko użytkownika narzędzi Otwórz folder i CMake.The Open Folder and CMake Tooling experience is updated. Teraz można używać narzędzia CMake 3.8.You can now use CMake 3.8.
  • Wprowadziliśmy usprawnienia w aparacie IntelliSense oraz kreatorach projektu i kodu dla usług języka C++.We made improvements to the IntelliSense engine, and to the project and the code wizards for C++ Language Services.
  • Zestaw narzędzi Visual C++ obsługuje określanie celu inicjowania wiersza polecenia.Visual C++ Toolset supports command-prompt initialization targeting.
  • Dodaliśmy możliwość korzystania z funkcji języka C# 7.1.We added the ability to use C# 7.1 Language features.
  • Możesz zainstalować wersje języka TypeScript niezależnie od aktualizacji programu Visual Studio.You can install TypeScript versions independent of Visual Studio updates.
  • Dodaliśmy obsługę debugowania w środowisku Node 8.We added support for Node 8 debugging.
  • Dodano obsługę NuGet dla nowych krótkich nazw platformy (netcoreapp2.0, netstandard2.0, Tizen), Semantic Versioning 2.0.0 oraz integrację MSBuild ostrzeżeń i błędów NuGet.NuGet has added support for new TFMs (netcoreapp2.0, netstandard2.0, Tizen), Semantic Versioning 2.0.0, and MSBuild integration of NuGet warnings and errors.
  • Program Visual Studio oferuje teraz narzędzia programistyczne .NET Framework 4.7 na obsługiwanych platformach z uwzględnionym środowiskiem uruchomieniowym w wersji 4.7.Visual Studio now offers .NET Framework 4.7 development tools to supported platforms with 4.7 runtime included.
  • Dodaliśmy klastry powiązanych zdarzeń do wyników wyszukiwania zapytań w narzędziu wyszukiwania usługi Application Insights.We added clusters of related events to the search query results in the Application Insights Search tool.
  • Poprawiliśmy obsługę składni dla programu SQL Server 2016 w usłudze SQL Search firmy Redgate.We improved syntax support for SQL Server 2016 in Redgate SQL Search.
  • Umożliwiliśmy obsługę interfejsów API programu Microsoft Graph w usługach połączonych.We enabled support for Microsoft Graph APIs in Connected Services.

Najważniejsze problemy rozwiązane w tej wersjiTop Issues Fixed in this Release

Posłuchaliśmy głosu społeczności deweloperów.The Developer Community spoke and we listened. Ta lista zawiera 10 problemów rozwiązanych w tej wersji, które zyskały najwięcej głosów.This list provides the 10 highest voted issues fixed in this release.

The Developer Community Portal Dowiedz się więcej o problemach zgłaszanych przez klientów, które zostały rozwiązane w programie Visual Studio 2017 w wersji 15.3. Learn more about customer-reported issues addressed in Visual Studio 2017 version 15.3.


Szczegóły: nowości w tej wersjiDetails: What's New in this Release

Ułatwienia dostępu Accessibility

W tej wersji rozwiązaliśmy ponad 1700 problemów związanych z ułatwieniami dostępu. Program Visual Studio jest teraz bardziej dostępny niż kiedykolwiek wcześniej.We addressed over 1,700 accessibility issues in this release and made Visual Studio more accessible than ever. Masz dostęp do nowego motywu „Niebieski (dodatkowy kontrast)” (Rysunek 1).You have access to the new “Blue (Extra Contrast)” theme (Figure 1). Ten motyw oferuje większy kontrast niż zwykły motyw „Niebieski” i jest przeznaczony dla użytkowników, którzy nie chcą lub nie potrzebują pełnego trybu wysokiego kontrastu.This theme offers you more contrast than the regular "Blue" theme if you don't want or need the full High Contrast mode.

Blue (Extra Contrast) theme
(Rysunek 1) Motyw Niebieski (dodatkowy kontrast)(Figure 1) Blue (Extra Contrast) theme

W edytorze programu Visual Studio możesz odnajdywać zakończenia tekstu i przechodzić między nimi za pomocą nowego zestawu poleceń „Pokaż adnotacje z linią”.With Visual Studio Editor, you can discover and navigate between text adornments via the new "Show Line Annotations" command set. Ta nowa funkcja jest dostępna w menu kontekstowym edytora (Rysunek 2).You can find the new feature on the Editor context menu (Figure 2). Zobacz sekcję dotyczącą edytora programu Visual Studio, aby uzyskać więcej informacji.See the Visual Studio Editor section for more information.

Show Line Annotations
(Rysunek 2) Pokaż adnotacje z linią(Figure 2) Show Line Annotations

Aby uzyskać więcej informacji o ułatwieniach dostępu, zobacz wpis w blogu Accessibility improvements in Visual Studio 2017 version 15.3 (Usprawnienia ułatwień dostępu w programie Visual Studio 2017 w wersji 15.3).For more accessibility news, visit the Accessibility improvements in Visual Studio 2017 version 15.3 blog post.


Chmury Azure Stack i Azure Government Azure Stack and Azure Government Clouds

Używaj tych samych narzędzi w programie Visual Studio —, np. Cloud Explorer, usługi połączone i ASP.NET Publish —, aby połączyć chmury Azure Stack i chmury dla instytucji rządowych.Use all the same tools in Visual Studio — like Cloud Explorer, Connected Services and ASP.NET Publish — to connect Azure Stack and government clouds. Wybierz istniejące chmury dla instytucji rządowych, np. platformę Azure w Chinach (Rysunek 3), lub wprowadź punkt końcowy odnajdywania dla usługi Azure Stack w organizacji.Pick an existing government cloud, like Azure in China (Figure 3), or enter the discovery endpoint for your organization’s Azure Stack.

Azure Stack
(Rysunek 3) Azure Stack(Figure 3) Azure Stack

Narzędzia funkcji platformy AzureAzure Function Tools

  • Narzędzia do projektowania usługi Azure Functions dla języka C# są dołączane jako część pakietu roboczego „Tworzenie aplikacji na platformie Azure”.Tools for developing C# Azure Functions are included as part of the “Azure development” workload.
  • Funkcje platformy Azure można tworzyć za pomocą wstępnie skompilowanych bibliotek klas języka C# i atrybutów w celu określania wyzwalaczy.You can develop Azure functions by using pre-compiled C# class libraries, and attributes to specify triggers.
  • Kompilowanie, uruchamianie i debugowanie można wykonywać na lokalnej maszynie do programowania.You can build, run, and debug on your local development machine.
  • Możliwe jest bezpośrednie publikowanie z programu Visual Studio na platformę Azure.You can publish directly to Azure from Visual Studio.

Aby uzyskać więcej informacji, zobacz wpis w blogu 2017 Visual Studio Tools for Azure Functions (Narzędzia programu Visual Studio 2017 dla usługi Azure Functions).For more details, see the Visual Studio 2017 Tools for Azure Functions blog post.


.NET Core i ASP.NET Core .NET Core and ASP.NET Core

  • Zestaw .NET Core 2.0 SDK można zainstalować z oddzielnie pobranego pliku w celu umożliwienia tworzenia aplikacji w programie .NET Core 2.0 przy użyciu programu Visual Studio 2017 w wersji 15.3.You can install .NET Core 2.0 SDK via a separate download to enable .NET Core 2.0 development in Visual Studio 2017 version 15.3. Program Visual Studio umożliwia teraz równoczesną obsługę wielu zestawów .NET Core SDK.Visual Studio now provides side-by-side support of multiple .NET Core SDKs. Możesz poeksperymentować z najnowszą dzienną kompilacją zestawu .NET Core SDK w trakcie programowania za pomocą najnowszej wersji publicznej zestawu SDK.You can experiment with the latest daily build of the .NET Core SDK while you develop with the latest public release of the SDK. Aby uzyskać szczegółowe informacje, zobacz bloga platformy .NET.See .NET blog for details.
  • Obsługa języka Visual Basic umożliwia teraz tworzenie aplikacji konsolowych programu .NET Core oraz bibliotek klas programów .NET Core i .NET Standard.With Visual Basic support, you now have the ability to create .NET Core console applications, and .NET Core, and .NET Standard class libraries in Visual Basic.
  • Międzyoperacyjność programów .NET Framework i .NET Standard/Core pozwala odwoływać się do bibliotek programu .NET Core/.NET Standard z projektów programu .NET Framework i na odwrót..NET Framework and .NET Standard/Core interop allows you to refer to .NET Core/.NET Standard libraries from .NET Framework projects and vice versa. Nie ma potrzeby ręcznego dodawania międzyoperacyjnych pakietów NuGet — program Visual Studio wykona tę czynność automatycznie.No need to manually add interop NuGet packages – Visual Studio does this for you automatically.
  • Rozszerzenie obsługi wielu platform docelowych umożliwia kompilowanie projektu dla wielu platform docelowych i użycie selektora TFM w operacji uruchomienia/debugowania do wybrania elementu TFM do uruchomienia.Multiple target framework support enhancement allows you to build your project for multiple target frameworks (TFM), and use the TFM picker in Debug/Run to pick the TFM to run.
  • Dodaliśmy obsługę obrazów systemu Windows Nano Server na potrzeby konteneryzowania aplikacji ASP.NET Core jako obrazów systemu Windows Nano Server.We added Windows Nano Server image support for containerizing ASP.NET Core apps as Windows Nano Server images. System Windows Nano Server można teraz wybrać jako platformę kontenerów.You can now select Windows Nano Server as the container platform. Tę czynność dla projektów ASP.NET Core można wykonać w obszarze Plik -> Nowy projekt.You can do this under File->New Project for ASP.NET Core projects. W przypadku istniejących projektów tę opcję można dodać za pomocą menu kontekstowego projektu.For your existing projects, it can be added using the Project Context Menu.
  • Obsługa lokalnych usług IIS: obecnie programowanie i debugowanie można przeprowadzać w programie Visual Studio przy użyciu usług IIS.Local IIS support: You can now develop and debug using IIS from Visual Studio.
  • ASP.NET Core w programie .NET Framework — w przypadku tworzenia projektu ASP.NET Core przeznaczonego dla pełnej wersji programu .NET Framework (tylko system Windows) używa się listy rozwijanej w oknie dialogowym aplikacji One ASP.NET.ASP.NET Core on .NET Framework – When you create an ASP.NET Core project targeting the full .NET Framework (Windows only), you will use the dropdown on the One ASP.NET dialog.
  • Funkcję Live Unit Testing można włączyć w projektach programu .NET Standard, .NET Core i ASP.NET Core.The Live Unit Testing feature can be enabled for your .NET Standard, .NET Core, and ASP.NET Core projects.

Narzędzia usługi Service FabricService Fabric Tools

Ta wersja oferuje nowy stanowy szablon projektów ASP.NET Core, obsługę zestawów SDK w wersjach 2.5 i 2.6 (i odpowiednie środowiska uruchomieniowe) dla usługi Service Fabric, a także kilka poprawek usterek.This release provides a new stateful ASP.NET Core project template, support for both 2.5 and 2.6 SDK's (and corresponding runtimes) of Service Fabric, as well as several bug fixes.

Narzędzia do ciągłego dostarczaniaContinuous Delivery Tools

Przenieśliśmy te funkcje z rozszerzenia CD4VS (Microsoft Continuous Delivery Tools for Visual Studio) do programu Visual Studio:We moved these features from the CD4VS (Microsoft Continuous Delivery Tools for Visual Studio) extension into Visual Studio:

  • Konfigurowanie ciągłego dostarczania dla rozwiązań zawierających projekty platformy ASP.NET przeznaczone dla usługi Azure App Service.Configure continuous delivery for solutions that contain ASP.NET projects targeting an Azure App Service.
  • Konfigurowanie ciągłego dostarczania dla rozwiązań zawierających projekty programu ASP.NET Core przeznaczone dla usługi Azure App Service.Configure continuous delivery for solutions that contain ASP.NET Core projects targeting an Azure App Service.

Visual Studio IDE Visual Studio IDE

  • Dodaliśmy polecenie menu Klawiatura — ułatwienia dostępu w menu „Pomoc”.We added the Keyboard Accessibility menu command under the "Help" menu. Udostępnia ono skrót do dokumentacji online, która zawiera porady i wskazówki związane z ułatwieniami dostępu.This provides you with a shortcut to online documention about Accessibility Tips and Tricks.
  • System diagnostyczny informuje użytkowników za pomocą paska informacji o rozszerzeniach, które mogły brać udział w nieoczekiwanym przerwaniu pracy programu Visual Studio (Rysunek 4).The diagnostic system informs you via the InfoBar about extensions that might have been involved in an unexpected termination of Visual Studio (Figure 4). Pasek informacji zawiera informacje o przerwaniu pracy oraz pytanie, czy chcesz wyłączyć podejrzane rozszerzenie.The InfoBar provides this information about the termination and asks if you would like to disable the suspected extension.
InfoBar notification
(Rysunek 4) Powiadomienie na pasku informacji(Figure 4) InfoBar notification
  • W scenariuszach obejmujących otwieranie folderów można wybrać żądany debuger za pośrednictwem dedykowanego interfejsu użytkownika.In open folder scenarios, you can select your desired debugger via dedicated UI.
  • Przestaliśmy udostępniać niektóre ustawienia, takie jak układ okna narzędzi, między różnymi równoległymi instalacjami programu Visual Studio 2017.We’ve stopped sharing certain settings, like tool window layout, between different side-by-side installations of Visual Studio 2017. Aby uzyskać więcej informacji, zobacz Synchronizowanie ustawień w programie Visual Studio.For more information, see the Synchronize your settings in Visual Studio documentation.
  • Usunęliśmy usterkę typu „ukryte okno”, z powodu której program Visual Studio zawieszał się przed wyświetleniem głównego okna.We fixed the "hidden window" bug that made Visual Studio appear to hang before its main window appeared.
  • Zwiększyliśmy docelowy obszar obsługujący kliknięcia, aby można było łatwiej odrzucać w nim porady związane z powiadomieniami.We increased the clickable target area to make it easier to dismiss notification tips.

Środowisko IDE programu .NET.NET IDE

  • Dodaliśmy kilka nowych refaktoryzacji i szybkich poprawek, takich jak „Rozwiązywanie konfliktów scalania”, „Dodawanie sprawdzania wartości null”, „Dodawanie parametru” i wiele innych.We added several new refactorings and quick fixes, like "Resolve merge conflicts", "Add null checks", "Add parameter", and many more. Zajrzyj na naszą stronę Refactoring, Code Generation and Quick Actions in Visual Studio (Refaktoryzacja, generowanie kodu i szybkie akcje w programie Visual Studio), aby uzyskać pełną listę.Take a look at our Refactoring, Code Generation and Quick Actions in Visual Studio page to see the full list.
  • Sugerujemy nazwy zmiennych w funkcji IntelliSense, aby pomóc w szybkim wyszukiwaniu zmiennych, np. Person person.We suggest variable names in IntelliSense to help you name your variables quickly, for example, Person person.
  • Opcja Edytuj i kontynuuj obsługuje funkcje języka C# 7.0 (z wyjątkiem funkcji lokalnych).Edit and Continue supports C# 7.0 features (except local functions).
  • Dodaliśmy obsługę symboli wieloznacznych w plikach poza folderem projektu dla platformy .NET Core.We added support for file globbing outside of your project folder for .NET Core.

Logowanie i tożsamośćSign In and Identity

Naprawiliśmy kontrolkę selektora konta, tak aby funkcja „Wprowadź ponownie poświadczenia” działała bardziej niezawodnie.We fixed the account picker control so "Re-enter credentials" works more reliably. W niektórych przypadkach podczas ponownego wprowadzania poświadczeń selektor konta czyścił konta.In some cases, the account picker would clear accounts upon re-entering credentials.

Strona początkowaStart Page

Zwiększyliśmy obszar umożliwiający klikanie dla „przypięć” w menu ostatnio używanych elementów strony startowej.We increased the clickable target area on Start Page MRU “pins”. Teraz łatwiej jest przypinać ważne elementy u góry menu ostatnio używanych elementów.It's easier to pin items you care about to the top of the MRU.

Uproszczone ładowanie rozwiązańLightweight Solution Load

  • Zwiększyliśmy stabilność i szybkość kompilacji.We increased build speed and stability.
  • Zmniejszyliśmy liczbę ładowanych projektów.We reduced the number of loaded projects.
  • Dodaliśmy nową opcję (Rysunek 5), która umożliwia wybranie przez program Visual Studio najlepszego sposobu działania dla rozwiązania.We added a new option (Figure 5) that allows Visual Studio to decide what’s best for your solution.
Lightweight Solution Load Options
(Rysunek 5) Opcje uproszczonego ładowania rozwiązań(Figure 5) Lightweight Solution Load Options
  • Dodaliśmy rozwiązania wyników wyszukiwania plików do funkcji wyszukiwania dla projektów odroczonych, a nie tylko dla projektów załadowanych.We added file search results solutions to search for deferred projects, instead of just loaded projects.
    • W przypadku ładowania projektu wszystkie istniejące wyszukiwania zostaną odświeżone w celu dodania wyników dotyczących postępu.When you load a project, all existing searches are refreshed to add progression results.
    • Ta funkcja ma następujące ograniczenia:There are limits to this:
      • Wyszukiwanie nie odbywa się we wnętrzu pliku i nie zawiera wyników progresywnych: klas, metod itd.Search does not extend within the file and does not include progressive results, i.e. classes, methods, etc.
      • Pliki należące do projektu są wyświetlane w postaci listy niezhierarchizowanej.Files that belong to a project are shown as a flat list. Jeśli pliki należą do folderu, zamiast tylko nazwy pliku jest wyświetlana ścieżka względna.When files belong to a folder, the relative path is shown instead of just the file name.
      • W widoku wyszukiwania nie ma menu kontekstowych powiązanych z elementami plików.There are no context menus for the file items in the search view.
  • Funkcje Przejdź do wszystkiego i Przejdź do plików pokazują zawartość z elementów zewnętrznych w obszarze roboczym.GoTo All and GoTo Files show content from external items in the workspace.
  • Poprawiliśmy działanie kompilacji wsadowej w projektach korzystających z uproszczonego ładowania rozwiązań.We improved Batch build in projects that use Lightweight Solution Load.

KonfiguracjaSetup

  • Instalator programu Visual Studio obsługuje teraz skalowanie w wysokiej rozdzielczości DPI na poziomach mniejszych niż 150%.Visual Studio Installer now supports high-DPI scaling at levels less than 150%.
  • Plik wykonywalny vswhere.exe został zaktualizowany w celu domyślnego wykluczania wystąpień w wersji zapoznawczej i będzie je uwzględniał, jeśli w wierszu polecenia zostanie użyta opcja --prerelease.The vswhere.exe executable file has been updated to exclude preview instances by default, and includes them when --prerelease is included on the command line.
  • Interfejs wiersza polecenia może obsługiwać elementy --verify, --fix i --clean.CLI is able to handle --verify, --fix and --clean.
    • Element --verify sprawdza układ i informuje Cię o brakujących i nieprawidłowych ładunkach.--verify verifies layout and informs you of missing and invalid payloads.
    • Opcja --fix służy do sprawdzania układu i ponownego pobierania pakietów, których brakuje lub które są nieprawidłowe.--fix verifies the layout and re-downloads packages that are either missing or invalid.
    • Opcja --clean służy do usuwania przestarzałych pakietów i umożliwia przycięcie układu do określonego zakresu wersji.--clean deletes obsolete packages and allows you to trim layout to a specific version range.
  • Do strony ze szczegółami instalacji dodaliśmy szczegóły, które pokazują wpływ na rozmiar netto dla poszczególnych dysków.We added details that show the net size impact per drive to the installation details page. (Rysunek 6).(Figure 6).
Drive Sizes listed in the Installer
(Rysunek 6) Rozmiary dysków pokazane w Instalatorze(Figure 6) Drive Sizes listed in the Installer

Edytor programu Visual Studio Visual Studio Editor

  • W przypadku dodania dużej liczby błędów ręczne przewijanie i wybieranie nie sprawia już problemów.Manual scroll and selection are no longer difficult when a large numbers of errors are being added.
  • Dodaliśmy nowy wariant motywu „Niebieski” przeznaczony w szczególności dla użytkowników, którzy potrzebują większego kontrastu w edytorze programu Visual Studio.We added a new variant of the "Blue" theme, which caters specifically to users who need more contrast in the Visual Studio Editor. Ten motyw oferuje większy kontrast niż zwykły motyw „Niebieski” i jest przeznaczony dla użytkowników, którzy nie chcą lub nie potrzebują pełnego trybu wysokiego kontrastu.This theme offers you more contrast than the regular "Blue" theme if you don't want or need the full High Contrast mode. Motyw możesz wypróbować, przechodząc kolejno do pozycji Narzędzia -> Opcje -> Środowisko -> Ogólne.You can try it out via Tools -> Options -> Environment -> General.
  • Jeśli korzystasz z czytnika zawartości ekranu, możesz teraz przechodzić między zakończeniami za pomocą nowego polecenia Pokaż adnotacje z linią.If you use a screen-reader, you can now navigate between adornments by using the new "Show Line Annotations" command.
    • Aby aktywować tę funkcję, wybierz pozycję „Pokaż adnotacje z linią” (Ctrl+K, Ctrl+M) w menu kontekstowym edytora.To activate, select "Show Line Annotations" (Ctrl+K, Ctrl+M) on the Editor context menu. Spowoduje to wyświetlenie w edytorze okienka wyskakującego z opisem zakończenia w danym wierszu.A popup will appear in the editor describing the adornments on that line.
    • Do poruszania się po wielu adnotacjach w wierszu służy kombinacja klawiszy Ctrl+K, Ctrl+ Right/Left Arrow.Navigate through multiple annotations on the line using Ctrl+K, Ctrl+ Right/Left Arrow.
    • Można również szybko odszukać kontekst w kodzie za pomocą polecenia „Pokaż strukturę” (Ctrl+K, Ctrl+G).You can also easily find context in code through the "Show Structure" command Ctrl+K, Ctrl+G. Powoduje ono wyświetlenie strukturalnego kontekstu wiersza kodu w okienku wyskakującym w miejscu karetki, który można odczytać przy użyciu czytnika zawartości ekranu.This shows the structural context of the line of code in the popup where the caret is located, and can be read by the screen reader.

Debugowanie i diagnostyka Debugging and Diagnostics

Obsługa debugera dla serwerów symboli usługi Visual Studio Team ServicesDebugger Support for Visual Studio Team Services Symbol Servers

  • Względem symboli można wykonywać zapytania i pobierać je z serwerów symboli usługi Visual Studio Team Services (Rysunek 7).You can query and download symbols (Figure 7) from Visual Studio Team Services Symbol Servers. Ścieżki usług Visual Studio Team Services można wybrać i dodać do środowiska programu Visual Studio przy użyciu strony Narzędzia -> Opcje -> Debuger -> Symbole.You can select and add Visual Studio Team Services symbol paths to your Visual Studio environment using the Tools->Options->Debugger->Symbols page. Aby skonfigurować serwer symboli usługi Visual Studio Team Services, zobacz stronę Korzystanie z serwera symboli w usłudze Team Services.To set up a Visual Studio Team Services Symbol Server, see the Use Symbol Server in Team Services page.
Add VSTS Symbol Server
(Rysunek 7) Dodawanie serwera symboli usługi VSTS(Figure 7) Add VSTS Symbol Server
  • Interfejs API SetThreadDescription jest obsługiwany w przypadku debugowania za pomocą opcji Rozpocznij debugowanie (F5) lub Dołącz do procesu (Ctrl+Alt+P).The SetThreadDescription API is supported while debugging when you use Start Debugging (F5) or Attach to Process (Ctrl+Alt+P). Nazwy wątków ustawiane za pośrednictwem tego interfejsu API są teraz wyświetlane w oknie Wątki i na liście rozwijanej Wątek na pasku narzędzi Lokalizacja debugowania.The thread names that are set via this API now show up in the Threads window and in the Thread dropdown in the Debug Location toolbar. Nie jest to obecnie obsługiwane w przypadku debugowania zrzutów.This is not currently supported while dump debugging.
  • W oknie danych wyjściowych są obecnie widoczne dane wyjściowe konsoli aplikacji uruchomionej w kontenerze systemu Windows podczas debugowania.The Output Window now shows you the console output of an application running inside a Windows Container while debugging.
  • Dodaliśmy nową obsługę debugowania aplikacji .NET Core uruchamianych wewnątrz kontenerów systemu Windows w oparciu o system Windows Nano Server.We added new support for debugging .NET Core apps you run inside Windows Containers based on Windows Nano Server.

Wskazanie i kliknięcie w celu ustawienia następnej instrukcjiPoint and Click to Set Next Statement

Po zatrzymaniu w punkcie przerwania podczas debugowania można przytrzymać klawisz Ctrl.You can hold down the Ctrl key while stopped at a breakpoint when debugging. Ikona Run to Click (Uruchom wykonywanie do tego miejsca), która znajduje się obok wiersza kodu, została zmieniona w funkcję „Ustaw następną instrukcję” (Rysunek 8).The Run to Click (Run execution to here) icon next to your line of code changes to “Set Next Statement” functionality (Figure 8). Kliknij ikonę, aby przenieść żółty wskaźnik instrukcji do danego wiersza i ustawić następną instrukcję do wykonania w debugerze.Click the icon to move the yellow instruction pointer to that line and set the next statement for the debugger to execute.

Click to set Next Statement
(Rysunek 8) Kliknięcie w celu ustawienia następnej instrukcji(Figure 8) Click to set Next Statement

Link źródłowy jest teraz obsługiwany w przypadku formatu plików PDB systemu Windows (oprócz przenośnych plików PDB).Source Link is now supported for Windows PDB file format (in addition to Portable PDBs). Kompilatory, które go obsługują, mogą umieścić niezbędne informacje w pliku PDB systemu Windows, a debuger może pobrać pliki źródłowe na podstawie tych informacji.Compilers that support it can put the necessary information in the Windows PDB file format and the debugger can retrieve source files based on that information.

Debugowanie funkcji Otwórz folderOpen Folder Debugging

Uprościliśmy środowisko debugowania używane w przypadku stosowania naszych nowych szablonów dla funkcji Otwórz folder.We have made your debugging experience easier when you use our new templates for Open Folder. Jeśli debuger podstawowy został zainstalowany, nasze nowe szablony umożliwiają wybór typu debugera do użycia.If you have the core debugger installed, our new templates allow you to choose the type of debugger you want to use. W Eksploratorze rozwiązań przy użyciu opcji „Ustawienia debugowania i uruchamiania” w oknie dialogowym „Wybór debugera” można wybrać wartość Zarządzany, Natywny lub Mieszany.Managed, Native, or Mixed can be chosen from the "Select a Debugger" dialog in the "Debug and Launch Settings" menu option in Solution Explorer. Jeśli zainstalowano środowisko MDD języka C++ (Android C++, debugowanie w systemie Linux itd.), będą teraz widoczne opcje obsługi rozwiązań MinGW i Cygwin przy użyciu debugera GDB na potrzeby dołączania i uruchamiania w ramach tej samej opcji menu.If you have a C++ MDD experience installed (Android C++, Linux Debugging, etc.), you now see options for MinGW and Cygwin support by using GDB for attach and launch within the same menu option.

Odświeżanie wszystkich zagnieżdżonych wartości w oknach zmiennychRefresh All Nested Values in Variable Windows

Po kliknięciu przycisku odświeżania dla węzła nadrzędnego zmiennej lub wyrażenia w oknach wyrażeń kontrolnych, zmiennych automatycznych i zmiennych lokalnych wszystkie widoczne zmienne i wyrażenia będące elementami podrzędnymi tego węzła zostaną również odświeżone i ponownie obliczone.When you click the refresh button for the parent node of a variable or expression in the Watch, Autos, and Locals windows, all visible variables and expressions that are children of that node also refresh and re-evaluate. Nie trzeba już klikać przycisku odświeżania dla każdego elementu podrzędnego.You no longer need to click on the refresh button for each of the children.

Obsługa funkcji Live Unit Testing dla programu .NET CoreLive Unit Testing Support for .NET Core

Funkcję Live Unit Testing możesz włączyć w projektach .NET Standard, .NET Core i ASP.NET Core.You can enable the Live Unit Testing feature for .NET Standard, .NET Core, and ASP.NET Core projects.


Xamarin Xamarin

  • Strony właściwości i operacje przeprojektowania manifestu aplikacji — kontynuowaliśmy pracę nad uproszczeniem stron właściwości dla projektów systemów iOS i Android.Property Pages & App Manifest Redesigns - We have continued our work on making property pages for iOS and Android projects easier to use.
  • Nowy edytor uprawnień — dodaliśmy edytora autonomicznego na potrzeby edytowania uprawnień do aplikacji.New Entitlements Editor - We added a standalone editor for editing app entitlements.

Pełne omówienie zmian ze szczegółami można znaleźć w witrynie developer.xamarin.com.For a complete overview of changes, be sure to check out developer.xamarin.com for more details.


Funkcja Otwórz folder i narzędzia CMake Open Folder and CMake Tools

  • Zwiększyliśmy stabilność przełączania między folderem i rozwiązaniem.We improved stability for toggling between folder and solution.
  • Rozszerzenia otwierania folderów mogą dodawać ikonę kontroli źródła do folderów.Open folder extenders can add a source control icon to your folders. Dzięki temu można szybko sprawdzić stan kontroli źródła plików w Eksploratorze rozwiązań, który jest aktualnie zaimplementowany w repozytorium SVN.This allows you to quickly see the source control state of your files in Solution Explorer, which is currently implemented by SVN.
  • Środowisko CMake w programie Visual Studio zostało uaktualnione do wersji CMake 3.8.The CMake experience in Visual Studio is upgraded to CMake 3.8.
  • Ulepszyliśmy obsługę edycji, kompilowania i debugowania w funkcji „Otwórz folder” dla projektów języka C++ korzystających z rozwiązań MinGW lub Cygwin.We improved editing, building, and debugging support in "Open Folder" for C++ projects that use MinGW or Cygwin.
  • Dodaliśmy obsługę definiowania zmiennych środowiskowych — globalnych i specyficznych dla konfiguracji — w plikach „CppProperties.json” i „CMakeSettings.json”.We added support to define global and configuration-specific environment variables in "CppProperties.json" and "CMakeSettings.json". Te zmienne środowiskowe mogą być używane przez konfiguracje debugowania definiowane w pliku „launch.vs.json” i zadania w pliku „tasks.vs.json”.These environment variables can be consumed by debug configurations defined in "launch.vs.json" and tasks in "tasks.vs.json".
  • Rozbudowaliśmy narzędzia CMake dla programu Visual Studio tak, aby zapewniały obsługę integracji CTest.We enhanced CMake tools for Visual Studio to provide you with support for CTest integration.
  • Teraz możesz używać generatora Ninja w narzędziu CMake, w tym korzystać z bezproblemowej współpracy z platformami 64-bitowymi oraz kompilowania, debugowania i edytowania za pomocą funkcji IntelliSense.You can now use the CMake's Ninja generator to easily target 64-bit platforms, build, debug, and edit with IntelliSense.

Usługi języka C++ C++ Language Services

Nazwa opcji „Włącz szybsze ładowanie projektu” w obszarze opcji eksperymentalnych została zmieniona na „Włącz buforowanie projektu”, a sama opcja została przeniesiona do obszaru ustawienia projektu VC++.The “Enable Faster Project Load” option under Experimental options has been renamed “Enable Project Caching” and moved under VC++ Project Settings. Stara wartość właściwości nie jest używana do wypełniania nowej opcji.The old property value is not propagated to the new option.

Aparat IntelliSenseIntelliSense Engine

  • Funkcja IntelliSense dla języka C++ obsługuje nowe funkcje języka C++17 zgodne z wersją kompilatora partii.C++ IntelliSense supports new C++17 features matching the batch compiler release.
  • Dodano opcję menu kontekstowego w edytorze języka C++ służącą do ponownego skanowania pliku, która może być używana, jeśli funkcja IntelliSense nie działa prawidłowo.Added context menu option in C++ editor to Rescan File, which can be used if IntelliSense is not working correctly.
  • Zmniejszono użycie procesora podczas uruchamiania funkcji Znajdź wszystkie odwołania lub Wywołaj hierarchię dla kodu języka C++.Reduced CPU usage when running Find All References or Call Hierarchy for C++ code.
  • Ulepszyliśmy całe środowisko aparatu funkcji IntelliSense dla języka C++.We've improved the overall C++ IntelliSense engine experience.

Kreator projektu i koduProject and Code Wizard

  • Ponownie napisaliśmy kilka kreatorów projektów i kodu w stylu okna dialogowego podpisu.We have rewritten several project and code wizards in the signature dialogue style.
  • Opcja Dodaj klasę powoduje bezpośrednie uruchomienie kreatora dodawania klasy.Add Class launches the Add Class wizard directly. Wszystkie inne elementy, które wcześniej znajdowały się w tym miejscu, są dostępne w obszarze „Dodaj > Nowy element”.All of the other items that were previously here are available under "Add > New Item".
  • Projekty Win32 należą do kategorii aplikacji klasycznych systemu Windows w oknie dialogowym Nowy projekt.Win32 projects are under the Windows Desktop category in the New Project dialog.
  • Szablony konsoli systemu Windows i aplikacji klasycznych umożliwiają teraz tworzenie projektów bez wyświetlania kreatora.The Windows Console and Desktop Application templates now create the projects without displaying a wizard. W tej samej kategorii jest dostępny nowy Kreator aplikacji klasycznej systemu Windows, który oferuje te same opcje co wcześniej.There's a new Windows Desktop Wizard under the same category that displays the same options as before.

Biblioteki i zestaw narzędzi języka Visual C++Visual C++ Toolset and Libraries

  • W wierszu polecenia dla deweloperów programu Visual Studio (i wierszu polecenia programu Visual C++) dodano obsługę inicjowania środowiska wiersza polecenia przeznaczonego dla zestawu narzędzi Visual C++ 2015 (wersja 140) za pomocą argumentu -vcvars_ver=14.0.The Developer Command Prompt for Visual Studio (and the Visual C++ Command Prompt) have added support for initializing a command-prompt environment targeting the Visual C++ 2015 Toolset (v140) via the -vcvars_ver=14.0 argument.
  • Nazwy katalogów plików pakietów redystrybucyjnych Visual C++ zmieniono na Microsoft.VC141.*, aby były zgodne z obsługiwanymi wersjami zestawu narzędzi (14.1x).Visual C++ Redist file directories have been renamed to Microsoft.VC141.* to match versioning with the toolset (14.1x). W programie Visual Studio 2017 RTM te katalogi miały nieprawidłową nazwę Microsoft.VC150.*.In Visual Studio 2017 RTM, these directories were incorrectly named Microsoft.VC150.*.
  • Katalogi i wersja pliku Visual C++ (Visual Studio 2017 15.3):Visual C++ File Version and Directories (Visual Studio 2017 15.3) :
    • Wersja pliku zestawu narzędzi VC++: 14.11.25506.0 lub 19.11.25506.0VC++ Toolset File Version : 14.11.25506.0 or 19.11.25506.0
    • Katalog narzędzi VC++: VC\Tools\MSVC\14.11.25503 (lokalizacja katalogu była zablokowana w wersji zapoznawczej)VC++ Tools Directory : VC\Tools\MSVC\14.11.25503 (directory location was locked in a Preview release)
    • Katalog pakietu redystrybucyjnego VC++ [a]: VC\Redist\MSVC\14.11.25325 (wszystkie środowiska uruchomieniowe z wyjątkiem MFC i OneCore)VC++ Redist Directory [a] : VC\Redist\MSVC\14.11.25325 (All runtimes except for MFC and OneCore)
    • Katalog pakietu redystrybucyjnego VC++ [b]: VC\Redist\MSVC\14.11.25415 (wszystkie środowiska uruchomieniowe z wyjątkiem MFC i OneCore)VC++ Redist Directory [b] : VC\Redist\MSVC\14.11.25415 (MFC and OneCore runtimes)

Obsługa języka C# 7.1C# 7.1 Language Support


JavaScript i TypeScriptJavaScript & TypeScript

  • Zmieniliśmy tryb uruchamiania serwera tsserver z węzła 64-bitowego na 32-bitowy i zmniejszyliśmy o połowę użycie pamięci przez usługę języka.We switched from 64-bit node to 32 bit-node when launching tsserver and cut language service memory consumption in half.
  • Funkcja IntelliSense na potrzeby ścieżki pliku w instrukcjach importowania działa teraz szybciej.File path IntelliSense in import statements is now faster.
  • Wersje języka TypeScript można instalować niezależnie od aktualizacji programu Visual Studio i wybierać je na podstawie projektu.TypeScript versions can be installed independent of Visual Studio updates and selected on a per project basis. Aby uzyskać więcej informacji, zobacz dokumentację Aktualizowanie języka TypeScript w programie Visual Studio 2017.For more information see the Updating TypeScript in Visual Studio 2017 documentation.

Node.jsNode.js

  • Dodaliśmy obsługę debugowania w środowisku Node 8.We added support for Node 8 debugging.
  • Wprowadziliśmy ulepszenia wydajności modułu uruchamiającego testy jednostkowe.We made unit test runner performance enhancements.
  • Uprościliśmy interfejs użytkownika instalatora pakietów npm.We simplified the npm package installer UI.

NuGet NuGet

  • Dodaliśmy obsługę następujących krótkich nazw platform — netcoreapp2.0, netstandard2.0 i Tizen.We have added support for the following TFMs - netcoreapp2.0, netstandard2.0, and Tizen.
  • Zintegrowaliśmy ostrzeżenia i błędy NuGet z rozwiązaniem MSBuild, dzięki czemu można używać istniejących właściwości MSBuild do pomijania niektórych ostrzeżeń lub podnoszenia ich do poziomu błędu.We have integrated NuGet warnings and errors with MSBuild so you can use existing MSBuild properties to suppress certain warnings or elevate them to errors.
  • Dodaliśmy obsługę funkcji Semantic Versioning 2.0.0.We have added support for Semantic Versioning 2.0.0.

Więcej informacji o tych usprawnieniach i kompletną listę poprawek znajdziesz w informacjach o wersji NuGet.You can find more details about these improvements and the complete list of bug fixes in the NuGet release notes.


.NET Framework 4.7 .NET Framework 4.7

Program Visual Studio 2017 w wersji 15.3 oferuje teraz narzędzia deweloperskie programu .NET Framework 4.7 na wszystkich platformach z dołączonym środowiskiem uruchomieniowym w wersji 4.7.Visual Studio 2017 version 15.3 now offers the .NET Framework 4.7 development tools to all supported platforms with the 4.7 runtime included. Program .NET Framework 4.7 oferuje kilka nowych funkcji i ulepszeń, jak również liczne poprawki niezawodności, stabilności, bezpieczeństwa i wydajności.The .NET Framework 4.7 offers several new features and improvements as well as numerous reliability, stability, security, and performance fixes.

Więcej informacji na temat platformy .NET 4.7 można znaleźć w następujących artykułach:You can find more details about .NET 4.7 in these articles:

Narzędzia programistyczne dla kontenerówContainer Development Tools

Program Visual Studio 2017 w wersji 15.3 obsługuje teraz zakres działań programistycznych dla kontenerów — od istniejących aplikacji .NET Framework z kontenerami systemu Windows po program .NET Core z obsługą systemów Windows i Linux.Visual Studio 2017 version 15.3 now supports the breadth of container development across existing .NET Framework apps with Windows Containers, to .NET Core with Windows, and Linux Support. Ostatnio dodane elementy to obsługa aplikacji .NET Core w kontenerach z systemem Windows Nano Server, a także ulepszenia debugowania dla aplikacji programu .NET Framework w kontenerach.Recent additions include support for your .NET Core applications in containers running Windows Nano Server, as well as debugging improvements for .NET Framework applications in containers.


Dodaliśmy klastry powiązanych zdarzeń do wyników wyszukiwania zapytań w narzędziu wyszukiwania usługi Application Insights.We added clusters of related events to the search query results in the Application Insights Search tool. Klastry te mogą pomóc w odnajdowaniu nieoczekiwanych wzorców w zachowaniu aplikacji, takich jak duża liczba wyjątków pochodzących z jednego kraju, wersji lub użytkownika.These clusters can help you discover surprising patterns in your application's behavior, like a large volume of exceptions coming from a single country, version, or user.


SQL Server Data Tools (SSDT) SQL Server Data Tools (SSDT)

Program Visual Studio 2017 w wersji 15.3 jest teraz dostarczany z narzędziami SQL Server Data Tools (SSDT), które w pełni obsługują program SQL Server 2017 uruchomiony w systemie Windows i Linux oraz klastrze Docker w systemie macOS.Visual Studio 2017 version 15.3 now ships with SQL Server Data Tools that fully supports SQL Server 2017 running on Windows, Linux and Docker in macOS. Narzędzia SSDT obsługują teraz wszystkie wersje usług SQL Server, SQLDB i DW na platformie Azure.SSDT now supports all versions of SQL Server, SQLDB and DW on Azure.

Poprawki dla najczęstszych problemów zgłaszanych przez klientów:Fixes for top customer reported issues:

  • Dodaliśmy opcję Ignoruj kolejność kolumn, aby zapobiegać niepotrzebnemu przenoszeniu danych w tabeli ze względu na zmianę kolejności kolumn.We added Ignore Column Order option to prevent unnecessary table data movement due to a column order change.
  • Naprawiliśmy błąd kompilacji ESENT i zwiększyliśmy stabilność oraz wydajność kompilacji projektu bazy danych w programie Visual Studio 2017.We fixed ESENT build error and increased the database project build stability and performance in Visual Studio 2017.
  • Rozwiązaliśmy wiele innych problemów zgłaszanych przez klientów.We addressed many more customer reported issues. Zobacz dziennik zmian narzędzi SSDT, aby uzyskać szczegółowe informacje o rozwiązanych problemach.See SSDT changelog for more details of fixed issues.

Narzędzia do obsługi danych Redgate Redgate Data Tools

Wszystkie narzędzia do obsługi danych RedgateAll Redgate Data Tools

Usunęliśmy okno dialogowe z wprowadzeniem, które było wyświetlane podczas pierwszego użycia narzędzi do obsługi danych Redgate.We removed the introduction dialog that appeared upon first use of Redgate Data Tools.

Dodatek Redgate SQL PromptRedgate SQL Prompt

Wprowadziliśmy ulepszenia formatowania.We made formatting improvements.

Redgate ReadyRollRedgate ReadyRoll

  • Okno otwierania projektu ReadyRoll zostało przeprojektowane.The ReadyRoll open project window has been redesigned.
  • Poprawiliśmy czas ładowania właściwości projektu.We improved the loading time of Project Properties.
  • Zastąpiliśmy widżet stanu skryptu paskiem akcji.We replaced the script status widget with an action bar.
  • Rozwiązaliśmy problemy z łącznością z platformą Azure.We fixed the connectivity problems with Azure.
  • Poprawiliśmy obsługę składni dla programu SQL Server 2016.We improved the syntax support for SQL Server 2016.

PythonPython

  • Ulepszyliśmy ułatwienia dostępu w ramach czytników ekranu, nawigacji za pomocą klawiatury i funkcji wysokiego kontrastu.We improved accessibility in screen readers, keyboard navigation and high contrast.
  • Poprawiliśmy lokalizację oprogramowania, dzięki czemu użytkownikom korzystającym z oprogramowania w wersji językowej innej niż angielska będzie wyświetlane mniej tekstu w języku angielskim w interfejsie użytkownika.We improved localization so that non-English users will see less English text in the UI.

Narzędzia języka RR Tools

  • Poprawiono środowisko użytkownika funkcji IntelliSense.The IntelliSense experience is improved.
  • Zapewniono lepszą łączność platformy Azure z maszynami, które blokują polecenie ping.You have better Azure connectivity to your machines that are blocking ping.
  • W przypadku wykonywania zdalnej instalacji usług nie musisz już posiadać uprawnień do zarządzania usługami.When you perform a remote services install, you are no longer required to have service management rights.
  • Ogólnie poprawiliśmy ułatwienia dostępu i lokalizację.We improved overall accessibility, and localization.

Dostawca programu Microsoft Graph w usługach połączonychMicrosoft Graph Provider in Connected Services

Umożliwiliśmy obsługę interfejsów API programu Microsoft Graph w usługach połączonych.We have enabled support for Microsoft Graph APIs in Connected Services. Ułatwiliśmy instalację.We've made Installation easier. Wystarczy otworzyć okno dialogowe połączonych usług, aby uzyskać dostęp i przeprowadzić instalację (Rysunek 9).Just open the Connected Services dialog to access and install (Figure 9).

Install Microsoft Graph provider
(Rysunek 9) Instalacja dostawcy programu Microsoft Graph(Figure 9) Install Microsoft Graph provider

Znane problemyKnown Issues

Visual Studio 2017 Known Issues Zobacz wszystkie znane problemy i ich rozwiązania dostępne w programie Visual Studio 2017 w wersji 15.3. See all existing known issues and available workarounds in Visual Studio 2017 version 15.3.

Bardzo uważnie wysłuchujemy opinii użytkowników.We are fully committed to listening to your feedback. Odwiedź witrynę Społeczność deweloperów, aby wyszukać najnowsze problemy, zarejestrować nowe problemy i ocenić te, które już istnieją.Visit the Developer Community site to find the latest issues, log new issues, and upvote existing issues.


Historia informacji o wersji programu Visual Studio 2017Visual Studio 2017 Release Notes History

Zobacz stronę Historia informacji o wersji programu Visual Studio 2017.Please see the Visual Studio 2017 Release Notes History page.


Góra strony
Top of Page