Visual Studio Icon Informacje o wersji dla programu Visual Studio 2019 w wersji 16.5



Developer Community | Wymagania systemowe | Zgodność | Kod dystrybucyjny | Postanowienia licencyjne | Blogi | Znane problemy w najnowszej wersji | Whats New in Visual Studio Docs


Kliknij przycisk, aby pobrać najnowszą wersję programu Visual Studio 2019. Aby uzyskać instrukcje dotyczące instalowania i aktualizowania programu Visual Studio 2019, zobacz informacje o aktualizowaniu programu Visual Studio 2019 do najnowszej wersji. Ponadto zobacz instrukcje na temat sposobu instalowania w trybie offline.

Community Download Button Professional Download Button Enterprise Download Button


Co nowego w programie Visual Studio 2019 w wersji 16.5

Wydania programu Visual Studio 2019 w wersji 16.5

Blog dotyczący programu Visual Studio 2019

Blog dotyczący programu Visual Studio 2019 to oficjalne źródło informacji o produkcie pochodzących od zespołu inżynierów ds. programu Visual Studio. Szczegółowe informacje na temat wersji programu Visual Studio 2019 można znaleźć w następujących wpisach:

Dołącz do dyskusji na temat informacji o wersji


Release Notes Icon Visual Studio 2019 w wersji 16.5.5 New release icon

wydany 12 maja 2020 r.

Poprawki wprowadzone w tym wydaniu programu Visual Studio 2019 w wersji 16.5

Zalecenia dotyczące zabezpieczeń

CVE-2020-1108 Odmowa usługi na platformie .NET Core

Zdalny nieuwierzytelniony atakujący może wykorzystać tę lukę, wysyłając do aplikacji .NET Core specjalnie przygotowane żądania. Aktualizacja zabezpieczeń usuwa tę lukę w zabezpieczeniach, poprawiając sposób obsługi żądań internetowych w aplikacji internetowej .NET Core.

CVE-2020-1161 Odmowa usługi na platformie .NET Core

Zdalny nieuwierzytelniony atakujący może wykorzystać tę lukę, wysyłając do aplikacji ASP.NET Core specjalnie przygotowane żądania. Aktualizacja zabezpieczeń usuwa tę lukę w zabezpieczeniach, poprawiając sposób obsługi żądań internetowych w aplikacji internetowej ASP.NET Core.


Release Notes Icon Program Visual Studio 2019 w wersji 16.5.4

wydany 14 kwietnia 2020 r.

Poprawki wprowadzone w tym wydaniu programu Visual Studio 2019 w wersji 16.5

Zalecenia dotyczące zabezpieczeń

CVE-2020-0899 Luka w zabezpieczeniach podniesienia uprawnień w programie Microsoft Visual Studio

W sytuacjach, gdy usługa aktualizatora programu Microsoft Visual Studio niepoprawnie obsługuje uprawnienia do pliku, występuje luka w zabezpieczeniach podniesienia uprawnień. Osoba atakująca, która pomyślnie wykorzysta tę lukę w zabezpieczeniach, może zastąpić dowolną zawartość pliku w kontekście zabezpieczeń systemu lokalnego.

CVE-2020-0900 Luka w zabezpieczeniach podniesienia uprawnień w usłudze instalatora rozszerzeń programu Visual Studio

Istnieje luka w zabezpieczeniach podniesienia uprawnień, gdy usługa instalatora rozszerzeń programu Visual Studio nieprawidłowo obsługuje operacje na plikach. Atakujący, któremu udałoby się wykorzystać tę lukę w zabezpieczeniach, mógłby usuwać pliki w dowolnych lokalizacjach z podwyższonym poziomem uprawnień.

CVE-2020-5260 Luka w zabezpieczeniach dotycząca przecieku poświadczeń w usłudze Git dla programu Visual Studio z powodu niewystarczającej weryfikacji adresów URL

Istnieje luka w zabezpieczeniach dotycząca przecieku poświadczeń, gdy specjalnie spreparowane adresy URL są analizowane i wysyłane do pomocników poświadczeń. Może to prowadzić do wysyłania poświadczeń do niewłaściwego hosta.


Release Notes Icon Visual Studio 2019 w wersji 16.5.3

wydany 7 kwietnia 2020 r.

Poprawki wprowadzone w tym wydaniu programu Visual Studio 2019 w wersji 16.5


Release Notes Icon Visual Studio 2019 w wersji 16.5.2 New release icon

wydany 31 marca 2020 r.

Poprawki wprowadzone w tym wydaniu programu Visual Studio 2019 w wersji 16.5


Release Notes Icon Visual Studio 2019 w wersji 16.5.1 New release icon

wydany 24 marca 2020 r.

Poprawki wprowadzone w tym wydaniu programu Visual Studio 2019 w wersji 16.5


Release Notes Icon Program Visual Studio 2019 w wersji 16.5.0

wydany 16 marca 2020 r.

W tym wydaniu programu Visual Studio 2019 w wersji 16.5


null

  • Po zatrzymaniu wskaźnika myszy dla każdego dokumentu na liście przepełnień grupy kart zostanie wyświetlony przycisk Zamknij
  • Wybór wielu katalogów platformy Azure
  • Wdrożone ulepszenia sugerowane przez użytkowników na kartach pionowych

Debugowanie


Narzędzia platformy Azure


C++


F# — język i narzędzia


  • Ulepszenia wydajności dla dużych rozwiązań
  • Funkcje rozwiązania FSharp.Core w wersji zapoznawczej są teraz chronione za pomocą flagi LangVersion
  • Różne poprawki usterek i ulepszenia

Produktywność platformy .NET


Testowanie


JavaScript/TypeScript


SQL


Narzędzia platformy UWP/WPF


Xamarin


Szczegóły nowości w programie Visual Studio w wersji 16.5

Visual Studio IDE

Teraz można filtrować konta do określonego podzestawu katalogów usługi Azure Active Directory, które mają być dostępne dla programu Visual Studio

Debugowanie

  • Teraz możesz dekompilować kod zarządzany nawet wtedy, gdy nie masz symboli, co pozwala na przejrzenie kodu, inspekcję zmiennych i ustawianie punktów przerwania.

  • Teraz możesz dołączać do procesów uruchomionych w kontenerach systemu Windows platformy Docker za pomocą okna dialogowego Dołączanie do procesu.

Attach to process in Docker Windows container Enclave debugging
  • W narzędziu do śledzenia alokacji obiektów platformy .NET wprowadzono kilka ulepszeń widoku alokacji. Widok śledzenia wstecznego został przeniesiony do oddzielnego panelu, aby ułatwić rozróżnianie typów alokacji i wywoływanych funkcji. Drzewa wywołań w widoku śledzenia wstecznego został przerzucony, aby ułatwić diagnozowanie, do których funkcji przydzielono najwięcej pamięci. Ponadto dodano ikony wskazujące typy wartości i odwołań, a wkrótce dodamy jeszcze dwie ikony kolekcji wartości i odwołań.
Allocation View

C++

  • Deweloperzy języka C++ mogą teraz trenować modele funkcji IntelliCode w swoich bazach kodu. Nazywamy to modelem uzupełniania zespołów, ponieważ korzystasz z rozwiązań Twojego zespołu. Ponadto ulepszono sugestie funkcji IntelliCode dotyczące zmiennych członkowskich.

  • Funkcja IntelliSense wyświetla teraz bardziej czytelne nazwy typów podczas pracy z biblioteką standardową.

  • Dodaliśmy możliwość określenia, czy znaki Enter, spacji i tabulacji mają pełnić funkcje znaków zatwierdzania, oraz do określenia, czy tabulacja jest używana do wstawiania fragmentu kodu. Te ustawienia znajdują się w obszarze Narzędzia > Opcje > Edytor tekstów > C/C++ > Zaawansowane > IntelliSense. Disabling autocomplete options

  • Teraz można korzystać z natywnej obsługi systemu WSL przez program Visual Studio podczas oddzielania systemu kompilacji od zdalnego systemu wdrażania. Dzięki temu można kompilować natywnie w systemie WSL i wdrażać artefakty kompilacji w drugim zdalnym systemie na potrzeby debugowania. Ten przepływ pracy jest obsługiwany przez projekty języka CMake i projekty systemu Linux oparte na platformie MSBuild.

  • Teraz można korzystać z przechowywanych połączeń zdalnych w wierszu polecenia. Jest to przydatne w przypadku takich zadań jak aprowizacja nowej maszyny deweloperskiej lub konfiguracja programu Visual Studio w ciągłej integracji. C++ Connection Manager

  • Program Visual Studio obsługuje teraz tryb zgodności ze standardem FIPS 140-2 podczas tworzenia aplikacji C++ przeznaczonych dla zdalnego systemu Linux.

  • Zoptymalizowano kopię pliku źródłowego dla projektów CMake przeznaczonych dla zdalnego systemu Linux. Program Visual Studio zachowuje teraz „plik odcisku palca” ostatniego zestawu źródeł, który jest domyślnie kopiowany, i optymalizuje zachowanie na podstawie liczby zmienionych plików.

  • Funkcje nawigowania po kodzie, takie jak przechodzenie do definicji oraz znajdowanie wszystkich odwołań, są teraz obsługiwane dla funkcji, zmiennych i elementów docelowych w plikach skryptów CMake. Language services for CMake scripts

  • Dodawaj, usuwaj i zmieniaj nazwy plików oraz elementów docelowych w projektach platformy CMake z poziomu środowiska IDE bez konieczności ręcznego edytowania skryptów CMake. Po dodaniu lub usunięciu plików w Eksploratorze rozwiązań program Visual Studio będzie automatycznie edytować projekt platformy CMake. Można również dodawać i usuwać elementy docelowe projektu oraz zmieniać ich nazwy z widoku elementów docelowych w Eksploratorze rozwiązań. 'Add' menu in CMake Targets View

F# — język i narzędzia

Ta wersja skoncentrowała się głównie na poprawie wydajności i skalowalności dużych baz kodu języka F# w programie Visual Studio. Na wykonywaną przez nas pracę miała wpływ bezpośrednia współpraca z klientami, którzy mają bardzo duże bazy kodu. Praca nad zwiększeniem wydajności nadal trwa, ale jeśli masz średnią lub dużą bazę kodu, prawdopodobnie zauważysz zmniejszone użycie pamięci.

Oprócz ulepszeń wydajności ta wersja obejmuje wiele innych poprawek, w przypadku których współautorami byli członkowie naszej fantastycznej społeczności OSS języka F#.

Język F#

Kilka funkcji języka F# w wersji zapoznawczej zostało scalonych. Możesz je wypróbować, ustawiając element LangVersion na preview w pliku projektu.

  • Dokument F# RFC FS-1076 - From the end slicing and indexing for collections (F# RFC FS-1076 — fragmentowanie od końca i indeksowanie na potrzeby kolekcji) został ukończony na potrzeby wersji zapoznawczej języka F#
  • Dokument F# RFC FS-1077 - Tolerant Slicing (F# RFC FS-1077 — fragmentowanie z tolerancją) został ukończony na potrzeby wersji zapoznawczej języka F#
  • Dokument F# RFC FS-1077 - Slicing for 3D/4D arrays with fixed index (F# RFC FS-1077 — fragmentowanie macierzy 3d/4D z ustalonym indeksem) został ukończony na potrzeby wersji zapoznawczej języka F#
  • Dokument F# RFC FS-1080 - Float32 without dot (F# RFC FS-1080 — wartość float32 bez kropki) został ukończony na potrzeby wersji zapoznawczej języka F#, współautor: Grzegorz Dziadkiewicz

kompilator F#

Podstawowa biblioteka języka F#

Narzędzia języka F# dla programu Visual Studio

Środowisko programistyczne języka F# typu open source

  • Kompilacja usługi FSharp.Compiler.Service w repozytorium języka F# została przeniesiona w celu korzystania z zestawu .NET SDK, współautor: Chet Husk

Produktywność platformy .NET

Teraz można przekształcić fragment kodu z istniejącej metody na funkcję lokalną. Wyróżnij kod, który ma zostać wyodrębniony. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Wyodrębnij funkcję lokalną.

Extract local function

Teraz można ustawiać elementy członkowskie jako statyczne. Umieść kursor na nazwie elementu członkowskiego. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Ustaw jako statyczny.

Make members static

Teraz można uprościć interpolacje ciągów, gdy jest to możliwe. Umieść kursor na interpolacji ciągu. Naciśnij klawisze (Ctrl+ . ), aby wywołać menu Szybkie akcje i operacje refaktoryzacji. Wybierz pozycję Uprość interpolację.

Simplify-string-interpolation

Teraz możesz wykluczyć wygenerowane pliki lub foldery podczas uruchamiania analizatorów. Utwórz plik EditorConfig i oznacz wymagane pliki lub foldery jako wygenerowane przy użyciu następującej składni:

EditorConfig option to exclude generated files or folders

Autorzy analizatorów mogą teraz dystrybuować niestandardowe refaktoryzacje kodu jako pakiet NuGet. Wcześniej można je było dystrybuować tylko jako pakiet VSIX.

Testowanie

Możesz teraz profilować test platformy .NET Core. Należy pamiętać, że wymagania wstępne dotyczące profilowania obejmują skonfigurowanie projektów platformy .NET Core pod kątem generowania pełnych plików PDB. Zaleca się również uaktualnienie pakietu Microsoft.Test.SDK do wersji 16.4 lub nowszej. Pozwoli to na profilowanie testów dla ustawień zarówno architektury x86, jak i x64. Aby profilować test, wybierz pozycję „Profiluj” z menu kontekstowego w eksploratorze testów. Profilowanie testów jest obsługiwane za pośrednictwem instrumentacji statycznej i dokumentu vsp eksploratora wydajności w programie Visual Studio.

Ustawienie domyślne architektury procesora dla testów ma teraz trzecią opcję („Auto”) w dodatku do opcji x64 i x86. Opcja „Auto” obsługuje różne domyślne architektury dla testów przeznaczonych dla platform .NET Framework i .NET Core. Dla testów platformy .NET Framework wartość domyślna dla wykonywania testów to x86, a w przypadku platformy .NET Core jest to x64. Opcja „Auto” umożliwia użytkownikowi nieokreślanie architektury i użycie różnych wartości domyślnych dla tych platform. Poprzednio opcja x86 była wartością domyślną we wszystkich przypadkach, jednak wprowadzono testy platformy .NET Core z opcją domyślną o wartości x64 i dlatego wynikła potrzeba zróżnicowania wartości domyślnej.

Ta wersja obejmuje znaczące ulepszenia wydajności dotyczące odnajdywania i wykonywania testów, szczególnie w przypadku dużych rozwiązań z dużą ilością testów. Zachęcamy do uruchomienia własnych testów porównawczych w celu oceny, jak jest to znaczące. Dzięki kodowi podstawowemu projektu Roslyn (kompilatora języków C# i Visual Basic) eksplorator testów zmniejszył użycie pamięci od 50% do 60%, a czas ładowania został skrócony o 60%.

Teraz jest dostępna lepsza diagnostyka dla funkcji Live Unit Testing. Gdy kompilacja funkcji Live Unit Testing nie powiedzie się, dodatkowe informacje diagnostyczne zostaną umieszczone w danych wyjściowych, w tym w dziennikach programu MSBuild. Będą również zgłaszane przypadki, w których ścieżka danych wyjściowych jest ustalona.

JavaScript/TypeScript

Wyszukiwanie w programie VS obsługuje teraz możliwość wyszukiwania typów i elementów członkowskich w plikach TypeScript i JavaScript. Obsługiwane jest również wyszukiwanie bloków JavaScript w otwartych plikach znaczników (tj. HTML, CSHTML)

Program Visual Studio obsługuje teraz narzędzie ESLint dla plików TypeScript: istnieje konfiguracja globalna z zestawem zalecanych reguł lub można skonfigurować narzędzie ESLint lokalnie dla projektu z pełnymi możliwościami dostosowywania. Więcej informacji i instrukcji jest dostępnych na naszej stronie usługi GitHub

Xamarin

  • Za pomocą przeładowywania kodu XAML na gorąco można teraz zobaczyć zmiany zaktualizowane w wielu obiektach docelowych Xamarin.Forms jednocześnie. Debuguj aplikację za pomocą wielu projektów startowych, zmień kod XAML i naciśnij przycisk Zapisz, aby wyświetlić zmiany w systemach Android i iOS jednocześnie.

  • Teraz można wyświetlić hierarchię kontrolek Xamarin.Forms w okienku konspektu dokumentu. W systemie Windows można je otworzyć za pomocą kombinacji klawiszy Ctrl+Alt+T (Widok > Inne okna > Konspekt dokumentu). Na komputerze Mac można je otworzyć za pomocą pozycji Widok > Konsole > Konspekt dokumentu.

  • Teraz można stosować zmiany zasobów systemu Android w czasie wykonywania przy użyciu funkcji stosowania zmian systemu Android. Ta funkcja umożliwia szybkie wyświetlanie zmian wprowadzonych w plikach zasobów systemu Android (układach XML, obiektów rysowalnych itp.) na urządzeniu z systemem Android lub w emulatorze bez konieczności ponownego uruchamiania aplikacji.

Android Apply Changes
  • Możesz teraz generować własne profile niestandardowe podczas korzystania z funkcji śledzenia uruchamiania w aplikacji systemu Android. Zapewnia to jeszcze bardziej wydajne środowisko uruchamiania przy minimalnym wzroście rozmiaru pliku APK.
  • Teraz można generować powiązania zestawu Xamarin.Android dla bibliotek Kotlin.
  • Teraz można używać scalania manifestu Google podczas scalania plików AndroidManifest.xml w projektach systemu Android. Pozwala to dostosować sposób, w jaki każdy manifest i jego zawartość zostaną scalone. Aby uzyskać więcej informacji na temat reguł, które mogą być stosowane, zobacz Scalanie wielu plików manifestu.
  • Teraz możesz wybrać nową opcję, która będzie automatycznie ładować ponownie wszystkie otwarte powierzchnie projektanta po wprowadzeniu modyfikacji do bazy kodu.
Custom Control Quick Changes for Android Layouts
  • Korzystaj z funkcji skonsolidowanego edytora, aby oferować szybszą i bardziej precyzyjną funkcję IntelliSense. Obejmuje to wiele zmian, m.in. ulepszone uzupełnianie typowych konstrukcji XML, takich jak cudzysłowy atrybutów i automatyczne aktualizowanie nazw tagów końcowych. Te zachowania można kontrolować za pomocą preferencji edytora XML systemu Android:
Android XML IntelliSense Options

Narzędzia platformy UWP/WPF

  • Przeciągnięcie obrazu z eksploratora rozwiązań do edytora XAML spowoduje teraz wygenerowanie tagu obrazu XAML z właściwością Source ustawioną na poprawną ścieżkę obrazu.

  • Zmiana koloru „tła obszaru kompilacji” dla projektanta XAML teraz współdziała z projektami WPF .NET Core (Opcje > Środowisko > Czcionki i kolory, a następnie przejdź do ustawień projektanta XAML i zaktualizuj tło obszaru kompozycji)

  • Projektant XAML teraz obsługuje ładowanie projektów programu .NET Core 3.x, które obejmują ustawienia PublishSingleFile, RuntimeIdenfier i PublishTrimmed w pliku projektu (csproj). Należy pamiętać, że włączenie tych ustawień spowalnia działanie projektanta.

Najważniejsze problemy z forum Developer Community



Znane problemy

Zobacz wszystkie problemy i dostępne obejścia w programie Visual Studio 2019 w wersji 16.5, wybierając poniższy link.

Visual Studio 2019 Known Issues


Opinie i sugestie

Chcemy poznać Twoją opinię! Problemy możesz zgłaszać za pomocą opcji Zgłoś problem w prawym górnym rogu instalatora lub bezpośrednio w środowisku IDE programu Visual Studio. Program Feedback Icon znajduje się w prawym górnym rogu. Zgłaszanie sugestii dotyczących produktów i śledzenie problemów jest możliwe w społeczności deweloperów programu Visual Studio, gdzie można też zadawać pytania, znajdować odpowiedzi i proponować nowe funkcje. Możesz też uzyskać bezpłatną pomoc dotyczącą instalacji za pośrednictwem naszej pomocy technicznej przez czat na żywo.


Blogi

Skorzystaj ze szczegółowych informacji i zaleceń dostępnych w witrynie blogów dotyczących narzędzi programistycznych, aby być na bieżąco ze wszystkimi nowymi wersjami i zyskać dostęp do szczegółowych wpisów dotyczących szerokiego zakresu funkcji.


Historia informacji o wersji programu Visual Studio 2019

Więcej informacji na temat poprzednich wersji programu Visual Studio 2019 można znaleźć na stronie Historia informacji o wersji programu Visual Studio 2019.


Początek strony