Realizar sideload de suplementos do Office no Office na Web para testeSideload Office Add-ins in Office on the web for testing

Você pode instalar um suplemento do Office para teste usando sideloading, sem precisar primeiro colocá-lo em um catálogo de suplementos.You can install an Office Add-in for testing without having to first put it in an add-in catalog by using sideloading. O Sideload pode ser feito no Microsoft 365 ou no Office na Web.Sideloading can be done in either Microsoft 365 or Office on the web. O procedimento é ligeiramente diferente nas duas plataformas.The procedure is slightly different for the two platforms.

Quando você realiza o sideload de um suplemento, o manifesto do suplemento é armazenado localmente do navegador e, portanto, se você limpar o cache do navegador ou alternar para um navegador diferente, precisará realizar o sideload do suplemento novamente.When you sideload an add-in, the add-in manifest is stored in the browser's local storage, so if you clear the browser's cache, or switch to a different browser, you have to sideload the add-in again.

Observação

A realização do sideload como descrito neste artigo tem suporte no Word, no Excel e no PowerPoint. Para realizar o sideload de um suplemento do Outlook, confira Realizar sideload de suplementos do Outlook para teste.Sideloading as described in this article is supported on Word, Excel, and PowerPoint. To sideload an Outlook add-in, see Sideload Outlook add-ins for testing.

O vídeo a seguir oferece orientações para o processo de sideload do seu suplemento no Office na Web ou para área de trabalho.The following video walks you through the process of sideloading your add-in in Office on the web or desktop.

Realizar sideload de um suplemento do Office no Office na WebSideload an Office Add-in in Office on the web

  1. Abra o Office na Web.Open Office on the web.

  2. Em introdução aos aplicativos online agora, escolha Excel, Wordou PowerPoint; e, em seguida, abra um novo documento.In Get started with the online apps now, choose Excel, Word, or PowerPoint; and then open a new document.

  3. Abra a guia Inserir na faixa de opções e, na seção suplementos , escolha suplementos do Office.Open the Insert tab on the ribbon and, in the Add-ins section, choose Office Add-ins.

  4. Na caixa de diálogo suplementos do Office , selecione a guia meus suplementos , escolha gerenciar meus suplementose, em seguida, carregar meu suplemento.On the Office Add-ins dialog, select the MY ADD-INS tab, choose Manage My Add-ins, and then Upload My Add-in.

    A caixa de diálogo Suplementos do Office com um menu suspenso "Gerenciar meus suplementos" no canto superior direito e abaixo o menu suspenso com a opção "Carregar meu suplemento"

  5. Navegue até o arquivo de manifesto do suplemento e selecione Carregar.Browse to the add-in manifest file, and then select Upload.

    A caixa de diálogo Carregar suplemento com botões para pesquisar, carregar e cancelar.

  6. Verifique se o suplemento está instalado. Por exemplo, se for um comando do suplemento, ele deve aparecer na faixa de opções ou no menu de contexto. Se for um suplemento de painel de tarefas, o painel deve ser exibido.Verify that your add-in is installed. For example, if it is an add-in command, it should appear on either the ribbon or the context menu. If it is a task pane add-in, the pane should appear.

Observação

Para testar o suplemento do Office com o Microsoft Edge com o WebView original (EdgeHTML), é necessária uma etapa de configuração adicional.To test your Office Add-in with Microsoft Edge with the original WebView (EdgeHTML), an additional configuration step is required. Em um prompt de comando do Windows, execute a seguinte linha: npx office-addin-dev-settings appcontainer EdgeWebView --loopback --yes .In a Windows Command Prompt, run the following line: npx office-addin-dev-settings appcontainer EdgeWebView --loopback --yes. Isso não é necessário quando o Office está usando o WebView2 de borda baseado em Chromium.This is not required when Office is using the Chromium-based Edge WebView2. Para obter mais informações, consulte navegadores usados por suplementos do Office.For more information, see Browsers used by Office Add-ins.

Realizar sideload de um suplemento do Office no Office 365Sideload an Office Add-in in Office 365

  1. Entre em sua conta do Microsoft 365.Sign in to your Microsoft 365 account.

  2. Abra o inicializador de aplicativos na extremidade esquerda da barra de ferramentas e selecione Excel, Wordou PowerPointe, em seguida, crie um novo documento.Open the App Launcher on the left end of the toolbar and select Excel, Word, or PowerPoint, and then create a new document.

  3. As etapas 3 a 6 são as mesmas da seção anterior Realize sideload para um suplemento do Office no Office na Web. Steps 3 - 6 are the same as in the preceding section Sideload an Office Add-in in Office on the web.

Sideload de um suplemento usando o Visual StudioSideload an add-in when using Visual Studio

Se estiver usando o Visual Studio para desenvolver o suplemento, o processo de sideload é semelhante.If you're using Visual Studio to develop your add-in, the process to sideload is similar. A única diferença é que você deve atualizar o valor do elemento SourceURL no manifesto para incluir a URL completa em que o suplemento for implantado.The only difference is that you must update the value of the SourceURL element in your manifest to include the full URL where the add-in is deployed.

Observação

Embora você possa realizar o sideload de suplementos do Visual Studio para o Office na Web, não é possível depurá-los no Visual Studio.Although you can sideload add-ins from Visual Studio to Office on the web, you cannot debug them from Visual Studio. Para depurar você precisará usar as ferramentas de depuração do navegador.To debug you will need to use the browser debugging tools. Para saber mais, confira Depurar suplementos no Office na Web.For more information, see Debug add-ins in Office on the web.

  1. No Visual Studio, abra a janela Propriedades escolhendo Modo de exibição -> Janela de propriedades.In Visual Studio, show the Properties window by choosing View -> Properties Window.
  2. No Gerenciador de Soluções, selecione o projeto Web.In the Solution Explorer, select the web project. Isso exibirá as propriedades para o projeto na janela Propriedades.This will display properties for the project in the Properties window.
  3. Na janela Propriedades, copie a URL de SSL.In the Properties window, copy the SSL URL.
  4. No projeto de suplemento, abra o arquivo XML do manifesto.In the add-in project, open the manifest XML file. Certifique-se de que você está editando o XML do código-fonte.Be sure you are editing the source XML. Para alguns tipos de projeto o Visual Studio abrirá o modo de exibição de visualização do XML que não funcionará para a próxima etapa.For some project types Visual Studio will open a visual view of the XML which will not work for the next step.
  5. Pesquisar e substituir todas as instâncias de ~remoteAppUrl/ pela URL de SSL que você copiou.Search and replace all instances of ~remoteAppUrl/ with the SSL URL you just copied. Você verá várias substituições dependendo do tipo de projeto e as novas URLs serão muito similares a https://localhost:44300/Home.html.You will see several replacements depending on the project type, and the new URLs will appear similar to https://localhost:44300/Home.html.
  6. Salve o arquivo XML.Save the XML file.
  7. Clique com botão direito do mouse no projeto Web e escolha Depurar -> Iniciar nova instância.Right click the web project and choose Debug -> Start new instance. Isso executará o projeto Web sem iniciar o Office.This will run the web project without launching Office.
  8. No Office na Web, realize o sideload do suplemento usando as etapas descritas anteriormente em Sideload de um suplemento do Office no Office na Web.From Office on the web, sideload the add-in using steps previously described in Sideload an Office Add-in in Office on the web.

Remover um suplemento do suplementos foi feitoRemove a sideloaded add-in

Você pode remover um suplemento suplementos foi feito anteriormente limpando o cache do navegador.You can remove a previously sideloaded add-in by clearing your browser's cache. Além disso, se você fizer alterações no manifesto do suplemento (por exemplo, atualizar nomes de arquivo de ícones ou texto de comandos de suplemento), talvez seja necessário limpar o cache e, em seguida, resideload o suplemento usando o manifesto atualizado.Additionally, if you make changes to your add-in's manifest (for example, update file names of icons or text of add-in commands), you may need to clear the cache and then re-sideload the add-in using updated manifest. Isso permitirá que o Office processe o suplemento conforme descrito no manifesto atualizado.Doing so will allow Office to render the add-in as it's described by the updated manifest.