Cenário: Exceção de armazenamento após a redefinição de conexão no Azure HDInsight

Este artigo descreve as etapas de solução de problemas e possíveis soluções para problemas durante a interação com clusters do Azure HDInsight.

Problema

Não é possível criar uma nova tabela do Apache HBase.

Causa

Durante um processo de truncamento de tabela, houve um problema de conexão de armazenamento. A entrada da tabela foi excluída na tabela de metadados do HBase. Todos, exceto um arquivo de blob, foram excluídos.

Embora não haja nenhum blob de pasta chamado /hbase/data/default/ThatTable sentado no armazenamento. O driver WASB encontrou a existência do arquivo de blob acima e não permitiria que ele criasse qualquer blob chamado /hbase/data/default/ThatTable porque presumia que as pastas pai existiam, portanto, a criação de tabela falha.

Resolução

  1. Na interface do usuário do Apache Ambari, reinicie o HMaster ativo. Isso permite que um dos dois HMaster em espera se torne o ativo e o novo HMaster ativo recarregue as informações da tabela de metadados. Assim, você não vê a already-deleted tabela no HMaster UI.

  2. Você pode encontrar o arquivo de blob órfão nas ferramentas de interface do usuário, como o Cloud Explorer ou executando o comando como hdfs dfs -ls /xxxxxx/yyyyy. Execute hdfs dfs -rmr /xxxxx/yyyy para excluir esse BLOB. Por exemplo, hdfs dfs -rmr /hbase/data/default/ThatTable/ThatFile.

Agora você pode criar uma nova tabela com o mesmo nome no HBase.

Próximas etapas

Se você não encontrou seu problema ou não conseguiu resolver seu problema, visite um dos seguintes canais para obter mais suporte:

  • Obtenha respostas de especialistas do Azure por meio do Suporte da Comunidade do Azure.

  • Conecte-se com @AzureSupport – a conta oficial do Microsoft Azure para aprimorar a experiência do cliente. Como se conectar à comunidade do Azure para os recursos certos: respostas, suporte e especialistas.

  • Se precisar de mais ajuda, poderá enviar uma solicitação de suporte do portal do Azure. Selecione Suporte na barra de menus ou abra o hub Ajuda + suporte. Para obter informações mais detalhadas, consulte Como criar uma solicitação de Suporte do Azure. O acesso ao Gerenciamento de assinaturas e ao suporte de cobrança está incluído na sua assinatura do Microsoft Azure, e o suporte técnico é fornecido por meio de um dos Planos de suporte do Azure.