Criar um projeto de aplicativo de console C++

O ponto de partida usual para um programador C++ é um aplicativo "Olá, mundo!" que é executado na linha de comando. Isso é o que você criará em Visual Studio nesta etapa.

Pré-requisitos

  • Ter o Visual Studio com o desenvolvimento de Desktop com carga de trabalho do C++ instalada e em execução no seu computador. Se ele ainda não estiver instalado, confira Instalar suporte para C++ no Visual Studio.

Criar seu projeto de aplicativo

O Visual Studio usa os projetos para organizar o código em um aplicativo e as soluções para organizar seus projetos. Um projeto contém todas as opções, configurações e regras usadas para criar seus aplicativos. Ele gerencia a relação entre todos os arquivos do projeto e todos os arquivos externos. Para criar seu aplicativo, primeiro, crie um novo projeto e uma nova solução.

  1. Em Visual Studio, abra o menu Arquivo e escolha Nova > Project para abrir a caixa de diálogo Criar um novo Project. Selecione o modelo de Aplicativo de Console que tem marcas C++, Windows e Console e escolha Avançar.

    Create a new project dialog.

  2. Na caixa de diálogo Configurar seu novo projeto, insira HelloWorld na caixa de edição de nome Project. Escolha Criar para criar o projeto.

    Screenshot of the Configure your new project dialog box with Hello World typed in the Project name text field.

    Visual Studio cria um novo projeto. Ele está pronto para adicionar e editar seu código-fonte. Por padrão, o modelo do Aplicativo de Console preenche seu código-fonte com um aplicativo "Olá, Mundo":

    Screenshot of the Hello World project in the IDE.

    Quando o código se parecer com isso no editor, você estará pronto para ir para a próxima etapa e compilar seu aplicativo.

Houve um problema.

  1. Em Visual Studio, abra o menu Arquivo e escolha Nova > Project para abrir a caixa de diálogo Nova Project.

    Use the File, New, Project command to open the Property Pages dialog.

  2. Na caixa de diálogo Novo Project, selecione O Visual C++ instalado > se ele ainda não estiver selecionado e escolha o modelo de Project Vazio. No campo Nome , insira HelloWorld. Escolha OK para criar o projeto.

    Screenshot of the New Project dialog box with Installed > Visual C plus plus selected and called out, the Empty Project option called out, and Hello World typed in the Name text box.

Visual Studio cria um projeto novo e vazio. Ele está pronto para você se especializar no tipo de aplicativo que deseja criar e adicionar seus arquivos de código-fonte. Você fará isso em seguida.

Houve um problema.

Tornar seu projeto um aplicativo de console

Visual Studio pode criar todos os tipos de aplicativos e componentes para Windows e outras plataformas. O modelo empty Project não é específico sobre que tipo de aplicativo ele cria. Um aplicativo de console é aquele que é executado em um console ou janela de prompt de comando. Para criar um, você deve informar Visual Studio criar seu aplicativo para usar o subsistema de console.

  1. Em Visual Studio, abra o menu Project e escolha Propriedades para abrir a caixa de diálogo Páginas de Propriedades do HelloWorld.

  2. Na caixa de diálogo Páginas de Propriedades, selecione Sistema do Vinculador > de Propriedades > de Configuração e escolha a caixa de edição ao lado da propriedade Subsistema. No menu suspenso exibido, selecione Console (/SUBSYSTEM:CONSOLE). Escolha OK para salvar suas alterações.

    View of using the Property Pages dialog to set the Subsystem property.

Visual Studio agora sabe criar seu projeto para ser executado em uma janela do console. Em seguida, você adicionará um arquivo de código-fonte e inserirá o código para seu aplicativo.

Houve um problema.

Adicionar um arquivo de código-fonte

  1. Em Gerenciador de Soluções, selecione o projeto HelloWorld. Na barra de menus, escolha Project, Adicionar Novo Item para abrir a caixa de diálogo Adicionar Novo Item.

  2. Na caixa de diálogo Adicionar Novo Item , selecione Visual C++em Instalado se ele ainda não estiver selecionado. No painel central, selecione o arquivo C++ (.cpp). Altere o nome para HelloWorld.cpp. Escolha Adicionar para fechar a caixa de diálogo e criar o arquivo.

    View of the process to add a source file for HelloWorld.cpp.

O Visual Studio cria um novo arquivo de código-fonte vazio e o abre em uma janela do editor, pronto para inserir o código-fonte.

Houve um problema.

Adicionar código ao arquivo de origem

  1. Copie esse código para a janela do editor HelloWorld.cpp.

    #include <iostream>
    
    int main()
    {
        std::cout << "Hello, world!" << std::endl;
        return 0;
    }
    

    O código deve ter esta aparência na janela do editor:

    Screenshot of the Hello World code in the editor.

Quando o código se parecer com isso no editor, você estará pronto para ir para a próxima etapa e compilar seu aplicativo.

Houve um problema.

Próximas etapas

Guia de Solução de Problemas

Venha aqui para obter soluções para problemas comuns ao criar seu primeiro projeto C++.

Criar seu projeto de aplicativo: problemas

A caixa de diálogo Novo Project deve mostrar um modelo de Aplicativo de Console que tenha marcas C++, Windows e Console. Se você não vir, há duas causas possíveis. Ele pode ser filtrado para fora da lista ou pode não ser instalado. Primeiro, verifique as listas suspensas de filtro na parte superior da lista de modelos. Defina-os como C++, Windows e Console. O modelo do Aplicativo de Console C++ deve aparecer; caso contrário, o desenvolvimento da área de trabalho com carga de trabalho C++ não está instalado.

Para instalar o desenvolvimento da área de trabalho com C++, você pode executar o instalador diretamente na caixa de diálogo Nova Project. Escolha o link Instalar mais ferramentas e recursos na parte inferior da lista de modelos para iniciar o instalador. Se a caixa de diálogo Controle de Conta de Usuário solicitar permissões, escolha Sim. No instalador, verifique se o desenvolvimento da área de trabalho com carga de trabalho C++ está verificado. Em seguida, escolha Modificar para atualizar sua instalação Visual Studio.

Se outro projeto com o mesmo nome já existir, escolha outro nome para seu projeto. Ou exclua o projeto existente e tente novamente. Para excluir um projeto existente, exclua a pasta da solução (a pasta que contém o arquivo helloworld.sln) no Explorador de Arquivos.

Voltar.

Se a caixa de diálogo Novo Project não mostrar uma entrada do Visual C++em Installed, sua cópia de Visual Studio provavelmente não terá o desenvolvimento da Área de Trabalho com a carga de trabalho C++ instalada. Você pode executar o instalador diretamente na caixa de diálogo Novo Project. Escolha o link Abrir Instalador do Visual Studio para iniciar o instalador novamente. Se a caixa de diálogo Controle de Conta de Usuário solicitar permissões, escolha Sim. Atualize o instalador, se necessário. No instalador, verifique se o desenvolvimento da área de trabalho com carga de trabalho C++ está verificado e escolha OK para atualizar sua instalação Visual Studio.

Se outro projeto com o mesmo nome já existir, escolha outro nome para seu projeto. Ou exclua o projeto existente e tente novamente. Para excluir um projeto existente, exclua a pasta da solução (a pasta que contém o arquivo helloworld.sln) no Explorador de Arquivos.

Voltar.

Tornar seu projeto um aplicativo de console: problemas

Se você não vir o Vinculador listado em Propriedades de Configuração, escolha Cancelar para fechar a caixa de diálogo Páginas de Propriedades . Verifique se o projeto HelloWorld está selecionado em Gerenciador de Soluções antes de tentar novamente. Não selecione a solução HelloWorld ou outro item no Gerenciador de Soluções.

O controle suspenso não aparece na caixa de edição da propriedade SubSystem até que você selecione a propriedade. Clique na caixa de edição para selecioná-la. Ou, você pode pressionar Tab para percorrer os controles de diálogo até que o SubSistema seja realçado. Escolha o controle suspenso ou pressione Alt+Down para abri-lo.

Voltar

Adicionar um arquivo de código-fonte: problemas

Tudo bem se você der ao arquivo de código-fonte um nome diferente. No entanto, não adicione mais de um arquivo que contenha o mesmo código ao seu projeto.

Se você adicionou o tipo de arquivo errado ao seu projeto, como um arquivo de cabeçalho, exclua-o e tente novamente. Para excluir o arquivo, selecione-o em Gerenciador de Soluções. Em seguida, pressione a tecla Delete .

Voltar.

Adicionar código ao arquivo de origem: problemas

Se você fechou acidentalmente a janela do editor do arquivo de código-fonte, poderá abri-la facilmente novamente. Para abri-lo, clique duas vezes em HelloWorld.cpp na janela Gerenciador de Soluções.

Se os rabiscos vermelhos aparecerem em qualquer coisa no editor de código-fonte, verifique se o código corresponde ao exemplo em ortografia, pontuação e maiúsculas e minúsculas. O caso é significativo no código C++.

Voltar.