Instalar o .NET Core no LinuxInstall .NET Core on Linux

O .NET Core está disponível em diferentes distribuições do Linux..NET Core is available on different Linux distributions. A maioria das plataformas e distribuições do Linux tem uma versão principal a cada ano, e a maioria fornece um Gerenciador de pacotes usado para instalar o .NET Core.Most Linux platforms and distributions have a major release each year, and most provide a package manager that is used to install .NET Core. Este artigo descreve o que tem suporte no momento e qual Gerenciador de pacotes é usado.This article describes what is currently supported and which package manager is used.

O restante deste artigo é uma análise de cada grande distribuição do Linux com suporte do .NET Core.The rest of this article is a breakdown of each major Linux distribution that .NET Core supports. Todas as versões do .NET Core permanecem com suporte até que a versão do .NET Core atinja o fim do suporte ou a distribuição do Linux atinja o fim da vida útil.All .NET Core releases remain supported until either the version of .NET Core reaches end-of-support or the Linux distribution reaches end-of-life.

Para obter a melhor compatibilidade, escolha uma versão de LTS (versão de longo prazo).For the best compatibility, choose a long-term release (LTS) version.

Versões sem suporteUnsupported releases

Não há mais suporte para as seguintes versões do .NET Core ❌ .The following versions of .NET Core are ❌ no longer supported. Os downloads para eles ainda permanecem publicados:The downloads for these still remain published:

  • 3.03.0
  • 2.22.2
  • 2,02.0

Essas versões sem suporte não são detalhadas nas seções abaixo e sua quilometragem pode variar se você tentar instalá-las.These unsupported versions aren't detailed in the sections below and your mileage may vary if you try to install them.

AlpineAlpine

Não há instaladores para o Alpine.There are no installers for Alpine. Você deve usar o script de instalação ou seguir as instruções de instalação manual .You must either use the install script or follow the manual install instructions.

A tabela a seguir é uma lista de versões do .NET Core com suporte no momento e as versões do Alpine para as quais têm suporte.The following table is a list of currently supported .NET Core releases and the versions of Alpine they're supported on. Essas versões permanecem com suporte até que a versão do .NET Core atinja o fim do suporte ou a versão do Alpine alcance o fim da vida útil.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of Alpine reaches end-of-life.

  • Um ✔️ indica que a versão do Alpine ou .NET Core ainda tem suporte.A ✔️ indicates that the version of Alpine or .NET Core is still supported.
  • Um ❌ indica que a versão do Alpine ou .NET Core não tem suporte nessa versão do Alpine.A ❌ indicates that the version of Alpine or .NET Core isn't supported on that Alpine release.
  • Quando uma versão do Alpine e uma versão do .NET Core têm ✔️, há suporte para essa combinação de so e .NET.When both a version of Alpine and a version of .NET Core have ✔️, that OS and .NET combination are supported.
AlpineAlpine .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 Versão prévia do .NET 5.NET 5 Preview
✔️ 3,12✔️ 3.12 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
✔️ 3,11✔️ 3.11 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
✔️ 3,10✔️ 3.10 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
✔️ 3,9✔️ 3.9 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
3.83.8 ✔️ 2,1✔️ 2.1 ❌3,1❌ 3.1 ❌visualização de 5,0❌ 5.0 Preview

Para obter mais informações, consulte instalar o .NET Core no Alpine Ski.For more information, see Install .NET Core on Alpine.

CentOSCentOS

O CentOS 7 usa o yum como um Gerenciador de pacotes e o CentOS 8 usa o DNF.CentOS 7 uses Yum as a package manager and CentOS 8 uses DNF.

A tabela a seguir é uma lista de versões do .NET Core com suporte atualmente no CentOS 7 e no CentOS 8.The following table is a list of currently supported .NET Core releases on both CentOS 7 and CentOS 8. Essas versões permanecem com suporte até que a versão do .NET Core atinja o fim do suporte ou a versão do CentOS não seja mais suportada.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of CentOS is no longer supported.

CentOSCentOS .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 Versão prévia do .NET 5 (somente instalação manual).NET 5 Preview (manual install only)
✔️ 8✔️ 8 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
✔️ 7✔️ 7 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview

Para obter mais informações, consulte instalar o .NET Core no CentOS.For more information, see Install .NET Core on CentOS.

DebianDebian

Debian usa APT (ferramenta de pacote avançado) como um Gerenciador de pacotes.Debian uses APT (Advanced Package Tool) as a package manager.

A tabela a seguir é uma lista de versões do .NET Core com suporte no momento e as versões do Debian nas quais elas têm suporte.The following table is a list of currently supported .NET Core releases and the versions of Debian they're supported on. Essas versões permanecem com suporte até que a versão do .NET Core atinja o fim do suporte ou a versão do Debian atinja o fim da vida útil.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of Debian reaches end-of-life.

  • Um ✔️ indica que a versão do Debian ou do .NET Core ainda tem suporte.A ✔️ indicates that the version of Debian or .NET Core is still supported.
  • Um ❌ indica que a versão do Debian ou do .NET Core não tem suporte nessa versão do Debian.A ❌ indicates that the version of Debian or .NET Core isn't supported on that Debian release.
  • Quando uma versão do Debian e uma versão do .NET Core têm ✔️, há suporte para essa combinação de so e .NET.When both a version of Debian and a version of .NET Core have ✔️, that OS and .NET combination are supported.
DebianDebian .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 Versão prévia do .NET 5 (somente instalação manual).NET 5 Preview (manual install only)
✔️ 10✔️ 10 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
✔️ 9✔️ 9 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
88 ✔️ 2,1✔️ 2.1 ❌3,1❌ 3.1 ❌visualização de 5,0❌ 5.0 Preview

Para obter mais informações, consulte instalar o .NET Core no Debian.For more information, see Install .NET Core on Debian.

FedoraFedora

Fedora usa DNF como seu Gerenciador de pacotes.Fedora uses DNF as its package manager.

A tabela a seguir é uma lista de versões do .NET Core com suporte no momento e as versões do Fedora em que têm suporte.The following table is a list of currently supported .NET Core releases and the versions of Fedora they're supported on. Essas versões permanecem com suporte até que a versão do .NET Core atinja o fim do suporte ou a versão do Fedora atinja o fim da vida útil.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of Fedora reaches end-of-life.

  • Um ✔️ indica que a versão do Fedora ou do .NET Core ainda tem suporte.A ✔️ indicates that the version of Fedora or .NET Core is still supported.
  • Um ❌ indica que a versão do Fedora ou do .NET Core não tem suporte nessa versão do Fedora.A ❌ indicates that the version of Fedora or .NET Core isn't supported on that Fedora release.
  • Quando uma versão do Fedora e uma versão do .NET Core têm ✔️, há suporte para essa combinação de so e .NET.When both a version of Fedora and a version of .NET Core have ✔️, that OS and .NET combination are supported.
FedoraFedora .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 Versão prévia do .NET 5 (somente instalação manual).NET 5 Preview (manual install only)
✔️ 32✔️ 32 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
✔️ 31✔️ 31 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
3030 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 ❌visualização de 5,0❌ 5.0 Preview
2929 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 ❌visualização de 5,0❌ 5.0 Preview
2828 ✔️ 2,1✔️ 2.1 ❌3,1❌ 3.1 ❌visualização de 5,0❌ 5.0 Preview
2727 ✔️ 2,1✔️ 2.1 ❌3,1❌ 3.1 ❌visualização de 5,0❌ 5.0 Preview

Para obter mais informações, consulte instalar o .NET Core em Fedora.For more information, see Install .NET Core on Fedora.

openSUSEopenSUSE

openSUSE usa zypper como o Gerenciador de pacotes.openSUSE uses zypper as the package manager.

A tabela a seguir é uma lista de versões do .NET Core com suporte no momento no openSUSE 15.The following table is a list of currently supported .NET Core releases on openSUSE 15. Essas versões permanecem com suporte até que a versão do .NET Core atinja o fim do suporte ou a versão do openSUSE não seja mais suportada.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of openSUSE is no longer supported.

  • Um ✔️ indica que a versão do openSUSE ou do .NET Core ainda tem suporte.A ✔️ indicates that the version of openSUSE or .NET Core is still supported.
  • Um ❌ indica que a versão do openSUSE ou do .NET Core não tem suporte nessa versão do openSUSE.A ❌ indicates that the version of openSUSE or .NET Core isn't supported on that openSUSE release.
  • Quando uma versão do openSUSE e uma versão do .NET Core têm ✔️, há suporte para essa combinação de so e .NET.When both a version of openSUSE and a version of .NET Core have ✔️, that OS and .NET combination are supported.
openSUSEopenSUSE .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 Versão prévia do .NET 5 (somente instalação manual).NET 5 Preview (manual install only)
✔️ 15✔️ 15 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview

Para obter mais informações, consulte instalar o .NET Core em openSUSE.For more information, see Install .NET Core on openSUSE.

Red HatRed Hat

Red Hat Enterprise Linux (RHEL) usa yum (RHEL 7) e DNF (RHEL 8) como o Gerenciador de pacotes.Red Hat Enterprise Linux (RHEL) uses yum (RHEL 7) and DNF (RHEL 8) as the package manager.

A tabela a seguir é uma lista de versões do .NET Core com suporte no momento no RHEL 7 e RHEL 8.The following table is a list of currently supported .NET Core releases on both RHEL 7 and RHEL 8. Essas versões permanecem com suporte até que a versão do .NET Core atinja o fim do suporte ou a versão do RHEL não seja mais suportada.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of RHEL is no longer supported.

  • Um ✔️ indica que a versão do RHEL ou do .NET Core ainda tem suporte.A ✔️ indicates that the version of RHEL or .NET Core is still supported.
  • Um ❌ indica que a versão do RHEL ou do .NET Core não tem suporte nessa versão do RHEL.A ❌ indicates that the version of RHEL or .NET Core isn't supported on that RHEL release.
  • Quando uma versão do RHEL e uma versão do .NET Core têm ✔️, há suporte para essa combinação de so e .NET.When both a version of RHEL and a version of .NET Core have ✔️, that OS and .NET combination are supported.
RHELRHEL .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 Versão prévia do .NET 5 (somente instalação manual).NET 5 Preview (manual install only)
✔️ 8✔️ 8 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
✔️ 7✔️ 7 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview

Para obter mais informações, consulte instalar o .NET Core no RHEL.For more information, see Install .NET Core on RHEL.

SLESSLES

O SLES usa zypper como o Gerenciador de pacotes.SLES uses zypper as the package manager.

A tabela a seguir é uma lista de versões do .NET Core com suporte no momento no SLES 12 SP2 e no SLES 15.The following table is a list of currently supported .NET Core releases on both SLES 12 SP2 and SLES 15. Essas versões permanecem com suporte até que a versão do .NET Core atinja o fim do suporte ou a versão do SLES não seja mais suportada.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of SLES is no longer supported.

  • Um ✔️ indica que a versão do SLES ou do .NET Core ainda tem suporte.A ✔️ indicates that the version of SLES or .NET Core is still supported.
  • Um ❌ indica que a versão do SLES ou do .NET Core não tem suporte nessa versão do SLES.A ❌ indicates that the version of SLES or .NET Core isn't supported on that SLES release.
  • Quando uma versão do SLES e uma versão do .NET Core têm ✔️, há suporte para essa combinação de so e .NET.When both a version of SLES and a version of .NET Core have ✔️, that OS and .NET combination are supported.
SLESSLES .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 Versão prévia do .NET 5 (somente instalação manual).NET 5 Preview (manual install only)
✔️ 15✔️ 15 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
✔️ 12 SP2✔️ 12 SP2 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview

Para obter mais informações, consulte instalar o .NET Core no SLES.For more information, see Install .NET Core on SLES.

UbuntuUbuntu

O Ubuntu usa a APT (ferramenta de pacote avançado) como um Gerenciador de pacotes.Ubuntu uses APT (Advanced Package Tool) as a package manager.

A tabela a seguir representa o status de suporte do Ubuntu e do .NET Core.The following table represents the support status of Ubuntu and .NET Core.

  • Um ✔️ indica que a versão do Ubuntu ou do .NET Core ainda tem suporte.A ✔️ indicates that the version of Ubuntu or .NET Core is still supported.
  • Um ❌ indica que a versão do Ubuntu ou do .NET Core não tem suporte nessa versão do Ubuntu.A ❌ indicates that the version of Ubuntu or .NET Core isn't supported on that Ubuntu release.
  • Quando uma versão do Ubuntu e uma versão do .NET Core têm ✔️, há suporte para essa combinação de so e .NET.When both a version of Ubuntu and a version of .NET Core have ✔️, that OS and .NET combination are supported.
UbuntuUbuntu .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 Versão prévia do .NET 5 (somente instalação manual).NET 5 Preview (manual install only)
✔️ 20, 4 (LTS)✔️ 20.04 (LTS) ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
✔️ 19,10✔️ 19.10 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
19, 419.04 ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 ❌visualização de 5,0❌ 5.0 Preview
18,1018.10 ✔️ 2,1✔️ 2.1 ❌3,1❌ 3.1 ❌visualização de 5,0❌ 5.0 Preview
✔️ 18, 4 (LTS)✔️ 18.04 (LTS) ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview
17.1017.10 ✔️ 2,1✔️ 2.1 ❌3,1❌ 3.1 ❌visualização de 5,0❌ 5.0 Preview
17.0417.04 ✔️ 2,1✔️ 2.1 ❌3,1❌ 3.1 ❌visualização de 5,0❌ 5.0 Preview
16,1016.10 ❌2,1❌ 2.1 ❌3,1❌ 3.1 ❌visualização de 5,0❌ 5.0 Preview
✔️ 16, 4 (LTS)✔️ 16.04 (LTS) ✔️ 2,1✔️ 2.1 ✔️ 3,1✔️ 3.1 versão prévia do ✔️ 5,0✔️ 5.0 Preview

Para obter mais informações, consulte instalar o .NET Core no Ubuntu.For more information, see Install .NET Core on Ubuntu.

Próximas etapasNext steps