Requisitos do sistema do .NET Framework.NET Framework system requirements

As tabelas neste artigo fornecem os requisitos de hardware, sistema operacional e software para as seguintes versões de .NET Framework:The tables in this article provide the hardware, operating system, and software requirements for the following .NET Framework versions:

  • .NET Framework 4.5 e respectivos pontos de lançamento (4.5.1 e 4.5.2)..NET Framework 4.5 and its point releases (4.5.1 and 4.5.2).
  • .NET Framework 4.6 e respectivos pontos de lançamento (4.6.1 e 4.6.2)..NET Framework 4.6 and its point releases (4.6.1 and 4.6.2).
  • .NET Framework 4.7 e suas versões de ponto (4.7.1 e 4.7.2)..NET Framework 4.7 and its point releases (4.7.1 and 4.7.2).
  • .NET Framework 4.8.NET Framework 4.8

Para informações sobre versões do .NET Framework anteriores ao .NET Framework 4.5, veja Versões e dependências do .NET Framework.For information on .NET Framework versions earlier than .NET Framework 4.5, see .NET Framework versions and dependencies.

Ambientes de desenvolvimento que permitem desenvolver aplicativos para .NET Framework têm um conjunto separado de requisitos.Development environments that enable you to develop apps for .NET Framework have a separate set of requirements.

Importante

Todas as versões do .NET Framework, desde o .NET Framework 4, são atualizações in-loco. Por esse motivo, apenas uma versão 4.x pode estar presente no sistema.All .NET Framework versions since .NET Framework 4 are in-place updates, so only a single 4.x version can be present on a system. Além disso, versões específicas do .NET Framework são pré-instaladas em algumas versões do sistema operacional Windows.In addition, particular versions of .NET Framework are pre-installed on some versions of the Windows operating system. Isso significa que:This means that:

  • Se você já instalou uma versão 4.x posterior no computador, não é possível instalar uma versão 4.x anterior.If there's a later 4.x version installed on the machine already, you can't install a previous 4.x version.
  • Se o SO vier pré-instalado com uma determinada versão do .NET Framework, não é possível instalar uma versão 4.x anterior no mesmo computador.If the OS comes pre-installed with a particular .NET Framework version, you can't install a previous 4.x version on the same machine.
  • Caso instale uma versão posterior, não é necessário desinstalar primeiro a versão anterior.If you install a later version, you don't have to first uninstall the previous version.

Para obter informações sobre download e links, consulte Instalar o .NET Framework para desenvolvedores.For download information and links, see Install the .NET Framework for developers.

Para saber mais sobre o ciclo de vida de suporte de versões do .NET Framework, veja Ciclo de vida do Suporte da Microsoft.For information on the support lifecycle of .NET Framework versions, see Microsoft Support Lifecycle.

Requisitos de hardwareHardware requirements

ProcessadorProcessor 1 GHz1 GHz
RAMRAM 512 MB512 MB
Espaço em disco (mínimo)Disk space (minimum)
32 bits32-bit 4,5 GB4.5 GB
64 bits64-bit 4,5 GB4.5 GB

Requisitos de instalaçãoInstallation requirements

.NET Framework requer privilégios de administrador para instalação..NET Framework requires administrator privileges for installation. Se você não tiver direitos de administrador para o computador em que deseja instalar .NET Framework, entre em contato com o administrador da rede.If you don't have administrator rights to the computer where you'd like to install .NET Framework, contact your network administrator.

Sistemas operacionais cliente compatíveisSupported client operating systems

Sistema operacionalOperating system Edições compatíveisSupported editions Pré-instalado com o sistema operacionalPreinstalled with the OS Instalado separadamenteInstallable separately
Atualização de 2020 de maio do Windows 10Windows 10 May 2020 Update
(versão 2004)(version 2004)
32 bits e 64 bits32-bit and 64-bit .NET Framework 4.8.NET Framework 4.8 --
Atualização de 2019 de novembro do Windows 10Windows 10 November 2019 Update
(versão 1909)(version 1909)
32 bits e 64 bits32-bit and 64-bit .NET Framework 4.8.NET Framework 4.8 --
Atualização de maio de 2019 para Windows 10Windows 10 May 2019 Update
(versão 1903)(version 1903)
32 bits e 64 bits32-bit and 64-bit .NET Framework 4.8.NET Framework 4.8 --
Atualização de outubro de 2018 para o Windows 10Windows 10 October 2018 Update
(versão 1809)(version 1809)
32 bits e 64 bits32-bit and 64-bit .NET Framework 4.7.2.NET Framework 4.7.2 .NET Framework 4.8.NET Framework 4.8
Atualização de abril de 2018 do Windows 10Windows 10 April 2018 Update
(versão 1803)(version 1803)
32 bits e 64 bits32-bit and 64-bit .NET Framework 4.7.2.NET Framework 4.7.2 .NET Framework 4.8.NET Framework 4.8
Windows 10 Fall Creators UpdateWindows 10 Fall Creators Update
(versão 1709)(version 1709)
32 bits e 64 bits32-bit and 64-bit .NET Framework 4.7.1.NET Framework 4.7.1 .NET Framework 4.7.2.NET Framework 4.7.2

.NET Framework 4.8.NET Framework 4.8
Atualização do Windows 10 para CriadoresWindows 10 Creators Update
(versão 1703)(version 1703)
32 bits e 64 bits32-bit and 64-bit .NET Framework 4.7.NET Framework 4.7 .NET Framework 4.7.1.NET Framework 4.7.1

.NET Framework 4.7.2.NET Framework 4.7.2

.NET Framework 4.8.NET Framework 4.8
Atualização de Aniversário do Windows 10Windows 10 Anniversary Update
(versão 1607)(version 1607)
32 bits e 64 bits32-bit and 64-bit .NET Framework 4.6.2.NET Framework 4.6.2 .NET Framework 4.7.NET Framework 4.7

.NET Framework 4.7.1.NET Framework 4.7.1

.NET Framework 4.7.2.NET Framework 4.7.2

.NET Framework 4.8.NET Framework 4.8
Atualização de novembro do Windows 10Windows 10 November Update
(versão 1511)(version 1511)
32 bits e 64 bits32-bit and 64-bit .NET Framework 4.6.1.NET Framework 4.6.1 .NET Framework 4.6.2.NET Framework 4.6.2
Windows 10Windows 10
(versão 1507)(version 1507)
32 bits e 64 bits32-bit and 64-bit .NET Framework 4.6.NET Framework 4.6 .NET Framework 4.6.1.NET Framework 4.6.1

.NET Framework 4.6.2.NET Framework 4.6.2
Windows 8.1Windows 8.1 32 bits, 64 bits e ARM32-bit, 64-bit, and ARM .NET Framework 4.5.1.NET Framework 4.5.1 .NET Framework 4.5.2.NET Framework 4.5.2

.NET Framework 4.6.NET Framework 4.6

.NET Framework 4.6.1.NET Framework 4.6.1

.NET Framework 4.6.2.NET Framework 4.6.2

.NET Framework 4.7.NET Framework 4.7

.NET Framework 4.7.1.NET Framework 4.7.1

.NET Framework 4.7.2.NET Framework 4.7.2

.NET Framework 4.8.NET Framework 4.8
Windows 8Windows 8 32 bits, 64 bits e ARM32-bit, 64-bit, and ARM .NET Framework 4.5.NET Framework 4.5 .NET Framework 4.5.1.NET Framework 4.5.1

.NET Framework 4.5.2.NET Framework 4.5.2

.NET Framework 4.6.NET Framework 4.6

.NET Framework 4.6.1.NET Framework 4.6.1
Windows 7 SP1Windows 7 SP1 32 bits e 64 bits32-bit and 64-bit -- .NET Framework 4.NET Framework 4

.NET Framework 4.5.NET Framework 4.5

.NET Framework 4.5.1.NET Framework 4.5.1

.NET Framework 4.5.2.NET Framework 4.5.2

.NET Framework 4.6.NET Framework 4.6

.NET Framework 4.6.1.NET Framework 4.6.1

.NET Framework 4.6.2.NET Framework 4.6.2

.NET Framework 4.7.NET Framework 4.7

.NET Framework 4.7.1.NET Framework 4.7.1

.NET Framework 4.7.2.NET Framework 4.7.2

.NET Framework 4.8.NET Framework 4.8
Windows Vista SP2Windows Vista SP2 32 bits e 64 bits32-bit and 64-bit -- .NET Framework 4.NET Framework 4

.NET Framework 4.5.NET Framework 4.5

.NET Framework 4.5.1.NET Framework 4.5.1

.NET Framework 4.5.2.NET Framework 4.5.2

.NET Framework 4.6.NET Framework 4.6
Windows XPWindows XP 32 bits e 64 bits32-bit and 64-bit -- .NET Framework 4.NET Framework 4

Observações:Notes:

  • Em sistemas Windows 7, .NET Framework requer o Windows 7 SP1.On Windows 7 systems, .NET Framework requires Windows 7 SP1. Se você usa o Windows 7 e ainda não instalou o Service Pack 1, faça isso antes de instalar o .NET Framework.If you're on Windows 7 and haven't yet installed Service Pack 1, you need to do so before installing the .NET Framework.

  • O .NET Framework 4.5 é compatível com o Windows PE (Ambiente de Pré-Instalação do Windows)..NET Framework 4.5 is supported on the Windows Preinstallation Environment (Windows PE). Nem todos os recursos são compatíveis com o Windows PE.Not all features are supported on Windows PE.

  • O .NET Framework 4 também é compatível com a plataforma IA64..NET Framework 4 also supports the IA64 platform.

  • Para todas as plataformas, recomendamos que você atualize para o Service Pack mais recente do Windows e instale atualizações críticas disponíveis no Windows Update para garantir a melhor compatibilidade e segurança.For all platforms, we recommend that you upgrade to the latest Windows Service Pack and install critical updates available from Windows Update to ensure the best compatibility and security.

  • Em sistemas operacionais de 64 bits, .NET Framework dá suporte a WOW64 (processamento de 32 bits em um computador de 64 bits) e processamento nativo de 64 bits.On 64-bit operating systems, .NET Framework supports both WOW64 (32-bit processing on a 64-bit machine) and native 64-bit processing.

Sistemas operacionais de servidor compatíveisSupported server operating systems

Sistema operacionalOperating system Edições compatíveisSupported editions Pré-instalado com o sistema operacionalPreinstalled with the OS Instalado separadamenteInstallable separately
Windows Server 2019Windows Server 2019 64 bits64-bit .NET Framework 4.7.2.NET Framework 4.7.2 .NET Framework 4.8.NET Framework 4.8
Windows Server, versão 1809Windows Server, version 1809 64 bits64-bit .NET Framework 4.7.2.NET Framework 4.7.2 .NET Framework 4.8.NET Framework 4.8
Windows Server, versão 1803Windows Server, version 1803 64 bits64-bit .NET Framework 4.7.2.NET Framework 4.7.2 .NET Framework 4.8.NET Framework 4.8
Windows Server, versão 1709Windows Server, version 1709 64 bits64-bit .NET Framework 4.7.1.NET Framework 4.7.1 .NET Framework 4.7.2.NET Framework 4.7.2
Windows Server 2016Windows Server 2016 64 bits64-bit .NET Framework 4.6.2.NET Framework 4.6.2 .NET Framework 4.7.NET Framework 4.7

.NET Framework 4.7.1.NET Framework 4.7.1

.NET Framework 4.7.2.NET Framework 4.7.2

.NET Framework 4.8.NET Framework 4.8
Windows Server 2012 R2Windows Server 2012 R2 64 bits64-bit .NET Framework 4.5.1.NET Framework 4.5.1 .NET Framework 4.5.2.NET Framework 4.5.2

.NET Framework 4.6.NET Framework 4.6

.NET Framework 4.6.1.NET Framework 4.6.1

.NET Framework 4.6.2.NET Framework 4.6.2

.NET Framework 4.7.NET Framework 4.7

.NET Framework 4.7.1.NET Framework 4.7.1

.NET Framework 4.7.2.NET Framework 4.7.2

.NET Framework 4.8.NET Framework 4.8
Windows Server 2012 (64-bit edition)Windows Server 2012 (64-bit edition) 64 bits64-bit .NET Framework 4.5.NET Framework 4.5 .NET Framework 4.5.1.NET Framework 4.5.1

.NET Framework 4.5.2.NET Framework 4.5.2

.NET Framework 4.6.NET Framework 4.6

.NET Framework 4.6.1.NET Framework 4.6.1

.NET Framework 4.6.2.NET Framework 4.6.2

.NET Framework 4.7.NET Framework 4.7

.NET Framework 4.7.1.NET Framework 4.7.1

.NET Framework 4.7.2.NET Framework 4.7.2

.NET Framework 4.8.NET Framework 4.8
Windows Server 2008 R2 SP1Windows Server 2008 R2 SP1 64 bits64-bit -- .NET Framework 4.NET Framework 4

.NET Framework 4.5.NET Framework 4.5

.NET Framework 4.5.1.NET Framework 4.5.1

.NET Framework 4.5.2.NET Framework 4.5.2

.NET Framework 4.6.NET Framework 4.6

.NET Framework 4.6.1.NET Framework 4.6.1

.NET Framework 4.6.2.NET Framework 4.6.2

.NET Framework 4.7.NET Framework 4.7

.NET Framework 4.7.1.NET Framework 4.7.1

.NET Framework 4.7.2.NET Framework 4.7.2

.NET Framework 4.8.NET Framework 4.8
Windows Server 2008 SP2Windows Server 2008 SP2 32 bits e 64 bits32-bit and 64-bit -- .NET Framework 4.NET Framework 4

.NET Framework 4.5.NET Framework 4.5

.NET Framework 4.5.1.NET Framework 4.5.1

.NET Framework 4.5.2.NET Framework 4.5.2

.NET Framework 4.6.NET Framework 4.6

Observações:Notes:

  • O Windows Server 2012 inclui .NET Framework 4,5, portanto, você não precisa instalá-lo separadamente.Windows Server 2012 includes .NET Framework 4.5, so you don't have to install it separately. Da mesma forma, o Windows Server 2012 R2 inclui o .NET Framework 4.5.1.Similarly, Windows Server 2012 R2 includes .NET Framework 4.5.1.

  • .NET Framework tem suporte limitado para a função Server Core com o Windows Server 2008 R2 SP1 ou posterior..NET Framework has limited support for the Server Core Role with Windows Server 2008 R2 SP1 or later. Consulte Server Core .NET Functionality (Funcionalidade do Server Core .NET) para obter uma lista de APIs incompatíveis.See Server Core .NET Functionality for a list of unsupported APIs.

  • Não há suporte para .NET Framework no Windows Server 2008 R2 for Itanium-Based Systems..NET Framework isn't supported on Windows Server 2008 R2 for Itanium-Based Systems.

  • No Windows Server 2008 SP2, não há suporte para .NET Framework na função Server Core.On Windows Server 2008 SP2, .NET Framework is not supported in the Server Core Role.

  • Para todas as plataformas, recomendamos que você atualize para o último Service Pack do Windows e as atualizações críticas disponíveis no Windows Update para garantir a melhor compatibilidade e segurança.For all platforms, we recommend that you upgrade to the latest Windows Service Pack and critical updates available from Windows Update to ensure the best compatibility and security. A instalação do Windows Service Pack mais recente pode ser necessária em alguns sistemas operacionais.Installation of the latest Windows Service Pack may be required on some operating systems.

  • Em sistemas operacionais de 64 bits, .NET Framework dá suporte a WOW64 (processamento de 32 bits em um computador de 64 bits) e processamento nativo de 64 bits.On 64-bit operating systems, .NET Framework supports both WOW64 (32-bit processing on a 64-bit machine) and native 64-bit processing.

Confira tambémSee also