Pré-requisitos do Exchange Server

Este tópico fornece as etapas para instalar os pré-requisitos necessários para a instalação do sistema operacional Windows Server para os servidores de Caixa de Correio do Exchange Server 2016 e do Exchange Server 2019 e os servidores de Transporte de Borda, e também fornece os pré-requisitos do Windows para instalar as Ferramentas de Gerenciamento do Exchange em computadores clientes do Windows.

Depois que seu ambiente estiver preparado para o Exchange Server, use o Assistente de Implantação do Exchange para as próximas etapas da implantação real. Para saber mais sobre implantações híbridas, confira Implantações Híbridas do Exchange Server.

Para realmente instalar o Exchange 2016 e o Exchange 2019, consulte Implantar novas instalações do Exchange.

Dica

O que você precisa saber antes de começar?

  • Verifique se seu Active Directory atende aos requisitos do Exchange 2016: servidores de rede e diretório do Exchange 2016.

  • A opção de instalação completa do Windows Server 2012 e do Windows Server 2012 R2 deve ser usada para todos os servidores que executam funções de servidor ou ferramentas de gerenciamento do Exchange 2016.

  • Alguns pré-requisitos exigem que você reinicie o servidor para concluir a instalação.

Observação

Não é possível atualizar o Windows de uma versão para outra, ou de Standard para Datacenter, caso o Exchange esteja instalado no servidor.

Observação

Uma novidade do Exchange 2019 é a capacidade de atualizar seu sistema operacional para uma versão mais recente enquanto o Exchange estiver instalado no Windows Server 2019 ou posterior.

  • Verifique se que o computador ingressou no domínio interno apropriado do Active Directory.

  • Instale as atualizações do Windows mais recentes no seu computador.

Dica

Se estiver com dificuldades, peça ajuda nos fóruns do Exchange. Acesse os fóruns em: Exchange Server.

Pré-requisitos do Exchange 2019 para preparar o Active Directory

Você pode usar qualquer membro do domínio do Active Directory para preparar o Active Directory para o Exchange 2019.

  1. O computador requer os seguintes softwares:

    a. .NET Framework 4.8

    Observação

    Ao instalar no Windows Server Core, você deve usar a tecla "/q" para instalar esse pacote. Opcionalmente, você pode usar "/log [PATH]" para o registro em log.

    b. Pacote Redistribuível do Visual C++ para o Visual Studio 2012

    Observação

    • Os requisitos do sistema para o Pacote Redistribuível do Visual C++ não mencionam o suporte para Windows Server 2016 ou Windows Server 2019, mas o pacote redistribuível pode ser instalado com segurança nessas versões do Windows.

    • Uma visão geral das versões mais recentes e compatíveis está disponível em: Versões do Pacote Redistribuível do Visual C++.

    • O pacote redistribuível do Visual C++ é necessário se você estiver usando o Assistente de Configuração do Exchange para preparar o Active Directory. Se você estiver usando a Instalação autônoma da linha de comando para preparar o Active Directory, este pacote não será necessário. Para obter mais informações, consulte Preparar Active Directory e domínios.

  2. Instale o Pacote de Administração de Ferramentas Remotas usando o seguinte comando no Windows PowerShell:

    Install-WindowsFeature RSAT-ADDS
    

Observação

O uso do Assistente de Configuração do Exchange para preparar o Active Directory exige a instalação da função Ferramentas de Gerenciamento do Exchange.

Pré-requisitos do Windows Server 2019 para o Exchange 2019

Os requisitos para instalar o Exchange 2019 em computadores com o Windows Server 2019 são descritos nas seções a seguir. Recomendamos os seguintes métodos para instalar os pré-requisitos do Windows para Exchange 2019:

  • Use a opção /InstallWindowsComponents no modo de Instalação autônoma.
  • Marque a caixa de seleção no Assistente de Configuração do Exchange para instalar os pré-requisitos do Windows.

Ao usar uma dessas opções, não será necessário reiniciar o computador depois que os componentes do Windows forem adicionados.

Servidores de Caixa de Correio do Exchange 2019 no Windows Server 2019

  1. Instale o seguinte software:

    a. .NET Framework 4.8

    b. Pacote Redistribuível do Visual C++ para o Visual Studio 2012

    c. Pacote Redistribuível do Visual C++ para o Visual Studio 2013

    Observação

    • Os requisitos de sistema do pacote redistribuível do Visual C++ não mencionam o suporte ao Windows Server 2016 ou Windows Server 2019, mas o pacote redistribuível é seguro para ser instalado nessas versões do Windows.

    • Uma visão geral das versões mais recentes e compatíveis está disponível em: versões Redistribuíveis do Visual C++ .

  2. Adicione os componentes necessários do Lync Server ou Skype for Business Server:

    a. Instale o recurso Server Media Foundation do Windows executando o seguinte comando no Windows PowerShell:

    Install-WindowsFeature Server-Media-Foundation
    

    b. Instale a Unified Communications Managed API 4.0. Este pacote está disponível para download e na pasta \UCMARedist na mídia do Exchange Server.

    Observação

    Ao instalar o Windows Server Core, você deve usar o pacote de instalação localizado na \UCMARedist da mídia distribuída.

  3. Se você não usar a Configuração do Exchange para instalar os componentes necessários do Windows (no assistente ou na linha de comando), execute um dos seguintes comandos no Windows PowerShell:

    • Experiência Desktop:

      Install-WindowsFeature Server-Media-Foundation, NET-Framework-45-Features, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Clustering-CmdInterface, RSAT-Clustering-Mgmt, RSAT-Clustering-PowerShell, WAS-Process-Model, Web-Asp-Net45, Web-Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Lgcy-Mgmt-Console, Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, Web-Net-Ext45, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, Web-Windows-Auth, Web-WMI, Windows-Identity-Foundation, RSAT-ADDS
      
    • Server Core:

      Install-WindowsFeature Server-Media-Foundation, NET-Framework-45-Features, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Clustering-CmdInterface, RSAT-Clustering-PowerShell, WAS-Process-Model, Web-Asp-Net45, Web-Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Metabase, Web-Mgmt-Service, Web-Net-Ext45, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, Web-Windows-Auth, Web-WMI, RSAT-ADDS
      

Servidores de Transporte de Borda do Exchange 2019 no Windows Server 2019

  1. Instale o seguinte software:

    a. .NET Framework 4.8

    b. Pacote Redistribuível do Visual C++ para o Visual Studio 2012

    Observação

    • Os requisitos de sistema do pacote redistribuível do Visual C++ não mencionam o suporte ao Windows Server 2016 ou Windows Server 2019, mas o pacote redistribuível é seguro para ser instalado nessas versões do Windows.

    • Uma visão geral das versões mais recentes e compatíveis está disponível em: versões Redistribuíveis do Visual C++ .

  2. Se você não usar a Configuração do Exchange para instalar os componentes necessários do Windows (no assistente ou na linha de comando), execute o seguinte comando no Windows PowerShell:

    Install-WindowsFeature ADLDS
    

Pré-requisitos do cliente do Windows 10 para as ferramentas de gerenciamento do Exchange 2019

  1. Instale o Pacote Redistribuível do Visual C++ para o Visual Studio 2012.

    Observação

    • Os requisitos de sistema do pacote redistribuível do Visual C++ não mencionam o suporte ao Windows Server 2016 ou Windows Server 2019, mas o pacote redistribuível é seguro para ser instalado nessas versões do Windows.

    • Uma visão geral das versões mais recentes e compatíveis está disponível em: versões Redistribuíveis do Visual C++ .

  2. Se você não usar a Configuração do Exchange para instalar os componentes necessários do Windows (no assistente ou na linha de comando), execute o seguinte comando no Windows PowerShell:

    Enable-WindowsOptionalFeature -Online -FeatureName IIS-ManagementScriptingTools,IIS-ManagementScriptingTools,IIS-IIS6ManagementCompatibility,IIS-LegacySnapIn,IIS-ManagementConsole,IIS-Metabase,IIS-WebServerManagementTools,IIS-WebServerRole
    

Pré-requisitos do Exchange 2016 para preparar o Active Directory

Você pode usar qualquer membro do domínio do Active Directory para preparar o Active Directory para o Exchange 2016.

  1. O computador requer os seguintes softwares:

    a. .NET Framework 4.8

    b. Pacote Redistribuível do Visual C++ para o Visual Studio 2012

    Observação

    • Os requisitos de sistema do pacote redistribuível do Visual C++ não mencionam o suporte ao Windows Server 2016 ou Windows Server 2019, mas o pacote redistribuível é seguro para ser instalado nessas versões do Windows.

    • Uma visão geral das versões mais recentes e compatíveis está disponível em: versões Redistribuíveis do Visual C++ .

  2. Instale o Pacote de Administração de Ferramentas Remotas usando o seguinte comando no Windows PowerShell:

    Install-WindowsFeature RSAT-ADDS
    

Após a instalação do Remote Tools Administration Pack, você conseguirá usar o computador para preparar o Active Directory. Para saber mais, confira Preparar o Active Directory e domínios.

Pré-requisitos do Windows Server 2016 para o Exchange 2016

Os pré-requisitos necessários para instalar o Exchange 2016 em um computador que executa o Windows Server 2016 depende de quais funções do Exchange você deseja instalar. Leia a seção abaixo correspondente à função que você deseja instalar.

Importante

O Windows Server 2016 requer a Atualização Cumulativa 3 ou posterior do Exchange Server 2016.

Servidores de Caixa de Correio do Exchange 2016 no Windows Server 2016

  1. Execute o seguinte comando no Windows PowerShell para instalar os componentes necessários do Windows:

    Install-WindowsFeature NET-Framework-45-Features, Server-Media-Foundation, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Clustering-CmdInterface, RSAT-Clustering-Mgmt, RSAT-Clustering-PowerShell, WAS-Process-Model, Web-Asp-Net45, Web-Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Lgcy-Mgmt-Console, Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, Web-Net-Ext45, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, Web-Windows-Auth, Web-WMI, Windows-Identity-Foundation, RSAT-ADDS
    
  2. Instale os seguintes softwares nessa ordem:

    a. .NET Framework 4.8

    b. Atualização de segurança de 13 de dezembro de 2016 (KB3206632)

    Observação

    Você só poderá instalar essa atualização se a sua versão do Windows Server 2016 for 14393.576 ou anterior (por volta de dezembro, 2016). Você pode visualizar a versão do Windows Server executando o comando winver. Se a sua versão do Windows Server 2016 for maior que 14393.576, não será necessário ter essa atualização ouo KB3213522 de substituição, lançado uma semana mais tarde. A configuração do Exchange 2016 procura a instalação desta atualização, não permitirá que você continue se essa atualização estiver ausente e o informará claramente se você precisar dela.

    c. Pacote Redistribuível do Visual C++ para o Visual Studio 2012

    d. Pacote Redistribuível do Visual C++ para o Visual Studio 2013

    Observação

    • Os requisitos de sistema do pacote redistribuível do Visual C++ não mencionam o suporte ao Windows Server 2016 ou Windows Server 2019, mas o pacote redistribuível é seguro para ser instalado nessas versões do Windows.

    • Uma visão geral das versões mais recentes e compatíveis está disponível em: Versões Redistribuíveis do Visual C++ .

    • Somente a função Caixa de correio requer os Pacotes redistribuíveis do Visual C++ para Visual Studio 2013. Outras instalações do Exchange (ferramentas de gerenciamento e Transporte de Borda) exigem apenas os Pacotes redistribuíveis do Visual C++ para Visual Studio 2012.

    c. Tempo de execução de 64 bits do Core do Microsoft Unified Communications Managed API 4.0

Servidores de Transporte de Borda do Exchange 2016 no Windows Server 2016

  1. Execute o seguinte comando no Windows PowerShell para instalar os componentes necessários do Windows:

    Install-WindowsFeature ADLDS
    
  2. Instale os seguintes softwares nessa ordem:

    a. .NET Framework 4.8

    b. Pacote Redistribuível do Visual C++ para o Visual Studio 2012

    Observação

    • Os requisitos de sistema do pacote redistribuível do Visual C++ não mencionam o suporte ao Windows Server 2016 ou Windows Server 2019, mas o pacote redistribuível é seguro para ser instalado nessas versões do Windows.

    • Uma visão geral das versões mais recentes e compatíveis está disponível em: versões Redistribuíveis do Visual C++ .

Pré-requisitos do Windows Server 2012 e do Windows Server 2012 R2 para o Exchange 2016

Os pré-requisitos do Exchange 2016 em computadores Windows Server 2012 ou Windows Server 2012 R2 dependem da função do Exchange que será instalada. Leia a seção a seguir que corresponde à função que você deseja instalar.

Servidores de Caixa de Correio do Exchange 2016 no Windows Server 2012 ou Windows Server 2012 R2

  1. Execute o seguinte comando no Windows PowerShell para instalar os componentes necessários do Windows:

    Install-WindowsFeature AS-HTTP-Activation, Server-Media-Foundation, NET-Framework-45-Features, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Clustering-CmdInterface, RSAT-Clustering-Mgmt, RSAT-Clustering-PowerShell, WAS-Process-Model, Web-Asp-Net45, Web-Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Lgcy-Mgmt-Console, Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, Web-Net-Ext45, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, Web-Windows-Auth, Web-WMI, Windows-Identity-Foundation, RSAT-ADDS
    
  2. Instale os seguintes softwares nessa ordem:

    a. .NET Framework 4.8

    b. Pacote Redistribuível do Visual C++ para o Visual Studio 2012

    c. Pacote Redistribuível do Visual C++ para o Visual Studio 2013

    Observação

    • Os requisitos de sistema do pacote redistribuível do Visual C++ não mencionam o suporte ao Windows Server 2016 ou Windows Server 2019, mas o pacote redistribuível é seguro para ser instalado nessas versões do Windows.

    • Uma visão geral das versões mais recentes e compatíveis está disponível em: Versões Redistribuíveis do Visual C++ .

    • Somente a função Caixa de correio requer os Pacotes redistribuíveis do Visual C++ para Visual Studio 2013. As instalações das ferramentas de gerenciamento do Exchange e dos servidores de Transporte de Borda exigem apenas os Pacotes redistribuíveis do Visual C++ para Visual Studio 2012.

    d. Tempo de execução do Core de 64 bits do Microsoft Unified Communications Managed API 4.0

Servidores do Transporte de Borda do Exchange 2016 no Windows Server 2012 ou Windows Server 2012 R2

  1. Execute o seguinte comando no Windows PowerShell para instalar os componentes necessários do Windows:

    Install-WindowsFeature ADLDS
    
  2. Instale os seguintes softwares nessa ordem:

    a. .NET Framework 4.8

    b. Pacote Redistribuível do Visual C++ para o Visual Studio 2012

    Observação

    • Os requisitos de sistema do pacote redistribuível do Visual C++ não mencionam o suporte ao Windows Server 2016 ou Windows Server 2019, mas o pacote redistribuível é seguro para ser instalado nessas versões do Windows.

    • Uma visão geral das versões mais recentes e compatíveis está disponível em: versões Redistribuíveis do Visual C++ .

Pré-requisitos do cliente do Windows para as ferramentas de gerenciamento do Exchange 2016

Ferramentas de gerenciamento do Exchange 2016 no Windows 10

  1. Instalar o. Pacote Redistribuível do Visual C++ para o Visual Studio 2012

    Observação

    • Os requisitos de sistema do pacote redistribuível do Visual C++ não mencionam o suporte ao Windows Server 2016 ou Windows Server 2019, mas o pacote redistribuível é seguro para ser instalado nessas versões do Windows.

    • Uma visão geral das versões mais recentes e compatíveis está disponível em: versões Redistribuíveis do Visual C++ .

  2. Execute o comando a seguir em uma janela elevada do Windows PowerShell (uma janela do Windows PowerShell que você abre selecionando Executar como administrador):

    Enable-WindowsOptionalFeature -Online -FeatureName IIS-ManagementScriptingTools,IIS-ManagementScriptingTools,IIS-IIS6ManagementCompatibility,IIS-LegacySnapIn,IIS-ManagementConsole,IIS-Metabase,IIS-WebServerManagementTools,IIS-WebServerRole
    

Ferramentas de gerenciamento do Exchange 2016 no Windows 8.1

  1. Instale o .NET Framework 4.8

  2. Instalar o. Pacote Redistribuível do Visual C++ para o Visual Studio 2012

    Observação

    • Os requisitos de sistema do pacote redistribuível do Visual C++ não mencionam o suporte ao Windows Server 2016 ou Windows Server 2019, mas o pacote redistribuível é seguro para ser instalado nessas versões do Windows.

    • Uma visão geral das versões mais recentes e compatíveis está disponível em: versões Redistribuíveis do Visual C++ .

  3. Execute o comando a seguir em uma janela elevada do Windows PowerShell (uma janela do Windows PowerShell que você abre selecionando Executar como administrador):

    Enable-WindowsOptionalFeature -Online -FeatureName IIS-ManagementScriptingTools,IIS-ManagementScriptingTools,IIS-IIS6ManagementCompatibility,IIS-LegacySnapIn,IIS-ManagementConsole,IIS-Metabase,IIS-WebServerManagementTools,IIS-WebServerRole