Excel.RangeView interface

RangeView representa um conjunto de células visíveis do intervalo pai.

Propriedades

cellAddresses

Representa os endereços de célula da RangeView.

columnCount

O número de colunas visíveis.

formulas

Representa a fórmula em notação A1.

formulasLocal

Representa a fórmula em notação A1, na formatação de número da localidade e no idioma do usuário. Por exemplo, a fórmula "=SUM(A1, 1.5)" em inglês seria "=SOMA(A1; 1,5)" em português.

formulasR1C1

Representa a fórmula em notação no estilo L1C1.

index

Retorna um valor que representa o índice da RangeView.

numberFormat

Representa o código de formato de número do Excel para determinada célula.

rowCount

O número de linhas visíveis.

rows

Representa uma coleção de exibições de tabelas associadas ao intervalo.

text

Valores de texto do intervalo especificado. O valor de texto não depende da largura da célula. A # substituição de sinal que acontece na IU do Excel não afetará o valor de texto retornado pela API.

values

Representa os valores brutos da exibição do intervalo especificado. Os dados retornados podem ser dos tipos: cadeia de caracteres, número ou booliano. Células que contêm um erro retornarão a cadeia de caracteres de erro.

valueTypes

Representa o tipo de dados de cada célula.

Métodos

getRange()

Obtém o intervalo pai associado à RangeView atual.

load(propertyNames)

Coloca um comando na fila para carregar as propriedades especificadas do objeto. Você deve chamar context.sync() antes de ler as propriedades.

Detalhes da propriedade

cellAddresses

Representa os endereços de célula da RangeView.

readonly cellAddresses: any[][];

Valor da propriedade

any[][]

columnCount

O número de colunas visíveis.

readonly columnCount: number;

Valor da propriedade

number

formulas

Representa a fórmula em notação A1.

formulas: any[][];

Valor da propriedade

any[][]

formulasLocal

Representa a fórmula em notação A1, na formatação de número da localidade e no idioma do usuário. Por exemplo, a fórmula "=SUM(A1, 1.5)" em inglês seria "=SOMA(A1; 1,5)" em português.

formulasLocal: any[][];

Valor da propriedade

any[][]

formulasR1C1

Representa a fórmula em notação no estilo L1C1.

formulasR1C1: any[][];

Valor da propriedade

any[][]

index

Retorna um valor que representa o índice da RangeView.

readonly index: number;

Valor da propriedade

number

numberFormat

Representa o código de formato de número do Excel para determinada célula.

numberFormat: any[][];

Valor da propriedade

any[][]

rowCount

O número de linhas visíveis.

readonly rowCount: number;

Valor da propriedade

number

rows

Representa uma coleção de exibições de tabelas associadas ao intervalo.

readonly rows: RangeViewCollection;

Valor da propriedade

text

Valores de texto do intervalo especificado. O valor de texto não depende da largura da célula. A # substituição de sinal que acontece na IU do Excel não afetará o valor de texto retornado pela API.

readonly text: string[][];

Valor da propriedade

string[][]

values

Representa os valores brutos da exibição do intervalo especificado. Os dados retornados podem ser dos tipos: cadeia de caracteres, número ou booliano. Células que contêm um erro retornarão a cadeia de caracteres de erro.

values: any[][];

Valor da propriedade

any[][]

valueTypes

Representa o tipo de dados de cada célula.

readonly valueTypes: RangeValueType[][];

Valor da propriedade

Detalhes do método

getRange()

Obtém o intervalo pai associado à RangeView atual.

getRange(): Range;

Retornos

load(propertyNames)

Coloca um comando na fila para carregar as propriedades especificadas do objeto. Você deve chamar context.sync() antes de ler as propriedades.

load(propertyNames?: string | string[]): void;

Parâmetros

propertyNames
string | string[]

Uma cadeia de caracteres delimitada por vírgula ou uma matriz de cadeias de caracteres que especificam as propriedades a serem carregadas.

Retornos

void