Erro ao abrir um arquivo no Teams: Você não tem acesso a este arquivo

Sintomas

No Microsoft Teams, você compartilha um arquivo com outro usuário em uma janela de bate-papo. Em seguida, o arquivo é armazenado automaticamente no seu site do OneDrive. Quando o outro usuário tenta abrir o arquivo no Teams, a seguinte mensagem de erro é exibida:

Você não tem acesso a este arquivo.

Motivo

Esse problema ocorre porque o recurso do Modo de bloqueio de permissões de usuário com acesso limitado é ativado no site do OneDrive. Esse é um recurso de conjunto de sites que ajuda a impedir que usuários anônimos acessem páginas de aplicativos que são principalmente úteis em sites clássicos e baseados em SharePoint. Recomendamos que você não habilite esse recurso em sites do OneDrive.

Resolução

Para corrigir esse problema, desative esse recurso no OneDrive.

  1. Entre no site do OneDrive.
  2. Selecione o ícone Configuração no canto superior direito da página.
  3. Selecione Configurações do OneDrive>Mais Configurações.
  4. Em Recursos e armazenamento, selecione Recursos do Conjunto de Sites.
  5. Localize o Modo de bloqueio de permissões de usuário com acesso limitado e, em seguida, selecione Desativar.

Para obter mais informações sobre o Modo de bloqueio de permissões de usuário com acesso limitado, consulte Ativar ou desativar os recursos do conjunto de sites.

Execute uma ferramenta de autodiagnóstico

Os usuários administradores do Microsoft 365 têm acesso a diagnósticos que podem ser executados dentro do locatário para verificar possíveis problemas com o acesso a arquivos compartilhados chat do Teams.

Observação

Esse recurso não está disponível para o Microsoft 365 Government, Microsoft 365 operado pela 21Vianet ou Microsoft 365 Alemanha.

Selecione Executar Testes abaixo, o que preencherá o diagnóstico no Centro de Administração do Microsoft 365.

O diagnóstico executa uma grande variedade de verificações.

Precisa de mais ajuda?

Obtenha ajuda da comunidade online do Microsoft Community, procure mais informações no Suporte da Microsoft ou na Ajuda e Tutorial do Office ou saiba mais sobre as opções de Suporte Assistido.