Erro "0xC004F038: o computador não pôde ser ativado" na ativação do KMS

Este artigo foi escrito por Eric Ashton, engenheiro sênior de escalonamento de suporte.

Sintomas

Você tenta ativar o Microsoft Office 2013 ou o Office 2016 por meio do host KMS (Serviço de Gerenciamento de Chaves) usando qualquer um dos seguintes métodos:

  • Ferramenta de Gerenciamento de Ativação por Volume (VAMT)
  • Assistente de ativação do Office de um computador cliente
  • script OSPP.vbs /act

No entanto, você recebe a seguinte mensagem de erro:

0xC004F038: o Serviço de Licenciamento de Software informou que o computador não pôde ser ativado. A contagem relatada pelo KMS (Serviço de Gerenciamento de Chaves) é insuficiente. Entre em contato com o administrador do sistema.

Motivo

Esse problema ocorre porque o pool de KMS do Office contém menos de cinco computadores cliente exclusivos.

Resolução

Para resolve esse problema, aumente o número de computadores cliente no pool de KMS do Office para cinco ou mais.

Observação

Para determinar quantos computadores cliente estão atualmente no pool do Office KMS no host KMS, execute o seguinte comando em uma janela de Prompt de Comando elevada de c:\windows\system32 e pressione Enter:

Cscript slmgr.vbs -dlv all >c:\temp\KMSInfo.txt

Vá para c:\temp (ou qualquer local personalizado em que você coloque a saída) e abra KMSInfo.txt. Pesquise o Office para encontrar os detalhes da instalação do host do Office KMS. Verifique o valor da Contagem Atual . Se o valor de contagem de KMS do Office for menor que 5, os clientes do Office não serão ativados.

Quando o pool do Office KMS contiver cinco ou mais computadores cliente, tente ativar o Office usando o assistente de ativação do Office, OSPP.vbsou VAMT.

Se você usar a Preparação do Sistema (Sysprep) em seu ambiente, é possível que o Office não tenha sido armado antes da criação da imagem. Portanto, os computadores podem ter a mesma ID do computador cliente (CMID) para o Office.

Se você tiver mais de cinco computadores que estão tentando ativar e ainda vir essa mensagem de erro, marcar o logon do host KMS Visualizador de Eventos no servidor KMS. Por exemplo, você vê entradas que se assemelham ao seguinte:

  • 0x0,5,Ignite1.ignite.local,930bd202-a335-4c7e-bd9d-7305361f0d37,Date/Time,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c
  • 0x0,5,Ignite2.ignite.local,2f362dd3-fb39-4d18-94e6-de1d30dd27d5,Data/hora,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c
  • 0x0,5,Ignite5.ignite.local,930bd202-a335-4c7e-bd9d-7305361f0d37,Data/hora,0,5,0,6f327760-8c5c-417c-9b61-836a98287e0c

Neste exemplo, observe que Ignite5 e ignite1 têm o mesmo CMID (930bd202-a335-4c7e-bd9d-7305361f0d37). Isso indica que o rearm do Office foi ignorado mesmo que a imagem do sistema operacional base possa ter sido gerada.

Observação

Antes que o Sysprep prepare a imagem, verifique se você executa um dos seguintes comandos, com base na versão do Office bit, para garantir um CMID exclusivo do Office.

  • Para o Office de 32 bits

    C:\Arquivos do Programa (x86)\Microsoft Office\Office16\ospprearm.exe

  • Para o Office de 64 bits

    C:\Arquivos do Programa\Microsoft Office\Office16\ospprearm.exe

Para obter informações detalhadas sobre como rearmar a instalação do Office, confira os seguintes artigos:

Você pode executar o script de inicialização a seguir nesses computadores para rearmar o Office e gerar novas IDs exclusivas do Office. Neste script, substitua XX pelo valor apropriado, com base na versão do Office:

XX = 15 para Office 2013

XX = 16 para Office 2016

@echo off

:OSPP 

reg query HKLM\Software\Microsoft\Office\XX.0\Common\OSPPREARM if %errorlevel%==1 (goto RUN) else (goto END)

:RUN set ProgramFilesPath=%ProgramFiles% 

"%ProgramFilesPath%\Microsoft Office\OfficeXX\OSPPREARM.EXE"

C:\Windows\system32\cscript.exe "%ProgramFilesPath%\Microsoft Office\OfficeXX\ospp.vbs" /act set ProgramFilesPath=%ProgramFiles(x86)%

"%ProgramFilesPath%\Microsoft Office\OfficeXX\OSPPREARM.EXE"

C:\Windows\system32\cscript.exe "%ProgramFilesPath%\Microsoft Office\OfficeXX\ospp.vbs" /act REG ADD "HKLM\Software\Microsoft\Office\XX.0\Common\OSPPREARM"

:END

Exit