Erro 80048163 quando um usuário federado tenta entrar no Office 365, no Azure ou no Intune

Observação

O Office 365 ProPlus está sendo renomeado como Microsoft 365 Apps para empresas. Para obter mais informações sobre essa mudança, leia esta postagem de blog.

Problema

Quando um usuário federado tenta entrar em um serviço de nuvem da Microsoft, como o Office 365, o Microsoft Azure ou o Microsoft Intune a partir de uma página da Web de entrada cuja URL começa com https://login.microsoftonline.com , a autenticação desse usuário não é bem-sucedida. O usuário Obtém a seguinte mensagem de erro:

Sorry, but we're having trouble signing you in

Please try again in a few minutes. If this doesn't work, you might want to contact your admin and report the following error:
80048163

Motivo

Esse problema pode ocorrer se uma das seguintes condições for verdadeira:

  • O UPN de um usuário foi atualizado, e as informações de entrada antigas foram armazenadas em cache no servidor dos serviços de Federação do Active Directory (AD FS). Quando a conta SAM do usuário é alterada, as informações de entrada armazenadas em cache podem causar problemas na próxima vez que o usuário tenta acessar os serviços.
  • As declarações que são configuradas no confiança de terceira parte confiável com o Azure Active Directory (Azure AD) retornam dados inesperados. Esse comportamento pode ocorrer quando as declarações associadas ao confiança da terceira parte confiável são editadas ou removidas manualmente.

Solução

Resolução 1: desabilitar o cache de credencial LSA (autoridade de segurança local) no servidor do AD FS

Você pode atualizar a configuração de tempo limite de cache LSA no servidor AD FS para desabilitar o cache de informações de credenciais do Active Directory. Use este método com cuidado. Ele pode colocar uma carga adicional no servidor e no Active Directory.

Importante

Este método contém etapas que explicam como modificar o registro. No entanto, problemas graves poderão ocorrer se você modificar o registro incorretamente. Portanto, certifique-se de seguir essas etapas cuidadosamente. Para mais proteção, faça o backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo sobre como fazer backup e restaurar o registro no Windows.

Para resolver esse problema, siga estas etapas:

  1. Certifique-se de que as alterações no UPN do usuário sejam sincronizadas por meio da sincronização de diretórios.

  2. Instrua o usuário a fazer logoff do computador e, em seguida, fazer logon novamente.

  3. Se as etapas 1 e 2 não resolverem o problema, siga estas etapas:

    1. Abra o editor do registro e localize a seguinte subchave:

      HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Control\Lsa

    2. Clique com o botão direito do mouse em LSA, clique em novoe em valor DWORD.

    3. Digite LsaLookupCacheMaxSizee pressione ENTER para nomear o novo valor.

    4. Clique com o botão direito do mouse em LsaLookupCacheMaxSizee clique em Modificar.

    5. Na caixa dados do valor , digite 0e clique em OK.

    6. Saia do Editor do Registro.

A reconfiguração do LsaLookupCacheMaxSize pode afetar o desempenho de entrada e essa reconfiguração não é necessária após o lado dos sintomas. Esse método deve ser usado apenas temporariamente e é altamente recomendável que você exclua o valor LsaLookupCacheMaxSize após a resolução do problema. Para fazer isso, execute estas etapas:

  1. Abra o editor do registro e localize a seguinte subchave:

    HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Control\Lsa

  2. Clique com o botão direito do mouse em LsaLookupCacheMaxSizee clique em excluir.

  3. Saia do Editor do Registro.

Resolução 2: atualizar o confiança de terceira parte confiável com o Azure AD

Para atualizar a confiança da terceira parte confiável, consulte a seção "como atualizar a configuração do domínio federado do Office 365" do seguinte artigo da Microsoft:

Como atualizar ou reparar as configurações de um domínio federado no Office 365, no Azure ou no Intune

Mais informações

Ainda precisa de ajuda? Acesse o site da Microsoft Community ou os fóruns do Azure Active Directory.