"Já existe um usuário com esse nome. Use um nome diferente. " erro no portal do Office 365

Observação

O Office 365 ProPlus está sendo renomeado como Microsoft 365 Apps para empresas. Para obter mais informações sobre essa mudança, leia esta postagem de blog.

Problema

No Microsoft Office 365, você recebe uma mensagem de erro semelhante à seguinte no portal do Microsoft Office 365:

Já existe um usuário com esse nome. Use um nome diferente.

Motivo

Esse problema pode ocorrer se o nome de usuário já estiver sendo usado ou se um endereço de email existente com base no nome de usuário já existir.

A tentativa de licenciamento falhará se o processo de provisionamento determinar que outro objeto já tem um nome de usuário ou um endereço de email que corresponda ao nome de usuário que está sendo criado.

Por padrão, quando os usuários são adicionados ou atribuídos a uma licença do Exchange Online, os usuários recebem um endereço SMTP principal baseado em seu nome de usuário. E os usuários recebem um endereço de email com base no domínio de roteamento direto do Microsoft Online (MODRD), como, por exemplo, contoso.onmicrosoft.com. Além disso, quando um nome de usuário é alterado, o endereço SMTP principal também pode ser alterado. No entanto, os endereços alternativos não são atualizados ou removidos.

Aqui estão alguns exemplos de cenários.

Cenário 1

Um usuário é adicionado com um nome de usuário john@contoso.com , o MODRD da organização é contoso.onmicrosoft.com e o usuário recebe uma licença do Exchange Online. Neste cenário, são fornecidos os seguintes endereços de email:

  • O usuário recebe um endereço SMTP principal john@contoso.com .
  • O usuário é fornecido com um endereço de email alternativo john@contoso.onmicrosoft.com .

Cenário 2

Um usuário é adicionado com um nome de usuário john@contoso.onmicrosoft.com , o MODRD da organização é contoso.onmicrosoft.com e o usuário recebe uma licença do Exchange Online. Neste cenário, é fornecido o seguinte endereço de email:

  • O usuário recebe um endereço SMTP principal john@contoso.onmicrosoft.com .

Cenário 3

Um nome de usuário é alterado de john@contoso.com para johnsmith@contoso.com . Neste cenário, ocorrem os eventos a seguir:

  • O endereço SMTP principal, john@contoso.com , pode ser alterado para johnsmith@contoso.com .
  • O endereço de email alternativo, john@contoso.com , não é alterado. Portanto, ocorrerão problemas se você tentar adicionar john@contoso.com mais tarde.
  • Nenhum endereço de email alternativo para johnsmith@contoso.onmicrosoft.com foi criado.

Solução

Para corrigir esse problema, siga um ou mais destes procedimentos:

  • Ao adicionar um usuário, use um nome de usuário diferente.
  • Ao adicionar um usuário, localize e altere o nome de usuário existente para que você possa usar o nome de usuário com o qual você está enfrentando o problema.
  • Ao adicionar ou atribuir um usuário a uma licença do Exchange Online, localize e altere os endereços de email existentes baseados no nome de usuário que você está tentando usar.

Para verificar se um endereço de email já existe, siga estas etapas:

  1. Conecte-se ao Exchange Online usando o PowerShell remoto. Para obter mais informações sobre como fazer isso, acesse o seguinte site da Microsoft:

    Conectar-se ao Exchange Online usando o PowerShell remoto

  2. Execute o seguinte cmdlet:

    get-mailbox| where {$_.EmailAddresses -match "user name"} | ft Name, RecipientType, EmailAddresses
    

    Observação

    "nome de usuário" é o nome de usuário com o qual você está enfrentando o problema.

  3. Com base nos resultados recebidos após a execução do cmdlet, atualize ou exclua o endereço de email existente.

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