Visão geral de Consulta no Power BI DesktopQuery overview in Power BI Desktop

Com o Power BI Desktop você pode se conectar ao mundo dos dados, criar relatórios atraentes e fundamentais e compartilhar seus esforços com outras pessoas — que poderão se basear em seu trabalho e expandir seus esforços de business intelligence.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

O Power BI Desktop tem três modos de exibição:Power BI Desktop has three views:

  • Exibição de Relatório – em que você usa as consultas que cria para elaborar visualizações atraentes, organizadas como você deseja que elas apareçam e com várias páginas, que você pode compartilhar com outras pessoasReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Exibição de Dados – consulte os dados em seu relatório no formato de modelo de dados, em que você pode adicionar medidas, criar novas colunas e gerenciar relaçõesData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Exibição de Relações – obtenha uma representação gráfica das relações que foram estabelecidas no seu modelo de dados e gerencie-as ou modifique-as conforme necessário.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Esses modos de exibição são acessados selecionando um dos três ícones no lado esquerdo do Power BI Desktop.These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. Na imagem a seguir, a Exibição de relatório é selecionada, indicada pela faixa amarela ao lado do ícone.In the following image, Report view is selected, indicated by the yellow band beside the icon.

O Power BI Desktop também vem com o Editor de Consultas, no qual você pode se conectar a uma ou várias fontes de dados, formatar e transformar os dados para atender às suas necessidades e, em seguida, carregar esse modelo no Power BI Desktop.Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Este documento fornece uma visão geral do trabalho com dados no Editor de Consultas.This document provides an overview of the work with data in the Query Editor. É claro que há mais para aprender e sendo assim, no final deste documento, você encontrará links para diretrizes detalhadas sobre os tipos de dados para os quais há suporte, conexão a dados, formatação de dados, criação de relações e como começar.There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

Mas primeiro, vamos nos familiarizar com o Editor de Consultas.But first, let’s see get acquainted with Query Editor.

O Editor de ConsultasThe Query Editor

Para ir até o Editor de Consultas, selecione Editar Consultas na guia Página Inicial do Power BI Desktop.To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Sem conexões de dados, o Editor de Consultas é exibido como um painel em branco, pronto para receber dados.With no data connections, Query Editor appears as a blank pane, ready for data.

Quando uma consulta é carregada, a exibição do Editor de Consultas torna-se mais interessante.Once a query is loaded, Query Editor view becomes more interesting. Se nos conectarmos à fonte de dados da Web a seguir, o Editor de Consultas carrega informações sobre os dados, que você pode começar a formatar em seguida.If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

https://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Eis como o Editor de Consultas aparece após o estabelecimento de uma conexão de dados:Here’s how Query Editor appears once a data connection is established:

  1. Na faixa de opções, muitos botões agora estão ativos para interagir com os dados na consultaIn the ribbon, many buttons are now active to interact with the data in the query

  2. No painel esquerdo, as consultas são listadas e ficam disponíveis para seleção, visualização e formataçãoIn the left pane, queries are listed and available for selection, viewing, and shaping

  3. No painel central, dados da consulta selecionada são exibidos e estarão disponíveis para formataçãoIn the center pane, data from the selected query is displayed and available for shaping

  4. A janela Configurações de Consulta é exibida, listando as propriedades da consulta e as etapas aplicadasThe Query Settings window appears, listing the query’s properties and applied steps

Vamos examinar cada uma destas quatro áreas – a faixa de opções, o painel de consultas, a exibição de dados e o painel de configurações de consulta – nas seções a seguir.We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

A faixa de opções de consultaThe query ribbon

A faixa de opções no Editor de Consultas consiste em quatro guias – Página Inicial, Transformar, Adicionar Coluna e Exibição.The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

A guia Home contém as tarefas comuns de consulta, incluindo a primeira etapa em qualquer consulta, que é Obter Dados.The Home tab contains the common query tasks, including the first step in any query, which is Get Data. A imagem a seguir mostra a faixa de opções HomeThe following image shows the Home ribbon.

Para conectar-se a dados e começar a processo de criação de consultas, selecione o botão Obter Dados .To connect to data and begin the query building process, select the Get Data button. Um menu é exibido, fornecendo as fontes de dados mais comuns.A menu appears, providing the most common data sources.

Para obter mais informações sobre as fontes de dados disponíveis, consulte Fontes de Dados.For more information about available data sources, see Data Sources. Para obter informações sobre como se conectar a dados, inclusive exemplos e etapas, consulte Conectar-se a Dados.For information about connecting to data, including examples and steps, see Connect to Data.

A guia Transformar fornece acesso a tarefas comuns de transformação de dados, como adicionar ou remover colunas, alterar os tipos de dados, dividir colunas e outras tarefas direcionadas a dados.The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. A imagem a seguir mostra a guia Transformar .The following image shows the Transform tab.

Para obter mais informações sobre como transformar dados, incluindo exemplos, consulte Combinar e Formatar Dados.For more information about transforming data, including examples, see Combine and Shape Data.

A guia Adicionar Coluna fornece tarefas adicionais associadas à adição de uma coluna, formatação de dados da coluna e adição de colunas personalizadas.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. A imagem a seguir mostra a guia Adicionar Coluna .The following image shows the Add Column tab.

A guia Exibição na faixa de opções é usada para ativar ou desativar a exibição de determinados painéis ou janelas.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Ela também é usada para exibir o Editor Avançado.It’s also used to display the Advanced Editor. A imagem a seguir mostra a guia Exibição .The following image shows the View tab.

É útil saber que muitas das tarefas disponíveis na faixa de opções também estão disponíveis clicando com o botão direito do mouse em uma coluna ou em outros dados, no painel central.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

O painel esquerdoThe left pane

O painel esquerdo exibe o número de consultas ativas, bem como o nome da consulta.The left pane displays the number of active queries, as well as the name of the query. Quando você seleciona uma consulta no painel à esquerda, seus dados são exibidos no painel central, no qual você pode formatar e transformar os dados para atender às suas necessidades.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. A imagem a seguir mostra o painel à esquerda com várias consultas.The following image shows the left pane with multiple queries.

O painel central (dados)The center (data) pane

No painel central ou painel Dados, os dados da consulta selecionada são exibidos.In the center pane, or Data pane, data from the selected query is displayed. É ali que muito do trabalho da Visualização da Consulta é realizado.This is where much of the work of the Query view is accomplished.

Na imagem a seguir, a conexão de dados da Web estabelecida anteriormente é exibida, a coluna Pontuação geral está selecionada e seu cabeçalho foi clicado com o botão direito do mouse para exibir os itens de menu disponíveis.In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. Observe que muitos desses itens de menu de atalho são os mesmos botões nas guias da faixa de opções.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Quando você seleciona um item de menu de clique com o botão direito do mouse (ou um botão da faixa de opções), a Consulta aplica a etapa aos dados e salva-a como parte da própria consulta.When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. As etapas são registradas no painel Configurações de Consulta em ordem sequencial, conforme descrito na próxima seção.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

O painel de configurações de consultaThe query settings pane

O painel de Configurações de Consulta é o local onde todas as etapas associadas a uma consulta são exibidas.The Query Settings pane is where all steps associated with a query are displayed. Por exemplo, na imagem a seguir, a seção Etapas Aplicadas do painel Configurações de Consulta reflete o fato de que acabamos de alterar o tipo da coluna Pontuação geral .For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Conforme as etapas de formatação adicionais são aplicadas à consulta, elas são capturadas na seção Etapas Aplicadas .As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

É importante saber que os dados subjacentes não são alterados; em vez disso, o Editor de Consultas ajusta e formata sua exibição dos dados, sendo que qualquer interação com os dados subjacentes ocorre com base no modo de exibição formatado e modificado do Editor de Consultas para esses dados.It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

No painel Configurações de Consulta , você pode renomear etapas, excluir etapas ou reordenar as etapas conforme necessário.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Para fazer isso, clique com o botão direito do mouse na seção Etapas Aplicadas e selecione uma opção no menu que aparece.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Todas as etapas de consulta são executadas na ordem em que aparecem no painel Etapas Aplicadas .All query steps are carried out in the order they appear in the Applied Steps pane.

O Editor AvançadoThe Advanced Editor

Se você quiser ver o código que a Consulta está criando a cada etapa ou criar seu próprio código de formatação, você pode usar o Editor Avançado.If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. Para iniciar o editor avançado, selecione Exibição na faixa de opções, então selecione Editor Avançado.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Uma janela aparece, mostrando o código de consulta existente.A window appears, showing the existing query code.

Você pode editar o código diretamente na janela Editor Avançado .You can directly edit the code in the Advanced Editor window. Para fechar a janela, selecione o botão Concluído ou Cancelar .To close the window, select the Done or Cancel button.

Salvando seu trabalhoSaving your work

Quando sua consulta está onde você deseja, é possível fazer com que o Editor de Consulta aplique as alterações ao modelo de dados no Power BI Desktop e feche o Editor de Consulta.When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. Para fazer isso, selecione Fechar e Aplicar no menu Arquivo do Editor de Consultas.To do that, select Close & Apply from Query Editor's File menu.

Conforme registramos progresso, o Power BI Desktop fornece uma caixa de diálogo para exibir seu status.As progress is made, Power BI Desktop provides a dialog to display its status.

Uma vez que a consulta esteja onde você quer, ou se você apenas desejar certificar-se de que seu trabalho seja salvo, o Power BI Desktop pode salvar seu trabalho na forma de um arquivo .pbix.Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

Para salvar seu trabalho, selecione Arquivo > Salvar (ou Arquivo > Salvar Como), conforme mostrado na imagem a seguir.To save your work, select File > Save (or File > Save As), as shown in the following image.

Próximas etapasNext steps

Há inúmeras coisas que você pode fazer com o Power BI Desktop.There are all sorts of things you can do with Power BI Desktop. Para obter mais informações sobre seus recursos, consulte as seguintes fontes:For more information on its capabilities, check out the following resources: