Visão geral de Consulta no Power BI DesktopQuery overview in Power BI Desktop

Com o Power BI Desktop você pode se conectar ao mundo dos dados, criar relatórios atraentes e fundamentais e compartilhar seus esforços com outras pessoas — que poderão então se basear em seu trabalho e expandir seus esforços de business intelligence.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

O Power BI Desktop tem três modos de exibição:Power BI Desktop has three views:

  • Exibição de Relatório – em que você usa as consultas que cria para elaborar visualizações atraentes, organizadas como você deseja que elas apareçam e com várias páginas, que você pode compartilhar com outras pessoasReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Exibição de Dados – consulte os dados em seu relatório no formato de modelo de dados, em que você pode adicionar medidas, criar novas colunas e gerenciar relaçõesData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Exibição de Relações – obtenha uma representação gráfica das relações que foram estabelecidas no seu modelo de dados e gerencie-as ou modifique-as conforme necessário.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Acesse essas exibições selecionando um dos três ícones no lado esquerdo do Power BI Desktop.Access these views by selecting one of the three icons along the left side of Power BI Desktop. Na imagem a seguir, a exibição de Relatório está selecionada, indicada pela faixa amarela ao lado do ícone.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Captura de tela do Power BI Desktop mostrando a exibição de Relatório selecionada.

O Power BI Desktop também é fornecido com o Editor do Power Query.Power BI Desktop also comes with Power Query Editor. Use o Editor do Power Query para se conectar a uma ou várias fontes de dados, formatar e transformar os dados para atender às suas necessidades e, em seguida, carregar esse modelo no Power BI Desktop.Use Power Query Editor to connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Este documento fornece uma visão geral do trabalho com os dados no Editor do Power Query, mas há mais coisas para aprender.This document provides an overview of the work with data in the Power Query Editor, but there's more to learn. No final deste documento, você encontrará links para diretrizes detalhadas sobre os tipos de dados compatíveis.At the end of this document, you'll find links to detailed guidance about supported data types. Você também encontrará diretrizes sobre como se conectar a dados, formatar dados, criar relações e como começar a usar.You'll also find guidance about connecting to data, shaping data, creating relationships, and how to get started.

Mas, primeiro, vamos nos familiarizar com o Editor do Power Query.But first, let's see get acquainted with Power Query Editor.

Editor do Power QueryPower Query Editor

Para ir até o Editor do Power Query, selecione Transformar dados na guia Página Inicial do Power BI Desktop.To get to Power Query Editor, select Transform data from the Home tab of Power BI Desktop.

Captura de tela do Power BI Desktop mostrando a guia Página Inicial do Editor do Power Query.

Sem conexões de dados, o Editor do Power Query é exibido como um painel em branco, pronto para receber dados.With no data connections, Power Query Editor appears as a blank pane, ready for data.

Captura de tela do Power BI Desktop mostrando o Editor do Power Query sem conexões de dados.

Quando uma consulta é carregada, a exibição do Editor do Power Query torna-se mais interessante.Once a query is loaded, Power Query Editor view becomes more interesting. Se nos conectarmos à seguinte fonte de dados da Web, o Editor do Power Query carregará informações sobre os dados, que você pode começar a formatar em seguida:If we connect to the following Web data source, Power Query Editor loads information about the data, which you can then begin to shape:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Veja como o Editor do Power Query é exibido após o estabelecimento de uma conexão de dados:Here's how Power Query Editor appears once a data connection is established:

  1. Na faixa de opções, muitos botões agora estão ativos para interagir com os dados na consulta.In the ribbon, many buttons are now active to interact with the data in the query.

  2. No painel esquerdo, as consultas são listadas e ficam disponíveis para seleção, exibição e formatação.In the left pane, queries are listed and available for selection, viewing, and shaping.

  3. No painel central, os dados da consulta selecionada são exibidos e ficarão disponíveis para formatação.In the center pane, data from the selected query is displayed and available for shaping.

  4. O painel Configurações de Consulta é exibido, listando as propriedades da consulta e as etapas aplicadas.The Query Settings pane appears, listing the query's properties and applied steps.

    Captura de tela do Power BI Desktop mostrando o painel Configurações de Consulta no Editor do Power Query.

Vamos examinar cada uma destas quatro áreas: a faixa de opções, o painel Consultas, a exibição de Dados e o painel Configurações de Consulta.We'll look at each of these four areas: the ribbon, the Queries pane, the Data view, and the Query Settings pane.

A faixa de opções de consultaThe query ribbon

A faixa de opções no Editor do Power Query é composta por quatro guias: Página Inicial, Transformar, Adicionar Coluna e Exibir.The ribbon in Power Query Editor consists of four tabs: Home, Transform, Add Column, and View.

A guia Página Inicial contém as tarefas comuns de consulta.The Home tab contains the common query tasks.

Captura de tela do Power BI Desktop mostrando a faixa de opções de consulta do Editor do Power Query.

Para conectar-se aos dados e começar o processo de criação da consulta, selecione Nova Origem.To connect to data and begin the query building process, select New Source. Um menu é exibido, fornecendo as fontes de dados mais comuns.A menu appears, providing the most common data sources.

Captura de tela do Power BI Desktop mostrando o botão Nova Fonte.

Para obter mais informações sobre as fontes de dados disponíveis, consulte Fontes de Dados.For more information about available data sources, see Data Sources. Para obter informações sobre como se conectar a dados, inclusive exemplos e etapas, consulte Conectar-se a Dados.For information about connecting to data, including examples and steps, see Connect to Data.

A guia Transformar fornece acesso a tarefas comuns de transformação de dados, como:The Transform tab provides access to common data transformation tasks, such as:

  • Adicionar ou remover colunasAdding or removing columns
  • Alterar tipos de dadosChanging data types
  • Dividir colunasSplitting columns
  • Outras tarefas controladas por dadosOther data-driven tasks

Captura de tela do Power BI Desktop mostrando a guia Página Inicial.

Para obter mais informações sobre como transformar dados, incluindo exemplos, confira Tutorial: Formatar e combinar dados no Power BI Desktop.For more information about transforming data, including examples, see Tutorial: Shape and combine data in Power BI Desktop.

A guia Adicionar Coluna fornece tarefas adicionais associadas à adição de uma coluna, formatação de dados da coluna e adição de colunas personalizadas.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. A imagem a seguir mostra a guia Adicionar Coluna .The following image shows the Add Column tab.

Captura de tela do Power BI Desktop mostrando a guia Adicionar Coluna.

A guia Exibição na faixa de opções é usada para ativar ou desativar a exibição de determinados painéis ou janelas.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Ela também é usada para exibir o Editor Avançado.It's also used to display the Advanced Editor. A imagem a seguir mostra a guia Exibição .The following image shows the View tab.

Captura de tela do Power BI Desktop mostrando a guia Exibir.

É útil saber que muitas das tarefas disponíveis na faixa de opções também estão disponíveis com o clique do botão direito do mouse em uma coluna ou em outros dados, no painel central.It's useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

O painel esquerdo (Consultas)The left (Queries) pane

O painel esquerdo ou painel Consultas, exibe o número de consultas ativas e o nome da consulta.The left pane, or Queries pane, displays the number of active queries and the name of the query. Quando você seleciona uma consulta no painel à esquerda, seus dados são exibidos no painel central, no qual você pode formatar e transformar os dados para atender às suas necessidades.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. A imagem a seguir mostra o painel esquerdo com uma consulta.The following image shows the left pane with a query.

Captura de tela do Power BI Desktop mostrando Consultas no painel esquerdo.

O painel central (Dados)The center (Data) pane

No painel central ou no painel Dados, os dados da consulta selecionada são exibidos.In the center pane, or Data pane, data from the selected query is displayed. Esse painel é o local em que muito do trabalho da exibição Consulta é realizado.This pane is where much of the work of the Query view is accomplished.

A imagem a seguir mostra a conexão de dados da Web estabelecida anteriormente.In the following image shows the Web data connection established earlier. A coluna Product está selecionada e você pode clicar com o botão direito do mouse no cabeçalho dela para mostrar os itens de menu disponíveis.The Product column is selected, and its header is right-clicked to show the available menu items. Observe que muitos desses itens de menu de atalho são os mesmos botões nas guias da faixa de opções.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Captura de tela do Power BI Desktop mostrando Dados no painel central.

Quando você seleciona um item de menu de clique com o botão direito do mouse (ou um botão de faixa de opções), a consulta aplica a etapa aos dados.When you select a right-click menu item (or a ribbon button), the query applies the step to the data. Ela também salva a etapa como parte da consulta em si.It also saves step as part of the query itself. As etapas são registradas no painel Configurações de Consulta em ordem sequencial, conforme descrito na próxima seção.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

O painel direito (Configurações de Consulta)The right (Query Settings) pane

O painel direito ou painel Configurações de Consulta, é o local em que todas as etapas associadas a uma consulta são exibidas.The right pane, or Query Settings pane, is where all steps associated with a query are displayed. Por exemplo, na imagem a seguir, a seção Etapas Aplicadas do painel Configurações de Consulta reflete o fato de que acabamos de alterar o tipo da coluna Pontuação geral .For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Captura de tela do Power BI Desktop mostrando as Configurações de Consulta no painel direito.

Conforme outras etapas de formatação são aplicadas à consulta, elas são capturadas na seção Etapas Aplicadas.As additional shaping steps are applied to the query, they're captured in the Applied Steps section.

É importante saber que os dados subjacentes não são alterados.It's important to know that the underlying data isn't changed. Em vez disso, o Editor do Power Query ajusta e forma a exibição dos dados.Rather, Power Query Editor adjusts and shapes its view of the data. Ele também formata e ajusta a exibição de qualquer interação com os dados subjacentes que ocorrem com base na exibição formatada e modificada do Editor do Power Query desses dados.It also shapes and adjusts the view of any interaction with the underlying data that occurs based on Power Query Editor's shaped and modified view of that data.

No painel Configurações de Consulta , você pode renomear etapas, excluir etapas ou reordenar as etapas conforme necessário.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Para fazer isso, clique com o botão direito do mouse na seção Etapas Aplicadas e selecione uma opção no menu que aparece.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Todas as etapas de consulta são executadas na ordem em que aparecem no painel Etapas Aplicadas .All query steps are carried out in the order they appear in the Applied Steps pane.

Captura de tela do Power BI Desktop mostrando os filtros Propriedades de Configurações de Consulta e Etapas Aplicadas.

Editor AvançadoAdvanced Editor

O Editor Avançado permite que você veja o código que o Editor do Power Query está criando com cada etapa.The Advanced Editor lets you see the code that Power Query Editor is creating with each step. Ele também permite que você crie um código de formatação próprio.It also lets you create your own shaping code. Para iniciar o editor avançado, selecione Exibição na faixa de opções, então selecione Editor Avançado.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Uma janela aparece, mostrando o código de consulta existente.A window appears, showing the existing query code.
Captura de tela do Power BI Desktop mostrando a caixa de diálogo do Editor Avançado.Screenshot of Power B I Desktop showing Advanced Editor dialog box.

Você pode editar o código diretamente na janela Editor Avançado .You can directly edit the code in the Advanced Editor window. Para fechar a janela, selecione o botão Concluído ou Cancelar .To close the window, select the Done or Cancel button.

Salvando seu trabalhoSaving your work

Quando sua consulta estiver onde você deseja, selecione Fechar e Aplicar no menu Arquivo do Editor do Power Query.When your query is where you want it, select Close & Apply from Power Query Editor's File menu. Essa ação aplica as alterações e fecha o editor.This action applies the changes and closes the editor.
Captura de tela do Power BI Desktop mostrando a opção Fechar e Aplicar na guia Arquivo.Screenshot of Power B I Desktop showing Close and Apply option under File tab.

Conforme registramos progresso, o Power BI Desktop fornece uma caixa de diálogo para exibir seu status.As progress is made, Power BI Desktop provides a dialog to display its status.
Captura de tela da caixa de diálogo do Power BI Desktop mostrando a caixa de diálogo de confirmação Alterações da Consulta Aplicadas.

Quando estiver pronto, o Power BI Desktop poderá salvar seu trabalho na forma de um arquivo .pbix.When you're ready, Power BI Desktop can save your work in the form of a .pbix file.

Para salvar seu trabalho, selecione Arquivo > Salvar (ou Arquivo > Salvar como), conforme mostrado na imagem a seguir.To save your work, select File > Save (or File > Save As), as shown in the following image.
Captura de tela do Power BI Desktop mostrando a guia Arquivo do Editor do Power Query.Screenshot of Power B I Desktop showing Power Query Editor File tab.

Próximas etapasNext steps

Há inúmeras coisas que você pode fazer com o Power BI Desktop.There are all sorts of things you can do with Power BI Desktop. Para obter mais informações sobre seus recursos, consulte as seguintes fontes:For more information on its capabilities, check out the following resources: