Instalar e configurar o WMF 5.1 (Preview)Install and Configure WMF 5.1 (Preview)

Instale o .NET 4.6Install .Net 4.6

É necessário instalar o .NET Framework 4.6 para usar o WMF 5.1.You must install the .NET Framework 4.6 to use WMF 5.1. Isso é necessário para habilitar os novos recursos de assinatura de catálogo, que afetam várias áreas do carregamento de módulo e script no WMF 5.1.This is required to enable the new catalog-signing features, which impacts several areas of module and script loading in WMF 5.1.

O .NET Framework 4.6 está disponível como a KB 3045560.The .NET Framework 4.6 is available as KB 3045560. Instruções de instalação estão disponíveis no local de download.Install instructions are available at the download location.

Observação: esse é um problema conhecido em que o requisito do .NET 4.6 não é detectado pelo instalador do WMF 5.1 Preview; portanto, você poderá instalar o WMF 5.1 Preview antes de instalar o .NET 4.6.Note: It is a known issue that .NET 4.6 requirement is not detected by the WMF 5.1 Preview installer, so you will be able to install WMF 5.1 Preview before installing .NET 4.6. Nossos testes mostraram que é possível instalar o .NET 4.6 após a instalação do WMF 5.1 Preview.Our testing has shown that you can install .NET 4.6 after installing the WMF 5.1 Preview. A versão final do WMF 5.1 verificará corretamente essa exigência de pré-requisito antes da instalação.The final version of WMF 5.1 will correctly check this prerequisite requirement before installing.

Baixe e instale a Preview do WMF 5.1Download and install the WMF 5.1 Preview

Baixe o pacote do WMF 5.1 para o sistema operacional e a arquitetura em que você deseja instalá-lo:Download the WMF 5.1 package for the operating system and architecture you wish to install it on:

Sistema operacionalOperating System Pré-requisitosPrerequisites Links de pacotePackage Links
Windows Server 2012 R2Windows Server 2012 R2 .NET Framework 4.6.NET Framework 4.6 Win8.1AndW2K12R2-KB3156422-x64.msuWin8.1AndW2K12R2-KB3156422-x64.msu
Windows Server 2012Windows Server 2012 .NET Framework 4.6.NET Framework 4.6 W2K12-KB3156423-x64.msuW2K12-KB3156423-x64.msu
Windows Server 2008 R2Windows Server 2008 R2 .NET Framework 4.6.NET Framework 4.6
Windows Management Framework 4.0WMF 4.0
Atualização de segurança para assinatura de código do SHA-2Security update for SHA-2 Code Signing
Win7AndW2K8R2-KB3156424-x64.msuWin7AndW2K8R2-KB3156424-x64.msu
Windows 8.1Windows 8.1 .NET Framework 4.6.NET Framework 4.6 x64: Win8.1AndW2K12R2-KB3156422-x64.msux64: Win8.1AndW2K12R2-KB3156422-x64.msu
x86: Win8.1-KB3156422-x86.msux86: Win8.1-KB3156422-x86.msu
Windows 7 SP1Windows 7 SP1 .NET Framework 4.6.NET Framework 4.6
Windows Management Framework 4.0WMF 4.0
Atualização de segurança para assinatura de código do SHA-2Security update for SHA-2 Code Signing
x64: Win7AndW2K8R2-KB3156424-x64.msux64: Win7AndW2K8R2-KB3156424-x64.msu
x86: Win7-KB3156424-x86.msux86: Win7-KB3156424-x86.msu

Instale o WMF 5.1 do Windows Explorer (ou Explorador de Arquivos no Windows Server 2012 R2 ou Windows 8.1)Install WMF 5.1 from Windows Explorer (or File Explorer in Windows Server 2012 R2 or Windows 8.1)

  1. Navegue até a pasta na qual você baixou o arquivo MSU.Navigate to the folder into which you downloaded the MSU file.

  2. Clique duas vezes no MSU para executá-lo.Double-click the MSU to run it.

Instalar o WMF 5.1 por meio do Prompt de ComandoInstall WMF 5.1 from the Command Prompt##

  1. Depois de baixar o pacote correto para a arquitetura de seu computador, abra uma janela do Prompt de Comando com direitos de usuário elevados (Executar como Administrador).After downloading the correct package for your computer's architecture, open a Command Prompt window with elevated user rights (Run as Administrator). Nas opções de instalação Server Core do Windows Server 2012 R2, Windows Server 2012 ou Windows Server 2008 R2 SP1, por padrão, o Prompt de Comando é aberto com direitos de usuário elevados.On the Server Core installation options of Windows Server 2012 R2, Windows Server 2012, or Windows Server 2008 R2 SP1, Command Prompt opens with elevated user rights by default.

  2. Altere os diretórios para a pasta para a qual você baixou ou copiou o pacote de instalação do WMF 5.1.Change directories to the folder into which you have downloaded or copied the WMF 5.1 installation package.

  3. Execute um dos seguintes comandos:Run one of the following commands:

    • Em computadores que executem o Windows Server 2012 R2 ou o Windows 8.1 x64, execute Win8.1AndW2K12R2-KB3156422-x64.msu /quiet.On computers that are running Windows Server 2012 R2 or Windows 8.1 x64, run Win8.1AndW2K12R2-KB3156422-x64.msu /quiet.
    • Em computadores que executem o Windows Server 2012, execute W2K12-KB3156423-x64.msu /quiet.On computers that are running Windows Server 2012, run W2K12-KB3156423-x64.msu /quiet.
    • Em computadores que executem o Windows Server 2008 R2 SP1 ou o Windows 7 SP1 x64, execute Win7AndW2K8R2-KB3156424-x64.msu /quiet.On computers that are running Windows Server 2008 R2 SP1 or Windows 7 SP1 x64, run Win7AndW2K8R2-KB3156424-x64.msu /quiet.
    • Em computadores que executem o Windows 8.1 x86, execute Win8.1-KB3156422-x86.msu /quiet.On computers that are running Windows 8.1 x86, run Win8.1-KB3156422-x86.msu /quiet.
    • Em computadores que executem o Windows 7 SP1 x86, execute Win7-KB3156424-x86.msu /quiet.On computers that are running Windows 7 SP1 x86, run Win7-KB3156424-x86.msu /quiet.

Notas de Instalação adicionais para Windows Server 2008 R2 SP1 e Windows 7 SP1Additional Installation Notes for Windows Server 2008 R2 SP1 and Windows 7 SP1##

A instalação do Windows Management Framework 5.1 no Windows Server 2008 R2 SP1 ou no Windows 7 SP1 exige a instalação do:Installation of WMF 5.1 on either Windows Server 2008 R2 SP1 or Windows 7 SP1, require the installation of:

Dependência de WinRM – a DSC (Configuração de Estado Desejado) do Windows PowerShell depende do WinRM.WinRM Dependency - Windows PowerShell Desired State Configuration (DSC) depends on WinRM. O WinRM não é habilitado por padrão no Windows Server 2008 R2 e Windows 7.WinRM is not enabled by default on Windows Server 2008 R2 and Windows 7. Execute Set-WSManQuickConfig, em uma sessão de privilégios elevados do Windows PowerShell, para habilitar o WinRM.Run Set-WSManQuickConfig, in a Windows PowerShell elevated session, to enable WinRM.