Erro (acesso negado) para contas de usuário gerenciadas pelo PIM no SharePoint ou no centro de administração do OneDrive

Sintomas

Você recebe uma mensagem de erro "acesso negado" ou tem uma experiência inconsistente ao tentar acessar uma conta de usuário gerenciada pelo gerenciamento de identidade privilegiado (PIM) em um SharePoint Online (SPO) ou no centro de administração do onedrive.

Motivo

O acesso a uma conta de usuário não está disponível imediatamente no SPO quando você solicita esse acesso usando o PIM no Azure Active Directory (AAD). O acesso deve ser concedido no SPO em algumas horas. No entanto, pode levar mais tempo.

Solução alternativa

O possível atraso pode variar. Portanto, recomendamos que você forneça acesso à conta definindo o período de acesso do PIM como 24 horas, em vez de defini-lo como uma duração menor.

A Microsoft está pesquisando esse problema e publicará mais informações neste artigo quando as informações forem disponibilizadas.

Mais informações

Como funciona o PIM e a função de administrador do SharePoint

Se um administrador habilitar a função de administrador do SharePoint no AAD usando o PIM às 7 A.M. por quatro horas, o PIM desabilita a atribuição de função às 11 da manhã. O usuário perde o acesso ao centro de administração do SPO.

Depois que a função é ativada no PIM, ela deve ser sincronizada com o SPO. Essa sincronização pode levar algum tempo para ser concluída. Isso significa que o usuário não terá acesso completo a quatro horas. Por exemplo, se a ativação no PIM terminar às 7 horas e a sincronização do SPO termina às 9 A.M., o usuário terá acesso somente por duas horas (supondo que a duração é de quatro horas).

Portanto, esse problema deve ocorrer se você tentar acessar o centro de administração do SPO imediatamente após habilitar a função no PIM. O sistema requer algum tempo para sincronizar as alterações do AAD para o SPO. Portanto, recomendamos a janela de acesso 24 horas.

Para obter mais informações, consulte os seguintes artigos da base de conhecimento:

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