Alterar o nível de compatibilidade dos bancos de dados de conteúdo para a migração

Ao migrar um banco de dados de conteúdo de um farm do SharePoint para outro, o nível de compatibilidade do banco de dados de conteúdo pode ser menor do que o nível da instância de destino do SQL Server. Isso ocorre porque diferentes farms do SharePoint podem usar versões diferentes do SQL Server. Por causa disso, quando você restaura ou anexa o banco de dados de conteúdo à instância de destino do SQL Server, a versão do SQL Server pode ser maior do que a instância do SQL Server original.

Nesse caso, você pode alterar o nível de compatibilidade do banco de dados se a versão do SQL Server for suportada no farm do SharePoint. No entanto, não é possível alterar o nível de compatibilidade dos bancos de dados do aplicativo de perfil de usuário (UPA), pois não há suporte para ele.

Problema que você pode enfrentar

Se houver uma grande diferença entre a instância do SQL Server original e o destino um, pode levar muito tempo para executar o cmdlet Mount-SPContentDatabase para anexar o banco de dados.

Por exemplo, se o nível de compatibilidade do banco de dados de conteúdo original for 90 (corresponde ao SQL Server 2005) enquanto o banco de dados de destino for 130 (corresponde ao SQL Server 2016), o processo Mount-SPContentDatabase poderá levar horas para ser concluído. O processo pode ser mais rápido se você alterar o nível de compatibilidade do banco de dados de conteúdo original para 130.

Mais informações

Ainda precisa de ajuda? Vá para a comunidade do SharePoint.