Salvar um plano de execução em formato XMLSave an Execution Plan in XML Format

APLICA-SE A: SimSQL Server SimBanco de Dados SQL do Azure NãoAzure Synapse Analytics (SQL DW) NãoParallel Data Warehouse APPLIES TO: YesSQL Server YesAzure SQL Database NoAzure Synapse Analytics (SQL DW) NoParallel Data Warehouse

Use o SQL Server Management StudioSQL Server Management Studio para salvar planos de execução como um arquivo XML e abri-los para exibição.Use SQL Server Management StudioSQL Server Management Studio to save execution plans as an XML file, and to open them for viewing.

Para usar o recurso plano de execução em Management StudioManagement Studio, ou usar as opções SET Showplan XML, os usuários devem ter as permissões apropriadas para executar a consulta Transact-SQLTransact-SQL para qual um plano de execução está sendo gerado, e deve ser concedida a permissão SHOWPLAN para todos os bancos de dados referenciados pela consulta.To use the execution plan feature in Management StudioManagement Studio, or to use the XML Showplan SET options, users must have the appropriate permissions to execute the Transact-SQLTransact-SQL query for which an execution plan is being generated, and they must be granted the SHOWPLAN permission for all databases referenced by the query.

Para salvar um plano de consulta usando as opções SET Showplan XMLTo save a query plan by using the XML Showplan SET options

  1. Em SQL Server Management StudioSQL Server Management Studio abra um editor de consulta e conecte a Mecanismo de Banco de DadosDatabase Engine.In SQL Server Management StudioSQL Server Management Studio open a query editor and connect to Mecanismo de Banco de DadosDatabase Engine.

  2. Ative o SHOWPLAN_XML com a seguinte instrução:Turn SHOWPLAN_XML on with the following statement:

    SET SHOWPLAN_XML ON;  
    GO  
    

    Para ativar o STATISTICS XML, use a seguinte instrução:To turn STATISTICS XML on, use the following statement:

    SET STATISTICS XML ON;  
    GO  
    

    Observação

    O SHOWPLAN_XML gera informações de plano de execução de consulta de tempo de compilação para uma consulta, mas não executa a consulta.SHOWPLAN_XML generates compile-time query execution plan information for a query, but does not execute the query. Ele também é conhecido como o plano de execução estimado.This is also known as the estimated execution plan. O STATISTICS XML gera informações do plano de execução de consulta em runtime para uma consulta e a executa.STATISTICS XML generates runtime query execution plan information for a query, and executes the query. Ele também é conhecido como o plano de execução real.This is also known as the actual execution plan.

  3. Execute uma consulta.Execute a query. Exemplo:Example:

    USE AdventureWorks2012;  
    GO  
    SET SHOWPLAN_XML ON;  
    GO  
    -- Execute a query.  
    SELECT BusinessEntityID   
    FROM HumanResources.Employee  
    WHERE NationalIDNumber = '509647174';  
    GO  
    SET SHOWPLAN_XML OFF;  
    
  4. No painel Resultados , clique com o botão direito do mouse em Plano de execução XML do Microsoft SQL Server que contém o plano de consulta e clique em Salvar Resultados Como.In the Results pane, right-click the Microsoft SQL Server XML Showplan that contains the query plan, and then click Save Results As.

  5. Na caixa de diálogo Salvar <Grade ou Texto> Resultados, na caixa Salvar como tipo, clique em Todos os arquivos (*.*) .In the Save <Grid or Text> Results dialog box, in the Save as type box, click All files (*.*).

  6. Na caixa Nome do arquivo, forneça um nome no formato <name >.sqlplan e clique em Salvar.In the File name box provide a name, in the format <name >.sqlplan, and then click Save.

Para salvar um plano de execução usando opções do SQL Server Management StudioTo save an execution plan by using SQL Server Management Studio options

  1. Gere um plano de execução estimado ou um plano de execução atual usando Management StudioManagement Studio.Generate either an estimated execution plan or an actual execution plan by using Management StudioManagement Studio. Para obter mais informações, consulte Exibir o plano de execução estimado e Exibir um plano de execução real.For more information, see Display the Estimated Execution Plan and Display an Actual Execution Plan.

  2. Na guia Plano de execução do painel de resultados, clique com o botão direito do mouse no plano de execução gráfico e escolha Salvar Plano de Execução Como.In the Execution plan tab of the results pane, right-click the graphical execution plan, and choose Save Execution Plan As.

    Como alternativa, você também pode escolher Salvar Plano de Execução Como no menu Arquivo .As an alternative, you can also choose Save Execution Plan As on the File menu.

  3. Na caixa de diálogo Salvar Como, verifique se a opção Salvar como tipo está definida como Arquivos de Plano de Execução (*.sqlplan) .In the Save As dialog box, make sure that the Save as type is set to Execution Plan Files (*.sqlplan).

  4. Na caixa Nome do arquivo, forneça um nome no formato <name >.sqlplan e clique em Salvar.In the File name box provide a name, in the format <name >.sqlplan, and then click Save.

Para abrir um plano de consulta XML salvo em SQL Server Management StudioTo open a saved XML query plan in SQL Server Management Studio

  1. Em SQL Server Management StudioSQL Server Management Studio, no menu Arquivo , escolha Abrire então clique em Arquivo.In SQL Server Management StudioSQL Server Management Studio, on the File menu, choose Open, and then click File.

  2. Na caixa de diálogo Abrir Arquivo, defina Arquivos de tipo para Arquivos de Plano de Execução (*.sqlplan) para gerar uma lista filtrada dos arquivos de plano de consulta XML salvos.In the Open File dialog box, set Files of type to Execution Plan Files (*.sqlplan) to produce a filtered list of saved XML query plan files.

  3. Selecione o arquivo plano consulta XML que você quer exibir e clique em Abrir.Select the XML query plan file that you want to view, and click Open.

    Como alternativa, no Windows Explorer, clique duas vezes em um arquivo com a extensão .sqlplan.As an alternative, in Windows Explorer, double-click a file with extension .sqlplan. O plano abre em Management StudioManagement Studio.The plan opens in Management StudioManagement Studio.

Consulte TambémSee Also

SET SHOWPLAN_XML (Transact-SQL) SET SHOWPLAN_XML (Transact-SQL)
SET STATISTICS XML (Transact-SQL)SET STATISTICS XML (Transact-SQL)