Reporting Services no SQL Server Data Tools (SSDT)Reporting Services in SQL Server Data Tools (SSDT)

SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) é um MicrosoftMicrosoft Visual StudioVisual Studio ambiente para criar soluções de business intelligence.is a MicrosoftMicrosoft Visual StudioVisual Studio environment for creating business intelligence solutions. O SSDT contém um ambiente de autoria do Designer de Relatórios, em que você pode abrir, modificar, visualizar, salvar e implantar Reporting ServicesReporting Services definições de relatório paginados, fontes de dados compartilhados, conjuntos de dados compartilhados e partes de relatório.SSDT features the Report Designer authoring environment, where you can open, modify, preview, save, and deploy Reporting ServicesReporting Services paginated report definitions, shared data sources, shared datasets, and report parts. SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) não é incluído com o SQL Server.is not included with SQL Server. Baixar o SQL Server Data Tools.Download SQL Server Data Tools.

Este tópico descreve as soluções, os projetos, os modelos de projetos e as configurações do SQL Server Data ToolsSQL Server Data Tools usados para o Reporting ServicesReporting Servicese as exibições, menus, barras de ferramentas e atalhos que podem ser usados no Designer de Relatórios.This topic describes SQL Server Data ToolsSQL Server Data Tools solutions, projects, project templates, and configurations used for Reporting ServicesReporting Services, and the views, menus, toolbars, and shortcuts that you can use in Report Designer.

Para começar a criação de relatórios, consulte Criar relatórios com o Designer de Relatórios (SSRS).To get started designing reports, see Design Reports with Report Designer (SSRS).

Soluções e projetosSolutions and Projects

Um projeto de relatório atua como um contêiner para recursos e definições de relatório.A report project acts as a container for report definitions and resources. Cada arquivo no projeto de relatório é publicado no servidor de relatório quando o projeto é implantado.Every file in the report project is published to the report server when the project is deployed. Quando você cria um projeto pela primeira vez, uma solução também é criada como contêiner para o projeto.When you create a project for the first time, a solution is also created as a container for the project. É possível adicionar vários projetos a uma única solução.You can add multiple projects to a single solution.

ConfiguraçõesConfigurations

Para criar vários conjuntos de propriedades de projeto para variações de implantação como teste de empresa e servidores de relatórios de produção, use o Gerenciador de Configuração.To create multiple sets of project properties for deployment variations such as enterprise test and production report servers, use the Configuration Manager. Para obter mais informações, veja Implantação e suporte de versão no SQL Server Data Tools (SSRS).For more information, see Deployment and Version Support in SQL Server Data Tools (SSRS).

Projetos do Servidor de RelatórioReport Server Projects

Ao instalar o Reporting ServicesReporting Services, os seguintes modelos de projeto são disponibilizados em SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT):When you install Reporting ServicesReporting Services, the following project templates are made available in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT):

  • Projeto do servidor de relatório.Report Server Project. Quando você seleciona um Projeto do Servidor de Relatórios, o Designer de Relatórios é aberto.When you select a Report Server Project, Report Designer opens. O Projeto do Servidor de Relatório é um modelo Projetos do Business Intelligence instalado pelo Visual StudioVisual Studio que está disponível na caixa de diálogo Novo Projeto .A Report Server Project is a Business Intelligence Projects template installed by Visual StudioVisual Studio that is available from the New Project dialog box. Para obter mais informações, consulte Adicionar um relatório novo ou existente a um projeto de relatório (SSRS). As propriedades de projeto do Servidor de Relatório se aplicam a todos os relatórios e a todas as fontes de dados compartilhadas em um projeto do SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).For more information, see Add a New or Existing Report to a Report Project (SSRS).Report Server project properties apply to all reports and all shared data sources in a SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) project. Estas propriedades incluem a URL para o servidor de relatórios e os nomes de pastas para relatórios e fontes de dados compartilhadas.These properties include the URL for the report server and the folder names for reports and shared data sources. Use a caixa de diálogo Páginas de Propriedades de Projeto para exibir os valores da propriedade atual.Use the Project Property Pages dialog box to view the current property values. Para abrir essa caixa de diálogo, no menu Projeto , clique em Propriedades.To open this dialog box, on the Project menu, click Properties.

  • Assistente de projeto do servidor de relatório.Report Server Project Wizard. Quando você seleciona um Projeto do Assistente do Servidor de Relatórios, um projeto do servidor de relatórios é criado automaticamente e o Assistente de Relatório, aberto.When you select a Report Server Wizard Project, a report server project is automatically created, and the Report Wizard opens. No assistente, você pode criar um relatório seguindo as instruções em cada página para criar uma cadeia de conexão em uma origem de dados, definir credenciais de fonte de dados, criar uma consulta, adicionar uma região de dados de tabela ou matriz, especificar dados e grupos de relatórios, selecionar um estilo de fonte e cor, publicar o relatório em um servidor de relatórios e visualizá-lo localmente.In the wizard, you can create a report by following instructions on each page to create a connection string to a data source, set data source credentials, design a query, add a table or matrix data region, specify report data and groups, pick a font and color style, publish the report to a report server, and preview the report locally. Depois de criar um relatório com o assistente, você pode alterar os dados e o designer de relatórios, usando o Designer de Relatórios no Projeto do Servidor de Relatórios.After you create a report with the wizard, you can change the report data and the report designer by using Report Designer in the Report Server project.

Novos modelos de Projeto no SSDTNew Project templates in SSDT

Janelas e painéis do Designer de RelatóriosReport Designer Windows and Panes

O Designer de Relatórios dá suporte a dois modos de exibição: Design para definir os dados e layout do relatório, e Visualização para exibir uma exibição processada do relatório.Report Designer supports two views: Design to define the report data and report layout, and Preview to display a rendered view of the report. Em cada exibição, você pode exibir várias janelas úteis para design ou exibição de um relatório renderizado.In each view, you can display multiple windows to help you design or view a rendered report.

Painel de Dados do RelatórioReport Data Pane

O painel de Dados do Relatório exibe campos internos, fontes de dados, conjuntos de dados, coleções de campos, parâmetros do relatório e imagens.The Report Data pane displays built-in fields, data sources, datasets, field collections, report parameters, and images.

Use o painel de Dados do Relatório para exibir:Use the Report Data pane to view:

  • Campos Internos Informações predefinidas do relatório, como o nome do relatório ou a hora em que o relatório foi processado.Built-in Fields Predefined report information such as the report name or the time the report was processed.

  • Fontes de dados Uma fonte de dados representa um nome e uma conexão a uma fonte de dados.Data sources A data source represents a name and connection to a source of data.

  • Conjuntos de Dados Cada conjunto de dados inclui uma consulta que especifica quais dados recuperar da fonte de dados.Datasets Each dataset includes a query that specifies which data to retrieve from the data source. Expanda o conjunto de dados para exibir a coleção de campos especificada pela consulta de conjunto de dados.Expand the dataset to view the collection of fields specified by the dataset query.

    Em alguns designers de consulta de conjuntos de dados multidimensionais, você pode especificar filtros no painel Filtros e indicar se deseja criar parâmetros de relatório.In some query designers for multidimensional datasets, you can specify filters in the Filters pane and indicate whether to create report parameters. Se você especificar a opção de parâmetro de relatório, um conjunto de dados especial será criado automaticamente para popular a lista de valores válidos dos parâmetros.If you specify the report parameter option, a special dataset is automatically created to populate the parameter's valid values list. Por padrão, esses conjuntos de dados não são exibidos no painel de dados do relatório.By default, the dataset does not appear in the Report Data Pane. Para obter mais informações, consulte Mostrar conjuntos de dados ocultos para obter valores de parâmetros para dados multidimensionais (Construtor de Relatórios e SSRS).For more information, see Show Hidden Datasets for Parameter Values for Multidimensional Data (Report Builder and SSRS).

  • Parâmetros de Relatório A lista de parâmetros de relatório.Report parameters The list of report parameters. Os parâmetros podem ser criados manual ou automaticamente quando uma consulta de conjunto de dados inclui parâmetros de consulta.Parameters can be created manually or automatically when a dataset query includes query parameters.

  • Imagens A lista de imagens que estão disponíveis para serem incluídas como um item de Imagem em um relatório.Images The list of images that are available to include as an Image report item in a report.

As fontes de dados e os conjuntos de dados no painel Dados do Relatório representam os elementos da definição do relatório.Data sources and datasets in the Report Data pane represent the elements in the report definition. O painel de Dados do Relatório é um recurso com suporte de vários ambientes de criação de relatórios.The Report Data pane is a feature supported by multiple report authoring environments. No Construtor de Relatórios, esse é o único painel disponível para gerenciar fontes de dados e conjuntos de dados.In Report Builder, it is the only pane available for managing data sources and datasets. No Designer de Relatórios, o painel de Dados do Relatório funciona com o Gerenciador de Soluções, que lista fontes de dados e conjuntos de dados compartilhados como arquivos.In Report Designer, the Report Data pane works with Solution Explorer, which lists shared data sources and shared datasets as files. As fontes de dados compartilhadas e os conjuntos de dados compartilhados do painel de Dados do Relatório devem apontar para suas fontes de dados compartilhadas e conjuntos de dados compartilhados no Gerenciador de Soluções.Shared data sources and shared datasets in the Report Data pane must point to their corresponding Shared Data Sources and Shared Datasets in Solution Explorer. Os elementos do painel de Dados do Relatórios então contêm uma referência aos arquivos de dados no Gerenciador de Soluções.The Report Data pane elements then contain a reference to the data files in Solution Explorer. As propriedades do projeto determinam se as fontes de dados compartilhadas e os conjuntos de dados compartilhados são implantados no servidor de relatório ou no site do SharePoint.The project properties determine whether the shared data sources and shared datasets are deployed to the report server or SharePoint site. Para obter mais informações, consulte Converter fontes de dados (Construtor de Relatórios e SSRS).For more information, see Convert Data Sources (Report Builder and SSRS).

Observação

Se o painel Dados do Relatório não estiver visível, clique na área de Design e, em seguida, no menu Exibir , clique em Dados do Relatório.If you do not see the Report Data pane, click in the Design area and then on the View menu, click Report Data. Se o painel de dados do relatório estiver flutuando, é possível ancorá-lo.If the Report Data pane is floating, you can anchor it. Para obter mais informações, consulte Encaixar o painel de dados do relatório no Designer de Relatórios (SSRS).For more information, see Dock the Report Data Pane in Report Designer (SSRS).

Painel AgrupamentoGrouping Pane

Use o painel de Agrupamento para definir grupos para uma região de dados tablix.Use the Grouping pane to define groups for a tablix data region. É possível definir grupos de linhas e de detalhes para tabelas, e grupos de linhas e de colunas para matrizes.You can define row groups and detail groups for tables and row and column groups for matrices. Você não pode usar o painel de Agrupamento para definir grupos para Gráficos ou outras regiões de dados.You cannot use the Grouping pane to define groups for Charts or other data regions. Para obter mais informações, consulte Compreendendo grupos (Construtor de Relatórios e SSRS).For more information, see Understanding Groups (Report Builder and SSRS).

O painel de Agrupamento tem dois modos:The Grouping pane has two modes:

  • Padrão.Default. Use a caixa de diálogo Padrão para exibir todos os grupos de linhas e colunas em um formato hierárquico que mostre a relação dos grupos pai, filho, adjacentes e de detalhes.Use the Default mode to display all row and column groups in a hierarchical format that shows the relationship of parent groups, child groups, adjacent groups, and detail groups. Um grupo filho aparece em e sob o próximo nível de recuo em relação ao respectivo grupo pai.A child group appears under and at the next indent level compared to its parent group. Um grupo adjacente é exibido no mesmo nível de recuo que seus grupos irmãos ou pares.An adjacent group appears at the same indent level as its peer or sibling groups.

    Use o modo padrão para adicionar, editar ou excluir grupos.Use default mode to add, edit, or delete groups. Para grupos baseados em um único campo de conjunto de dados, arraste o campo para o painel de Grupos de Linhas ou de Grupos de Colunas.For groups based a single dataset field, drag the field to the Row Groups or Column Groups pane. É possível inserir o grupo acima ou abaixo de um grupo existente.You can insert the group above or below an existing group. Para adicionar um grupo adjacente, clique com o botão direito do mouse no grupo irmão e use o menu de atalhos.To add an adjacent group, right-click the sibling group, and use the shortcut menu. Para exibir quais células tablix pertencem a um grupo, selecione o grupo no painel de Agrupamento.To display which tablix cells belong to a group, select the group in the Grouping pane.

  • Avançado.Advanced. Use a caixa de diálogo Avançado para exibir os membros de grupos de linhas e de colunas estáticos e dinâmicos da região de dados tablix selecionada.Use the Advanced mode to display static and dynamic row and column group members of the selected tablix data region. Use os membros do grupo para definir as propriedades que controlam a visibilidade das linhas e colunas associadas a um grupo ou a um membro do grupo ou as regras que os renderizadores usam ao tentar manter os grupos juntos em uma página.You must use group members to set properties that control the visibility of the rows and columns associated with a group or group member, or the rules that renderers use to try to keep groups together on a page. Os membros do grupo aparecem na superfície de design como células no grupo de linhas e nas áreas do grupo de colunas.Group members appear on the design surface as cells in the row group and column group areas.

Observação

Para alternar entre os modos Padrão e Avançado , clique com o botão direito do mouse na seta para baixo à direita do ícone Grupos de Colunas .To toggle between Default and Advanced modes, right-click the down arrow to the right of the Column Groups icon.

Para obter mais informações, consulte Grouping Pane.For more information, see Grouping Pane.

Caixa de FerramentasToolbox

A Caixa de Ferramentas contém itens de relatório que você pode arrastar para a superfície de design.The Toolbox contains report items that you can drag to the design surface. Regiões de dados são itens de relatório que você usa para organizar os dados no relatório.Data regions are report items that you use to organize data on the report. Tabela, Matriz, Lista, Gráfico, Medidor, Barra de dados, Minigráfico e Indicador são regiões de dados.Table, Matrix, List, Chart, Gauge, Data Bar, Sparkline, and Indicator are data regions. Outros itens de relatório incluem Mapa, Caixa de Texto, Retângulo, Linha, Imagem e Sub-relatório.Other report items include Map, Text Box, Rectangle, Line, Image, and Subreport. Itens de relatório personalizados também podem constar dessa lista se forem instalados e registrados pelo administrador do sistema.Custom report items might also appear on this list if they have been installed and registered by your system administrator.

Painel PropriedadesProperties Pane

O painel Propriedades é uma janela do Visual StudioVisual Studio padrão que apresenta os nomes e os valores das propriedades para o item de relatório atualmente selecionado na superfície de design.The Properties pane is a standard Visual StudioVisual Studio window that shows property names and values for the currently selected report item on the design surface. Na maioria dos casos, os nomes de propriedades correspondem aos elementos e atributos no arquivo de linguagem RDL.In most cases, property names correspond to elements and attributes in the Report Definition Language (RDL) file. As propriedades mais comumente utilizadas podem ser definidas usando a caixa de diálogo Propriedades do item selecionado.The most commonly used properties can be set by using the Properties dialog box for the selected item. Para abrir a caixa de diálogo correspondente, clique no botão Páginas de Propriedades na barra de tarefas do painel Propriedades.To open the corresponding dialog box, click the Property Pages button on the Properties pane toolbar. Os usuários avançados podem definir valores de propriedades diretamente no painel de Propriedades.Advanced users can set property values directly in the Properties pane.

Use o painel de Propriedades para:Use the Properties pane to:

  • Definir propriedades para o item selecionado na superfície de design.Set properties for the currently selected item on the design surface. Algumas propriedades apresentam uma lista suspensa de valores.Some properties provide a drop-down list of values. Também é possível digitar o valor diretamente na célula.You can also type the value directly in the cell. Algumas propriedades contêm uma coleção de valores, indicada pelo valor (Coleção) .Some properties contain a collection of values, indicated by the value (Collection). A maioria das propriedades pode aceitar uma expressão; expressões complexas são indicadas pelo valor <Expression> .Most properties can accept an expression; complex expressions are indicated by the value <Expression>. Clique em <Expression> para abrir a caixa de diálogo Expressão.Click <Expression> to open the Expression dialog box. Para obter mais informações, consulte Expression Dialog Box.For more information, see Expression Dialog Box.

  • Use os botões da barra de tarefas do painel Propriedades para alterar a grade de exibição por categoria para exibição alfabética.Use the Properties pane toolbar buttons to change the grid from category view to alphabetical view. Na exibição por categoria, pode ser necessário expandir a categoria para ver todas as propriedades que ela contém.In category view, you may need to expand a category to see all the properties under it. Para abrir a caixa de diálogo Propriedades de um item, clique no botão Páginas de Propriedades na barra de ferramentas ou clique no item com o botão direito do mouse e clique em Propriedades.To open an item's Properties dialog box, click the Property Pages button on the toolbar or by right-click the item and click Properties.

  • Defina as propriedades do membro do grupo selecionado atualmente no painel de Agrupamento.Set properties for the currently selected group member in the Grouping pane. A propriedades de membro do grupo ajudam a controlar como as linhas de cabeçalho e de rodapé de grupos estáticos são repetidas para cada instância do grupo.Group member properties help control how static group header and footer rows repeat for each group instance. Para obter mais informações, consulte Exibir cabeçalhos e rodapés com um grupo (Construtor de Relatórios e SSRS).For more information, see Display Headers and Footers with a Group (Report Builder and SSRS).

Para exibir o painel Propriedades, no menu Exibir , clique em Janela Propriedades.To display the Properties pane, from the View menu, click Properties Window. É possível desencaixar esse painel e movê-lo para outra área da janela do SQL Server Data ToolsSQL Server Data Toolsou exibi-lo como uma exibição com guias na superfície de design.You can undock this pane and move it to another area of the SQL Server Data ToolsSQL Server Data Toolswindow, or display it as a tabbed view on the design surface.

Gerenciador de SoluçõesSolution Explorer

O Gerenciador de Soluções é um componente padrão do Visual StudioVisual Studio que exibe todos os itens do projeto.Solution Explorer is a standard Visual StudioVisual Studio component that displays all the items in your project. Para um projeto do Servidor de Relatório, isso inclui pastas para organizar fontes de dados compartilhadas, conjuntos de dados compartilhados, relatórios e recursos.For a Report Server project, this includes folders to organize shared data sources, shared datasets, reports and resources. Os itens de pasta são automaticamente alfabetizados quando você abre o arquivo da solução.Folder items are automatically alphabetized when you open the solution file. Para exibir propriedades de itens no painel de Propriedades, selecione o item.To view item properties in the Properties pane, select the item.

SaídaOutput

A janela Saída exibe os erros de processamento quando você visualiza um relatório e os erros de publicação quando você implanta um relatório ou uma fonte de dados compartilhada.The Output window displays processing errors when you preview a report, and publishing errors when you deploy a report or a shared data source.

Use a Saída e as janelas da Estrutura de Tópicos do Documento para ajudar a depurar erros em expressões.Use the Output and the Document Outline windows to help debug errors in expressions.

Estrutura de Tópicos do DocumentoDocument Outline

A janela Estrutura de Tópicos do Documento exibe uma lista hierárquica de todos os itens de relatório na definição do relatório.The Document Outline window displays a hierarchical list of all report items in the report definition. Para abrir o painel Estrutura de Tópicos do Documento, no menu Exibir , aponte a Outras Janelas e clique em Janela de Documentos.To open the Document Outline pane, from the View menu, point to Other Windows and click Document Window.

Use o painel de Estrutura de Tópicos do Documento para ajudar a identificar caixas de texto e outros itens de relatório por nome.Use the Document Outline pane to help identify text boxes and other report items by name. Quando você seleciona um item na Estrutura de Tópicos do Documento, o item também é selecionado na Superfície de Design.When you select an item in the Document Outline, the item is also selected on the Design Surface.

Lista de TarefasTask List

A janela Lista de Tarefas exibe erros de compilação para recursos sem-suporte quando você importa um relatório de outro aplicativo, como o MicrosoftMicrosoft Access.The Task List window displays build errors for unsupported features when you import a report from another application, such as MicrosoftMicrosoft Access.

Exibição do design do Designer de RelatóriosReport Designer Design View

Por padrão, quando você cria um projeto do Servidor de Relatório, o Designer de Relatórios é aberto na exibição Design e exibe a superfície de design.By default, when you create a Report Server project, Report Designer opens in Design view and displays the design surface. Por padrão, a superfície de design exibe o corpo do relatório e o plano de fundo do relatório.By default, the design surface displays the report body and the report background.

O menu de atalhos no plano de fundo apresenta opções para adicionar cabeçalho e rodapé de página e, no menu Exibir, exibe uma régua e o painel Agrupamento.The shortcut menu on the background provides options to add a page header and page footer, and from the View menu, display a ruler and the Grouping pane.

Use o controle de zoom para aumentar ou diminuir a ampliação do relatório.Use the zoom control to increase or decrease the magnification of the report.

Para criar um relatório, arraste os itens de relatório da Caixa de Ferramentas para a superfície de design e, em seguida, configure suas propriedades e altere sua disposição no relatório.To design a report, drag report items from the Toolbox to the design surface, and then configure their properties and alter their arrangement on the report.

Visualização do Designer de RelatóriosReport Designer Preview

Use Visualização para executar o relatório e exibir o relatório renderizado no visualizador de relatórios.Use Preview to run the report and view the rendered report in the report viewer. Visualize os dados dos relatórios em cache localmente.Preview caches report data locally. Você também pode definir as propriedades de configuração para executar o relatório na exibição de depuração, usando um navegador.You can also set configuration properties to run the report in debug view, using a browser.

Quando você visualiza um relatório, o Designer de Relatórios conecta-se às fontes de dados do relatório, executa consultas nos conjuntos de dados, armazena em cache os dados no computador local, processa o relatório de modo a combinar dados e layout, e renderiza o relatório.When you preview a report, Report Designer connects to the report data sources, runs dataset queries, caches the data on the local computer, processes the report to combine data and layout, and renders the report. É possível exibir o relatório na guia Visualizar ou configurar as propriedades do projeto para exibi-lo no modo de depuração e diretamente em um navegador.You can view the report in on the Preview tab or you can set up project properties to view the report in debug mode and view it directly in a browser.

  • Visualizando relatórios com parâmetros.Previewing Parameterized Reports. Quando você visualiza um relatório, ele será processado automaticamente se todos os parâmetros forem valores padrão válidos.When you preview a report, the report is processed automatically if all report parameters have valid default values. Se um ou mais parâmetros do relatório não tiver um valor padrão válido, você deve escolher um valor para cada parâmetro não atribuído e, na barra de ferramentas de relatórios, clicar em Exibir Relatório.If one or more report parameters do not have a valid default value, you must choose a value for each unassigned parameter, and then, on the report toolbar, click View Report.

  • Compreendendo o cache de dados local Quando você visualiza um relatório, o processador de relatórios executa todas as consultas dos conjuntos de dados no relatório com os padrões atuais dos parâmetros e salva os resultados como um arquivo de cache de dados local (.rdl.data).Understanding the Local Data Cache When you preview a report, the report processor runs all the queries for datasets in the report using the current parameter defaults, and saves the results as a local data cache (.rdl.data) file. É possível continuar a criar o relatório sem incorrer na sobrecarga de recuperar os dados novamente caso você não faça nenhuma alteração nas consultas do conjunto de dados de relatório ou nos parâmetros do relatório.You can continue to design your report without incurring the overhead of retrieving this data again if you make no changes to either the report dataset queries or the report parameters.

  • Visualizando o relatório usando o Gerenciador de configuração e depuração.Previewing the Report using Configuration Manager and Debug. No SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), as propriedades do projeto definem como você deseja implantar e depurar seus relatórios.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), project properties define how you want to deploy and debug your reports. Essas propriedades são aplicadas a todos os relatórios e fontes de dados compartilhadas no projeto.These properties apply to all reports and shared data sources in the project. Para definir as propriedades de projeto, no menu Projeto , clique em Propriedades.To set the project properties, from the Project menu, click Properties. Use estas configurações para testar seus relatórios e publicá-los no servidor de relatórios.Use these settings to test your reports and publish them to the report server.

  • Monitorando o painel Saída para mensagens de erro.Monitoring the Output Pane for Error Messages. Quando você visualiza um relatório e o processador de relatório detecta um problema, ele registra as mensagens de erro no painel Saída.When you preview a report and the report processor detects a problem, it writes error messages to the Output pane.

Menus do Designer de RelatóriosReport Designer Menus

Quando um projeto do Designer de Relatórios está ativo no SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), as barras de ferramentas a seguir são adicionadas à barra de ferramentas principal.When a Report Designer project is active in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), the following toolbars are added to the main toolbar. Os menus do Designer de Relatórios são visíveis apenas na exibição Design.The Report Designer menus are visible only when in Design view.

Menu FormatarFormat Menu

Quando você seleciona um item na superfície de design, o menu Formatar contém as seguintes opções:When you select an item on the design surface, the Format menu contains the following options:

  • Cor do Primeiro Plano Selecione uma cor de texto.Foreground Color Select a text color. Preto é a cor de texto padrão.Black is the default text color.

  • Cor do Plano de Fundo Selecione uma cor de plano de fundo para as caixas de texto e regiões de dados.Background Color Select a background color for your text boxes and data regions.

  • Fonte Especifique se o texto deve estar em negrito, itálico ou sublinhado.Font Specify whether the text is bold, italic, or underlined.

  • Justificar Especifique se o texto deve estar alinhado à direita, ao centro ou à esquerda.Justify Specify whether the text is right-aligned, centered, or left-aligned.

  • Alinhar Especifique o alinhamento entre os objetos no relatório.Align Specify how the selected objects are aligned in relation to one another within the report.

  • Mesmo Tamanho Ajuste o tamanho dos objetos selecionados no relatório.Make Same Size Adjust the size of the selected objects within the report.

  • Espaçamento horizontal Ajuste o espaçamento horizontal entre os objetos selecionados no relatório.Horizontal Spacing Adjust the horizontal spacing between the selected objects within the report.

  • Espaçamento Vertical Ajuste o espaçamento vertical entre os objetos selecionados no relatório.Vertical Spacing Adjust the vertical spacing between the selected objects within the report.

  • Centralizar no Formulário Centralize o objeto selecionado vertical e horizontalmente em relação à janela Designer de Relatórios.Center in Form Center the selected object vertically and horizontally in relation to the Report Designer window.

  • Ordem Mova os objetos selecionados para o primeiro ou segundo plano.Order Move selected objects into the background or foreground.

Menu RelatórioReport Menu

Quando o foco está na superfície de design do relatório, o menu Relatório contém as seguintes opções:When the report design surface has focus, the Report menu contains the following options:

  • Propriedades do Relatório Selecione esta opção para abrir a caixa de diálogo Propriedades do Relatório .Report Properties Select to open the Report Properties dialog box. Nesta caixa de diálogo, é possível atribuir propriedades gerais do relatório, como o nome do autor e espaçamento da grade, além de propriedades específicas do layout, como o número de colunas e o tamanho da página.In this dialog box, you can assign general report properties, such as author name and grid spacing, and specify properties for the report layout, such as the number of columns and page size. Você também pode incluir código personalizado, referência a assemblies e classes, e os nomes de elementos de saída de dados, transformações de dados e esquemas de dados.You can also include custom code, references to assemblies and classes, and the names of data output elements, data transforms, and data schemas.

  • Exibição Alternar entre as duas guias do Designer de relatórios: Design e visualização.View Switch between the two Report Designer tabs: Design and Preview.

  • Cabeçalho da Página Adicione (ou exclua) um cabeçalho de página ao relatório.Page Header Add or delete a page header to the report. Quando você exclui um cabeçalho de página, todos os itens no cabeçalho são excluídos.When you delete a page header, all items in the page header are deleted.

  • Rodapé da Página Adicione (ou exclua) um rodapé de página ao relatório.Page Footer Add or delete a page footer to the report. Quando você exclui um rodapé de página, todos os itens no rodapé de página são excluídos.When you delete a page footer, all items in the page footer are deleted.

  • Painel Agrupamento Mostre ou oculte o painel Agrupamento.Grouping Pane Show or hide the Grouping pane.

Menu ExibirView Menu

Use o menu Exibir para exibir as janelas do Designer de Relatórios e barras de ferramentasUse the View menu to display Report Designer windows and toolbars

  • Lista de Erros Use esta opção para exibir os erros detectados ao publicar ou visualizar um relatório.Error List Use this option to display errors detected when publishing or previewing a report.

  • Saída Use esta opção para exibir os erros detectados ao publicar ou processar um relatório, ou para obter mais informações sobre erros de expressão quando o relatório exibe o texto "#Error".Output Use this option to display errors detected when publishing or processing a report, or for more information about expression errors when a report displays the text "#Error".

  • Janela Propriedades Use esta opção para exibir os valores de propriedade do item de relatórios atualmente selecionado na superfície de design.Properties Window Use this option to display the property values for the currently selected report item on the design surface. Para consultar as propriedades dos itens de relatório aninhados, clique em um item várias vezes para alternar entre a hierarquia de um item de relatório e seus membros aninhados.To see properties for nested report items, you must click a report item multiple times to cycle through the hierarchy for a report item and its nested members. Verifique o nome do item que aparece na parte superior do painel Propriedades para ver quais propriedades do item de relatório são exibidas.Check the name of the item that appears at the top of the Properties pane to see which report item's properties are displayed.

  • Caixa de Ferramentas Use esta opção para exibir a Caixa de Ferramentas.Toolbox Use this option to display the Toolbox.

  • Outras Janelas Use esta opção para exibir o seguinte painel:Other Windows Use this option to display the following pane:

    • Estrutura de Tópicos do Documento Use esta opção para exibir uma exibição hierárquica dos itens de relatório.Document Outline Use this option to display a hierarchical view of report items and their collections of text boxes in a report.
  • Barras de Ferramentas Use esta opção para exibir as barras de ferramentas que dão suporte aos recursos do Designer de Relatórios, inclusive Bordas do Relatório e Formatação do Relatório.Toolbars Use this option to display toolbars that support Report Designer features, including Report Borders and Report Formatting. Para obter mais informações, consulte Barras de Ferramentas do Designer de Relatórios.For more information, see Report Designer Toolbars.

  • Dados do Relatório Use esta opção para exibir o painel de dados do relatório, onde você pode adicionar parâmetros do relatório, fontes de dados, conjuntos de dados e imagens.Report Data Use this option to display the Report Data pane, where you can add report parameters, data sources, datasets, images.

Menu ProjetoProject Menu

Use o menu Projeto para gerenciar fontes de dados compartilhadas e relatórios em um projeto.Use the Project menu to manage shared data sources and reports in a project. Quando você adiciona ou remove itens do projeto, a exibição hierárquica de itens de projeto no Gerenciador de Soluções é atualizada automaticamente.When you add or remove items from the project, the hierarchical display of project items in Solution Explorer is automatically updated.

  • Adicionar Novo Item Adicione uma nova fonte de dados compartilhada ou um novo relatório para o projeto.Add New Item Add a new shared data source or new report to the project.

  • Adicionar Item Existente Adicione uma fonte de dados compartilhada ou um relatório existente ao projeto.Add Existing Item Add an existing shared data source or an existing report to the project.

  • Importar Relatórios Importe relatórios de outro aplicativo, por exemplo, o Microsoft Access.Import Reports Import reports from another application, for example, Microsoft Access.

  • Excluir do Projeto Exclua itens do projeto.Exclude from Project Exclude items from the project. Esta opção não exclui o item do seu sistema de arquivos.This option does not delete the item from your file system.

  • Mostrar Todos os Arquivos Exiba todos os arquivos em um projeto.Show All Files Show all files in a project.

  • Atualizar Itens da Caixa de Ferramentas Projeto Atualize o cache da caixa de ferramentas ao instalar novos itens de relatório personalizados no projeto.Refresh Project Toolbox Items Refresh the toolbox cache when you install new custom report items in your project.

  • Propriedades Abra a caixa de diálogo Páginas de Propriedades para o projeto.Properties Open the Property Pages dialog box for this project. Para obter mais informações, consulte Caixa de diálogo Páginas de Propriedades do Projeto.For more information, see Project Property Pages Dialog Box.

Barras de Ferramentas do Designer de RelatóriosReport Designer Toolbars

O Designer de Relatórios fornece as seguintes barras de ferramentas especializadas para criação de relatórios:Report Designer provides the following specialized toolbars to use when designing reports:

  • Relatório Adicione um cabeçalho ou rodapé à página, defina as propriedades do relatório, alterne para a régua ou painel Agrupamento, ou use o zoom para alterar exibição do relatório.Report Add a page header or page footer, set report properties, toggle the ruler or Grouping pane, or use zoom to change your view of the report.

  • Bordas do Relatório Defina a cor, o estilo e a largura de todas as linhas selecionadas e as bordas de todos os itens do relatório selecionados.Report Borders Set the color, style, and width for all selected lines and the borders of all selected report items.

  • Formatação de Relatório Defina o formato dos itens de relatório selecionados.Report Formatting Set the format of selected report items. Para as caixas de texto, os seguintes tipos de formatação podem ser alterados usando a barra de ferramentas: propriedades da fonte, cor do texto, cor do plano de fundo e justificação do texto.For text boxes, the following types of formatting can be changed using the toolbar: font properties and text color, background color, and text justification.

  • Layout Defina a ordem de desenho dos itens de relatório e as células de mesclagem em uma região de dados.Layout Set the drawing order of report items and merging cells within a data region.

  • Padrão Abra ou salve projetos, exiba janelas e selecione a configuração de Depuração.Standard Open or save projects, display windows, and select the Debug configuration.

Use o menu Exibir para controlar se essas barras de ferramentas serão exibidas.Use the View menu to control whether to display these toolbars. Outras barras de ferramentas do Visual StudioVisual Studio podem ser desativadas se a funcionalidade não se aplicar aos recursos do Designer de Relatórios.Other Visual StudioVisual Studio toolbars may be disabled if their functionality does not apply to Report Designer features.

Controle do código-fonteSource Control

SQL Server Data ToolsSQL Server Data Tools pode ser integrado com plug-ins de origem. Use as páginas de Projetos e Soluções na caixa de diálogo Opções para especificar o plug-in e configurar as propriedades.can integrate with source plug-ins. Use the Projects and Solutions pages in the Options dialog box to specify the plug-in and configure properties.

Modelos de relatório personalizadosCustom Report Templates

Para usar relatórios personalizados como modelos de novos relatórios, basta copiá-los na pasta ReportProject no computador em que o SQL Server Data ToolsSQL Server Data Tools está instalado.To use custom reports as templates for new reports, you simply copy them to the ReportProject folder on the computer on which SQL Server Data ToolsSQL Server Data Tools is installed. Por padrão, esta pasta está no seguinte local: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject.By default, this folder is in the following location: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject. Quando você adiciona um novo item ao projeto de relatório, o relatório personalizado aparece no painel Modelos.When you add a new item to the report project, your custom report appears in the Templates pane.

Também é possível adicionar estilos personalizados ao assistente de relatório.You can also add custom styles to the report wizard.

Suporte de linha de comando para o SQL Server Data ToolsCommand Line Support for SQL Server Data Tools

SQL Server Data ToolsSQL Server Data Tools se baseia no MicrosoftMicrosoft Visual StudioVisual Studio e no aplicativo devenv.exe subjacente.is based on MicrosoftMicrosoft Visual StudioVisual Studio and the underlying devenv.exe application. Antes de usar essas opções, você deve definir valores válidos para estes dois itens:Before you can use these options, you must set valid values for following two items:

  • Propriedades de projeto para OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder e TargetServerURL.Project properties for OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder, and TargetServerURL.

  • Pelo menos um conjunto de propriedades de configuração, por exemplo, Debug ou Release.At least one set of configuration properties, for example, Debug or Release.

Para obter mais informações, consulte Publishing Data Sources and Reports.For more information, see Publishing Data Sources and Reports.

Para um projeto de servidor de relatório, é possível especificar as seguintes opções pela linha de comando:For a report server project, you can specify the following options from the command line:

  • /deploy Implanta relatórios usando as propriedades de projeto especificadas em um arquivo de configuração./deploy Deploy reports by using the project properties specified in a configuration file. Por exemplo, o seguinte comando implanta os relatórios especificados pelo arquivo de solução Reports.sln usando os parâmetros de configuração de Release especificados nas propriedades de projeto:For example, the following command deploys the reports specified by the solution file Reports.sln by using the Release configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /deploy "Release"  
    
  • /build Cria o arquivo de solução, mas não implanta./build Build the solution file, but do not deploy it. Por exemplo, o seguinte comando cria os relatórios especificados pelo arquivo de solução Reports.sln usando os parâmetros de configuração de Debug especificados nas propriedades de projeto:For example, the following command builds the reports specified by the solution file Reports.sln by using the Debug configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug"  
    
  • /out Redireciona a saída gerada pela criação de uma solução para o arquivo especificado./out Redirect the output generated by building a solution to the specified file. Por exemplo, o comando a seguir redireciona a saída da criação no exemplo anterior para um arquivo denominado mybuildlog.txt.For example, the following command redirects the output from the build in the previous example to a file named mybuildlog.txt.

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug" /out mybuildlog.txt  
    

Teclas de atalho no Reporting ServicesKeyboard Shortcuts in Reporting Services

Use os atalhos do teclado para:Use keyboard shortcuts to:

  • Controlar janelas e modos no SQL Server Data ToolsSQL Server Data Tools:Control windows and modes in SQL Server Data ToolsSQL Server Data Tools:

    DescriçãoDescription Combinação de teclasKey Combination
    Compilar o projeto selecionadoBuild the selected project CTRL+SHIFT+BCTRL+SHIFT+B
    Exibir a janela PropriedadesDisplay Properties window F4F4
    Exiba janela de DadosDisplay Data window CTRL+Alt+DCTRL+Alt+D
    Iniciar a depuraçãoStart debugging F5F5
    Mover de uma janela aberta para outraMove from one open window to the next F6F6
  • Controlar itens na superfície de design de relatório:Control items on the report design surface:

    DescriçãoDescription Combinação de teclasKey Combination
    Mover o foco de um item de relatório para outro item de relatórioMove focus from one report item to the next report item TABTAB
    Mover o item de relatório selecionadoMove selected report item Teclas de direçãoArrow keys
    Ajustar o item de relatório selecionadoNudge selected report item CTRL+Teclas de direçãoCTRL+Arrow keys
    Aumentar ou diminuir o tamanho do item de relatório selecionadoIncrease or decrease the size of the selected report item CTRL+SHIFT+Teclas de direçãoCTRL+SHIFT+Arrow keys
    Em uma caixa de texto, mover o cursor para o início do texto que estiver sendo visualizadoIn a text box, move cursor to the beginning of the display text that is visible CTRL+HOMECTRL+HOME
    Em uma caixa de texto, mover o cursor para o fim do texto que estiver sendo visualizadoIn a text box, move cursor to the end of the display text that is visible CTRL+ENDCTRL+END
    Em uma caixa de texto, selecionar o texto a partir da posição atual do cursor até o início do texto que estiver sendo visualizadoIn a text box, select text from the current cursor position to the beginning of the display text that is visible SHIFT+HOMESHIFT+HOME
    Em uma caixa de texto, selecionar o texto a partir da posição atual do cursor até o fim do texto que estiver sendo visualizadoIn a text box, select text from the current cursor position to the end of the display text that is visible SHIFT+ENDSHIFT+END
    Em uma caixa de texto, selecionar o texto a partir da posição atual do cursor até o início da expressãoIn a text box, select text from the current cursor position to the beginning of the expression CTRL+SHIFT+HOMECTRL+SHIFT+HOME
    Em uma caixa de texto, selecionar o texto a partir da posição atual do cursor até o fim da expressãoIn a text box, select text from the current cursor position to the end of the expression CTRL+SHIFT+ENDCTRL+SHIFT+END
    Abrir o atalhe de menu do item de relatório selecionadoOpen the shortcut menu for the selected report item SHIFT+F10+Tecla de Propriedade, em modelos de teclado mais novosSHIFT+F10+Property Key on newer keyboards

Próximas etapasNext steps

Baixar o SQL Server Data Tools Gerenciador de Soluções Download SQL Server Data Tools Solution Explorer
Relatórios do Reporting Services Reporting Services Reports
Linguagem RDL Report Definition Language
Implantação e suporte de versão no SQL Server Data ToolsDeployment and Version Support in SQL Server Data Tools

Ainda tem dúvidas?More questions? Experimente perguntar no fórum do Reporting ServicesTry asking the Reporting Services forum