Trabalhar com projetos do SSMA (OracleToSQL)Working with SSMA Projects (OracleToSQL)

Migrar bancos de dados Oracle para SQL ServerSQL Server, primeiro você cria um projeto do SSMA.To migrate Oracle databases to SQL ServerSQL Server, you first create an SSMA project. O projeto é um arquivo que contém as seguintes informações:The project is a file that contains the following information:

  • Metadados sobre os bancos de dados do Oracle que você deseja migrar para SQL ServerSQL Server.Metadata about the Oracle databases you want to migrate to SQL ServerSQL Server.

  • Metadados sobre a instância de destino SQL ServerSQL Server que receberá os objetos migrados e os dados.Metadata about the target instance of SQL ServerSQL Server that will receive the migrated objects and data.

  • SQL ServerSQL Server informações de conexão.connection information.

  • Configurações do projeto.Project settings.

Quando você abre um projeto, ele é desconectado do Oracle e SQL ServerSQL Server.When you open a project, it is disconnected from Oracle and SQL ServerSQL Server. Que permite que você trabalhe offline.That lets you work offline. Para obter informações sobre a reconectar-se ao SQL ServerSQL Server, consulte conectando ao SQL Server (OracleToSQL).For information about reconnecting to SQL ServerSQL Server, see Connecting to SQL Server (OracleToSQL).

Revisar as configurações padrão de projetoReviewing Default Project Settings

O SSMA contém várias configurações de conversão e carregar objetos de banco de dados, migração de dados e sincronizando SSMA com a Oracle e SQL ServerSQL Server.SSMA contains several settings for converting and loading database objects, migrating data, and synchronizing SSMA with Oracle and SQL ServerSQL Server. As configurações padrão são apropriadas para muitos usuários.The default settings are appropriate for many users. No entanto, antes de criar um novo projeto SSMA, examine as configurações.However, before you create a new SSMA project, you should review the settings. Se você quiser, você pode alterar as configurações padrão que serão usadas para todos os seus projetos novos.If you want to, you can change the default settings that will be used for all your new projects.

Para examinar as configurações de projeto padrãoTo review default project settings

  1. Sobre o ferramentas menu, clique em configurações do projeto padrão.On the Tools menu, click Default Project Settings.

  2. Selecione o tipo de projeto no versão de destino de migração lista suspensa para as configurações que são necessárias para ser exibida ou alterada e clique geral guia.Select the project type in Migration Target Version drop down for which settings are required to be viewed or changed and then Click General tab.

  3. No painel esquerdo, clique em conversão.In the left pane, click Conversion.

  4. No painel direito, revise e altere as configurações conforme necessário.In the right pane, review and change the settings as necessary. Para obter mais informações sobre essas configurações, consulte configurações do projeto (conversão) (OracleToSQL).For more information about these settings, see Project Settings (Conversion) (OracleToSQL).

  5. Repita as etapas 1 a 3 para as páginas de migração, sincronização, carregando objetos do sistema, GUI e mapeamento de tipo.Repeat Steps 1-3 for the Migration, Synchronization, Loading System Objects, GUI, and Type Mapping pages.

Criação de novos projetosCreating New Projects

Para migrar dados de bancos de dados Oracle para SQL ServerSQL Server, você deve primeiro criar um projeto.To migrate data from Oracle databases to SQL ServerSQL Server, you must first create a project.

Para criar um projetoTo create a project

  1. No menu Arquivo, clique em Novo Projeto.On the File menu, click New Project.

    A caixa de diálogo Novo Projeto é exibida.The New Project dialog box appears.

  2. No nome , digite um nome para seu projeto.In the Name box, enter a name for your project.

  3. No local caixa, digite ou selecione uma pasta para o projeto e, em seguida, clique em Okey.In the Location box, enter or select a folder for the project, and then click OK.

  4. No migração à lista suspensa, selecione a versão de destino SQL ServerSQL Server usado para a migração.In the Migration To drop down, select the version of target SQL ServerSQL Server used for migration. As opções disponíveis são:The options available are:

    • SQL ServerSQL Server 20052005

    • SQL ServerSQL Server 20082008

    • SQL ServerSQL Server 20142014

    • SQL ServerSQL Server 20162016

    • Azure SQL DBAzure SQL DB

Personalizando configurações de projetoCustomizing Project Settings

Além de definir configurações de projeto padrão que se aplicam a todos os novos projetos do SSMA, você pode personalizar as configurações para cada projeto.In addition to defining default project settings that apply to all new SSMA projects, you can customize the settings for each project. Para obter mais informações, consulte definir opções do projeto (OracleToSQL).For more information, see Setting Project Options (OracleToSQL).

Quando você personaliza os mapeamentos de tipo de dados entre bancos de dados de origem e destino, você pode definir mapeamentos no projeto, no banco de dados ou no nível do objeto.When you customize data type mappings between source and target databases, you can define mappings at the project, database, or object level. Para obter mais informações, consulte mapeamento Oracle e tipos de dados do SQL Server (OracleToSQL).For more information, see Mapping Oracle and SQL Server Data Types (OracleToSQL).

Salvando projetosSaving Projects

Quando você salvar um projeto, o SSMA retém as configurações de projeto e, opcionalmente, os metadados do banco de dados, para o arquivo de projeto.When you save a project, SSMA retains the project settings, and optionally the database metadata, to the project file.

Para salvar um projetoTo save a project

  • Sobre o arquivo menu, clique em Salvar projeto.On the File menu, click Save Project.

    Se os esquemas no projeto foram alterados ou não foram convertidas, o SSMA solicitará que você carregar e salvar os metadados.If schemas in the project have changed or have not been converted, SSMA will prompt you to load and save metadata. Carregar e salvar metadados permitirá trabalhar offline.Loading and saving metadata will let you work offline. Ele também permite que você enviar um arquivo de projeto completo para outras pessoas, como a equipe de suporte técnico.It also lets you send a complete project file to other people, such as technical support personnel. Se você for solicitado a salvar os metadados, faça o seguinte:If you are prompted to save metadata, do the following:

    1. Para cada esquema que mostra um status de metadados ausentes, marque a caixa de seleção ao lado do nome do banco de dados.For each schema that shows a status of Metadata missing, select the check box next to the database name.

      Salvando metadados pode levar vários minutos.Saving metadata might take several minutes. Se você não quiser salvar os metadados ainda, não selecione as caixas de seleção.If you do not want to save metadata yet, do not select any check boxes.

    2. Clique no botão Salvar.Click the Save button.

      O SSMA analisará os esquemas do Oracle e salvar os metadados para o arquivo de projeto.SSMA will parse the Oracle schemas and save the metadata to the project file.

Abrindo projetosOpening Projects

Quando você abre um projeto, ele é desconectado do Oracle e do SQL ServerSQL Server.When you open a project, it is disconnected from Oracle and from SQL ServerSQL Server. Que permite que você trabalhe offline.That lets you work offline. Para atualizar os metadados, carregar objetos de banco de dados em SQL ServerSQL Server.To update metadata, load database objects into SQL ServerSQL Server. Para migrar dados, você deve reconectar-se ao Oracle e SQL ServerSQL Server.To migrate data, you must reconnect to Oracle and SQL ServerSQL Server.

Para abrir um projetoTo open a project

  1. Use um dos procedimentos a seguir:Use one of the following procedures:

    • Sobre o arquivo , aponte para projetos recentese, em seguida, clique no projeto que você deseja abrir.On the File menu, point to Recent Projects, and then click the project you want to open.

    • Sobre o arquivo menu, selecione Abrir projeto, localize o arquivo de projeto .o2ssproj, selecione o arquivo e, em seguida, clique em abrir.On the File menu, select Open Project, locate the .o2ssproj project file, select the file, and then click Open.

  2. Para reconectar-se ao Oracle, sobre o arquivo menu, clique em reconectar-se ao Oracle.To reconnect to Oracle, on the File menu, click Reconnect to Oracle.

  3. Para se reconectar à SQL ServerSQL Serverdiante a arquivo menu, clique em reconectar-se ao SQL Server.To reconnect to SQL ServerSQL Server, on the File menu, click Reconnect to SQL Server.

Próxima etapaNext Step

É a próxima etapa no processo de migração conectar-se ao banco de dados Oracle (OracleToSQL).The next step in the migration process is to Connecting to Oracle Database (OracleToSQL).

Consulte tambémSee Also

Migrando do Oracle bancos de dados para o SQL Server (OracleToSQL)Migrating Oracle Databases to SQL Server (OracleToSQL)
Conectar-se ao banco de dados Oracle (OracleToSQL)Connecting to Oracle Database (OracleToSQL)
Conectando ao SQL Server (OracleToSQL)Connecting to SQL Server (OracleToSQL)