Erro AADSTS50003 - Nenhuma chave de assinatura configurada

Este artigo descreve um problema no qual você recebe a mensagem de erro "Erro AADSTS50003 - Nenhuma chave de assinatura configurada". ao tentar entrar em um aplicativo configurado SSO (SSO) baseado em SAML que foi integrado ao Azure Active Directory (Azure AD).

Sintomas

Você recebe um erro ao tentar entrar em um aplicativo que foi configurado para usar o Azure AD para gerenciamento de identidade usando o AADSTS50003 SSO baseado em SAML.

Motivo

O objeto application está corrompido e o Azure AD não reconhece o certificado configurado para o aplicativo.

Solução

Para excluir e criar um novo certificado, siga as etapas abaixo:

  1. Na tela de configuração SSO baseada em SAML, selecione Criar novo certificado na seção Certificado de assinatura SAML.
  2. Selecione Data de expiração e clique em Salvar.
  3. Verifique Tornar novo certificado ativo para substituir o certificado ativo. Em seguida, clique em Salvar na parte superior do painel e aceite ativar o certificado de rolagem.
  4. Na seção Certificado de Assinatura SAML, clique em remover para remover o certificado nãoutilado.

Informações adicionais

Para uma lista completa de códigos de erro de autenticação e autorização do Active Directory, consulte Códigos de erro de autenticação e autorização do Azure AD