Compartilhar via


Erro "Sua sessão de postagem no nível de transação anterior não terminou o processamento" ao abrir a janela Entrada de Transação de Vendas no Processamento de Pedidos de Vendas

Este artigo fornece uma resolução para a sessão de postagem em nível de transação anterior que não terminou o erro de processamento que pode ocorrer quando você tenta abrir a janela Entrada de Transação de Vendas no Processamento de Pedidos de Vendas no Microsoft Dynamics GP ou em Soluções de Negócios da Microsoft – Grandes Planícies.

Aplica-se a: Microsoft Dynamics GP
Número de KB original: 852623

Sintomas

Você pode receber a seguinte mensagem de erro ao tentar abrir a janela Entrada de Transação de Vendas no Processamento de Pedidos de Vendas no Microsoft Dynamics GP ou no Microsoft Business Solutions – Great Plains:

Sua sessão de postagem no nível da transação anterior não terminou o processamento. Permita tempo para que ele seja concluído. Se você acredita que falhou, saia de Great Plains e faça logon de volta para recuperar transações.

Observação

Para abrir a janela Entrada de Transação de Vendas, selecione Transações, aponte para Vendas e selecione Entrada de Transação de Vendas.

Motivo

Esse problema pode ocorrer quando os registros são bloqueados na tabela SY00500, na tabela SY00800 ou na tabela SOP10100. Os registros têm um número de lote que está em branco ou a ID do usuário é listada como o número do lote.

Resolução

Para resolver este problema, execute as seguintes etapas:

  1. Fazer com que todos os usuários saiam do Microsoft Dynamics GP.

  2. Faça um backup do banco de dados da empresa.

  3. No Analisador de Consultas SQL, execute a seguinte instrução de exclusão na tabela SY00800 no banco de dados DYNAMICS.

    DELETE SY00800
    
  4. Procure os registros de problemas na tabela SY00500 executando as duas instruções a seguir no banco de dados da empresa.

    Observação

    Nas instruções a seguir, xxx representa a ID do usuário que contém o erro.

    SELECT * from SY00500 where BACHNUMB = ''
    SELECT * from SY00500 where BACHNUMB = 'xxx'
    
  5. Se você tiver registros retornados com um campo BACHNUMB em branco, use a seguinte instrução de exclusão.

    DELETE SY00500 where BACHNUMB = ''
    
  6. Se você tiver registros retornados com uma ID de usuário no campo BACHNUMB, use a seguinte instrução de exclusão.

    Observação

    Na instrução a seguir, xxx representa a ID do usuário que contém o erro.

    DELETE SY00500 where BACHNUMB ='xxx'
    
  7. Verifique se você pode selecionar documentos existentes na janela Entrada de Transação de Vendas. Para abrir essa janela, selecione Transações, aponte para Vendas e selecione Entrada de Transação de Vendas. Se você quiser excluir um documento existente, selecione Excluir. Se você quiser anular um documento existente, selecione Void.

  8. Se você continuar recebendo a mensagem de erro ou se não puder selecionar os documentos existentes na janela Entrada de Transação de Vendas, execute os scripts a seguir no SQL Query Analyzer no banco de dados da empresa para localizar registros de problemas na tabela SOP10100.

    Observação

    Nos scripts a seguir, xxx representa a ID do usuário que contém o erro.

    SELECT BACHNUMB,* from SOP10100 where BACHNUMB = '' SELECT BACHNUMB,* from SOP10100 where BACHNUMB = '<xxx>'
    SELECT * FROM SOP10200 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = 'xxx')
    SELECT * FROM SOP10200 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = ' ')
    SELECT * FROM SOP10102 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = 'xxx')
    SELECT * FROM SOP10102 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = ' ')
    
  9. Observe todos os registros retornados e execute a seguinte instrução no Analisador de Consultas SQL para excluir os registros de problema da tabela SOP10100.

    Observação

    • Você deve verificar se as transações são postadas no módulo Inventário e nos módulos de Gerenciamento de Recebíveis. Se as transações não tiverem sido postadas no módulo Inventário e no módulo Gerenciamento de Recebíveis, você deverá reentrada nas transações na janela Entrada de Transação de Vendas depois de executar as instruções de exclusão.
    • Nas instruções a seguir, xxx representa a ID do usuário que contém o erro.
    DELETE SOP10200 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = 'xxx')
    DELETE SOP10200 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = ' ')
    DELETE SOP10102 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = 'xxx')
    DELETE SOP10102 where SOPNUMBE in (SELECT SOPNUMBE from SOP10100 where BACHNUMB = ' ')
    DELETE SOP10100 where BACHNUMB = '' DELETE SOP10100 where BACHNUMB = 'xxx'
    
  10. No Microsoft Dynamics GP, aponte para Manutenção no menu do Microsoft Dynamics GP e selecione Verificar Links.

  11. Na lista Séries, selecione Vendas e execute o procedimento de links marcar no grupo de tabela Sales Work.

  12. Se as transações não tiverem sido postadas no módulo Gerenciamento de Recebíveis e no módulo Inventário, reentrada as transações na janela Entrada de Transação de Vendas.