Configuration Manager clientes reinstalam a cada cinco horas e podem causar uma atualização inadvertida do cliente

Este artigo discute um problema no system center 2012 Configuration Manager cliente e no cliente do System Center 2012 R2 Configuration Manager cliente que poderia causar uma atualização inadvertida do cliente em uma Configuration Manager ambiente de branch atual ou ltSB (branch de manutenção de longo prazo).

Versão original do produto: Microsoft System Center 2012 Configuration Manager, Microsoft System Center 2012 R2 Configuration Manager
Número de KB original: 4018655

Resumo

O CCMSetup (instalação do cliente Configuration Manager) falha inicialmente e faz com que uma tarefa de repetição de cliente seja registrada no Agendador de Tarefas do Windows. Depois que a instalação do cliente for bem-sucedida, a tarefa de repetição não será excluída conforme o esperado. Portanto, os clientes continuam reinstalando a cada cinco horas.

Nessa situação, se você atualizar a infraestrutura de Configuration Manager para Configuration Manager branch atual ou LTSB e se você não atualizar os clientes Configuration Manager, a tarefa de repetição agendada continuará forçando a reinstalação de um cliente a cada cinco horas.

Na próxima vez que o CCMSetup for executado, os clientes encontrarão um ponto de gerenciamento ou ponto de distribuição atualizado e reinstalarão o software cliente. Isso atualiza os clientes para Configuration Manager.

Essas atualizações contínuas ocorrem fora do processo normal de atualização configurado pelo administrador. Isso inclui o recurso de pilotagem do cliente.

Sintomas

Em um ambiente do Microsoft System Center 2012 ou System Center 2012 R2, você observa os seguintes sintomas:

  • Os clientes se reinstalam com êxito a cada cinco horas. Essa atividade está registrada em logs de eventos do ccmsetup.log e do Windows.
  • Ao exibir a pasta \Microsoft\Microsoft\ConfigurationManager no Agendador de Tarefas, você encontrará uma tarefa chamada Configuration Manager Tarefa de Repetição do Cliente.

Motivo

Esse problema ocorre porque o CCMSetup cria a tarefa de repetição do cliente na pasta errada no cliente. Isso impede que o CCMSetup localize e remova a tarefa.

A tarefa agendada é criada na pasta \Microsoft\Microsoft\Configuration Manager em vez da pasta \Microsoft\Configuration Manager.

Solução alternativa 1

Remova manualmente Configuration Manager Tarefa de Repetição do Cliente da pasta \Microsoft\Microsoft\Configuration Manager usando o Agendador de Tarefas.

Solução alternativa 2

Implante um script para remover Configuration Manager Tarefa de Repetição do Cliente da pasta \Microsoft\Microsoft\Configuration Manager.

Exemplo Windows PowerShell comandos a serem adicionados ao script:

get-scheduledtask -taskname "Configuration Manager Client Retry Task"  
unregister-scheduledtask -taskname "Configuration Manager Client Retry Task" -confirm:$false

Mais informações

No Configuration Manager versão atual do branch 1602 e versões posteriores e na versão 1606 do LTSB, o Ccmsetup remove corretamente a tarefa agendada depois que os clientes são atualizados.