Caixa de diálogo Geral, Depuração, OpçõesGeneral, Debugging, Options Dialog Box

O Ferramentas > Opções > Depuração > geral página permite que você defina as opções descritas neste artigo.The Tools > Options > Debugging > General page lets you set the options described in this article.

Se você precisar restaurar as configurações padrão, você pode fazer isso usando ferramentas > importar e exportar configurações > redefinir todas as configurações.If you need to restore default settings, you can do that using Tools > Import and Export Settings > Reset all settings. Se você quiser redefinir um subconjunto de configurações, salve suas configurações na Import and Export Settings Wizard antes de fazer as alterações que você deseja testar, em seguida, importar as configurações salvas mais tarde.If you only want to reset a subset of settings, save your settings in the Import and Export Settings Wizard before making the changes that you want to test, then import your saved settings later.

Perguntar antes de excluir todos os pontos de interrupção requer a confirmação antes de concluir a excluir todos os pontos de interrupção comando.Ask before deleting all breakpoints Requires confirmation before completing the Delete All Breakpoints command.

Interromper todos os processos quando um processo for interrompido interrompe simultaneamente todos os processos aos quais o depurador é anexado, quando ocorrer uma interrupção.Break all processes when one process breaks Simultaneously breaks all processes to which the debugger is attached, when a break occurs.

Interromper quando exceções cruzarem AppDomain ou limites gerenciados/nativos na depuração gerenciada ou de modo misto, o common language runtime pode capturar exceções que cruzem os limites de domínio de aplicativo ou limites gerenciados/nativos quando o seguinte as condições forem verdadeiras:Break when exceptions cross AppDomain or managed/native boundaries In managed or mixed-mode debugging, the common language runtime can catch exceptions that cross application domain boundaries or managed/native boundaries when the following conditions are true:

1) quando o código nativo chama código gerenciado usando interoperabilidade COM e o código gerenciado gera uma exceção.1) When native code calls managed code by using COM Interop and the managed code throws an exception. Ver Introdução à interoperabilidade COM.See Introduction to COM Interop.

2) quando o código gerenciado em execução no domínio do aplicativo 1 chama o código gerenciado no domínio do aplicativo 2, e o código no domínio do aplicativo 2 gera uma exceção.2) When managed code running in application domain 1 calls managed code in application domain 2, and the code in application domain 2 throws an exception. Ver programação com domínios do aplicativo.See Programming with Application Domains.

3) quando o código chama uma função por meio de reflexão e a função gerará uma exceção.3) When code calls a function by using reflection, and the function throws an exception. Ver reflexão.See Reflection.

Condição 2 e 3, a exceção é às vezes detectada pelo código gerenciado em mscorlib em vez do common language runtime.In condition 2 and 3, the exception is sometimes caught by managed code in mscorlib instead of the common language runtime. Esta opção não afeta a quebra em exceções capturadas por mscorlib.This option does not affect breaking on exceptions caught by mscorlib.

Habilitar a depuração do nível de endereços habilita recursos avançados para depuração no nível do endereço (a desmontagem janela, o registra janela e pontos de interrupção de endereço).Enable address-level debugging Enables advanced features for debugging at the address level (the Disassembly window, the Registers window, and address breakpoints).

  • Mostrar desmontagem se a fonte não está disponível mostra automaticamente o desmontagem janela quando você tenta depurar o código para o qual fonte não está disponível.Show disassembly if source is not available Automatically shows the Disassembly window when you try to debug code for which source is unavailable.

Habilitar filtros de ponto de interrupção permite que você defina filtros em pontos de interrupção para que elas afetarão apenas processos específicos, threads ou computadores.Enable breakpoint filters Enables you to set filters on breakpoints so that they will affect only specific processes, threads, or computers.

Use o novo auxiliar de exceção permite que o auxiliar de exceção (Visual Studio 2017) que substitui o Assistente de exceção.Use the new Exception Helper Enables the Exception Helper (Visual Studio 2017) that replaces the exception assistant.

Note

Para código gerenciado, essa opção foi chamada anteriormente habilitar o Assistente de exceção .For managed code, this option was previously called Enable the exception assistant .

Habilitar apenas meu código o depurador exibe e as etapas no código do usuário ("meu código"), ignorando o código de sistema e outro código que é otimizado ou que não tem símbolos de depuração.Enable Just My Code The debugger displays and steps into user code ("My Code") only, ignoring system code and other code that is optimized or that does not have debugging symbols.

  • Avisar se não houver código de usuário na inicialização (somente gerenciado) quando a depuração começa com o Just My Code ativado, esta opção advertirá se não houver nenhum código de usuário ("meu código").Warn if no user code on launch (Managed only) When debugging starts with Just My Code enabled, this option warns you if there is no user code ("My Code").

Habilitar o .NET Framework depuração da origem permite que o depurador para percorrer o código-fonte do .NET Framework.Enable .NET Framework source stepping Allows the debugger to step into .NET Framework source. Habilitar esta opção desativa automaticamente Apenas Meus Código dos símbolos do .NET Framework que serão baixados em um local do cache.Enabling this option automatically disables Just My Code .NET Framework symbols will be downloaded to a cache location. Você pode alterar o local do cache na opções caixa de diálogo depuração categoria, símbolos página.You can change the cache location in the Options dialog box, Debugging category, Symbols page.

Depurar parcialmente propriedades e operadores (somente gerenciado) impede que o depurador de depuração de propriedades e operadores no código gerenciado.Step over properties and operators (Managed only) Prevents the debugger from stepping into properties and operators in managed code.

Habilitar a avaliação de propriedade e outras chamadas de função implícitas chama de ativar a avaliação automática de propriedades e de função implícitas nas janelas de variáveis e os QuickWatch caixa de diálogo.Enable property evaluation and other implicit function calls Turns on automatic evaluation of properties and implicit function calls in variables windows and the QuickWatch dialog box.

  • Chamar a função de conversão de cadeia de caracteres em objetos nas janelas de variáveis (c# e JavaScript somente) executa uma chamada de conversão de cadeia de caracteres implícita ao avaliar objetos nas janelas variáveis.Call string conversion function on objects in variables windows (C# and JavaScript only) Executes an implicit string conversion call when evaluating objects in variables windows. O resultado é exibido como uma cadeia de caracteres em vez do nome de tipo.The result is displayed as a string instead of the type name. Aplica-se somente à depuração no código em C.Only applies while debugging in C# code. Essa configuração pode ser substituída pelo atributo DebuggerDisplay (consulte usando o atributo DebuggerDisplay).This setting may be overridden by the DebuggerDisplay attribute (see Using the DebuggerDisplay Attribute).

Habilitar o suporte do servidor de origem informa o depurador do Visual Studio para obter os arquivos de origem de servidores de origem que implementam o SrcSrv (srcsrv.dll) protocolo.Enable source server support Tells the Visual Studio debugger to get source files from source servers that implement the SrcSrv (srcsrv.dll) protocol. Team Foundation Server e as ferramentas de depuração para Windows são dois servidores de origem que implementam o protocolo.Team Foundation Server and the Debugging Tools for Windows are two source servers that implement the protocol. Para obter mais informações sobre a configuração de SrcSrv, consulte o SrcSrv documentação.For more information about SrcSrv setup, see the SrcSrv documentation. Além disso, consulte especificar arquivos de símbolo (. PDB) e código-fonte.In addition, see Specify Symbol (.pdb) and Source Files.

Important

Pois lendo . PDB arquivos pode executar código arbitrário em arquivos, certifique-se de que você confia no servidor.Because reading .pdb files can execute arbitrary code in the files, make sure that you trust the server.

  • Imprimir mensagens de diagnóstico de servidor de origem para a janela de saída ao suporte do servidor de origem está habilitado, essa configuração ativa ao diagnóstico.Print source server diagnostic messages to the Output window When source server support is enabled, this setting turns on diagnostic display.

  • Permitir que o servidor de origem para os assemblies de confiança parcial (somente gerenciado) ao suporte do servidor de origem está habilitado, essa configuração substitui o comportamento padrão de não recuperar as fontes para assemblies de confiança parcial.Allow source server for partial trust assemblies (Managed only) When source server support is enabled, this setting overrides the default behavior of not retrieving sources for partial trust assemblies.

Habilitar o suporte a Link de origem informa o depurador do Visual Studio para baixar os arquivos de origem para os arquivos. PDB que contêm informações de Link de origem.Enable Source Link support Tells the Visual Studio debugger to download source files for .pdb files that contain Source Link information. Para obter mais informações sobre o Link de origem, consulte a especificação de Link de origem.For more information about Source Link, see the Source Link Specification.

> [!IMPORTANT]
>  Because Source Link will download files using http or https, make sure you trust the .pdb file.  

Realçar a linha inteira para pontos de interrupção e a instrução atual (C++) quando o depurador realça um ponto de interrupção ou a instrução atual, ele realça a linha inteira.Highlight entire line for breakpoints and current statement (C++ only) When the debugger highlights a breakpoint or current statement, it highlights the entire line.

Exigir arquivos de origem correspondam exatamente à versão original informa o depurador para verificar se um arquivo de origem corresponde a versão do código-fonte usado para criar o arquivo executável que você está depurando.Require source files to exactly match the original version Tells the debugger to verify that a source file matches the version of the source code used to build the executable you are debugging. Se não coincide com a versão, você será solicitado a encontrar uma origem correspondente.If the version does not match, you'll be prompted to find a matching source. Se uma fonte compatível não for encontrada, o código-fonte não será exibido durante a depuração.If a matching source is not found, the source code will not be displayed during debugging.

Redirecionar todo o texto da janela Saída para a janela imediata envia todas as mensagens do depurador que normalmente apareceriam na saída janela para o imediato janela em vez disso.Redirect all Output window text to the Immediate window Sends all debugger messages that would ordinarily appear in the Output window to the Immediate window instead.

Mostrar estrutura bruta de objetos nas janelas de variáveis desativa todas as personalizações de exibição de estrutura de objeto.Show raw structure of objects in variables windows Turns off all object structure view customizations. Para obter mais informações sobre personalizações de exibição, consulte criar exibições personalizadas de objetos gerenciados.For more information about view customizations, see Create custom views of .managed objects.

Suprimir Otimização JIT no carregamento do módulo (somente gerenciado) desabilita a otimização JIT de código gerenciado quando um módulo é carregado e JIT é compilado enquanto o depurador é anexado.Suppress JIT optimization on module load (Managed only) Disables the JIT optimization of managed code when a module is loaded and JIT is compiled while the debugger is attached. Desativar a otimização pode facilitar a depuração de alguns problemas, embora às custas de desempenho.Disabling optimization may make it easier to debug some problems, although at the expense of performance. Se você estiver usando Apenas Meu Código, a supressão da otimização de JIT poderá fazer com que código que não seja do usuário apareça como código do usuário ("Meu Código").If you are using Just My Code, suppressing JIT optimization can cause non-user code to appear as user code ("My Code"). Para obter mais informações, consulte Otimização JIT e depuração.For more information, see JIT Optimization and Debugging.

Habilitar a depuração de JavaScript para ASP.NET (Chrome e o IE) permite que o depurador de script para aplicativos ASP.NET.Enable JavaScript debugging for ASP.NET (Chrome and IE) Enables the script debugger for ASP.NET apps. No primeiro uso no Chrome, você precisa entrar no navegador no primeiro uso, para habilitar as extensões do Chrome que você instalou.On first use in Chrome, you may need to sign into the browser on first use to enable Chrome extensions that you have installed. Desabilite essa opção para reverter para o comportamento herdado.Disable this option to revert to legacy behavior.

Carregar exportações de dll carrega as tabelas de exportação de dll.Load dll exports Loads dll export tables. Informações de símbolo de tabelas de exportação de dll podem ser útil se você estiver trabalhando com mensagens do Windows, procedimentos do Windows (WindowProcs), objetos COM, ou marshaling ou qualquer dll para o qual você não tem símbolos.Symbol information from dll export tables can be useful if you are working with Windows messages, Windows procedures (WindowProcs), COM objects, or marshaling, or any dll for which you do not have symbols. Informações de exportação lendo dll envolve alguma sobrecarga.Reading dll export information involves some overhead. Desse modo, esse recurso é desativado por padrão.Therefore, this capability is turned off by default.

Para ver quais símbolos estão disponíveis na tabela de exportação de uma dll, use dumpbin /exports.To see what symbols are available in the export table of a dll, use dumpbin /exports. Símbolos estão disponíveis para qualquer dll do sistema de 32 bits.Symbols are available for any 32-bit system dll. Ao ler a saída dumpbin /exports, você pode ver o nome exato da função, incluindo caracteres não alfanuméricos.By reading the dumpbin /exports output, you can see the exact function name, including non-alphanumeric characters. Isso é útil para definir um ponto de interrupção em uma função.This is useful for setting a breakpoint on a function. Nomes de função de tabelas de exportação de dll podem aparecer truncados em outro lugar no depurador.Function names from dll export tables might appear truncated elsewhere in the debugger. As chamadas são listadas na ordem de chamada, com a função atual (a mais profundamente aninhada) na parte superior.The calls are listed in the calling order, with the current function (the most deeply nested) at the top. Para obter mais informações, consulte dumpbin/exportações.For more information, see dumpbin /exports.

Mostrar pilhas paralelas de baixo para cima de diagrama controla a direção na qual as pilhas são exibidas na pilhas paralelas janela.Show parallel stacks diagram bottom-up Controls the direction in which stacks are displayed in the Parallel Stacks window.

Ignorar as exceções de acesso de memória GPU, se os dados gravados não tiver alterado o valor ignora as condições de corrida que foram detectadas durante a depuração caso os dados não forem alterados.Ignore GPU memory access exceptions if the data written didn't change the value Ignores race conditions that were detected during debugging if the data didn't change. Para obter mais informações, consulte depurando código de GPU.For more information, see Debugging GPU Code.

Use o modo de compatibilidade gerenciado substitui o mecanismo com uma versão herdada para habilitar estes cenários de depuração padrão:Use Managed Compatibility Mode Replaces the default debugging engine with a legacy version to enable these scenarios:

  • Você está usando uma linguagem .NET Framework diferente de C#, VB ou F#, que fornece seu próprio Avaliador de Expressão (incluindo C++/CLI).You are using a .NET Framework language other than C#, VB, or F# that provides its own Expression Evaluator (this includes C++/CLI).

  • Você deseja habilitar editar e continuar para projetos do C++ durante a depuração de modo misto.You want to enable Edit and Continue for C++ projects while mixed mode debugging.

Note

O modo escolhendo compatibilidade gerenciada desativa alguns recursos que são implementados somente no mecanismo de depuração padrão.Choosing Managed Compatibility mode disables some features that are implemented only in the default debugging engine.

Use os avaliadores de expressão c# e VB herdados o depurador usará os avaliadores de expressão do Visual Studio 2013 C# /VB em vez dos avaliadores de expressão baseada em Roslyn de 2015 do Visual Studio.Use the legacy C# and VB expression evaluators The debugger will use the Visual Studio 2013 C#/VB expression evaluators instead of the Visual Studio 2015 Roslyn-based expression evaluators.

Avisar ao usar os visualizadores do depurador personalizados contra processos potencialmente inseguros (somente gerenciado) Visual Studio avisa você quando você estiver usando um visualizador de depurador personalizada que está executando o código do processo de depuração, porque ele pode estar em execução não seguro código.Warn when using custom debugger visualizers against potentially unsafe processes (Managed only) Visual Studio warns you when you are using a custom debugger visualizer that is running code in the debuggee process, because it could be running unsafe code.

Habilitar alocador de heap de depuração do Windows (somente nativo) permite que o heap de depuração do windows melhorar o diagnóstico de heap.Enable Windows debug heap allocator (Native only) Enables the windows debug heap to improve heap diagnostics. Habilitar essa opção afetará o desempenho de depuração.Enabling this option will impact debugging performance.

Habilitar ferramentas de depuração da interface do usuário para XAML a Live Visual Tree e os windows Live propriedade explorar aparecerão quando você inicia a depuração (F5) um tipo de projeto com suporte.Enable UI Debugging Tools for XAML The Live Visual Tree and the Live Property Explore windows will appear when you start debugging (F5) a supported project type. Para obter mais informações, consulte propriedades de XAML de inspecionar durante a depuração.For more information, see Inspect XAML properties while debugging.

  • Visualizar os elementos selecionados no Live Visual Tree elemento XAML o cujo contexto é selecionado também está selecionado em de Live Visual Tree janela.Preview selected elements in Live Visual Tree The XAML element whose context is selected is also selected in the Live Visual Tree window.

  • Mostrar ferramentas de tempo de execução no aplicativo mostra a Live Visual Tree comandos em uma barra de ferramentas na janela principal do aplicativo XAML que está sendo depurado.Show runtime tools in application Shows the Live Visual Tree commands in a toolbar on the main window of the XAML application that is being debugged. Essa opção foi introduzida no Visual Studio 2015 atualização 2.This option was introduced in Visual Studio 2015 Update 2.

  • Habilitar o XAML Edit and Continue lhe permite usar Editar e continuar o recurso para o código XAML.Enable XAML Edit and Continue Allows you to use Edit and Continue feature for XAML code.

Habilitar ferramentas de diagnóstico durante a depuração as ferramentas de diagnóstico janela é exibida enquanto você está depurando.Enable Diagnostic Tools while debugging The Diagnostic Tools window appears while you are debugging.

Mostrar tempo decorrido PerfTip durante a depuração a janela de código exibe o tempo decorrido de uma chamada de método fornecido quando você estiver depurando.Show elapsed time PerfTip while debugging The code window displays the elapsed time of a given method call when you are debugging.

Habilitar Editar e continuar você pode usar o editar e continuar funcionalidade durante a depuração.Enable Edit and Continue You can use the Edit and Continue functionality while debugging.

  • Habilitar nativo de editar e continuar você pode usar o editar e continuar funcionalidade durante a depuração de código C++ nativo.Enable Native Edit and Continue You can use the Edit and Continue functionality while debugging native C++ code. Para obter mais informações, consulte editar e continuar (Visual C++).For more information, see Edit and Continue (Visual C++).

  • Aplicar alterações ao continuar (somente nativo) Visual Studio compila automaticamente e aplica as alterações de código pendentes feitas ao continuar o processo de um estado de interrupção.Apply changes on continue (Native only) Visual Studio automatically compiles and applies any outstanding code changes you have made when continuing the process from a break state. Se não estiver selecionada, você pode optar por aplicar alterações usando o item de "Aplicar alterações de código" no menu Depurar.If not selected, you can choose to apply changes using the "Apply Code Changes" item under the Debug menu.

  • Avisar sobre código obsoleto (somente nativo) obter avisos sobre código obsoleto.Warn about stale code (Native only) Get warnings about stale code.

Mostrar execução clique de botão no editor durante a depuração quando essa opção é selecionada, o executar com um clique botão será mostrado durante a depuração.Show run to click button in editor while debugging When this option is selected, the Run to Click button will be shown while debugging.

Opções com suporte em versões mais antigas do Visual StudioOptions supported in older versions of Visual Studio

Se você estiver usando uma versão mais antiga do Visual Studio, algumas opções adicionais podem estar presentes.If you are using an older version of Visual Studio, some additional options might be present.

Habilitar o Assistente de exceção para código gerenciado, habilitado o Assistente de exceção.Enable the exception assistant For managed code, enabled the exception assistant. No Visual Studio 2017, o auxiliar de exceção substituído o Assistente de exceção.In Visual Studio 2017, the Exception Helper replaced the exception assistant.

Desenrolar a pilha de chamadas em exceções não tratadas faz com que o pilha de chamadas janela para reverter a pilha de chamadas para o ponto antes da ocorrência de exceção sem tratamento.Unwind the call stack on unhandled exceptions Causes the Call Stack window to roll back the call stack to the point before the unhandled exception occurred.

Avisar se não houver símbolos na inicialização (somente nativo) exibe uma caixa de diálogo de aviso quando você tenta depurar um programa para o qual o depurador não tem nenhuma informação de símbolo.Warn if no symbols on launch (native only) Displays a warning dialog box when you try to debug a program for which the debugger has no symbol information.

Avisar se a depuração de script estiver desabilitada na inicialização exibe uma caixa de diálogo de aviso quando o depurador é iniciado com a depuração de script desabilitada.Warn if script debugging is disabled on launch Displays a warning dialog box when the debugger is launched with script debugging disabled.

Usar o modo de compatibilidade nativa quando essa opção é selecionada, o depurador usa o depurador nativo do Visual Studio 2010, em vez do novo depurador nativo.Use Native Compatibility Mode When this option is selected, the debugger uses the Visual Studio 2010 native debugger instead of the new native debugger.

Você deve usar essa opção quando você estiver depurando o código C++ .NET, pois o novo mecanismo de depuração não dá suporte a expressões de avaliação C++ .NET.You should use this option when you are debugging .NET C++ code, because the new debugging engine does not support evaluating .NET C++ expressions. No entanto, a habilitação do modo de compatibilidade nativa desabilita muitos recursos que dependem da implementação atual do depurador para operar.However, enabling Native Compatibility Mode disables many features that depend on the current debugger implementation to operate. Por exemplo, o mecanismo herdado não tem muitos visualizadores para tipos internos, como std::string em projetos do Visual Studio 2015.For example, the legacy engine lacks many visualizers for built-in types like std::string in Visual Studio 2015 projects. Use os projetos do Visual Studio 2013 para a melhor experiência de depuração nesses casos.Use Visual Studio 2013 projects for the optimal debugging experience in these cases.

Consulte tambémSee also

Depurando no Visual StudioDebugging in Visual Studio
Tour dos recursos do depuradorDebugger Feature Tour