Recursos do IntelliTrace (C#, Visual Basic, C++)IntelliTrace Features (C#, Visual Basic, C++)

Você pode usar o IntelliTrace para registrar eventos e o método chama seu aplicativo, o que permite que você examine seu estado (valores de pilha de chamada e variáveis locais) em pontos diferentes na execução.You can use IntelliTrace to record events and method calls your application, which allows you to examine its state (call stack and local variable values) at different points in the execution. Basta iniciar a depuração como de costume – o IntelliTrace é ativado por padrão e você pode ver que o IntelliTrace de informações está gravando na janela novo ferramentas de diagnóstico na guia eventos . Selecione um evento e clique em Ativar depuração histórica para ver a pilha de chamadas e os locais registrados para este evento.Just start debugging as usual - IntelliTrace is turned on by default, and you can see the information IntelliTrace is recording in the new Diagnostic Tools window under the Events tab. Select an event and click Activate Historical Debugging to see the call stack and locals recorded for this event.

Para obter uma descrição passo a passo, consulte passo a passo: Usando o IntelliTrace.For a step-by-step description, see Walkthrough: Using IntelliTrace.

O IntelliTrace está disponível na edição Visual Studio Enterprise, mas não nas edições Visual Studio Professional ou Community.IntelliTrace is available in Visual Studio Enterprise edition, but not in the Visual Studio Professional or Community editions.

Para confirmar que o IntelliTrace está ativado, abra as ferramentas > opções > página Opções do IntelliTrace.To confirm that IntelliTrace is turned on, open the Tools > Options > IntelliTrace options page. Habilitar o IntelliTrace deve ser verificado por padrão.Enable IntelliTrace should be checked by default.

Observação

O escopo de todas as configurações na página de opções do IntelliTrace é o Visual Studio como um todo, e não projetos individuais ou soluções.The scope of all settings on the IntelliTrace options page is Visual Studio as a whole, not individual projects or solutions. Uma alteração nessas configurações se aplica a todas as instâncias do Visual Studio, todas as sessões de depuração e todos os projetos ou soluções.A change in these settings applies to all instances of Visual Studio, all debugging sessions and all projects or solutions.

Escolha os eventos que o IntelliTrace registra (C#, Visual Basic)Choose the events that IntelliTrace records (C#, Visual Basic)

Você pode ativar ou desativar a gravação de eventos específicos do IntelliTrace.You can turn on or off recording for specific IntelliTrace events.

Se você estiver depurando, pare a depuração.If you're debugging, stop debugging. Vá para ferramentas > opções > intellitrace > eventos do IntelliTrace.Go to Tools > Options > IntelliTrace > IntelliTrace Events. Escolha os eventos que você deseja que o IntelliTrace registre.Choose the events you want IntelliTrace to record.

Coletar instantâneos (C#, Visual Basic, C++)Collect snapshots (C#, Visual Basic, C++)

Isso não é habilitado por padrão, mas o IntelliTrace pode capturar instantâneos do seu aplicativo em cada ponto de interrupção e evento de etapa do depurador, e você pode exibir esses instantâneos em uma sessão de depuração histórica.This isn't enabled by default, but IntelliTrace can capture snapshots of your application at every breakpoint and debugger step event, and you can view these snapshots in a historical debugging session. Um instantâneo fornece uma exibição do estado completo do aplicativo.A snapshot gives you a view of your full application state. Para habilitar a captura de instantâneos, vá para ferramentas > opções > IntelliTrace > geral e selecione instantâneos do IntelliTrace (gerenciados e nativos).To enable the capture of snapshots, go to Tools > Options > IntelliTrace > General, and select IntelliTrace snapshots (managed and native). Para saber mais, confira Inspecionar estados anteriores do aplicativo usando o IntelliTrace.For more information, see Inspect previous app states using IntelliTrace.

Os instantâneos estão disponíveis na versão 15,5 e superior do Visual Studio Enterprise 2017 e exigem atualização de aniversário do Windows 10 ou superior.Snapshots are available in Visual Studio Enterprise 2017 version 15.5 and higher, and it requires Windows 10 Anniversary Update or above. Para aplicativos .NET Core e ASP.NET Core, Visual Studio Enterprise 2017 versão 15,7 é necessária.For .NET Core and ASP.NET Core apps, Visual Studio Enterprise 2017 version 15.7 is required. Para aplicativos nativos direcionados para o Windows, Visual Studio Enterprise 2017 versão 15,9 Preview 2 é necessário.For native apps targeting Windows, Visual Studio Enterprise 2017 version 15.9 Preview 2 is required.

Coletar eventos do IntelliTrace e chamar informações (C#, Visual Basic)Collect IntelliTrace events and call information (C#, Visual Basic)

Isso não é habilitado por padrão, mas o IntelliTrace pode registrar chamadas de método juntamente com eventos.This isn't enabled by default, but IntelliTrace can record method calls along with events. Para habilitar a coleta de chamadas de método, acesse ferramentas > opções > IntelliTrace > geral e selecione eventos do IntelliTrace e chame informações (somente gerenciado).To enable collection of method calls go to Tools > Options > IntelliTrace > General, and select IntelliTrace events and call information (managed only).

As informações de chamada não estão disponíveis no momento para aplicativos .NET Core e ASP.NET Core.Call information is not currently available for .NET Core and ASP.NET Core apps.

Isso permite que você veja o histórico da pilha de chamadas e percorra as chamadas para trás e para frente em seu código.This lets you see the call stack history and step backward and forward through calls in your code. O IntelliTrace registra dados como nomes de métodos, entrada de método e pontos de saída e certos valores de parâmetro e valores de retorno.IntelliTrace records data such as method names, method entry and exit points, and certain parameter values and return values.

Dica

Essa opção não é habilitada por padrão porque adiciona uma sobrecarga considerável.This option is not enabled by default because it adds considerable overhead. Não apenas o IntelliTrace precisa interceptar cada chamada de método que seu aplicativo faz, mas também precisa lidar com um conjunto muito maior de dados quando se trata de mostrá-lo na tela ou mantê-lo em disco.Not only does IntelliTrace have to intercept every method call your application makes, but it also has to deal with a much larger set of data when it comes to showing it on the screen or persisting it to disk.

Você pode reduzir a sobrecarga de desempenho restringindo a lista de eventos que o IntelliTrace registra e mantendo o número de módulos que você está coletando para um mínimo.You can reduce the performance overhead by restricting the list of events that IntelliTrace records and by keeping the number of modules you are collecting to a minimum. Para obter mais informações, consulte controlar a quantidade de informações de chamada registros do IntelliTrace.For more information, see Control how much call information IntelliTrace records.

Usar a medianiz de navegaçãoUse the navigation gutter

Você pode usar a medianiz de navegação que aparece à esquerda da janela de código.You can use the navigation gutter that appears to the left of the code window. Se você não vir a medianiz de navegação, vá para ferramentas > opções > IntelliTrace > avançado e selecione exibir a medianiz de navegação enquanto estiver no modo de depuração.If you don't see the navigation gutter, go to Tools > Options > IntelliTrace > Advanced, and select Display the navigation gutter while in debug mode.

A medianiz de navegação permite que você avance para frente e para trás através de chamadas de método e eventos no modo de depuração histórica.The navigation gutter allows you to move forwards and backwards through method calls and events in historical debugging mode. Para obter mais informações sobre depuração histórica, consulte depuração histórica.For more information about historical debugging, see Historical Debugging. Ele tem vários comandos:It has a number of commands:

ComandoCommand DescriçãoDescription
Definir o contexto do depurador aquiSet Debugger Context Here Defina o contexto de depuração para o período de chamada onde ele aparece.Set the debugging context to the call timeframe where it appears.

Esse ícone aparece apenas na pilha de chamadas atual.This icon appears only on the current call stack.
Voltar para o site de chamadaReturn to Call Site Mova o ponteiro e Depurando o contexto de volta para o local em que a função atual foi chamada.Move the pointer and debugging context back to where the current function was called.

Se você estiver no modo de depuração dinâmica, esse comando ativará a depuração histórica em.If you are in Live Debugging mode, this command turns Historical Debugging on. Se você navegar de volta para a interrupção de execução original, a depuração histórica será desativada e a depuração dinâmica será ativada.If you navigate back to the original execution break, Historical Debugging is turned off and Live Debugging is turned on.
Ir para chamada anterior ou para evento do IntelliTraceGo to Previous Call or IntelliTrace Event Mova o ponteiro e a depuração do contexto de volta para a chamada ou evento anterior.Move the pointer and debugging context back to the previous call or event.

Se você estiver no modo de depuração dinâmica, esse comando ativará a depuração histórica.If you are in Live Debugging mode, this command turns on Historical Debugging.
EntrarStep In Passe para a função selecionada no momento.Step into the currently selected function.

Esse comando está disponível somente quando você está no modo de depuração histórica.This command is available only when you are in Historical Debugging mode.
Ir para próxima chamada ou para evento do IntelliTraceGo to Next Call or IntelliTrace Event Mova o ponteiro e o contexto de depuração para a próxima chamada ou evento para o qual os dados do IntelliTrace existem.Move the pointer and debugging context to the next call or event for which IntelliTrace data exists.

Esse comando está disponível somente quando você está no modo de depuração histórica.This command is available only when you are in Historical Debugging mode.
Ir para o modo ao vivoGo to Live Mode Retornar ao modo de depuração dinâmica.Return to Live Debugging mode.

Pesquisar uma linha ou um método no IntelliTraceSearch for a line or method in IntelliTrace

Você pode Pesquisar métodos somente quando as informações de chamada de método tiverem sido habilitadas.You can search methods only when method call information has been enabled. Você pode pesquisar o histórico do IntelliTrace para uma linha ou um método específico.You can search IntelliTrace history for a specific line or method. Enquanto a execução do depurador é interrompida, clique com o botão direito do mouse dentro do corpo da função para ver o menu de contexto e clique em Pesquisar por essa linha no IntelliTrace ou pesquise esse método no IntelliTrace.While debugger execution is halted, right-click inside the body of the function to see the context menu, and click either Search For This LIne In IntelliTrace or Search For This Method In IntelliTrace.

Controlar a quantidade de informações de chamada gravadas pelo IntelliTraceControl how much call information IntelliTrace records

Por padrão, o IntelliTrace registra informações para todos os módulos usados por sua solução.By default IntelliTrace records information for all the modules used by your solution. Você pode definir o IntelliTrace para registrar informações de chamada somente para os módulos que lhe interessam.You can set IntelliTrace to record call information only for the modules that interest you. Em ferramentas > opções > módulos do intellitrace >, você pode especificar os módulos a serem incluídos ou os módulos a serem excluídos do IntelliTrace.In Tools > Options > IntelliTrace > Modules, You can specify the modules to include or the modules to exclude from IntelliTrace. O IntelliTrace coletará somente os eventos originados dos módulos que você especificou e as chamadas de método que aconteceram nos módulos nos quais você está interessado.IntelliTrace will collect only the events that originated from the modules you have specified, and the method calls that happened within the modules you are interested in.

Para adicionar vários módulos, use o caractere curinga * no início ou no final da cadeia de caracteres.To add multiple modules, use the wildcard character * at the start or the end of the string. Para nomes de módulos, use nomes de arquivos, e não nomes de assembly.For module names, use file names, not assembly names. Caminhos de arquivo não são aceitos.File paths are not accepted.

Tente manter o número mínimo de módulos.Try to keep the number of modules to a minimum. Você Obtém um melhor desempenho porque há menos dados a serem coletados.You get better performance because there is less data to be collected. Você também obtém menos ruído na interface do usuário porque há menos dados para passar.You also get less noise in the UI because there is less data to go through.

Salvar dados do IntelliTrace em arquivo (C#, Visual Basic, C++)Save IntelliTrace data to file (C#, Visual Basic, C++)

Você pode salvar os dados que o IntelliTrace coletou para depurar > o IntelliTrace > salvar a sessão do IntelliTrace enquanto você está Depurando e o aplicativo está em um estado de interrupção.You can save the data that IntelliTrace has collected going to Debug > IntelliTrace > Save IntelliTrace Session while you are debugging and the application is in a break state. O item de menu está desabilitado e você não poderá salvar o IntelliTrace de dados coletado se o aplicativo ainda estiver em execução ou se você tiver interrompido a depuração.The menu item is disabled and you will not be able to save the data IntelliTrace has collected if the application is still running or if you have stopped debugging.

Você pode configurar o IntelliTrace para salvar automaticamente em um arquivo acessando ferramentas > opções > IntelliTrace > avançado e selecionando armazenar gravações do IntelliTrace nesse diretório.You can configure IntelliTrace to automatically save to a file by going to Tools > Options > IntelliTrace > Advanced and selecting Store IntelliTrace recordings in this directory. Você também pode configurar um tamanho definido para o arquivo gerado, o que faz com que o IntelliTrace grave dados mais antigos quando ele ficar sem espaço.You can also configure a set size for the generated file, which causes IntelliTrace to write over older data when it runs out of space. O Visual Studio cria dois arquivos para cada sessão do IntelliTrace quando eles são salvos automaticamente e o processo de hospedagem do Visual Studio (vshost.exe) é ativado.Visual Studio creates two files for each IntelliTrace session when they are saved automatically and the Visual Studio hosting process (vshost.exe) is turned on.

Dica

Para economizar espaço em disco, desative o salvamento de arquivos automaticamente quando você não precisar mais deles.To save disk space, turn off saving files automatically when you don't need them anymore. Todos os arquivos existentes não serão excluídos.Any existing files will not be deleted. Você sempre pode salvar em arquivo sob demanda no menu de contexto.You can always save to file on demand from the context menu.

Ao salvar dados do IntelliTrace no arquivo, você obtém um arquivo. itrace para cada processo que o IntelliTrace coletou.When you save IntelliTrace data to file, you get one .itrace file for each process that IntelliTrace collected from. Em seguida, você pode abrir o arquivo. itrace no Visual Studio acessando arquivo > abrir > arquivo e selecionando o arquivo. itrace na caixa de diálogo abrir arquivo.You can then open the .itrace file in Visual Studio by going to File > Open > File and selecting the .itrace file from the Open File dialog. Para obter mais informações, consulte usando dados do IntelliTrace salvos.For more information, see Using saved IntelliTrace data.

BlogsBlogs

IntelliTrace no Visual Studio Enterprise 2015IntelliTrace in Visual Studio Enterprise 2015

Passo a passos de depuração dinâmica usando o IntelliTrace no Visual Studio 2015 (editor de texto)Walkthrough of Live Debugging using IntelliTrace in Visual Studio 2015 (Text Editor)

Passo a passos de depuração dinâmica usando o IntelliTrace no Visual Studio 2015 (clube social)Walkthrough of Live Debugging using IntelliTrace in Visual Studio 2015 (Social Club)

O IntelliTrace no Visual Studio Enterprise 2015 agora dá suporte à anexação!IntelliTrace in Visual Studio Enterprise 2015 now supports attach!

Coletar dados de um serviço do Windows usando o coletor autônomo do IntelliTraceCollect data from a windows service using the IntelliTrace Standalone Collector

Editando o plano de coleta do IntelliTraceEditing the IntelliTrace collection plan

Rastreamento e depuração personalizados usando o IntelliTraceCustom TraceSource and debugging using IntelliTrace

Coletor autônomo do IntelliTrace e pools de aplicativos em execução em contas de Active DirectoryIntelliTrace Standalone Collector and Application Pools running under Active Directory accounts

FórunsForums

Depurador do Visual StudioVisual Studio Debugger

vídeosVideos

Experiência do IntelliTraceIntelliTrace Experience

Depuração histórica com o IntelliTrace no Microsoft Visual Studio Ultimate 2015Historical Debugging with IntelliTrace in Microsoft Visual Studio Ultimate 2015