Introdução ao Visual Studio e ao UnityGet started with Visual Studio and Unity

Observação

Este guia pressupõe que você já instalou o Unity usando o programa do Hub do Unity.This guide assumes you already have installed Unity using the Unity Hub program. Se você for novo no Unity, é recomendável visitar o Unity Learn e concluir o tutorial introdução with Unity primeiro.If you are new to Unity, we recommend visiting Unity Learn and complete the Getting Started with Unity tutorial first.

Instalar o suporte do Unity para o Visual StudioInstall Unity support for Visual Studio

Ferramentas do Visual Studio para Unity é uma extensão gratuita que fornece suporte para escrever e depurar C# e muito mais.Visual Studio Tools for Unity is a free extension that provides support for writing and debugging C# and more. Visite a visão geral do Tools for Unity para obter uma lista completa do que as extensões incluem.Visit the Tools for Unity overview for a complete list of what the extensions includes.

Observação

Este guia de instalação é para o Visual Studio.This installation guide is for Visual Studio. Se você estiver usando Visual Studio Code, visite a documentação de desenvolvimento do Unity com vs Code.If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

  1. Baixe o instalador do Visual Studioou execute-o se já estiver instalado.Download the Visual Studio installer, or run it if already installed.

  2. Clique em Modificar (se já estiver instalado) ou em Instalar (para novas instalações) para a versão desejada do Visual Studio.Click Modify (if already installed) or Install (for new installations) for your desired version of Visual Studio.

  3. Na guia cargas de trabalho , role até a seção jogos e selecione o desenvolvimento de jogos com carga de trabalho do Unity.On the Workloads tab, scroll to the Gaming section and select the Game development with Unity workload.

    Desenvolvimento de jogos com a caixa carga de trabalho do Unity no instalador

Observação

Este guia de instalação é para Visual Studio para Mac.This installation guide is for Visual Studio for Mac. Se você estiver usando Visual Studio Code, visite a documentação de desenvolvimento do Unity com vs Code.If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

As ferramentas para o Unity estão incluídas na instalação do Visual Studio para Mac e não são necessárias etapas de instalação separadas.Tools for Unity is included with the installation of Visual Studio for Mac and no separate installation steps are required. Você pode verificar isso no menu Visual Studio para Mac > Extensions > desenvolvimento de jogos .You can verify this in the Visual Studio for Mac > Extensions > Game Development menu. As ferramentas de Visual Studio para Mac para Unity devem ser habilitadas.Visual Studio for Mac Tools for Unity should be enabled.

Exibição do Gerenciador de extensões mostrando as ferramentas de Visual Studio para Mac para o Unity habilitado

Verificar atualizaçõesCheck for updates

É recomendável manter o Visual Studio e Visual Studio para Mac atualizado para que você tenha as mais recentes correções de bugs, recursos e suporte do Unity.It's recommended to keep Visual Studio and Visual Studio for Mac updated so you have the latest bug fixes, features, and Unity support. Isso não requer uma atualização das versões do Unity.This doesn't require an update of Unity versions.

  1. Clique no menu ajuda > verificar atualizações .Click the Help > Check for Updates menu.

    O menu verificar atualizações no Visual Studio 2019

  2. Se houver uma atualização disponível, o Instalador do Visual Studio mostrará uma nova versão.If there is an update available, the Visual Studio Installer will show a new version. Clique no botão Atualizar.Click the Update button.

  1. Clique no menu Visual Studio para Mac > verificar se há atualizações... para abrir a caixa de diálogo atualização do Visual Studio .Click the Visual Studio for Mac > Check for Updates... menu to open the Visual Studio Update dialog.
  2. Se houver uma atualização disponível, clique no botão instalar .If there is an update available, click the Install button.

Configurar o Unity para usar o Visual StudioConfigure Unity to use Visual Studio

Por padrão, o Unity já deve estar configurado para usar o Visual Studio ou Visual Studio para Mac como um editor de scripts.By default, Unity should already be configured to use Visual Studio or Visual Studio for Mac as a script editor. Você pode confirmar isso ou alterar o editor de script externo para uma versão específica do Visual Studio do editor do Unity.You can confirm this or change the external script editor to a specific version of Visual Studio from the Unity Editor.

  1. No editor do Unity, selecione o menu Editar preferências de > ..In the Unity Editor, select the Edit > Preferences menu..

  2. Selecione a guia Ferramentas externas à esquerda.Select the External Tools tab on the left.

  3. A lista suspensa Editor de scripts externos fornece uma maneira de escolher diferentes instalações do Visual Studio.The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. Você também pode clicar em procurar... na lista suspensa para adicionar uma versão não listada.You can also click Browse... from the dropdown list to add an unlisted version.

    O menu de preferências de ferramentas externas no editor do Unity no Windows

  4. Se Procurar... for selecionado, navegue até o diretório Common7/IDE dentro do seu diretório de instalação do Visual Studio e selecione devenv.exe.If Browse... was selected, navigate to the Common7/IDE directory inside your Visual Studio installation directory and select devenv.exe. Em seguida, clique em abrir.Then, click Open.

  5. Após a seleção do Visual Studio na lista Editor de Script Externo, confirme se a caixa de seleção Anexo do Editor está selecionada.Once Visual Studio is selected in the External Script Editor list, confirm that the Editor Attaching checkbox is selected.

  6. Feche a caixa de diálogo Preferências para concluir o processo de configuração.Close the Preferences dialog to complete the configuration process.

  1. No editor do Unity, selecione o menu de preferências do > do Unity .In the Unity Editor, select the Unity > Preferences menu..

  2. Selecione a guia Ferramentas externas à esquerda.Select the External Tools tab on the left.

  3. A lista suspensa Editor de scripts externos fornece uma maneira de escolher diferentes instalações do Visual Studio.The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. Você também pode clicar em procurar... na lista suspensa para adicionar uma versão não listada.You can also click Browse... from the dropdown list to add an unlisted version.

    O menu de preferências de ferramentas externas no editor do Unity no macOS

  4. Feche a caixa de diálogo Preferências para concluir o processo de configuração.Close the Preferences dialog to complete the configuration process.

Próximas etapasNext steps

Para saber como trabalhar com e depurar seu projeto do Unity no Visual Studio, visite usando ferramentas do Visual Studio para Unity.To learn how to work with and debug your Unity project in Visual Studio, visit Using Visual Studio Tools for Unity.