introdução ao Visual Studio e ao Unity

Observação

Este guia pressupõe que você já instalou o Unity usando o programa do Hub do Unity. Se você for novo no Unity, é recomendável visitar o Unity Learn e concluir primeiro o roteiro de aprendizagem do Unity Essentials .

Instalar o suporte do Unity para Visual Studio

Ferramentas do Visual Studio para Unity é uma extensão gratuita que fornece suporte para escrever e depurar C# e muito mais. Visite a visão geral do Tools for Unity para obter uma lista completa do que as extensões incluem.

Observação

Este guia de instalação é para Visual Studio. se você estiver usando Visual Studio Code, visite a documentação de desenvolvimento do Unity com VS Code.

  1. baixe o instalador do Visual Studioou execute-o se já estiver instalado.

  2. Clique em Modificar (se já estiver instalado) ou em Instalar (para novas instalações) para a versão desejada do Visual Studio.

  3. Na guia cargas de trabalho , role até a seção jogos e selecione o desenvolvimento de jogos com carga de trabalho do Unity.

    Desenvolvimento de jogos com a caixa carga de trabalho do Unity no instalador

Observação

este guia de instalação é para Visual Studio para Mac. se você estiver usando Visual Studio Code, visite a documentação de desenvolvimento do Unity com VS Code.

as ferramentas para o Unity estão incluídas na instalação do Visual Studio para Mac e não são necessárias etapas de instalação separadas. você pode verificar isso no menu Visual Studio para Mac > Extensions > desenvolvimento de jogos . as ferramentas de Visual Studio para Mac para Unity devem ser habilitadas.

exibição do gerenciador de extensões mostrando as ferramentas de Visual Studio para Mac para o Unity habilitado

Verificar atualizações

é recomendável manter Visual Studio e Visual Studio para Mac atualizado para que você tenha as mais recentes correções de bugs, recursos e suporte do Unity. Isso não requer uma atualização das versões do Unity.

  1. Clique no menu ajuda > verificar atualizações .

    o menu verificar atualizações no Visual Studio 2019

  2. se houver uma atualização disponível, o Instalador do Visual Studio mostrará uma nova versão. Clique no botão Atualizar.

  1. clique no menu Visual Studio para Mac > verificar se há atualizações... para abrir a caixa de diálogo de atualização de Visual Studio .
  2. Se houver uma atualização disponível, clique no botão instalar .

Configurar o Unity para usar Visual Studio

por padrão, o Unity já deve estar configurado para usar Visual Studio ou Visual Studio para Mac como um editor de scripts. você pode confirmar isso ou alterar o editor de script externo para uma versão específica do Visual Studio do editor do Unity.

  1. No editor do Unity, selecione o menu Editar preferências de > ..

  2. Selecione a guia Ferramentas externas à esquerda.

  3. A lista suspensa Editor de scripts externos fornece uma maneira de escolher diferentes instalações do Visual Studio. Você também pode clicar em procurar... na lista suspensa para adicionar uma versão não listada.

    O menu de preferências de ferramentas externas no editor do Unity no Windows

  4. Se Procurar... for selecionado, navegue até o diretório Common7/IDE dentro do seu diretório de instalação do Visual Studio e selecione devenv.exe. Em seguida, clique em abrir.

  5. Após a seleção do Visual Studio na lista Editor de Script Externo, confirme se a caixa de seleção Anexo do Editor está selecionada.

  6. Feche a caixa de diálogo Preferências para concluir o processo de configuração.

  1. No editor do Unity, selecione o menu de preferências do > do Unity .

  2. Selecione a guia Ferramentas externas à esquerda.

  3. A lista suspensa Editor de scripts externos fornece uma maneira de escolher diferentes instalações do Visual Studio. Você também pode clicar em procurar... na lista suspensa para adicionar uma versão não listada.

    O menu de preferências de ferramentas externas no editor do Unity no macOS

  4. Feche a caixa de diálogo Preferências para concluir o processo de configuração.

Próximas etapas

para saber como trabalhar com e depurar seu projeto do Unity no Visual Studio, visite usando Ferramentas do Visual Studio para Unity.