Criar e limpar projetos e soluções no Visual StudioBuild and clean projects and solutions in Visual Studio

Usando os procedimentos neste tópico, é possível criar, recriar ou limpar todos ou alguns projetos ou itens de projeto em uma solução.By using the procedures in this topic, you can build, rebuild, or clean all or some of the projects or project items in a solution. Para obter um tutorial passo a passo, confira Passo a passo: Criando um aplicativo.For a step-by-step tutorial, see Walkthrough: Building an application.

Note

Este tópico aplica-se ao Visual Studio no Windows.This topic applies to Visual Studio on Windows. Para o Visual Studio para Mac, confira Criar e limpar projetos e soluções no Visual Studio para Mac.For Visual Studio for Mac, see Build and clean projects and solutions in Visual Studio for Mac.

Note

A interface do usuário na sua edição do Visual Studio pode ser diferente do que este tópico descreve, dependendo das suas configurações ativas.The UI in your edition of Visual Studio might differ from what this topic describes, depending on your active settings. Para alterar as configurações, por exemplo, para configurações Gerais ou do Visual C++ , escolha Ferramentas > Importar e Exportar Configurações e, em seguida, escolha Redefinir todas as configurações.To change your settings, for example to General or Visual C++ settings, choose Tools > Import and Export Settings, and then choose Reset all settings.

Para criar, recriar ou limpar uma solução inteiraTo build, rebuild, or clean an entire solution

  1. No Gerenciador de Soluções, escolha ou abra a solução.In Solution Explorer, choose or open the solution.

  2. Na barra de menus, escolha Compilar e, em seguida, escolha um dos comandos a seguir:On the menu bar, choose Build, and then choose one of the following commands:

    • Escolha Compilar ou Compilar Solução para compilar somente esses componentes e arquivos de projeto e componentes que foram alterados desde o build mais recente.Choose Build or Build Solution to compile only those project files and components that have changed since the most recent build.

      Note

      O comando Compilar torna-se Compilar Solução quando uma solução inclui mais de um projeto.The Build command becomes Build Solution when a solution includes more than one project.

    • Escolha Recompilar Solução para "limpar" a solução e, em seguida, crie todos os arquivos de projeto e componentes.Choose Rebuild Solution to "clean" the solution and then build all project files and components.

    • Escolha Limpar Solução para excluir arquivos de saída e intermediários.Choose Clean Solution to delete any intermediate and output files. Com apenas os arquivos de projeto e de componente restantes, novas instâncias dos arquivos de saída e intermediários podem ser criadas.With only the project and component files left, new instances of the intermediate and output files can then be built.

Para compilar ou recompilar um único projetoTo build or rebuild a single project

  1. No Gerenciador de Soluções, escolha ou abra o projeto.In Solution Explorer, choose or open the project.

  2. Na barra de menus, escolha Compilar e, em seguida, escolha Compilar ProjectName ou Recompilar ProjectName.On the menu bar, choose Build, and then choose either Build ProjectName or Rebuild ProjectName.

    • Escolha Compilar ProjectName para compilar somente os componentes de projeto alterados desde o build mais recente.Choose Build ProjectName to build only those project components that have changed since the most recent build.

    • Escolha Recompilar ProjectName para "limpar" o projeto e, em seguida, compile os arquivos de projeto e todos os componentes do projeto.Choose Rebuild ProjectName to "clean" the project and then build the project files and all project components.

Para compilar apenas o projeto de inicialização e suas dependênciasTo build only the startup project and its dependencies

  1. Na barra de menus, escolha Ferramentas > Opções.On the menu bar, choose Tools > Options.

  2. Na caixa de diálogo Opções, expanda o nó Projetos e Soluções e, em seguida, escolha a página Compilar e Executar.In the Options dialog box, expand the Projects and Solutions node, and then choose the Build and Run page.

    A caixa de diálogo Compilar e Executar > Projetos e Soluções > Opções é aberta.The Build and Run > Projects and Solutions > Options dialog box opens.

  3. Marque a caixa de seleção Compilar apenas projetos de inicialização e dependências ao Executar.Select the Only build startup projects and dependencies on Run check box.

    Quando essa caixa de seleção estiver marcada, somente o projeto de inicialização atual e suas dependências serão compilados quando você executar qualquer uma das seguintes etapas:When this check box is selected, only the current startup project and its dependencies are built when you perform either of the following steps:

    • Na barra de menus, escolha Depurar > Iniciar (F5).On the menu bar, choose Debug > Start (F5).

    • Na barra de menus, escolha Compilar > Compilar Solução (Ctrl+Shift+B).On the menu bar, choose Build > Build Solution (Ctrl+Shift+B).

    Quando essa caixa de seleção estiver desmarcada, todos os projetos, suas dependências e os arquivos de solução serão compilados quando você executar um dos comandos anteriores.When this check box is cleared, all projects, their dependencies, and the solution files are built when you run either of the preceding commands. Por padrão, essa caixa de seleção está desmarcada.By default, this check box is cleared.

Para compilar somente o projeto Visual C++ selecionadoTo build only the selected Visual C++ project

Escolha um projeto Visual C++Visual C++ e, em seguida, na barra de menus, escolha Compilar > Somente Projeto e um dos seguintes comandos:Choose a Visual C++Visual C++ project, and then, on the menu bar, choose Build > Project Only, and one of the following commands:

  • Somente build ProjectNameBuild Only ProjectName

  • Somente Recompilação ProjectNameRebuild Only ProjectName

  • Somente Limpeza ProjectNameClean Only ProjectName

  • Somente Vinculação ProjectNameLink Only ProjectName

Esses comandos são aplicáveis somente ao projeto Visual C++Visual C++ escolhido, sem compilar, recompilar, limpar ou vincular as dependências do projeto ou os arquivos de solução.These commands apply only to the Visual C++Visual C++ project that you chose, without building, rebuilding, cleaning, or linking any project dependencies or solution files. Dependendo da sua versão do Visual StudioVisual Studio, o submenu Somente Projeto pode conter mais comandos.Depending on your version of Visual StudioVisual Studio, the Project Only submenu might contain more commands.

Para compilar vários itens de projeto C++To compile multiple C++ project items

Em Gerenciador de Soluções, escolha vários arquivos que possam ter ações compiladas, abra o menu de atalho para um desses arquivos e, em seguida, escolha Compilar.In Solution Explorer, choose multiple files that have can be compiled actions, open the shortcut menu for one of those files, and then choose Compile.

Se os arquivos tiverem dependências, os arquivos serão compilados em ordem de dependência.If the files have dependencies, the files will be compiled in dependency order. A operação de compilação falhará se os arquivos exigirem um cabeçalho pré-compilado que não está disponível quando você compila.The compile operation will fail if the files require a precompiled header that isn't available when you compile. A operação de compilação usa a configuração de solução ativa atual.The compile operation uses the current active solution configuration.

Para interromper um buildTo stop a build

Execute uma das seguintes etapas:Perform either of the following steps:

  • Na barra de menus, selecione Compilar > Cancelar.On the menu bar, select Build > Cancel.

  • Pressione Ctrl+Interromper.Press Ctrl+Break.

Consulte tambémSee also