Criar um novo projeto no Visual StudioCreate a new project in Visual Studio

Abrir a caixa de diálogo Novo ProjetoOpen the New Project dialog

Há várias maneiras de criar um projeto no Visual Studio 2017.There are multiple ways to create a new project in Visual Studio 2017. Na página Inicial, você pode digitar o nome de um modelo de projeto na caixa Pesquisar modelos de projeto ou escolher o link Criar novo projeto para abrir a caixa de diálogo Novo Projeto.On the Start page, you can type in the name of a project template in the Search project templates box or choose the Create new project link to open the New Project dialog box. Além da página Inicial, você também pode escolher Arquivo > Novo > Projeto na barra de menus ou clicar no botão Novo Projeto na barra de ferramentas.Aside from the Start page, you can also choose File > New > Project on the menu bar or click the New Project button on the toolbar.

Página inicial e Arquivo > Novo > Projeto

Selecione um tipo de modeloSelect a template type

Na caixa de diálogo Novo Projeto, os modelos de projeto disponíveis aparecem em uma lista sob a categoria Modelos.In the New Project dialog box, available project templates appear in a list under the Templates category. Os modelos são organizados por linguagem de programação e tipo de projeto, como Visual C#, JavaScript e Azure Data Lake.Templates are organized by programming language and project type, such as Visual C#, JavaScript, and Azure Data Lake.

Caixa de diálogo Novo Projeto

Note

A lista de linguagens e modelos de projeto disponíveis que é exibida depende da versão do Visual Studio que você está executando e das cargas de trabalho que estão instaladas.The list of available languages and project templates that appears depends on the version of Visual Studio you are running and the workloads that are installed. Para saber mais sobre como instalar cargas de trabalho adicionais, confira Modificar o Visual Studio adicionando ou removendo cargas de trabalho e componentes.To learn about how to install additional workloads, see Modify Visual Studio by adding or removing workloads and components.

Para mostrar a lista de modelos da linguagem de programação que você deseja usar, clique no triângulo próximo do nome da linguagem e, em seguida, escolha uma categoria de projeto (tal como Área de Trabalho do Windows).Show the list of templates for the programming language you want to use by clicking the triangle next to the language name and then choosing a project category (such as Windows Desktop).

A imagem a seguir mostra os modelos de projeto disponíveis para projetos .NET Core do Visual C#:The following image shows the project templates available for Visual C# .NET Core projects:

Modelos de projeto

Configurar seu projetoConfigure your project

Digite um nome para o novo projeto na caixa Nome.Enter a name for the new project in the Name box. Você pode salvar o projeto no local padrão em seu computador ou escolher o botão Procurar para encontrar outro local.You can save the project in the default location on your computer or click the Browse button to find another location. Você também pode escolher um nome da solução ou adicionar o novo projeto a um repositório Git, escolhendo Adicionar ao Controle do Código-Fonte.You can also choose a solution name or add the new project to a Git repository (by choosing Add to Source Control).

Clique em OK para criar a solução e o projeto.Click OK to create the solution and project.

Abrir a página Criar um novo projetoOpen the Create a new project page

Há várias maneiras de criar um projeto no Visual Studio 2019.There are multiple ways to create a new project in Visual Studio 2019. Quando você abre o Visual Studio pela primeira vez, é exibida a janela de início e, por meio dela, você pode escolher Criar um novo projeto.When you first open Visual Studio, the start window appears, and from there, you can choose Create a new project.

Criar um projeto na janela de início no VS 2019

Se o ambiente de desenvolvimento do Visual Studio já estiver aberto, você poderá criar um projeto escolhendo Arquivo > Novo > Projeto na barra de menus ou clicando em Novo Projeto na barra de ferramentas.If the Visual Studio development environment is already open, you can create a new project by choosing File > New > Project on the menu bar or by clicking the New Project button on the toolbar.

Botão Novo Projeto no Visual Studio 2019

Selecione um tipo de modeloSelect a template type

Na página Criar um novo projeto, uma lista de seus modelos recentemente selecionados aparece à esquerda.On the Create a new project page, a list of your recently selected templates appears on the left. Os modelos são classificados por usados mais recentemente.The templates are sorted by most recently used.

Se não selecionar entre os modelos usados recentemente, você poderá filtrar todos os modelos de projeto disponíveis por Linguagem de programação (por exemplo, C# ou C++), Plataforma (por exemplo, Windows ou Azure) e Tipo de projeto (por exemplo, Desktop ou Web).If you're not selecting from the recently used templates, you can filter all available project templates by Language (for example, C# or C++), Platform (for example, Windows or Azure), and Project type (for example, Desktop or Web). Você também pode inserir texto de pesquisa na caixa de pesquisa para filtrar ainda mais os modelos, por exemplo, asp.net.You can also enter search text into the search box to further filter the templates, for example, asp.net.

Filtros de modelo de projeto no Visual Studio 2019

As marcas que aparecem em cada modelo correspondem aos três filtros de lista suspensa (Tipo de projeto, Plataforma e Linguagem de programação).The tags that appear under each template correspond to the three dropdown filters (Language, Platform, and Project type).

Tip

Se não vir o modelo que você está procurando, você poderá ter uma carga de trabalho ausente para o Visual Studio.If you don't see the template you're looking for, you may be missing a workload for Visual Studio. Para instalar cargas de trabalho adicionais, por exemplo, Desenvolvimento do Azure ou Desenvolvimento móvel com .NET, clique no link Instalar mais ferramentas e recursos para abrir o Instalador do Visual Studio.To install additional workloads, for example, Azure Development or Mobile Development with .NET, click the Install more tools and features link to open Visual Studio Installer. Nele, selecione as cargas de trabalho que você deseja instalar e, em seguida, escolha Modificar.From there, select the workloads you want to install, and then choose Modify. Depois disso, modelos de projeto adicionais serão disponibilizados para sua escolha.After that, additional project templates will be available to choose from.

Instalar mais links de ferramentas e recursos no VS 2019

Selecione um modelo e, em seguida, clique em Avançar.Select a template and then click Next.

Configurar seu projetoConfigure your project

A página Configurar seu novo projeto tem opções para nomear seu projeto (e a solução), escolher um local de disco e selecionar uma versão do Framework (se aplicável ao modelo que você escolheu).The Configure your new project page has options to name your project (and solution), choose a disk location, and select a Framework version (if applicable to the template you chose).

Página Configurar seu novo projeto VS 2019

Note

Se você criar um projeto quando já tiver um projeto ou solução aberta no Visual Studio, uma opção de configuração adicional estará disponível.If you create a new project when you already have a project or solution open in Visual Studio, an extra configuration option is available. Você pode optar por criar uma solução ou adicionar o novo projeto à solução que já está aberta.You can choose to create a new solution or add the new project to the solution that's already open.

Criar solução ou adicionar a solução existente no VS 2019

Clique em Criar para criar o projeto.Click Create to create the new project.

Adicionar projetos adicionais a uma soluçãoAdd additional projects to a solution

Se quiser adicionar um projeto adicional a uma solução, clique com o botão direito do mouse no nó Solução no Gerenciador de Soluções e escolha Adicionar > Novo Projeto.If you want to add an additional project to a solution, right-click the solution node in Solution Explorer and choose Add > New Project.

Consulte tambémSee also