Criar soluções e projetosCreate solutions and projects

Os projetos armazenam os itens necessários para criação do aplicativo no Visual Studio, como arquivos de código-fonte, bitmaps, ícones e referências de componente e serviço.Projects hold the items needed to build your app in Visual Studio, such as source code files, bitmaps, icons, and component and service references. Quando você cria um novo projeto, o Visual Studio cria uma solução para contê-lo.When you create a new project, Visual Studio creates a solution to contain the project. Você poderá, então, adicionar projetos novos ou existentes à solução, se desejar.You can then add other new or existing projects to the solution if you want. As soluções também podem conter arquivos não conectados a nenhum projeto específico.Solutions can also contain files that aren't connected to any specific project.

Hierarquia de projeto/solução

Note

Este tópico aplica-se ao Visual Studio no Windows.This topic applies to Visual Studio on Windows. Para o Visual Studio para Mac, confira Criar projetos no Visual Studio para Mac.For Visual Studio for Mac, see Create projects in Visual Studio for Mac.

Você pode exibir suas soluções e projetos em uma janela de ferramentas chamada Gerenciador de Soluções.You can view your solutions and projects in a tool window called Solution Explorer. A seguinte captura de tela mostra uma solução de exemplo no Gerenciador de Soluções (BikeSharing.Xamarin-UWP) que contém dois projetos: BikeSharing.Clients.Core e BikeSharing.Clients.Windows.The following screenshot shows an example solution in Solution Explorer (BikeSharing.Xamarin-UWP) that contains two projects: BikeSharing.Clients.Core and BikeSharing.Clients.Windows. Cada projeto contém vários arquivos, pastas e referências.Each project contains multiple files, folders, and references. O nome do projeto em negrito é o projeto de inicialização, ou seja, o projeto que é iniciado quando você executa o aplicativo.The project name in bold is the startup project; that is, the project that starts when you run the app. Você pode especificar qual projeto é o projeto de inicialização.You can specify which project is the startup project.

Gerenciador de Soluções com projetos

Embora você possa construir um projeto por conta própria, adicionando nele os arquivos necessários, o Visual Studio oferece uma seleção de modelos de projeto para lhe proporcionar um ponto de partida.While you can construct a project yourself by adding the necessary files to it, Visual Studio offers a selection of project templates to give you a head start. A criação de um novo projeto com base em um modelo oferece um projeto com o que é essencial para aquele tipo de projeto e você pode renomear os arquivos ou adicionar código, novo ou existente, ao projeto, bem como adicionar outros recursos, conforme a necessidade.Creating a new project from a template gives you a project with the essentials for that project type, and you can rename the files or add new or existing code and other resources to it as needed.

Dito isso, soluções e projetos não são necessários para desenvolver aplicativos no Visual Studio.That being said, solutions and projects are not required to develop apps in Visual Studio. Você também pode simplesmente abrir código clonado do Git ou baixado em outro lugar.You can also just open code that you have cloned from Git or downloaded elsewhere. Para obter mais informações, consulte Desenvolver código no Visual Studio sem projetos nem soluções.For more information, see Develop code in Visual Studio without projects or solutions.

Criar um projeto com base em um modelo de projetoCreate a project from a project template

Para obter informações sobre como criar um projeto com base em um modelo, veja Criar um novo projeto no Visual Studio.For information about creating a new project from a template, see Create a new project in Visual Studio.

Criar um projeto com base em arquivos de código existentesCreate a project from existing code files

Se você tem uma coleção de arquivos de origem de código, é possível adicioná-los facilmente a um projeto.If you have a collection of code source files, you can easily add them to a project.

  1. No menu, escolha Arquivo > Novo > Projeto de Código Existente.On the menu, choose File > New > Project From Existing Code.

  2. No assistente Criação de Projeto de Arquivos de Código Existentes, escolha o tipo de projeto que você deseja na caixa de listagem suspensa Que tipo de projeto deseja criar? e, em seguida, escolha o botão Avançar.In the Create Project from Existing Code Files wizard, choose the project type you want in the What type of project would you like to create? drop-down list box, and then choose the Next button.

  3. No assistente, navegue até o local dos arquivos e, em seguida, insira um nome para o novo projeto na caixa Nome.In the wizard, browse to the location of the files and then enter a name for the new project in the Name box. Quando terminar, escolha o botão Concluir.When you are done, choose the Finish button.

Note

Essa opção funciona melhor para uma coleção relativamente simples de arquivos.This option works best for a relatively simple collection of files. Atualmente, somente os tipos de projeto do Visual C++, Apache Cordova, Visual Basic e C# são compatíveis.Currently, only Visual C++, Apache Cordova, Visual Basic, and C# project types are supported.

Adicionar arquivos a uma soluçãoAdd files to a solution

Se você tem um arquivo que se aplica a vários projetos, como um arquivo Leiame para a solução ou outros arquivos que pertençam de forma lógica ao nível da solução e não a um projeto específico, é possível adicioná-los à própria solução.If you have a file that applies to multiple projects, such as a readme file for the solution, or other files that logically belong at the solution level rather than under a specific project, then you can add them to the solution itself. Para adicionar um item a uma solução, no menu de contexto (clicar com o botão direito do mouse) do nó da solução no Gerenciador de Soluções, escolha Adicionar > Novo Item ou Adicionar > Item existente.To add an item to a solution, on the context (right-click) menu of the solution node in Solution Explorer, choose Add > New Item, or Add > Existing Item.

Criar um projeto .NET que direciona uma versão específica do .NET FrameworkCreate a .NET project that targets a specific version of the .NET Framework

Ao criar um projeto .NET Framework, você pode determinar uma versão específica do .NET Framework que deseja usar no projeto.When you create a .NET Framework project, you can specify a specific version of the .NET Framework that you want the project to use. (Ao criar um projeto .NET Core, você não especifica uma versão de estrutura.)(When you create a .NET Core project, you don't specify a framework version.)

Para especificar uma versão do .NET Framework, escolha o menu suspenso Framework na caixa de diálogo Novo Projeto.To specify a .NET Framework version, choose the Framework drop-down menu in the New Project dialog box.

A lista suspensa Estrutura na caixa de diálogo Novo Projeto

Note

É necessário ter o .NET Framework 3.5 instalado em seu sistema para acessar as versões do .NET Framework anteriores à versão 4.You must have .NET Framework 3.5 installed on your system to access .NET Framework versions earlier than .NET Framework 4.

Para especificar uma versão do .NET Framework, escolha o menu suspenso Framework na página Criar um projeto.To specify a .NET Framework version, choose the Framework drop-down menu on the Create a new project page.

Seletor de Framework em configurar um novo projeto

Criar soluções vaziasCreate empty solutions

Você também pode criar soluções vazias que não tenham projetos.You can also create empty solutions that have no projects. Isso é preferível em casos em que você deseja criar a solução e os projetos do zero.This might be preferable in cases where you want to construct your solution and projects from scratch.

Para criar uma solução vaziaTo create an empty solution

  1. Na barra de menus, selecione Arquivo > Novo > Projeto.On the menu bar, choose File > New > Project.
  1. No painel esquerdo (Modelos), escolha Outros Tipos de Projetos > Soluções do Visual Studio na lista expandida.In the left (Templates) pane, choose Other Project Types > Visual Studio Solutions in the expanded list.

  2. No painel central, selecione Solução em Branco.In the middle pane, choose Blank Solution.

  3. Insira os valores Nome e Local da sua solução e, em seguida, clique em OK.Enter Name and Location values for your solution, and then choose OK.

  1. Na página Criar um novo projeto, digite solução na caixa de pesquisa.On the Create a new project page, type solution into the search box.

  2. Selecione o modelo solução em branco e clique em Avançar.Select the Blank Solution template, and then click Next.

  3. Insira os valores Nome e Local da sua solução e, em seguida, clique em Criar.Enter Name and Location values for your solution, and then choose Create.

Depois de criar uma solução vazia, é possível adicionar projetos novos ou existentes ou itens a ele ao selecionar Adicionar Novo Item ou Adicionar Item Existente no menu Projeto.After you create an empty solution, you can add new or existing projects or items to it by choosing Add New Item or Add Existing Item on the Project menu.

Como mencionado anteriormente, você também pode abrir arquivos de código sem precisar de um projeto ou solução.As mentioned earlier, you can also open code files without needing a project or solution. Para saber mais sobre como desenvolver código dessa forma, consulte Desenvolver código no Visual Studio sem projetos ou soluções.To learn about developing code in this way, see Develop code in Visual Studio without projects or solutions.

Criar um projeto temporárioCreate a temporary project

(somente C# e Visual Basic)(C# and Visual Basic only)

Se você criar um projeto com base em .NET sem especificar um local de disco, ele será um projeto temporário.If you create a .NET-based project without specifying a disk location, it is a temporary project. Os projetos temporários permitem fazer experimentos com projetos do .NET.Temporary projects enable you to experiment with .NET projects. A qualquer momento, enquanto você está trabalhando com um projeto temporário, é possível escolher salvá-lo ou descartá-lo.At any time while you are working with a temporary project, you can choose to save it or discard it.

Para criar um projeto temporário, primeiro acesse Ferramentas > Opções > Projetos e Soluções > Geral e desmarque a caixa de seleção Salvar novos projetos quando criados.To create a temporary project, first go to Tools > Options > Projects and Solutions > General, and uncheck the Save new projects when created checkbox. Em seguida, abra a caixa de diálogo Novo projeto como de costume.Then open the New Project dialog box as usual.

Excluir uma solução, um projeto ou um itemDelete a solution, project, or item

Você pode excluir as soluções e seu conteúdo permanentemente, mas não usando o IDE do Visual Studio.You can delete solutions and their contents permanently, but not by using the Visual Studio IDE. A exclusão de itens dentro do Visual Studio somente os remove da solução ou do projeto atual.Deleting items within Visual Studio only removes them from the current solution or project. Para excluir permanentemente do sistema uma solução ou outro componente, use o Explorador de Arquivos para excluir a pasta que contém os arquivos de solução .sln e .suo.To permanently delete a solution or other component from your system, use File Explorer to delete the folder that contains the .sln and .suo solution files. No entanto, antes de excluir permanentemente uma solução, é recomendável que você faça backup de todos os projetos ou arquivos, caso sejam necessários novamente.However, before permanently deleting a solution, it's recommended that you back up any projects or files in case you need them again.

Note

O arquivo .suo é um arquivo oculto que não é exibido com as configurações padrão do Explorador de Arquivos.The .suo file is a hidden file that is not displayed under the default File Explorer settings. Para mostrar arquivos ocultos, no menu Exibir do Explorador de Arquivos, marque a caixa de seleção Itens Ocultos.To show hidden files, on the View menu in File Explorer, select the Hidden Items checkbox.

Excluir uma solução permanentementePermanently delete a solution

  1. No Gerenciador de Soluções, no menu do clique com o botão direito (menu de contexto) da solução que deseja excluir, escolha Abrir pasta no Explorador de Arquivos.In Solution Explorer, on the right-click menu (context menu) of the solution you want to delete, choose Open folder in File Explorer.

  2. No Gerenciador de Arquivos, navegue um nível acima.In File Explorer, navigate up one level.

  3. Escolha a pasta que contém a solução e pressione a tecla Delete.Choose the folder containing the solution and then press the Delete key.

Consulte tambémSee also