Localizar e substituir texto

Localize e substitua um texto no editor do Visual Studio usando Localizar e Substituir (Ctrl+F ou Ctrl+H) ou Localizar/Substituir em Arquivos (Ctrl+Shift+F ou Ctrl+Shift+H). Localize e substitua também apenas algumas instâncias de um padrão usando a seleção de vários sinais de interpolação.

Dica

Se você está renomeando os símbolos de código, como variáveis e métodos, é melhor refatorá-los em vez de usar o recurso Localizar e Substituir. A refatoração é inteligente e reconhece o escopo, enquanto o recurso Localizar e Substituir substitui cegamente todas as instâncias.

A funcionalidade Localizar e Substituir está disponível no editor, em algumas outras janelas baseadas em texto, como as janelas Localizar Resultados, em janelas do designer como o Designer XAML e o Designer de Formulários do Windows e nas janelas de ferramentas.

É possível definir o escopo das pesquisas para o documento atual, a solução atual ou um conjunto personalizado de pastas. Também é possível especificar um conjunto de extensões de nome de arquivo para pesquisas em vários arquivos. Personalize a sintaxe de pesquisa usando expressões regulares do .NET.

Dica

A caixa Localizar/Comando está disponível como um controle de barra de ferramentas, mas não fica visível por padrão. Para exibir a caixa Localizar/Comando, selecione Adicionar ou Remover Botões na barra de ferramentas Padrão e, em seguida, selecione Localizar.

Controle Localizar e Substituir

  • Pressione Ctrl + F como um atalho para encontrar uma cadeia de caracteres no arquivo atual.
  • Pressione Ctrl + H como um atalho para encontrar e substituir uma cadeia de caracteres no arquivo atual.

O controle Localizar e Substituir aparece no canto superior direito da janela do editor de código. Ele realça imediatamente todas as ocorrências da cadeia de caracteres de pesquisa fornecida no documento atual. Você pode navegar de uma ocorrência para outra escolhendo o botão Localizar próximo ou o botão Localizar anterior no controle de pesquisa.

Captura de tela da caixa de diálogo Encontrar e Substituir no Editor Visual Studio 2022.

Captura de tela da caixa de diálogo Encontrar e Substituir no Editor Visual Studio 2019 e versões anteriores.

Você pode acessar opções de substituição escolhendo o botão ao lado da caixa de texto Localizar. Para fazer uma substituição por vez, escolha o botão Substituir próximo ao lado da caixa de texto Substituir. Para substituir todas as correspondências, escolha o botão Substituir tudo.

Para alterar a cor de realce das correspondências, escolha o menu Ferramentas, selecione Opções e, em seguida, escolha Ambiente e selecione Fontes e Cores. Na lista Mostrar configurações para, selecione Editor de Texto e, em seguida, na lista Exibir itens, selecione Encontrar Realçando a Opção.

Janelas de ferramentas de pesquisa

Use o controle Localizar em janelas de texto ou de código, como janelas Saída e janelas Localizar Resultados selecionando Editar > Localizar e Substituir ou pressionando Ctrl+F.

Uma versão do controle Find também está disponível em algumas janelas de ferramentas. Por exemplo, você pode filtrar a lista de controles na janela Caixa de Ferramentas inserindo o texto na caixa de pesquisa. Outras janelas de ferramentas que permitem pesquisar seu conteúdo incluem o Gerenciador de Soluções, a janela Propriedades e o Team Explorer.

Localizar nos arquivos e substituir nos arquivos

  • Pressione Ctrl + Shift + F como um atalho para encontrar uma cadeia de caracteres em vários arquivos.
  • Pressione Ctrl + Shift + H como um atalho para encontrar e substituir uma cadeia de caracteres em vários arquivos.

Localizar/substituir em Arquivos funciona como o controle Localizar e Substituir, mas você pode definir um escopo para a pesquisa. Você pode pesquisar não apenas o arquivo atual aberto no editor, mas também todos os documentos abertos, toda a solução, o projeto atual e conjuntos de pastas selecionados. Você também pode pesquisar por extensão de nome de arquivo. Para acessar a caixa de diálogo Localizar/Substituir em Arquivos, selecione Localizar e Substituir no menu Editar (ou pressione Ctrl+Shift+F).

Captura de tela da caixa de diálogo Encontrar e Substituir no Visual Studio 20222, com a guia Encontrar em Arquivos aberta.

Captura de tela da caixa de diálogo Encontrar e Substituir no Visual Studio 2019, com a guia Encontrar em Arquivos aberta.

Importante

Se você estiver usando Visual Studio 2019 versão 16.6 ou anterior, a caixa de diálogo Encontrar e Substituir poderá não parecer com a exibida aqui. Alternar para Visual Studio versão 2017 desta página para descrições que corresponderão ao que você vê na tela.

Captura de tela da caixa de diálogo Encontrar e Substituir no Visual Studio 2017, com a guia Encontrar em Arquivos aberta.

Localizar Resultados

Quando você escolhe Localizar tudo, uma janela Localizar Resultados é aberta e lista as correspondências da pesquisa. Selecionar um resultado na lista exibe o arquivo associado e realça a correspondência. Se o arquivo ainda não estiver aberto para edição, ele será aberto em uma guia de visualização no lado direito da guia. É possível usar o controle Localizar para pesquisar na lista Localizar Resultados.

Criar conjuntos de pastas de pesquisa personalizados

Você pode definir um escopo de pesquisa escolhendo o botão Escolher Pastas de Pesquisa (ele se parece com ...) ao lado da caixa Procurar. Na caixa de diálogo Escolher Pastas de Pesquisa, especifique um conjunto de pastas a ser pesquisado e salve a especificação para reutilizá-la mais tarde.

Dica

Se você mapeou a unidade de um computador remoto para o computador local, especifique as pastas a serem pesquisadas no computador remoto.

Criar conjuntos de componentes personalizados

Você pode definir conjuntos de componentes como o escopo da pesquisa escolhendo o botão Editar conjunto de componentes personalizados ao lado da caixa Examinar. Você pode especificar componentes .NET ou COM instalados, projetos Visual Studio incluídos em sua solução ou qualquer assembly ou biblioteca de tipos (.dll, .tlb, .olb, .exe ou .ocx). Para pesquisar referências, selecione a caixa Examinar referências.

Seleção de vários cursores

Observação

Esta seção aplica-se ao Visual Studio no Windows. Para o Visual Studio para Mac, confira Seleção de bloco.

Introduzido no Visual Studio 2017 versão 15.8

Use a seleção de vários cursores para fazer a mesma edição em dois ou mais locais ao mesmo tempo. Por exemplo, você pode inserir o mesmo texto ou modificar o texto existente em vários locais ao mesmo tempo.

No Visual Studio 2022, aprimoramos a experiência de copiar e colar com vários nós. Anteriormente, colar várias linhas em vários pontos de cuidado resultou na duplicação de toda a área de transferência em cada aparador. Agora, colar várias linhas no mesmo número de pontos de cuidado inserirá cada linha em um respectivo caret.

Para usar vários cursor, pressione Alt + Shift mouse clique + ou Alt + + Shift. e, em seguida, use a tecla de + seta Shift + Ctrl para expandir as seleções. Em seguida, pressione Ctrl + C para copiar o texto em várias seleções. Use Alt + Shift mouse + clique para criar vários cursotes para cada linha para colar onde você deseja. Por fim, pressione Ctrl + V para colar cada linha em seu próprio caret.

Uma animação da ação de seleção de vários Visual Studio.

Além disso, você pode usar a tecla Deslinhar para cima (ou tecla de seta para baixo) ou Arrastar o mouse de Deslocamento Alt para selecionar + + com vários + + cursotes. Anteriormente, esses gestos criava uma seleção de caixa. Agora, uma seleção de caixa se transforma em vários pontos. Esse método é mais fácil e rápido do que ter que clicar em locais precisos para inserir caretas individuais.

Dica

Se você preferir continuar usando uma seleção de caixa com teclas de seta Alt Shift e Alt Shift do mouse ao expandir uma seleção de vários + + + + cursos, > > > vá para Ferramentas Opções Editor de Texto Avançado e selecione Usar seleção de caixa .

Você também pode acessar a seleção de vários caretas na barra de menus selecionando Editar Vários Pontos de Cuidado e, em seguida, selecionando > a ação que você deseja.

Captura de tela do menu suspenso Vários Pontos de Visual Studio 2022.

Na captura de tela a seguir, -0000 está selecionado em três locais. Se o usuário pressionar Excluir, as três seleções serão excluídas:

Seleção de vários cursores em um arquivo XML no Visual Studio

Para selecionar vários cursores, clique ou faça a primeira seleção de texto como de costume e, em seguida, pressione Alt enquanto você clica ou seleciona o texto em cada local adicional. Você pode adicionar texto correspondente automaticamente como seleções adicionais ou selecionar uma caixa de texto para editar de modo idêntico em cada linha.

Dica

Se você tiver selecionado Alt como a tecla modificadora do clique do mouse Ir para Definição em Ferramentas > Opções, a seleção de vários cursores estará desabilitada.

Comandos

Use as seguintes teclas e ações para os comportamentos da seleção de vários cursores:

Atalho Ação
Ctrl + Alt + clique Adicionar um cursor secundário
Ctrl + Alt + clique duas vezes Adicionar uma seleção de palavra secundária
Ctrl + Alt + clique em + arrastar Adicionar uma seleção secundária
Shift + Alt + . Adicionar o próximo texto correspondente como uma seleção
Shift + Alt + ; Adicionar todo o texto correspondente como seleções
Shift + Alt + , Remover a última ocorrência selecionada
Shift + Alt+/ Ignorar a próxima ocorrência de correspondência
Alt + clique Adicionar uma seleção de caixa
Esc ou clique Limpar todas as seleções

Alguns dos comandos também estão disponíveis no menu Editar, em Vários Cursores:

Captura de tela do menu suspenso Vários Pontos de Visual Studio

Confira também